14:01:23 <mgoddard> #startmeeting kayobe
14:01:23 <openstack> Meeting started Mon Jul  8 14:01:23 2019 UTC and is due to finish in 60 minutes.  The chair is mgoddard. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:26 <openstack> The meeting name has been set to 'kayobe'
14:01:36 <mgoddard> #topic rollcall
14:01:38 <mgoddard> \o
14:03:22 <priteau> o/
14:04:06 <mgoddard> #topic agenda
14:04:16 <mgoddard> * Roll-call
14:04:19 <mgoddard> * Announcements
14:04:21 <mgoddard> ** Kayobe to become a kolla deliverable
14:04:23 <mgoddard> ** Kayobe will be discussed in the kolla meeting from next week, Wednesday at 1500UTC
14:04:25 <mgoddard> ** #openstack-kayobe will close, please move to #openstack-kolla
14:04:27 <mgoddard> * Review actions from last meeting
14:04:29 <mgoddard> * Kayobe whiteboard https://etherpad.openstack.org/p/kayobe-whiteboard
14:04:31 <mgoddard> * Discussion
14:04:33 <mgoddard> ** Stein release https://etherpad.openstack.org/p/kayobe-stein-release
14:04:35 <mgoddard> * Open Discussion
14:04:37 <mgoddard> #topic announcements
14:04:55 <mgoddard> #info Kayobe to become a kolla deliverable
14:05:16 <mgoddard> Thanks kolla team for agreeing to have kayobe as a deliverable
14:05:32 <mgoddard> #info Kayobe will be discussed in the kolla meeting from next week, Wednesday at 1500UTC
14:05:36 <priteau> Yay team Kolla
14:05:45 <dougsz1> hey, sorry
14:05:45 <mgoddard> This will be the last kayobe meeting :(
14:05:50 <mgoddard> hi dougsz1
14:05:53 <priteau> We keep the separate IRC channel still?
14:06:29 <mgoddard> #link http://eavesdrop.openstack.org///#Kolla_Team_Meeting
14:06:42 <mgoddard> #info #openstack-kayobe will close, please move to #openstack-kolla
14:07:26 <mgoddard> we'll use openstack-kolla for kayobe discussions from now on
14:07:54 <mgoddard> #link https://wiki.openstack.org/wiki/Meetings/Kolla
14:08:24 <mgoddard> Any other announcements?
14:08:51 <dougsz1> nope, but nice to see the projects combine
14:09:21 <mgoddard> #topic review actions from last meeting
14:09:43 <mgoddard> mgoddard to schedule bug review and squash session
14:09:46 <mgoddard> mgoddard to investigate errors in kayobe-seed-upgrade-centos job
14:09:51 <mgoddard> well 1/2 isn't bad :)
14:10:09 <mgoddard> CI issues with seed upgrade job now resolved
14:10:20 <mgoddard> #action mgoddard to schedule bug review and squash session
14:10:26 <mgoddard> I'll have another go at that
14:10:46 <mgoddard> #topic Kayobe whiteboard https://etherpad.openstack.org/p/kayobe-whiteboard
14:11:07 <mgoddard> I guess we might want to combine whiteboards with kolla?
14:11:16 <mgoddard> #link https://etherpad.openstack.org/p/KollaWhiteBoard
14:11:43 <dougsz1> +1 to combine them
14:11:55 <priteau> Good idea
14:12:11 <jovial[m]> hi
14:12:59 <mgoddard> #info We will combine whiteboards with kolla for the train cycle
14:13:06 <mgoddard> hi jovial[m]
14:13:46 <mgoddard> CI looking mostly green
14:14:13 <mgoddard> we are getting a bit behind on reviews
14:14:37 <mgoddard> #link
14:14:40 <mgoddard> https://review.opendev.org/#/dashboard/?foreach=%28project%3Ax%2Fkayobe%29+status%3Aopen+NOT+label%3ACode-Review%3C%3D-2&title=Kayobe+Review+Dashboard&My+Patches+Requiring+Attention=owner%3Aself+%28label%3AVerified-1%2Czuul+OR+label%3ACode-Review-1+OR+label%3AWorkflow%3C%3D-1%29&Small+things+%28%3C25+LOC%2C+limit+10%29=delta%3A%3C%3D25+limit%3A10+%28NOT+label%3ACode-Review-1%2Ckayobe-core%29+label%3
14:14:42 <mgoddard> AVerified%3E%3D1%2Czuul+branch%3Amaster&Needs+Reverify=label%3AWorkflow%3E%3D1+NOT+label%3AWorkflow%3C%3D-1+label%3AVerified%3C%3D-1%2Czuul&Needs+Final+Approval+%28to+land+on+master%29=NOT+label%3AWorkflow%3E%3D1+NOT+label%3AWorkflow%3C%3D-1+NOT+owner%3Aself+label%3ACode-Review%3E%3D2+label%3AVerified%3E%3D1%2Czuul+%28NOT+label%3ACode-Review-1%2Ckayobe-core%29+branch%3Amaster&Newer+%28%3C1wk%29+Open
14:14:44 <mgoddard> +Patches+%28limit+25%29=-age%3A1week+limit%3A25+branch%3Amaster+NOT+label%3AWorkflow%3E%3D1+%28NOT+label%3ACode-Review-1%2Ckayobe-core%29+label%3AVerified%3E%3D1%2Czuul+NOT+label%3ACode-Review%3E%3D2&Older+%28%3E1wk%29+Open+Patches+Passing+Zuul+Tests+%28limit+50%29=age%3A1week+limit%3A50+NOT+label%3AWorkflow%3E%3D1+NOT+label%3ACode-Review%3C%3D-1+NOT+label%3ACode-Review%3E%3D1+age%3A1week+NOT+label%
14:14:46 <mgoddard> 3AVerified%3E%3D1%2Czuul+%28NOT+label%3ACode-Review-1%2Ckayobe-core%29&Open+Stable+Backports=branch%3A%5Estable%2F.%2A+status%3Aopen
14:14:48 <mgoddard> doh
14:14:49 <mgoddard> #link https://tiny.cc/kayobe-review-dash
14:16:49 <mgoddard> lots of easy patches with 1x +2
14:17:01 <mgoddard> if people have some time, please help land a few
14:17:19 <mgoddard> kolla is about to release stein, we shouldn't be too far behind
14:19:05 <mgoddard> #topic Stein release
14:19:34 <mgoddard> Kolla stein release this week (with any luck)
14:19:57 <mgoddard> What should we focus on, and what should we delay to train?
14:21:17 <priteau> There are lots of little fixes / features that could make it into Stein
14:21:45 <mgoddard> +1. I just added https://review.opendev.org/667451 and https://review.opendev.org/666820 to priorities, which have been bugging people for some time
14:21:57 <priteau> What about changing the default Docker driver, is this something we're ready to change?
14:22:24 <dougsz1> cool, 666820 would be a nice one
14:22:54 <mgoddard> Docker driver would be nice. Problem is we've had reports that overlay2 doesn't play nicely with libvirt
14:23:30 <jovial[m]> even with docker ce?
14:23:30 <mgoddard> We'll probably want to switch to it eventually, and I'm a bit wary of migrating twice
14:24:12 <mgoddard> jovial[m]: unsure about that. johnthetubaguy might be able to say for sure
14:24:28 <dougsz1> There was some interest in arbitrary docker options when running containers - is that in Kolla Ansible for Train and if so can we configure it via Kayobe?
14:24:39 <dougsz1> eg. specify docker logs driver etc.
14:25:50 <mgoddard> dougsz1: there is docker_custom_option, which goes in the systemd unit file rather than daemon.json
14:26:30 <mgoddard> dougsz1: I think GR had something for daemon.json but it hasn't made it out yet
14:26:38 <mgoddard> could ask nicely if you need it
14:26:47 <dougsz1> yeah, that's what I was thinking about
14:28:09 <dougsz1> I guess we might not get that in time
14:28:31 <dougsz1> i just heard that mgoddard was working on it :)
14:29:01 <mgoddard> back on review priorities, please also consider stable backports a priority. We have a few open currently
14:29:45 <mgoddard> if we keep up to date with backports, people shouldn't need to run forks
14:30:51 <mgoddard> #topic open discussion
14:31:23 <mgoddard> Does anyone have any questions about the switch to become part of kolla?
14:32:19 <jovial[m]> is there going to be a tighter integration or are we just going to continue as is?
14:32:33 <priteau> Will we need to release kayobe synchronised with kolla?
14:33:14 <mgoddard> jovial[m]: I don't think there is any plan for a tighter integration. If there is a proposal for a good way to do that we could consider
14:34:10 <mgoddard> jovial[m]: I'm not sure. Probably not, given that we consume kolla ansible we might always need time after the k-a release
14:34:18 <mgoddard> sorry, that was for priteau :)
14:34:34 <priteau> OK
14:34:58 <mgoddard> I'd certainly like to be following a roughly similar timeline, such that we are stabilising around the same time
14:35:41 <mgoddard> in practice, I think we'll switch to a cycle-trailing release model, which gives us 3 months after final release
14:35:47 <mgoddard> or else... I don't know what happens
14:35:58 <dougsz1> Do we get to switch to launchpad? :)
14:36:32 <priteau> Shouldn't Kolla switch to Storyboard instead?
14:37:01 <dougsz1> (I was partly joking, but Storyboard still seems painful to me for searching)
14:37:07 <mgoddard> dougsz1: :p
14:37:35 <mgoddard> I don't think there is a reverse migration path, unless you want to lose the last X months of changes
14:37:44 <dougsz1> yeah, not worth it :)
14:37:54 <dougsz1> more important things..
14:38:08 <mgoddard> kolla has resisted the switch to storyboard, mostly due to laziness :)
14:38:28 <mgoddard> perhaps kayobe will provide the incentive to standardise
14:39:05 <mgoddard> it might be nice to have a story with tasks in kolla, kolla-ansible and kayobe
14:40:02 <mgoddard> perhaps you can help me brainstorm what things we'll need to change for this migration
14:40:12 <dougsz1> yeah, that would make sense. A feature in Kolla Ansible may well require Kayobe support, and would be nice to track that all in one place
14:41:02 <mgoddard> so I have changes in governance and project-config to do the repo rename and officialness
14:41:10 <mgoddard> what will we need to change on our side?
14:41:57 <mgoddard> I've pushed a patch to switch to docs & release notes jobs that publish to  openstack.org
14:42:47 <mgoddard> we have various links that will need to change, for opendev.org/x/kayobe -> opendev.org/openstack/kayobe
14:43:28 <mgoddard> We have a wiki now
14:43:33 <priteau> And search for any mention of readthedocs
14:43:38 <priteau> They should all go
14:43:49 <mgoddard> +1
14:43:57 <mgoddard> should we switch to the kolla wiki or keep our own?
14:44:23 <dougsz1> hmm, didn't even realise we had a wiki
14:44:27 <priteau> We have a wiki?
14:44:39 <priteau> I had no idea
14:44:45 <dougsz1> And do we need one, if we have good docs?
14:44:54 <mgoddard> you guys
14:44:55 <dougsz1> Just another thing to maintain?
14:45:15 <mgoddard> definitely announced this in a meeting
14:45:18 <mgoddard> https://wiki.openstack.org/wiki/Kayobe
14:45:24 <priteau> One use I see for it is linking to Etherpads
14:45:38 <mgoddard> it was requested by someone at the forum
14:45:44 <priteau> You don't want to have to push commits to the docs for every new forum / ptg pad
14:46:19 <priteau> Maybe let's keep our own wiki for now?
14:47:11 <mgoddard> ok
14:48:04 <mgoddard> I might add kayobe to the kolla wiki though: https://wiki.openstack.org/wiki/Kolla
14:48:58 <mgoddard> What should we do with http://kayobe.readthedocs.io?
14:49:33 <dougsz1> I really quite like it to be honest
14:49:39 <dougsz1> It's very useful
14:49:57 <mgoddard> oh yes, no suggesting we remove any docs :)
14:50:03 <dougsz1> But I suppose the Kayobe OpenStack docs should be equally so
14:50:12 <mgoddard> but we will be allowed to use openstack.org
14:50:30 <dougsz1> How easy is it to migrate to that? Just a doc job?
14:50:46 <mgoddard> yeah, just start publishing there
14:50:54 <dougsz1> cool
14:51:15 <mgoddard> what can we do about RTD for people who are used to going there?
14:51:21 <dougsz1> Will be nice to update Kolla docs as well, to introduce Kayobe as a option early on
14:51:38 <mgoddard> probably doesn't hurt to keep publishing there, but would be nice not to have to do that forever
14:52:08 <dougsz1> I suppose providing that they *always* stay in sync it's not a huge issue
14:52:10 <mgoddard> I did add something about kayobe in kolla ansible docs, but perhaps we could be a bit louder
14:52:58 <dougsz1> sounds good - not an advertising pitch, but just make sure people understand the benefits and how it could be useful to them
14:53:10 <mgoddard> I wonder if there's a header we could add to direct people to official docs
14:53:33 <priteau> There might be a Sphinx extension to do that
14:53:37 <mgoddard> same issue for release notes really, which don't currently get auto updated
14:54:10 <mgoddard> priteau: that would be good
14:54:33 <mgoddard> When should we disable this channel?
14:55:32 <mgoddard> maybe once all the project-config changes have gone through
14:55:38 <priteau> Is everyone @here also on #kolla?
14:56:02 <priteau> dougsz1 isn't on #openstack-kolla :P
14:56:09 <mgoddard> doh
14:56:23 <dougsz1> flaky internet!
14:56:24 <jovial[m]> not yet
14:56:53 <mgoddard> ok. I'll stick around in this channel until the end, in case anyone pops up
14:57:06 <priteau> So everyone seems to be on #openstack-kolla except kgz, dougsz1 and jovial[m]
14:57:06 <mgoddard> everyone else feel free to move to openstack-kolla after this meeting
14:57:19 <dougsz1> Shall we update the channel topic to point people in the right direction?
14:57:26 <priteau> +1
14:57:44 <mgoddard> dougsz1: tried, didn't work first time so gave up :)
14:57:45 <priteau> I've made kgz run away :-(
14:57:59 <mgoddard> priteau: he works for jetstack in our office :)
14:58:17 <priteau> I know :-) He's on another channel anyway.
14:58:46 <mgoddard> 2 minutes to go
14:58:52 <mgoddard> any other burning questions?
14:59:02 <jovial[m]> can't we set up a redirect?
14:59:14 <mgoddard> IRC redirect/
14:59:17 <mgoddard> ?
14:59:27 <jovial[m]> yep
14:59:51 <mgoddard> I could ask in infra channel
15:00:18 <mgoddard> thanks for brainstorming, I have a list of things to do now
15:00:33 <mgoddard> if you ask nicely, I might even give you one :p
15:00:38 <jovial[m]> something like: https://epir.at/2016/06/26/redirecting-freenode-channels/
15:01:02 <mgoddard> jovial[m]: it's probably not in my power, but might be able to get infra to do it
15:02:00 <dougsz1> will try and pick something up
15:02:01 <mgoddard> Thanks everyone
15:02:05 <dougsz1> thanks
15:02:12 <mgoddard> Great work on getting kayobe to this point
15:02:22 <mgoddard> And so begins a new era :D
15:02:37 <priteau> I need to get a sticker
15:02:44 <mgoddard> They grow up so fast
15:02:57 <mgoddard> #endmeeting