18:07:05 <heckj> #startmeeting keystone
18:07:06 <openstack> Meeting started Tue Aug 28 18:07:05 2012 UTC.  The chair is heckj. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:07:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:07:08 <openstack> The meeting name has been set to 'keystone'
18:07:12 <heckj> Okay - new options :-)
18:07:26 <heckj> ola y'all
18:07:30 <dolphm> o/
18:07:33 <heckj> #topic hot issues
18:07:56 <heckj> We have a CVE that we're doing some review work on - dolph, you've got the patches
18:08:12 <heckj> dolphm: anything of note there other than the review process?
18:08:27 <dolphm> nope, i wasn't quite aware of it either
18:09:14 <heckj> Any other burning issues?
18:09:19 <dolphm> i done broke gerrit
18:09:23 <heckj> heh
18:09:57 <dolphm> i'm not sure how to get https://review.openstack.org/#/c/12058/ into a well-understood state
18:10:34 <heckj> dolphm: is this the first cut into the feature patch?
18:10:43 <heckj> er, feature branch?
18:10:49 <dolphm> heckj: yes, technically
18:11:06 <dolphm> i haven't another small patch i wanted to go in first, but i'm struggling with details
18:11:20 <gyee> that will go into folsom?
18:11:25 <dolphm> gyee: no
18:11:31 <heckj> gyee: no - this is spcifically a feature branch
18:11:50 <gyee> cool, lots of code to comb through :)
18:12:07 <heckj> gyee: intended to be a branch that we can work and merge into external to the release process
18:12:20 <heckj> then later we merge into mainline for a release
18:12:30 <dolphm> heckj: gyee: there's corresponding keystoneclient changes i don't have a feature branch to push to as well
18:12:48 <gyee> I'll finishup domains based on that branch then
18:13:06 <heckj> dolphm: I saw the request go out - if we don't hear back from ttx on it, I'll poke him today
18:13:17 <dolphm> gyee: hack away :)
18:13:53 <dolphm> heckj: when we're ready for this to merge to master (... thinking ahead here) ... will we have a chance to see the entire feature branch as a single gerrit review before it merges?
18:14:18 <dolphm> heckj: i'm thinking about how we should handle code reviews between now and then
18:14:27 <heckj> dolphm: that's my understanding of this process so far - that the merge to master will be a monster rebase and single commit
18:15:20 <dolphm> i.e. i wouldn't consider the above review master-merge-worthy as-is (falls short on test coverage, documentation, migrations, etc)
18:17:43 <heckj> dolphm: I think we're doing reviews to merge into the feature branch - we can relax the tests and tools around it to allow us to "break things" while we're doing this development
18:18:08 <heckj> then at some point down the road, we will choose to merge it back in and do that in close conjunction with the CI team
18:18:10 <dolphm> heckj: i'd rather continue to run tests + pep8 etc, personally
18:18:16 <heckj> dolphm: word
18:18:37 <heckj> #action heckj to pester ttx for a feature branch on keystoneclient for V3 work
18:18:55 <dolphm> heckj: mostly because this work should *not* affect things like devstack (which depends on v2), so those tests should continue to pass
18:19:05 * heckj nods
18:19:17 <heckj> good way to make sure it doesn't - I agree
18:19:48 <heckj> #topic open discussion
18:19:59 <heckj> Any open discussion?
18:20:06 <heckj> Did David Chadwick make it here today?
18:21:02 <dolphm> he's in the UK, no?
18:21:12 <heckj> yeah, but said he'd be trying to connect
18:21:23 <heckj> guess he's not making it as yet
18:21:46 <heckj> I think last week he connected to a different IRC system (not freenode)
18:22:03 <dolphm> ah, that's right
18:23:51 <heckj> gyee: you have anything
18:23:52 <heckj> ?
18:24:58 <gyee> heckj, no, I took a couple of weeks off, slowly getting back to the flow of things :)
18:27:28 <heckj> If folks don't have anything else, I'll end this early today
18:27:49 <dolphm> sounds good
18:27:51 <heckj> #endmeeting