18:00:21 <heckj> #startmeeting keystone
18:00:22 <openstack> Meeting started Tue Sep 18 18:00:21 2012 UTC.  The chair is heckj. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:24 <openstack> The meeting name has been set to 'keystone'
18:00:26 <heckj> ola all -
18:00:30 <dolphm> o/
18:00:41 <heckj> I never updated the Agenda from the last meeting (my bad) - so it's pretty light for today
18:01:00 <heckj> #topic hot issues
18:01:24 <heckj> We've got RC1 cut and out there, and testing is being actively encouraged against the whole RC1 kit available
18:01:30 <gyee> \o
18:01:34 <heckj> No new bugs (as of this morning) against keystone
18:01:39 <dolphm> yay
18:01:53 <gyee> not sure if there's a bug with auth_token middleware
18:02:09 <gyee> but seems like it no longer supports the cache property
18:02:16 <heckj> There's an outstanding high pri bug against keystoneclient that I need to nail down - might be pebkac, just need to try and repro it
18:02:17 <gyee> swift global cache I mean
18:02:41 <heckj> gyee: is there a bug filed there? And is that against auth_token or the swift variation of auth_token that's in swift's repo?
18:02:43 <dolphm> heckj: link?
18:02:49 <dolphm> heckj: or details
18:03:02 <gyee> heckj, I was going to file one, I just want to make sure its not intentional
18:03:20 <heckj> dolphm: this one: https://bugs.launchpad.net/python-keystoneclient/+bug/953619
18:03:21 <uvirtbot> Launchpad bug 953619 in python-keystoneclient "when create a tenant,the enabled's status is false,but when call tenant-list ,the enabled's status is true" [Critical,Triaged]
18:03:22 <gyee> used to be "cache = swift.cache" and swift.cache is set via env
18:03:49 <gyee> now we have to use local caching which is cache_servers
18:04:35 <dolphm> heckj: it looks like it's interpreting 'false' as a string -- i remember there being a similar bug in the client at some point
18:05:07 <gyee> auth_token still part of keystone right? just swift_auth had moved
18:05:15 <dolphm> gyee: as of today, yes
18:05:34 <gyee> I mean there's only one version of auth_token right?
18:05:56 <heckj> gyee: yep, just wanted to make sure you weren't using swift_auth instead of auth_token in your install - they do similiar things
18:06:18 <gyee> I'll file a bug then, auth_token no longer support the cache property
18:06:25 <gyee> that breaks backward compatibility
18:08:33 <dolphm> anyone see this review? https://review.openstack.org/#/c/12844/
18:08:41 <dolphm> to remove (some) backslash continuations
18:09:03 <heckj> dolphm: yeah - he's been periodically doing those
18:09:14 <heckj> gyee: thanks - bug welcome!
18:09:57 <dolphm> i'd be in favor of A) removing all backslash continuations, including sqlalchemy queries, and B) having a simple gate on jenkins to keep them out of the code for good
18:10:34 <gyee> A + B :)
18:10:39 <dolphm> curious how attached ya'll are to the session.query() \ .filter() \ .filter() \ .first() style
18:10:43 <dolphm> cause i hate it
18:11:14 <heckj> I thought it was cute, but don't have a strong opinion on it
18:11:21 <heckj> (was readable for me)
18:11:29 <gyee> same here, as long as the code still readable
18:11:51 <heckj> fine with putting in a test in unit tests that break on continuations existing and then using that as a gate mechanism - it's what other projects are doing
18:11:55 <dolphm> while we're at it, we could gate on trailing whitespace lol
18:12:20 <dolphm> heckj: a unit test?
18:13:04 <heckj> I think that's what nova had set up - something in the unit test framework that ran through the code and barfed if formatting wasn't kosher - wouldn't need to go re-read through that again
18:13:23 <heckj> #topic open discussion
18:13:36 <heckj> For summit sessions, have folks been suggesting items?
18:13:54 <heckj> I haven't scheduled many as yet - was going to sit down this weekend and work through some topics to get up there
18:16:02 <gyee> anybody created wadl and xsd for v3 yet?
18:16:12 <heckj> gyee: not yet
18:16:39 <heckj> dolphm: I've started to truck through the reviews for the V3 branches
18:16:42 <heckj> (starting on client work)
18:16:55 <heckj> was curious what the serialization method you set up was aimed at
18:17:04 <heckj> (can dig up the review if you need)
18:17:37 <dolphm> heckj: i responded to you comment this morning
18:17:45 <dolphm> heckj: basically i need to pass sort_keys=True
18:17:56 <dolphm> heckj: and doing so in the v2 client breaks all the v2 tests
18:18:06 * heckj hasn't seen the emails from gerrit on that yet
18:18:13 <heckj> hhhh
18:18:21 <heckj> got it
18:18:34 <dolphm> heckj: doing it that way was easier than rewriting all the v2 tests :)
18:18:47 <heckj> word, I'm good with it then - will change my review there
18:20:58 <heckj> any other topics? If not, I'll close this out early...
18:22:24 <dolphm> heckj: oh, v3 draft #next
18:22:43 <dolphm> heckj: how do you want to go about that, because i've got a list of notes that need to go into the next draft, based on what i've implemented
18:22:48 * heckj is a damn slacker and hasn't done it yet
18:23:10 <heckj> #action heckj to update the draft and create a new version
18:23:14 <dolphm> heckj: i'd be more than happy to do the next draft if you'd prefer
18:23:39 <heckj> dolphm: If you'd like to, have at
18:23:53 <dolphm> heckj: want to set up a new doc and send me the link?
18:24:54 <dolphm> i'll also include a "changes from the previous draft" type section
18:25:12 <heckj> dolphm: yep, you got it
18:27:09 <heckj> dolphm: https://docs.google.com/document/d/1gI_OEc_ZybuKFMGkQwELbkClqoIXsR3Fi8wqH2DvX-I/edit
18:28:37 <dolphm> heckj: can you give me edit privs at dolph.mathews@gmail.com
18:28:40 <heckj> dolphm: locked comments on previous version
18:29:20 <heckj> dolphm: done - get rid of antiver?
18:29:31 <dolphm> heckj: yeah
18:29:42 <heckj> ayoung: you around?
18:29:47 <dolphm> heckj: trying to switch all my stuff over to the email address i actually use :)
18:29:55 <heckj> understood
18:30:05 <heckj> permissions updated
18:31:41 <heckj> Okay - headin' out for a while -
18:31:43 <heckj> #endmeeting