#openstack-meeting: keystone

Meeting started by dolphm_ at 18:00:53 UTC (full logs).

Meeting summary

  1. High priority bugs or immediate issues? (dolphm_, 18:01:07)
    1. ACTION: gyee to put v3 auth interface up for review, without pluggability (dolphm_, 18:03:37)
    2. ACTION: core to review proposed security patches (dolphm_, 18:04:47)

  2. Default domain and v3 calls where domain_id is not specified (dolphm_, 18:05:14)
    1. http://lists.openstack.org/pipermail/openstack-dev/2013-January/004691.html (dolphm_, 18:06:10)
    2. ACTION: utilize domain-scoped authorization to imply owning domain_id on create user & project requests (dolphm_, 18:19:35)

  3. Tenant to Project, Roles versus Membership, and Trusts (dolphm_, 18:20:04)
    1. https://github.com/openstack/identity-api/blob/master/openstack-identity-api/src/markdown/identity-api-v3.md#grant-role-to-user-on-domain-put-domainsdomain_idusersuser_idrolesrole_id (dolphm_, 18:27:47)
    2. https://github.com/openstack/keystone/blob/master/keystone/identity/backends/sql.py#L242 (ayoung, 18:35:27)
    3. https://github.com/openstack/keystone/blob/master/keystone/identity/backends/sql.py#L550 (ayoung, 18:37:06)

  4. v3/auth (dolphm_, 18:47:48)
    1. ACTION: dolph to revise v3 API from /v3/tokens -> /v3/auth (dolphm_, 18:52:37)

  5. open discussion (dolphm_, 18:58:53)


Meeting ended at 19:00:01 UTC (full logs).

Action items

  1. gyee to put v3 auth interface up for review, without pluggability
  2. core to review proposed security patches
  3. utilize domain-scoped authorization to imply owning domain_id on create user & project requests
  4. dolph to revise v3 API from /v3/tokens -> /v3/auth


Action items, by person

  1. gyee
    1. gyee to put v3 auth interface up for review, without pluggability
  2. UNASSIGNED
    1. core to review proposed security patches
    2. utilize domain-scoped authorization to imply owning domain_id on create user & project requests
    3. dolph to revise v3 API from /v3/tokens -> /v3/auth


People present (lines said)

  1. ayoung (103)
  2. dolphm_ (91)
  3. dwchadwick (35)
  4. henrynash (30)
  5. gyee (27)
  6. topol (3)
  7. openstack (3)


Generated by MeetBot 0.1.4.