#openstack-meeting: keystone

Meeting started by dolphm at 18:02:37 UTC (full logs).

Meeting summary

  1. identity-specs repo coming soon (dolphm, 18:03:26)
    1. https://review.openstack.org/#/c/94119/ (dolphm, 18:03:51)
    2. Mandatory for feature proposals juno-2 onward (dolphm, 18:05:34)
    3. Propose a feature spec first, and when it's approved/merged, keystone-drivers will create and manage a corresponding blueprint in LP (dolphm, 18:05:40)
    4. https://github.com/admiyo/keystone-specs/ (ayoung, 18:06:03)
    5. https://github.com/openstack/nova-specs/blob/master/specs/template.rst nova's spec tempalte (dolphm, 18:11:38)

  2. Potential Keystone Hackathon dates in San Antonio, TX for Juno (dolphm, 18:21:03)
    1. http://doodle.com/s4g7mm9n7qyu9inh vote for dates here if you're planning on attending (dolphm, 18:21:19)
    2. http://openstack.10931.n7.nabble.com/keystone-Pagination-td17386.html (clu_, 18:28:14)

  3. Pagination and Filtering (dolphm, 18:29:30)
  4. Split of middleware (auth_token, etc) out of keystoneclient to separate repo (dolphm, 18:42:24)
    1. http://git.openstack.org/cgit/openstack/python-keystoneclient/tree/keystoneclient/middleware/auth_token.py#n146 (ayoung, 18:45:12)
    2. http://git.openstack.org/cgit/openstack/python-keystoneclient/tree/keystoneclient/middleware (ayoung, 18:49:45)
    3. http://git.openstack.org/cgit/openstack/keystone/tree/keystone/middleware/ec2_token.py (ayoung, 18:50:37)
    4. ACTION: morganfainberg to write a -spec to introduce keystonemiddleware repo (dolphm, 18:50:42)

  5. Add LDAP connection pool (dolphm, 18:50:51)
    1. https://bugs.launchpad.net/keystone/+bug/1320997 (dolphm, 18:51:00)
    2. https://pypi.python.org/pypi/ldappool/1.0 (dolphm, 18:53:27)


Meeting ended at 19:00:54 UTC (full logs).

Action items

  1. morganfainberg to write a -spec to introduce keystonemiddleware repo


Action items, by person

  1. morganfainberg
    1. morganfainberg to write a -spec to introduce keystonemiddleware repo


People present (lines said)

  1. dolphm (101)
  2. ayoung (62)
  3. morganfainberg (51)
  4. gyee (35)
  5. bknudson (26)
  6. nkinder (22)
  7. henrynash (18)
  8. dstanek (13)
  9. stevemar (11)
  10. jamielennox (9)
  11. lbragstad (8)
  12. clu_ (7)
  13. mfisch (4)
  14. openstack (3)
  15. jaypipes (1)
  16. uvirtbot (1)


Generated by MeetBot 0.1.4.