#openstack-meeting: keystone

Meeting started by morganfainberg at 18:02:13 UTC (full logs).

Meeting summary

  1. rollcall (morganfainberg, 18:02:44)
    1. VOTE: Voted on "Rollcall?" Results are, here: 17 (morganfainberg, 18:05:15)

  2. Midcycle update (morganfainberg, 18:06:01)
    1. ACTION: morganfainberg to send midcycle info email this week (morganfainberg, 18:06:34)
    2. Keystone midcycle, July 15-17 at Boston University (morganfainberg, 18:08:56)
    3. ACTION: ayoung to look into RedHat sponsorship of food etc. (morganfainberg, 18:09:17)
    4. ACTION: morganfainberg to look into HP sponsorship of food etc (morganfainberg, 18:09:28)

  3. For stevedore, should I assume no extensions? (morganfainberg, 18:13:10)
    1. stevedore loading of extension/backends will not include '.contrib.' in the namespace (morganfainberg, 18:17:27)

  4. Release Notes (Kilo) (morganfainberg, 18:17:39)
    1. https://wiki.openstack.org/wiki/ReleaseNotes/Kilo#OpenStack_Identity_.28Keystone.29 (morganfainberg, 18:18:27)
    2. ACTION: dolphm and samueldmq to confirm release notes are complete for Kilo by EOD Wednesday (morganfainberg, 18:22:07)

  5. Liberty Priorities (morganfainberg, 18:23:10)
    1. https://etherpad.openstack.org/p/keystone-liberty-priority-specs (morganfainberg, 18:23:20)
    2. http://docs.openstack.org/havana/config-reference/content/section_conductor.html (geoffarnold, 18:33:22)
    3. Liberty Priorities (API Impacting): Reseller(Approved Spec), Domain SQL Enhancements(Spec will be prior to summit), Dynamic-Policy(Clear Spec proposed before summit, Scope TBD @ summit), Tokenless-auth (Has Spec, needs approval, code ready), TBD@summit (morganfainberg, 18:45:58)
    4. Non-API Impacting Priorities: stevedore for drivers(Approved, No-spec), Functional Testing (has spec, needs approval), Stable KSDI (has spec, against backlog), Fix Dependency Injection (has spec, needs approval), Pecan (needs spec), python3 (has spec, backlog), v3-only (no keystone spec needed), keystonemiddleware-uses-auth-plugins(code-ready, has spec, approved), Token Provider Cleanup (morganfainberg, 18:52:43)

  6. Testing admin-less (morganfainberg, 18:53:06)
  7. Policy (morganfainberg, 18:55:56)
    1. https://review.openstack.org/#/c/133814/ (ayoung, 18:58:59)


Meeting ended at 19:00:46 UTC (full logs).

Action items

  1. morganfainberg to send midcycle info email this week
  2. ayoung to look into RedHat sponsorship of food etc.
  3. morganfainberg to look into HP sponsorship of food etc
  4. dolphm and samueldmq to confirm release notes are complete for Kilo by EOD Wednesday


Action items, by person

  1. ayoung
    1. ayoung to look into RedHat sponsorship of food etc.
  2. dolphm
    1. dolphm and samueldmq to confirm release notes are complete for Kilo by EOD Wednesday
  3. morganfainberg
    1. morganfainberg to send midcycle info email this week
    2. morganfainberg to look into HP sponsorship of food etc
  4. samueldmq
    1. dolphm and samueldmq to confirm release notes are complete for Kilo by EOD Wednesday


People present (lines said)

  1. morganfainberg (177)
  2. ayoung (91)
  3. gyee (33)
  4. bknudson (32)
  5. marekd (23)
  6. stevemar (21)
  7. jamielennox (20)
  8. Rockyg (13)
  9. samueldmq (13)
  10. openstack (12)
  11. dstanek (12)
  12. amakarov (12)
  13. henrynash (11)
  14. geoffarnold (10)
  15. david8hu (7)
  16. dolphm (7)
  17. lbragstad (6)
  18. rodrigods (6)
  19. ioram (4)
  20. dhellmann (4)
  21. raildo (4)
  22. rharwood (2)
  23. samleon (1)
  24. hogepodge (1)
  25. lhcheng (1)
  26. dims (1)
  27. roxanaghe (1)


Generated by MeetBot 0.1.4.