#openstack-meeting: Keystone

Meeting started by morganfainberg at 18:01:35 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/KeystoneMeeting (morganfainberg, 18:01:38)

  1. Dynamic Policies (morganfainberg, 18:02:19)
    1. to git repo https://github.com/admiyo/keystone-rbac-presentation (ayoung, 18:03:13)
    2. https://github.com/admiyo/keystone-rbac-presentation/raw/master/risk-assessment.pdf (ayoung, 18:03:43)
    3. https://www.mail-archive.com/openstack-dev@lists.openstack.org/msg57416.html (samueldmq, 18:08:24)
    4. https://blueprints.launchpad.net/keystone/+spec/dynamic-policies-delivery (samueldmq, 18:10:51)
    5. https://review.openstack.org/#/c/134655/ (ayoung, 18:29:29)
    6. https://review.openstack.org/#/c/197980/ (ayoung, 18:29:36)
    7. https://review.openstack.org/#/c/134655/ is the thing we are really voting on....the other is just better HTTP coding (ayoung, 18:30:57)
    8. VOTE: Voted on "Dynamic Policy SPFE Acceptance?" Results are, defer: 7, accept: 7 (morganfainberg, 18:36:53)
    9. ACTION: Keystone Cores - review the SPFE and Dynamic policy spec(s) specifically for liberty (morganfainberg, 18:37:45)

  2. Moving role assignment inheritance (OS-INHERIT) to core (morganfainberg, 18:39:04)
    1. https://review.openstack.org/#/c/200434/ (henrynash, 18:39:22)
    2. VOTE: Voted on "Accept SPFE for os-inherit behavior change when moved to core (old API/behavior deprecated)?" Results are, yes: 10 (morganfainberg, 18:45:52)

  3. Clarifying how domain_id, parent_id and is_domain are used in project hierarchies (morganfainberg, 18:46:29)
    1. https://review.openstack.org/#/c/200624/ (henrynash, 18:46:54)

  4. Making project.domain_id immutable (morganfainberg, 18:51:19)


Meeting ended at 18:59:51 UTC (full logs).

Action items

  1. Keystone Cores - review the SPFE and Dynamic policy spec(s) specifically for liberty


People present (lines said)

  1. morganfainberg (148)
  2. ayoung (69)
  3. samueldmq (46)
  4. gyee (38)
  5. henrynash (30)
  6. bknudson (28)
  7. htruta (21)
  8. geoffarnold (21)
  9. openstack (18)
  10. stevemar (10)
  11. dstanek (5)
  12. lbragstad (5)
  13. marekd (4)
  14. breton (4)
  15. dolphm (3)
  16. raildo (3)
  17. lhcheng (2)
  18. amakarov (2)
  19. ericksonsantos (1)


Generated by MeetBot 0.1.4.