#openstack-meeting: keystone

Meeting started by morgan_503 at 18:00:40 UTC (full logs).

Meeting summary

  1. Agenda (morgan_503, 18:00:49)
    1. https://wiki.openstack.org/wiki/Meetings/KeystoneMeeting (morgan_503, 18:00:54)

  2. Centralized Policies Distribution (morgan_503, 18:01:10)
    1. https://www.mail-archive.com/openstack-operators@lists.openstack.org/msg02805.html (samueldmq, 18:03:03)
    2. https://www.mail-archive.com/openstack-dev@lists.openstack.org/msg57416.html (samueldmq, 18:04:55)
    3. VOTE: Voted on "Approve SPFE for policy distribution and scaffolding for dynamic policy?" Results are, yes: 9, i_dislike_concrete_options_but_still_vote_yes: 2 (morgan_503, 18:11:56)
    4. https://review.openstack.org/#/c/134655/ (samueldmq, 18:13:29)
    5. https://review.openstack.org/#/c/197980/ (samueldmq, 18:13:29)

  3. Raising an exception if no domain specified on user/group/project create (morgan_503, 18:13:48)
    1. https://bugs.launchpad.net/keystone/+bug/1482330 (lbragstad, 18:15:09)

  4. HTTP caching support (morgan_503, 18:21:12)
    1. https://review.openstack.org/#/c/211396/ (dstanek, 18:21:42)
    2. http://paste.openstack.org/raw/412596/ (dstanek, 18:24:55)
    3. https://review.openstack.org/#/c/211693/ (dstanek, 18:25:28)
    4. ACTION: dstanek to work with jamielennox and continue exploring this path. more work to be done before it's really ready to go (morgan_503, 18:32:55)
    5. ACTION: dstanek to work with ayoung to ensure caching use-cases and cache avoidance for specific requests can occur (morgan_503, 18:38:02)

  5. X.509 Tokenless Authz needs a verdict (morgan_503, 18:38:37)
    1. https://review.openstack.org/#/c/156870/ (gyee, 18:40:25)
    2. ACTION: Cores: Please review code for tokenless auth (service users) (morgan_503, 18:42:08)

  6. Bug 1482701 - Federation: user's name in rules not respected (morgan_503, 18:48:03)
    1. https://github.com/openstack/keystone/blob/master/keystone/token/providers/fernet/token_formatters.py#L532-L533 (lbragstad, 18:52:45)

  7. lhcheng's bug for end_point filtering (morgan_503, 18:56:28)
    1. https://bugs.launchpad.net/keystone/+bug/1482772 (lhcheng, 18:56:42)


Meeting ended at 18:58:47 UTC (full logs).

Action items

  1. dstanek to work with jamielennox and continue exploring this path. more work to be done before it's really ready to go
  2. dstanek to work with ayoung to ensure caching use-cases and cache avoidance for specific requests can occur
  3. Cores: Please review code for tokenless auth (service users)


Action items, by person

  1. ayoung
    1. dstanek to work with ayoung to ensure caching use-cases and cache avoidance for specific requests can occur
  2. dstanek
    1. dstanek to work with jamielennox and continue exploring this path. more work to be done before it's really ready to go
    2. dstanek to work with ayoung to ensure caching use-cases and cache avoidance for specific requests can occur
  3. jamielennox
    1. dstanek to work with jamielennox and continue exploring this path. more work to be done before it's really ready to go


People present (lines said)

  1. morgan_503 (155)
  2. dstanek (50)
  3. ayoung (43)
  4. samueldmq (39)
  5. jamielennox (36)
  6. gyee (35)
  7. bknudson (29)
  8. lbragstad (26)
  9. henrynash (20)
  10. breton (16)
  11. openstack (11)
  12. lhcheng (10)
  13. stevemar (10)
  14. uvirtbot (6)
  15. david8hu (3)
  16. htruta_ (2)
  17. hogepodge (1)
  18. ericksonsantos (1)


Generated by MeetBot 0.1.4.