#openstack-meeting: keystone

Meeting started by dstanek at 18:02:53 UTC (full logs).

Meeting summary

  1. Agenda (dstanek, 18:03:06)
    1. https://wiki.openstack.org/wiki/Meetings/KeystoneMeeting (dstanek, 18:03:13)

  2. Voting on SPFE for IdP Specific WebSSO (dstanek, 18:03:38)
    1. https://review.openstack.org/#/c/199339/2 is the spec (dstanek, 18:03:38)
    2. http://lists.openstack.org/pipermail/openstack-dev/2015-August/071131.html is the mailing list discussion (dstanek, 18:03:45)
    3. VOTE: Voted on "Approve SPFE for IdP Specific WebSSO?" Results are, yes: 8, dont_care: 1, no: 1 (dstanek, 18:14:56)
    4. ACTION: lbragstad and/or jamielennox to code up the IdP specific WebSSO flow (dstanek, 18:15:45)

  3. Change default endpoint type for Keystone v3 to 'public' (dstanek, 18:15:54)
    1. https://review.openstack.org/#/c/185200/ is the review (dstanek, 18:16:06)
    2. https://github.com/openstack/python-keystoneclient/blob/master/keystoneclient/auth/identity/base.py#L313 (jamielennox, 18:19:12)
    3. VOTE: Voted on "Do we want to change from admin -> public and possibly break some applications?" Results are, yes: 2, no: 7 (dstanek, 18:34:04)
    4. ACTION: roxanaghe_ to look into alternatives (maybe deprecation) to "Change default endpoint type for Keystone v3 to 'public'" (dstanek, 18:35:50)

  4. Must tokens always have a user domain ID? (dstanek, 18:36:14)
    1. https://github.com/openstack/keystone/blob/master/keystone/token/providers/fernet/core.py#L123 (lbragstad, 18:49:52)
    2. https://github.com/openstack/keystone/blob/master/keystone/token/providers/fernet/core.py#L123 (lbragstad, 18:49:58)

  5. keystoneclient keystoneauth_integration feature branch still broken bknudson (dstanek, 18:51:14)
    1. https://review.openstack.org/#/c/213573/ proposed review (dstanek, 18:51:15)


Meeting ended at 19:00:16 UTC (full logs).

Action items

  1. lbragstad and/or jamielennox to code up the IdP specific WebSSO flow
  2. roxanaghe_ to look into alternatives (maybe deprecation) to "Change default endpoint type for Keystone v3 to 'public'"


Action items, by person

  1. jamielennox
    1. lbragstad and/or jamielennox to code up the IdP specific WebSSO flow
  2. lbragstad
    1. lbragstad and/or jamielennox to code up the IdP specific WebSSO flow
  3. roxanaghe_
    1. roxanaghe_ to look into alternatives (maybe deprecation) to "Change default endpoint type for Keystone v3 to 'public'"


People present (lines said)

  1. dstanek (57)
  2. jamielennox (53)
  3. bknudson (40)
  4. lbragstad (31)
  5. ayoung (31)
  6. roxanaghe_ (20)
  7. openstack (17)
  8. henrynash (15)
  9. stevemar (13)
  10. breton (5)
  11. samueldmq (3)
  12. Haneef__ (2)
  13. rodrigods (1)
  14. topol (1)
  15. tim_o (1)
  16. morgan_2549 (1)
  17. Shrews (1)
  18. raildo (1)


Generated by MeetBot 0.1.4.