#openstack-meeting: keystone

Meeting started by dstanek at 18:01:09 UTC (full logs).

Meeting summary

  1. Keystoneclient v2 branch (dstanek, 18:01:26)
  2. Changing driver version numbers....looking for guidance on how this should work? (dstanek, 18:03:55)
    1. https://review.openstack.org/#/c/191976/ (henrynash, 18:06:59)
    2. AGREED: we have frozen the v8 driver APIs as of L3 and require a FFE to make changes to them (dstanek, 18:18:38)
    3. ACTION: dstanek to follow up in the l2 vs l3 debate and write it in the docs (dstanek, 18:19:07)

  3. keystonemiddleware tests broken by keystoneclient release (dstanek, 18:20:02)
    1. https://bugs.launchpad.net/python-keystoneclient/+bug/1492600 (bug assigned to davechen) (dstanek, 18:20:10)
    2. http://logs.openstack.org/13/208213/2/check/gate-keystonemiddleware-python27/3e14ede/console.html.gz#_2015-09-04_17_56_39_631 (dstanek, 18:20:19)
    3. https://review.openstack.org/#/c/220736/ Proposed change to ksc (dstanek, 18:20:24)
    4. ACTION: blk-u fix KC (ayoung_, 18:21:08)
    5. ACTION: lhcheng to start looking into the ksm issue caused by the ksc release. (dstanek, 18:29:20)

  4. python-keystoneclient uses socket attributes that do not exist in Windows (dstanek, 18:29:36)
    1. https://review.openstack.org/#/c/211686/ proposed partial fix to make creating instances on Hyper-V possible (dstanek, 18:29:46)
    2. https://review.openstack.org/#/c/211686/7/keystoneclient/session.py (ayoung_, 18:35:26)

  5. Policies (dstanek, 18:41:22)
    1. Server: https://review.openstack.org/#/c/216851/ (samueldmq, 18:42:38)
    2. Middleware: https://review.openstack.org/#/c/205049/ (samueldmq, 18:42:42)
    3. Oslo: https://review.openstack.org/#/c/200257/ (samueldmq, 18:42:45)
    4. VOTE: Voted on "FFE for the policy over HTTP changes. allow it?" Results are, yes: 3, no: 8 (dstanek, 18:58:13)

  6. Reseller (dstanek, 18:58:52)


Meeting ended at 19:00:07 UTC (full logs).

Action items

  1. dstanek to follow up in the l2 vs l3 debate and write it in the docs
  2. blk-u fix KC
  3. lhcheng to start looking into the ksm issue caused by the ksc release.


Action items, by person

  1. dstanek
    1. dstanek to follow up in the l2 vs l3 debate and write it in the docs
  2. lhcheng
    1. lhcheng to start looking into the ksm issue caused by the ksc release.


People present (lines said)

  1. dstanek (74)
  2. samueldmq (41)
  3. stevemar (36)
  4. bknudson (35)
  5. ayoung_ (35)
  6. henrynash (25)
  7. gyee (22)
  8. morgan (19)
  9. claudiub (15)
  10. lbragstad (10)
  11. openstack (9)
  12. topol (8)
  13. amakarov (7)
  14. sigmavirus24 (6)
  15. htruta (4)
  16. lhcheng (3)
  17. raildo (2)
  18. hogepodge (1)


Generated by MeetBot 0.1.4.