#openstack-meeting: keystone

Meeting started by lbragstad at 18:01:56 UTC (full logs).

Meeting summary

  1. Announcement: Pike deadlines (lbragstad, 18:02:56)
    1. https://review.openstack.org/#/c/441999 (lbragstad, 18:03:02)

  2. Announcement: New release of keystoneauth today after the following merge (lbragstad, 18:04:30)
    1. https://review.openstack.org/#/c/442516/ (lbragstad, 18:04:37)
    2. https://review.openstack.org/#/c/442536/ (lbragstad, 18:04:37)

  3. VMT follow up from PTG (lbragstad, 18:05:29)
    1. https://openstack-security.github.io/collaboration/2016/04/26/threat-analysis-process.html (lbragstad, 18:06:01)
    2. https://openstack-security.github.io/collaboration/2016/01/16/threat-analysis.html (lbragstad, 18:06:01)
    3. https://openstack-security.github.io/collaboration/2016/04/26/threat-analysis-process.html (knangia, 18:16:39)
    4. ACTION: gagehugo and knikolla to start updating keystonemiddleware architecture doc and provide knangia and unrahul with an updated keystonemiddleware architecture diagram (lbragstad, 18:22:58)

  4. PTG Topics (lbragstad, 18:32:19)
  5. PTG Topics: Decouple auth from API version (lbragstad, 18:33:29)
    1. http://specs.openstack.org/openstack/keystone-specs/specs/keystone/backlog/decouple-auth-from-api-version.html (lbragstad, 18:33:34)

  6. PTG Topics: Materialized Path for HMT (lbragstad, 18:47:05)
    1. http://specs.openstack.org/openstack/keystone-specs/specs/keystone/backlog/materialize-project-hierarchy.html (lbragstad, 18:47:39)
    2. ACTION: keystone group to follow up on materialized path for HMT once we come to a conclusion on limits (lbragstad, 18:53:13)

  7. PTG Topics: Default Policy File (lbragstad, 18:53:41)
    1. http://specs.openstack.org/openstack/keystone-specs/specs/keystone/backlog/policy-default.html (lbragstad, 18:53:53)
    2. ACTION: lbragstad to remove policy default spec (lbragstad, 18:55:11)

  8. Reviews (lbragstad, 18:55:34)


Meeting ended at 18:59:49 UTC (full logs).

Action items

  1. gagehugo and knikolla to start updating keystonemiddleware architecture doc and provide knangia and unrahul with an updated keystonemiddleware architecture diagram
  2. keystone group to follow up on materialized path for HMT once we come to a conclusion on limits
  3. lbragstad to remove policy default spec


Action items, by person

  1. gagehugo
    1. gagehugo and knikolla to start updating keystonemiddleware architecture doc and provide knangia and unrahul with an updated keystonemiddleware architecture diagram
  2. knangia
    1. gagehugo and knikolla to start updating keystonemiddleware architecture doc and provide knangia and unrahul with an updated keystonemiddleware architecture diagram
  3. knikolla
    1. gagehugo and knikolla to start updating keystonemiddleware architecture doc and provide knangia and unrahul with an updated keystonemiddleware architecture diagram
  4. lbragstad
    1. lbragstad to remove policy default spec
  5. unrahul
    1. gagehugo and knikolla to start updating keystonemiddleware architecture doc and provide knangia and unrahul with an updated keystonemiddleware architecture diagram


People present (lines said)

  1. lbragstad (135)
  2. notmorgan (66)
  3. unrahul (26)
  4. knangia (16)
  5. knikolla (15)
  6. gagehugo (11)
  7. dstanek (10)
  8. edmondsw (7)
  9. ayoung (6)
  10. openstack (5)
  11. spilla (1)
  12. rderose (1)
  13. cmurphy (1)
  14. lamt (1)
  15. topol (1)


Generated by MeetBot 0.1.4.