18:00:02 <lbragstad> #startmeeting keystone
18:00:03 <openstack> Meeting started Tue Apr 11 18:00:02 2017 UTC and is due to finish in 60 minutes.  The chair is lbragstad. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:06 <openstack> The meeting name has been set to 'keystone'
18:00:07 <lbragstad> ping antwash, ayoung, breton, cmurphy, dstanek, gagehugo, henrynash, hrybacki, knikolla, lamt, lbragstad, notmorgan, ravelar, rderose, rodrigods, samueldmq, spilla
18:00:09 <cmurphy> o/
18:00:12 <gagehugo> o/
18:00:13 <lbragstad> o/
18:00:17 <spilla> o/
18:00:17 <knikolla> o/
18:00:21 <lamt> o/
18:00:23 <lbragstad> #link https://etherpad.openstack.org/p/keystone-weekly-meeting
18:00:25 <lbragstad> agenda ^
18:00:56 <samueldmq> o/
18:00:58 <samueldmq> heey
18:01:08 <ayoung> HI
18:01:19 <lbragstad> #topic announcements
18:01:26 <lbragstad> #info this week is pike-1
18:01:34 <lbragstad> which means pike proposal spec freeze
18:01:51 <lbragstad> if you have any last minute things to propose for Pike, this is the week
18:01:58 <ayoung> lbragstad, they have to be approved, or just submitted?
18:01:58 <dstanek> o/
18:02:06 <lbragstad> spec freeze is pike-2
18:02:14 <lbragstad> ayoung just submitted
18:02:17 <dstanek> ayoung: submitted
18:02:19 <ayoung> R
18:02:34 <lbragstad> #info roll call list has been pruned
18:02:47 <lbragstad> if you're not on the list, feel free to add yourself
18:03:01 <lbragstad> but i combined the roll calls we've taken to create the newlist
18:03:18 <lbragstad> # topic unified limits spec
18:03:30 <dstanek> it got trimmed way down
18:03:42 <lbragstad> yeah - it's real slim
18:03:47 <lbragstad> #link https://review.openstack.org/#/c/455709/
18:04:01 <lbragstad> in case you missed it, we merged sdague very well written doc on unified limits
18:04:33 <ayoung> Has anyone from the other teams looked at it?
18:04:49 <lbragstad> which was an overview document outlining an 1000 ft view of our approach to unified limits and eventually hierarchical quotas
18:04:53 <lbragstad> ayoung the original, yes
18:05:06 <ayoung> Right now, Keystone is the repository, but the consumers will be Cinder and the others
18:05:09 <lbragstad> we had buy in from cinder, nova, and neutron I think
18:05:16 <ayoung> Cool
18:05:30 <knikolla> this is the one that actually merged https://review.openstack.org/#/c/440815/
18:05:42 <lbragstad> #link https://review.openstack.org/#/c/440815/
18:05:58 <ayoung> Ah, looks like a good back-and-forth on that.  Cool
18:06:11 <lbragstad> we have glance sign off of on it,too
18:06:13 <ayoung> Nice to finally have some progress there.  Its only been 5 years
18:06:18 <lbragstad> right
18:06:39 <lbragstad> so - the next thing we have to do is start poking holes in the proposal sdague wrote up for the interface
18:06:52 <lbragstad> #link https://review.openstack.org/#/c/455709/
18:07:28 <lbragstad> keep in mind that all the other projects are going to be leveraging ^ that work in order to process limit information in order to enforce quota
18:07:57 <lbragstad> it might help to review it from that perspective
18:07:59 * lbragstad shrugs
18:08:26 <lbragstad> does anyone have questions on the unified limits approach?
18:09:13 <dstanek> there's been quite a few ways on how other services could use that data
18:09:14 <ayoung> We going to return quotas in the token validation response?
18:09:16 * ayoung ducks
18:09:17 <dstanek> #link https://review.openstack.org/#/c/441203/
18:09:30 <lbragstad> ayoung no - i don't think so
18:09:47 <dstanek> ayoung: no, i don't think it would be possible
18:09:52 <lbragstad> ayoung unless you were being sarcastic?
18:09:55 <ayoung> dstanek, course it would.
18:09:56 <dstanek> also it's limits we store and not quota
18:09:58 <ayoung> lbragstad, yes I was
18:10:03 <lbragstad> ayoung ok - good :)
18:10:18 <ayoung> dstanek, but actually, the service would know, based on the token, the set of limits it is going to need
18:10:34 <ayoung> would not be crazy to add in a header that said "included that data on token response"
18:10:38 <dstanek> ayoung: yep.
18:10:41 <ayoung> or request param
18:10:44 <lbragstad> dstanek yup - i don't expect the limits data to change much in a deployment, but it should be easy to do if needed
18:10:51 <ayoung> lets get it working, and we can optimize after
18:10:54 <dstanek> ayoung: but that might be a lot of data
18:11:20 <ayoung> dstanek, yeah, but if they are going to need it anyway, might as well get it up front
18:11:33 <ayoung> cheaper than multiple round trips, same amount of data
18:11:40 <ayoung> and can live in the token cache
18:11:49 <ayoung> not pushing for it, just saying it is not crazy crazy
18:11:51 <dstanek> ayoung: it'll be the same for all users of a project so getting it over and over isn't ideal
18:12:02 <ayoung> No per-user data?
18:12:11 <dstanek> and it's by service
18:12:12 <lbragstad> ayoung nope - it's per service/resource
18:12:18 <lbragstad> ayoung this is just the limit
18:12:19 <ayoung> ++
18:12:23 <lbragstad> not the quota
18:12:39 <dstanek> so you'd get limits for each thing that each service can do for a project, it's siblings and potientially it's parents
18:12:43 <ayoung> OK.  Still could be fetched on the first time a project is seen
18:12:55 <knikolla> what is the difference between quota and limits?
18:12:56 <ayoung> anyway, move ot
18:13:05 <lbragstad> a limit is the amount you're allowed
18:13:05 <ayoung> move on, we can optimize it later
18:13:11 <lbragstad> a quota is the amount you're using
18:13:18 <knikolla> lbragstad: gotcha
18:13:19 <dstanek> knikolla: limits are really just a count used in a quota calculation
18:13:51 <dstanek> luckily we won't be storing usage at all in this model
18:14:06 <lbragstad> (amen)
18:14:14 <lbragstad> #link http://specs.openstack.org/openstack/keystone-specs/specs/keystone/ongoing/unified-limits.html#limits-vs-usage-enforcement
18:14:17 <lbragstad> knikolla ^
18:14:29 <lbragstad> that's an example that helped me understand it
18:14:35 <breton> oh wow, it was merged
18:15:00 <lbragstad> breton yeah - now was have to move on to the next step
18:15:02 <lbragstad> #link https://review.openstack.org/#/c/455709/
18:15:27 <lbragstad> also - something else that might help in reviewing this is thinking about the library that is going to consume and process the data
18:16:01 <lbragstad> for those who might not know, it was proposed that was write a little library for all the projects to use to make the calculations
18:16:11 <lbragstad> that way enforcement is consistent
18:16:25 <lbragstad> #link http://specs.openstack.org/openstack/keystone-specs/specs/keystone/ongoing/unified-limits.html#common-behavior-between-projects
18:17:31 <lbragstad> any more questions on quota?
18:17:37 <lbragstad> or unified limits?
18:18:27 <lbragstad> cool
18:18:29 <lbragstad> we can move on then
18:18:33 <lbragstad> #topic open discussion
18:18:40 <lbragstad> i didn't have anything else for today's meeting
18:18:49 <lbragstad> does anyone have anything they want to talk about?
18:18:53 <ayoung> Yep
18:18:59 <dstanek> dangeous question
18:19:03 <ayoung> Middleware RBAC
18:19:07 <lbragstad> favorite recipes?
18:19:09 <ayoung> anyone dead set against it?
18:19:21 <ayoung> If so, please offer alternatives.
18:19:29 <ayoung> I'm all ears.  Er...eyes?
18:19:44 <ayoung> For example, dstanek does not like the URL based aspect of it.
18:19:52 <lbragstad> ayoung johnthetubaguy had a ton of questions
18:19:58 <ayoung> jamielennox was woried about performance
18:20:06 <ayoung> lbragstad, I answered his code review questions
18:20:08 <dstanek> ayoung: why performance?
18:20:22 <ayoung> dstanek, matchin the patterns against the route requested
18:20:22 <lbragstad> i feel like this topic is stretching the limit of IRC bandwidth
18:20:37 <ayoung> lbragstad, I was planning on discussing it at the summit
18:20:47 <ayoung> but looks like the dev side of the summit is going to be pretty light
18:20:53 <dstanek> ah, sure.
18:20:55 <ayoung> as in, is anyone going besides me?
18:20:56 <lbragstad> i was contemplating a video call of some kind
18:21:10 <ayoung> sure
18:21:12 <lbragstad> ayoung yeah - it's going to be light
18:21:34 <ayoung> I'd be happy to set up Google or Bluejeans or WhatApp, or whatever people want in ordr to discuss
18:21:48 <dstanek> ayoung: i'd be cool with that
18:21:51 <gagehugo> I think hangout had that issue of only 10 people max
18:22:02 <gagehugo> unless there is a business account?
18:22:02 <lbragstad> how many folks here would want to participate?
18:22:10 <knikolla> o/
18:22:11 <dstanek> i am meeting heavy tomorrow so Friday would work best, but i could juggle if need be
18:22:12 <ayoung> RH has a corporate Bluejeans account I can use, but people need to get the client installed
18:22:37 <lbragstad> what if we dedicate some time on Friday's office hours to it?
18:23:11 <ayoung> Works for me.  I already started the slides for my summit talk, so I can run through those at breakneck speed, and hopefully address the questions I've gotten thus far
18:23:16 <gagehugo> I'd be down for listening in
18:23:28 <breton> meet.jit.si
18:23:30 <breton> FOSS
18:23:48 <lbragstad> so i've got  - breton, gagehugo, ayoung, dstanek, knikolla attending for sure
18:23:51 <lbragstad> right?
18:24:05 <lbragstad> cc johnthetubaguy ^
18:24:10 <breton> lbragstad: nope, i'll pass
18:24:19 <lbragstad> breton timezone not idea?
18:24:23 <lbragstad> ideal*?
18:24:26 <ayoung> lbragstad, would love to get johnthetubaguy in there.  Willing to schedule it around him if needs be
18:24:30 <dstanek> lbragstad: what's johnthetubaguy's timezone?
18:24:30 <lamt> I'd like to listen in as well
18:24:35 <breton> lbragstad: don't have time for it :)
18:24:39 <lbragstad> dstanek +6 from us
18:24:41 <breton> lbragstad: just wanted to suggest a tool
18:24:49 <lbragstad> breton ++
18:24:51 <ayoung> breton, what did you call me?
18:25:12 <lbragstad> lamt ack
18:25:15 <dstanek> lol
18:25:22 <lbragstad> ok - so i think we're still under 10
18:25:38 <breton> ayoung: :( i don't get it
18:25:48 <dstanek> that'a about how many people were on rollcall!
18:25:51 <ayoung> " just wanted to suggest a tool"
18:26:05 <dstanek> breton: it's an Americanism
18:26:10 <ayoung> yeah
18:26:29 <ayoung> Google hangout least barrier to entry?
18:26:36 <lbragstad> i would think so
18:26:54 <lbragstad> but I'm open to hearing if it isn't feasible for someone
18:27:21 <lbragstad> does a ML thread communicating it seem appropriate?
18:27:43 <dstanek> google is my personal stalker so i'm fine with a hangout
18:28:12 <dstanek> lbragstad: well what's the hangout limit? you don't want 30 people dailing in just to watch
18:28:16 <ayoung> lbragstad, nah
18:28:28 <samueldmq> lbragstad: ayoung: there is still some life on https://review.openstack.org/#/c/452198/
18:28:34 <samueldmq> we keep discussing there, correct?
18:28:36 <ayoung> let me get this group.  knikolla and I have the talk at the summit for a wider audience
18:28:50 <lbragstad> right - that's what i was afraid of but I don't want it to seem like we're not being open
18:29:05 <ayoung> samueldmq, last update was Apr 6 8:51 AM  I hope that is live enough for you
18:29:25 <ayoung> lbragstad, any more than 10, and I think I'd have to do bluejeans instead
18:29:27 <lbragstad> #link  https://review.openstack.org/#/c/455629/
18:29:34 <samueldmq> ayoung: lbragstad commented on Apr 10
18:29:36 <lbragstad> johnthetubaguy ^ just posted that recently, too
18:29:59 <ayoung> Cool
18:30:06 <lbragstad> which I think is just another way to try and communicate
18:30:27 <dstanek> lbragstad: if there were interested in keystone development they's be here....we can also invite the peeple that are not here, but have comments on the specs
18:30:48 <lbragstad> dstanek yeah - that makes sense
18:30:59 <ayoung> Can we get a sense of how many people here are going to be at the Summit?
18:31:09 <lbragstad> alright - i'll start a thread (not on the ML) about getting something lined up for Firday and we'll use it to nail down a time
18:32:01 <lbragstad> ayoung i'm still up in the air
18:32:02 <dstanek> ayoung: 90% sure that i'm going
18:32:12 <lbragstad> i should hopefully have a better answer next week
18:33:22 <lbragstad> i think morgan and jamielennox both said they won't make it
18:33:45 <samueldmq> ayoung: I'll be there o/
18:33:57 <morgan> i def wont be there
18:34:03 <samueldmq> lbragstad: I know morgan won't
18:34:08 <samueldmq> morgan: ++ :-)
18:34:24 <gagehugo> I'll be there
18:34:39 * cmurphy will be there
18:34:56 <lamt> same.  I'll be there.
18:34:56 <lbragstad> before I forget
18:35:21 <lbragstad> #action lbragstad to send a note about organizing a policy chat on Friday
18:36:05 <lbragstad> does anyone have anything else?
18:36:17 <lbragstad> ayoung ?
18:36:22 <ayoung> Nah I'm good
18:36:25 <lbragstad> ok
18:36:31 <ayoung> bug me if you need specific reviews, please
18:36:50 <lbragstad> i think we can give folks some time back today
18:36:53 <lbragstad> which they can use to go review sdague's unified limits spec :)
18:36:57 <ayoung> Sounds good.
18:37:06 <lbragstad> thanks for coming everyone
18:37:14 <lbragstad> #endmeeting