18:00:13 <lbragstad> #startmeeting keystone
18:00:14 <openstack> Meeting started Tue Jun 20 18:00:13 2017 UTC and is due to finish in 60 minutes.  The chair is lbragstad. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:14 <samueldmq> hey
18:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:16 <henrynash> hi
18:00:18 <rderose> o/
18:00:19 <openstack> The meeting name has been set to 'keystone'
18:00:22 <samueldmq> henrynash: o/
18:00:23 <lbragstad> #link https://etherpad.openstack.org/p/keystone-weekly-meeting
18:00:27 <lbragstad> henrynash: rderose o/
18:00:30 <lbragstad> samueldmq: o/
18:00:31 <samueldmq> and rderose too
18:00:34 <spilla> o/
18:00:35 <samueldmq> :)
18:00:36 <knikolla> o/
18:00:40 <rderose> samueldmq: :)
18:00:51 <lbragstad> gettin' the band back together ;)
18:00:56 <rderose> ha
18:02:23 <lbragstad> alright - i suppose we can go ahead and get started
18:02:26 <lbragstad> #announcements
18:02:30 <raildo> o/
18:02:33 <lbragstad> #topic announcements
18:03:00 <lbragstad> #info review focus should be on features and efforts that have large patch sets
18:03:01 <hrybacki> o/
18:03:28 <lbragstad> e.g. policy-docs, project tags, api keys, documentation, etc...
18:03:31 <gagehugo> o/
18:03:57 <lbragstad> speaking of documentation, sjain and samueldmq shared a bunch of what they've accomplished last week
18:04:05 <lamt> o/
18:04:06 <lbragstad> and that's actually one of our topics for today
18:04:13 <lbragstad> #topic documentation follow-up
18:04:17 <lbragstad> samueldmq: sjain
18:04:18 <lbragstad> o/
18:04:44 <sjain> so the reorganisation of docs is here, https://review.openstack.org/#/c/475119/
18:04:58 <sjain> thanks for your reviews lbragstad
18:05:10 <sjain> I'll take those in accounts
18:05:20 <lbragstad> sjain: anytime - i think those patches look pretty good, thanks for putting them together
18:05:36 <sjain> the basic restructuring is done, we need to add some more descriptions in those
18:06:10 <sjain> meanwhile for the theme change, somehow the build failed https://review.openstack.org/#/c/466066/8
18:06:14 <lbragstad> for those who are unfamiliar with what's going to happen, there is a spec that details the work
18:06:17 <sjain> I'll look into that
18:06:18 <lbragstad> #link https://review.openstack.org/#/c/472275/
18:06:29 <henrynash> yeah, like the new split
18:06:47 <lbragstad> henrynash: ++
18:06:51 <lbragstad> i do too
18:06:53 <sjain> :)
18:06:59 <samueldmq> henrynash: ++ that's pretty awesome, the idea is to separate te docs for the different audiences
18:07:00 <lbragstad> i think it will give us an opportunity to clean up a lot of things
18:07:10 <samueldmq> so if you're a dev, all the docs for you will be in a single place, just for you
18:07:20 <samueldmq> lbragstad: that's my feeling too
18:07:31 <rderose> samueldmq: ++
18:07:35 <lbragstad> i'm not sure if this only applies to me, but i've always struggled with some of the content in our in-tree docs and if it should be in the offical openstack-manuals project
18:08:10 <samueldmq> lbragstad: yeah there might be some overlap (very likely)
18:08:14 <lbragstad> i'm hoping that if we pull more of that into our project, we'll have the ability to consolidate and reduce duplication if we notice any
18:08:38 <lbragstad> which is the plan according to the openstack-manuals spec
18:08:55 <samueldmq> yeah, lot of work going on
18:08:57 <sjain> Yes I have noticed some overlaps, which I will try to account while migrating
18:09:01 <samueldmq> luckily we have sjain with us :D
18:09:13 <sjain> happy to help :)
18:09:21 <lbragstad> yeah - we shouldn't be afraid to isolate the migration from the refactoring
18:09:35 <samueldmq> sjain: yeah, take notes, and make fixes after migrating
18:09:40 <samueldmq> so that we keep the migration clean
18:09:48 <samueldmq> what lbragstad just said
18:09:57 <lbragstad> that should make it easier for others to hop in and help too
18:10:06 <lbragstad> then we can start working patches in parallel
18:10:10 <sjain> yup sure
18:10:35 <lbragstad> sjain: from what I can tell, i think the migration looks good
18:10:53 <sjain> I migrated some docs and submitted the patches, but the docs team is currently working on those
18:10:59 <lbragstad> sjain: it also looks like the comments holding up the theme switch were addressed in a follow on patch
18:11:31 <sjain> yes in this one, https://review.openstack.org/#/c/475119/
18:12:05 <lbragstad> yep - good deal
18:12:19 <sjain> The comments mostly on toctree and sections are addressed with this reorganisation
18:12:39 <sjain> and overall it looks better
18:12:51 <lbragstad> just a word for everyone reviewing those patches, if they are organizing things that fall inline with what we have to do for https://review.openstack.org/#/c/472275/ then we should be sure to use the doc-migration branch
18:13:16 <lbragstad> that will make it easier for us to track that work
18:13:18 <samueldmq> lbragstad: branch -> patch?
18:13:21 <samueldmq> oops
18:13:22 <samueldmq> topic?
18:13:32 <lbragstad> er - topic, yes
18:13:38 <lbragstad> thanks samueldmq
18:13:57 <samueldmq> also
18:14:14 <samueldmq> there is a bunch of work in the docs migration (as per the cp spec lbragstad linked)
18:14:26 <samueldmq> so anyone is welcome to help with that too
18:14:26 <lbragstad> #link https://review.openstack.org/#/c/472275/
18:14:41 <lbragstad> ^ we'll need to accomplish the project specific items listed in that spec for Pike
18:14:47 <lbragstad> in order to be on track with the other projects
18:15:12 <lbragstad> luckily sjain and samueldmq have given us a good start
18:15:17 <samueldmq> yep, and we're ahead on the migration, we should be able to be done with it soon
18:15:17 <sjain> I'm anyways here to work on that :P
18:15:40 <lbragstad> awesome
18:15:42 <samueldmq> lbragstad: when is P-3?
18:15:55 <samueldmq> or when we'll have the rc's?
18:15:56 <lbragstad> sjain: samueldmq is there anything else you need from the rest of the team?
18:16:07 <lbragstad> samueldmq: let me check
18:16:13 <samueldmq> there will be more patches coming along the way
18:16:16 <samueldmq> they'll need love
18:16:17 <samueldmq> :)
18:16:27 <sjain> :D
18:16:48 <lbragstad> samueldmq: end of july
18:16:55 <lbragstad> july 24 - 28
18:16:58 <lbragstad> #link https://releases.openstack.org/pike/schedule.html
18:17:23 <lbragstad> also note that feature proposal freeze is next week
18:17:34 <lbragstad> #info keystone feature proposal freeze is next week
18:17:35 <samueldmq> that's close
18:17:43 <lbragstad> yes
18:17:48 <lbragstad> we should be in full on review mode
18:18:08 <samueldmq> ++
18:18:10 <lbragstad> anything else docs-wise?
18:18:16 <samueldmq> not from me
18:18:34 <sjain> nothing more for now
18:18:42 <lbragstad> good deal - moving on
18:18:46 <lbragstad> #topic Office Hours / Bug Days
18:18:48 <lbragstad> knikolla:
18:18:49 <lbragstad> o/
18:18:52 <knikolla> o/
18:19:01 <knikolla> We had bug day/office hours last friday. But nothing got merged because of low core attendance (only lbragstad). It would be nice to have at least 2 cores (3 would be ideal) during these activities so we can review and merge bugfixes.
18:19:13 <knikolla> To encourage more core attendance, we can either change the day to something more appropriate, instead of friday.
18:19:24 <knikolla> Alternatively, if we can’t find a day appropriate for everyone, I can keep track of everyone’s active hours and request reviews from them when they have shown time online.
18:19:31 <knikolla> </end copy paste>
18:19:37 <lbragstad> yeah - i like the idea of changing days
18:19:41 <gagehugo> ++
18:20:08 <lbragstad> with summer being here - it's hard to have good attendance on Friday's because of vacation and what-not
18:20:27 * hrybacki agrees
18:20:30 <lbragstad> which I find totally acceptable
18:20:38 <lbragstad> (not that anyone needs my permission)
18:20:48 <lbragstad> so - with that
18:21:00 <lbragstad> anyone have an alternate proposal for a bug day/office hours?
18:21:21 <hrybacki> lbragstad: do we want to dedicate an entire day?
18:21:21 <gagehugo> thursday?
18:21:34 <hrybacki> or would a half-day attract more folks?
18:21:34 <lbragstad> hrybacki: that's a good question, what do you have in mind?
18:21:39 <rderose> how about after this meeting?
18:22:01 <hrybacki> we'd need to poll the group but -- Thursday afternoons for example might be easier to fit into a schedule
18:22:13 <hrybacki> or following this meeting per rderose
18:22:18 <lbragstad> rderose: i was think something similar to that
18:22:24 <knikolla> ++ on poll. we're not having much attendance today to make a decision.
18:22:41 <hrybacki> knikolla: would you like to make a Doodle poll?
18:22:46 <lbragstad> rderose: other teams, like nova and openstack-ansible, dedicate 30 minutes to an hour to go through all new bugs and perform bug triage as a group
18:23:12 <hrybacki> lbragstad: I do like the idea of grooming the list and then setting goals to be accomplished by EOD
18:23:13 <rderose> lbragstad: I see, I like that idea
18:23:24 <lbragstad> hrybacki: rderose ++
18:23:30 <lbragstad> i do, too
18:23:51 <lbragstad> i think if we want to actually get something done, there is going to have to be some amount of goal setting
18:23:55 <hrybacki> lbragstad: knikolla do we have a 'contributor' list that accurately depicts those that are interested and able to help out?
18:24:15 <knikolla> hrybacki: stackalytics?
18:24:25 <lbragstad> we originally documented that here
18:24:27 <lbragstad> #link https://etherpad.openstack.org/p/keystone-office-hours
18:24:37 <hrybacki> knikolla: I'd say our targets are actually a subset of what would be on stackalytics
18:24:58 <knikolla> hrybacki: true, but that list is from october/november i think
18:25:01 <lbragstad> some folks are going tohave things pop up on various days that might limit their attendance
18:25:04 <knikolla> the one on the etherpad lbragstad linked
18:25:13 <hrybacki> lbragstad: of course
18:25:23 <hrybacki> knikolla: okay so maybe two first steps
18:25:48 <hrybacki> 1) Review list of people to help 2) Send Doodle poll to that group asking when (in general) would work best for them
18:26:14 <lbragstad> we could even just send it to the openstack-dev mailing list
18:26:17 <hrybacki> then we stick to that. Regular time/placed events attract a better following
18:26:34 <lbragstad> ++
18:26:36 <knikolla> ++
18:26:40 <hrybacki> lbragstad: we could. Personal emails will probably elicit a better response rate though
18:26:47 <lbragstad> hrybacki: true
18:27:05 <gagehugo> ++
18:27:09 <hrybacki> I think having a smaller, more committed crew (initially) will have a better pay off in the long run
18:27:18 <lbragstad> once we get consensus, we'll need a note sent to the openstack-dev mailing list advertising the changes
18:27:23 <hrybacki> ++
18:27:39 <lbragstad> another note about this effort
18:27:58 <lbragstad> i think it would be beneficial for all folks planning on attending to come with several bugs in mind
18:28:09 <lbragstad> how you go about collecting those is totally up to you
18:28:35 <rderose> lbragstad: ++
18:28:36 <lbragstad> but we can use our 30 minute meeting to consolidate our lists into what we want to work on
18:28:45 <lbragstad> and use that to set goals
18:28:45 <hrybacki> ++
18:29:17 <lbragstad> i think that'd be better than having one person dictate what we work on for the day
18:29:40 <lbragstad> if folks have the same bug on their list, they can break out into a group and blitz that specific set of bugs
18:30:44 <lbragstad> so - who's taking point on the Doodle?
18:30:51 <lbragstad> and sending the email?
18:31:27 <knikolla> lbragstad: i can do that, but i have a flight in a few hours
18:31:28 <hrybacki> I can construct the Doodle. knikolla lbragstad just give me the date/tiems
18:31:44 <lbragstad> ok - let's do that now
18:31:54 <lbragstad> if you have a date/time in mind, throw it out
18:32:02 <lbragstad> rderose: already proposed Tuesday afternoons
18:32:10 <hrybacki> how long specifically?
18:32:26 <lbragstad> I don't think I'd go shorter than 3 hours
18:32:35 <knikolla> lbragstad: i have no preferences. i am flexible on how i use my work hours.
18:32:49 <hrybacki> okay, so maybe Tues, Wed, Thurs evenings
18:32:55 <hrybacki> and Wed, Thurs mornings
18:33:04 <hrybacki> so we'll always have had this meeting prior
18:33:18 <lbragstad> so - nothing on monday or friday
18:33:24 <hrybacki> I think those are hard days
18:33:30 <lbragstad> i would agree
18:33:36 <hrybacki> Monday folks are catching up, Friday folks are winding down
18:33:51 <hrybacki> both have higher probability of folks just being gone
18:33:59 <lbragstad> hrybacki: so you're going to build a doodle with time slots for those days?
18:34:03 * hrybacki nods
18:34:07 <lbragstad> cool
18:34:17 <knikolla> sounds good
18:34:24 <hrybacki> I'll put a morning and an evening block for each day (less Tuesday)
18:34:30 <lbragstad> do we want to have two sessions a week or just one?
18:34:53 <hrybacki> start simple, grow complexity as it's needed
18:34:58 <lbragstad> e.g. how many votes do folks get?
18:35:09 <knikolla> lbragstad: one for now. after feature freeze we can have two maybe, since that will be the focus.
18:35:14 <hrybacki> ++
18:35:17 <lbragstad> knikolla: ++
18:35:21 <lbragstad> I'd agree
18:35:29 <lbragstad> let's get the format down and start proving that it works
18:35:36 <hrybacki> lbragstad: everyone in attendance gets one vote, cores get tie breaker rights?
18:35:50 <lbragstad> only if needed i'd say
18:35:55 * hrybacki agrees
18:35:57 <lbragstad> but we do need cores to be there
18:36:05 <knikolla> with a minumum of two cores
18:36:13 <lbragstad> i can make any of those times work,
18:36:28 <lbragstad> is there another core good with those days?
18:36:45 <samueldmq> Tuesdays morning?
18:37:04 <samueldmq> oops, it's said (less Tuesday)
18:37:09 <lbragstad> samueldmq: yep
18:37:15 <hrybacki> I'm not opposed to ^^
18:37:28 <samueldmq> well, I will do my best to be present
18:37:31 <samueldmq> when do we start?
18:37:41 <hrybacki> soon as we have the poll back
18:37:41 <knikolla> samueldmq: awesome! much appreciated!
18:37:47 <samueldmq> I wont complain to have things to review
18:37:50 <lbragstad> if we agree on a day later this week, i would say immediately
18:37:56 <samueldmq> and fix bugs, and make keystone better :)
18:38:32 <lbragstad> knikolla: hrybacki do you want to share the goal you have set? ;)
18:38:50 <samueldmq> 0-bugs in keystone by end of Queens
18:38:53 <samueldmq> :p
18:39:02 <lbragstad> :)
18:39:12 <hrybacki> that would be phenomenal
18:39:20 <knikolla> hahaha
18:39:26 <knikolla> including bug 968696? :P
18:39:27 <openstack> bug 968696 in OpenStack Identity (keystone) ""admin"-ness not properly scoped" [High,In progress] https://launchpad.net/bugs/968696
18:39:32 <hrybacki> LOL
18:39:44 * lbragstad hears a rewrite in the making
18:39:49 <samueldmq> ah well, we have that.
18:39:50 <hrybacki> hush now about 'bug-who-shall-not-be-named'
18:40:04 <samueldmq> the thing is, if we work on getting the list of open bugs really small
18:40:18 <samueldmq> it's just a matter of quickly triaging/attacking new bugs
18:40:26 * hrybacki nods
18:40:28 <lbragstad> yeah - it's a behavioral thing
18:40:29 <samueldmq> so we will always keep it small, and easy to keep track of
18:40:38 <hrybacki> 'It is easier to stay fit than get fit'
18:40:40 <samueldmq> lbragstad: exactly
18:41:04 <lbragstad> ideally - i think it would be great to get our bug queue down to 75 or less by the time we release Pike
18:41:23 <samueldmq> would be awesome
18:41:27 <samueldmq> + much better docs
18:41:32 <knikolla> with triaging and fixes should be doable
18:41:33 <samueldmq> would be a good deal for this cycle
18:41:42 <lbragstad> knikolla: ++
18:41:47 <hrybacki> that's a good gaol
18:41:49 <hrybacki> goal*
18:42:19 <lbragstad> we have a lot of work that is long-running, so filling the spaces with consistent and predictable bug work is a good thing to do
18:42:48 <lbragstad> #action hrybacki to build and send out doodle to collect feedback for new bug day times
18:43:06 <hrybacki> acl
18:43:07 <hrybacki> ack
18:43:24 <lbragstad> cool - hrybacki knikolla do either of you have anything else for office hours?
18:43:37 * hrybacki shakes his head
18:44:01 <knikolla> besides looking forward to it? :P
18:44:07 <lbragstad> good answer
18:44:12 <lbragstad> #topic open discussion
18:44:16 <lbragstad> floor is open
18:44:52 <hrybacki> I just want to say that after attending the upstream meetings for a couple months now things feel like they are going in positive direction :) Good job, team!
18:45:12 <lbragstad> hrybacki: thanks!
18:45:28 <knikolla> hrybacki: :)
18:46:15 <lbragstad> alright - well if we don't have anything else to go over, we can get some time back
18:46:27 <lbragstad> thanks for coming and look for hrybacki's note!
18:46:31 <lbragstad> #endmeeting