#openstack-meeting: keystone

Meeting started by lbragstad at 18:00:05 UTC (full logs).

Meeting summary

    1. https://etherpad.openstack.org/p/keystone-weekly-meeting (lbragstad, 18:01:00)

  1. announcements (lbragstad, 18:01:46)
    1. no meeting next week in observation of the 4th of July (lbragstad, 18:01:58)
    2. office hours have been moved from Friday to Tuesday 19:00 - 22:00 UTC (lbragstad, 18:02:34)
    3. http://lists.openstack.org/pipermail/openstack-dev/2017-June/118921.html (lbragstad, 18:02:51)
    4. we're two months away from release (lbragstad, 18:05:25)
    5. https://blueprints.launchpad.net/keystone/pike (lbragstad, 18:05:40)
    6. ACTION: rderose to assess and pick up the remaining federated attributes work (lbragstad, 18:12:10)
    7. ACTION: lbragstad to go through the deprecated-as-of-pike and removed-as-of-pike specs (lbragstad, 18:12:27)

  2. documentation migration (lbragstad, 18:12:35)
    1. https://review.openstack.org/#/c/469515/ (lbragstad, 18:13:07)
    2. https://review.openstack.org/#/c/474545/ (lbragstad, 18:13:11)
    3. https://review.openstack.org/#/c/474543/ (lbragstad, 18:13:30)
    4. https://etherpad.openstack.org/p/doc-migration-tracking (lbragstad, 18:16:14)

  3. PKI certificate cruft (lbragstad, 18:20:54)
    1. https://docs.openstack.org/developer/keystone/ (lbragstad, 18:21:25)
    2. https://review.openstack.org/#/c/476688/1 (lbragstad, 18:23:20)
    3. ACTION: lbragstad and sjain to go through the certification configuration options and assess them (lbragstad, 18:28:12)

  4. Cleaning up deprecated functionality/removals of Pike (lbragstad, 18:30:48)
    1. https://github.com/openstack/keystone/blob/9070172084fe31c9564de38886662fb198de68cb/keystone/cmd/cli.py#L26 (lbragstad, 18:32:04)
    2. https://github.com/openstack/keystone/blob/9070172084fe31c9564de38886662fb198de68cb/keystone/cmd/cli.py#L1097-L1101 (lbragstad, 18:32:22)
    3. https://github.com/openstack/keystone/blob/af4e98c770d771144463e6dd49cb4b559d48c403/keystone/auth/core.py#L38-L59 (samueldmq, 18:33:10)
    4. https://github.com/openstack/keystone/blob/9070172084fe31c9564de38886662fb198de68cb/keystone/cmd/cli.py#L1097-L1101 (lbragstad, 18:36:21)
    5. ACTION: lbragstad to remove domain_config_upload option (lbragstad, 18:36:38)
    6. https://github.com/openstack/keystone/blob/9070172084fe31c9564de38886662fb198de68cb/keystone/auth/core.py#L52-L57 (lbragstad, 18:37:05)
    7. https://github.com/openstack/keystone/commit/a5c5f5bce812fad3c6c88a23203bd6c00451e7b3 (lbragstad, 18:38:39)
    8. ACTION: lbragstad to send a note to the operator list about removing domain config upload functionality (lbragstad, 18:40:57)
    9. https://github.com/openstack/keystone/blob/9070172084fe31c9564de38886662fb198de68cb/keystone/auth/core.py#L52-L57 (lbragstad, 18:45:49)
    10. ACTION: samueldmq to propose patch for removing direct imports of auth plugins (lbragstad, 18:47:28)
    11. https://github.com/openstack/keystone/blob/9070172084fe31c9564de38886662fb198de68cb/keystone/conf/eventlet_server.py (lbragstad, 18:47:42)
    12. https://github.com/openstack/keystone/blob/9070172084fe31c9564de38886662fb198de68cb/keystone/conf/identity.py#L170 (lbragstad, 18:52:35)
    13. https://github.com/openstack/keystone/blob/9070172084fe31c9564de38886662fb198de68cb/keystone/conf/default.py#L162-L171 (lbragstad, 18:53:33)
    14. ACTION: lbragstad to propose removal date for secure ssl proxy configuration (lbragstad, 18:56:27)

  5. open discussion (lbragstad, 18:56:38)


Meeting ended at 18:58:47 UTC (full logs).

Action items

  1. rderose to assess and pick up the remaining federated attributes work
  2. lbragstad to go through the deprecated-as-of-pike and removed-as-of-pike specs
  3. lbragstad and sjain to go through the certification configuration options and assess them
  4. lbragstad to remove domain_config_upload option
  5. lbragstad to send a note to the operator list about removing domain config upload functionality
  6. samueldmq to propose patch for removing direct imports of auth plugins
  7. lbragstad to propose removal date for secure ssl proxy configuration


Action items, by person

  1. lbragstad
    1. lbragstad to go through the deprecated-as-of-pike and removed-as-of-pike specs
    2. lbragstad and sjain to go through the certification configuration options and assess them
    3. lbragstad to remove domain_config_upload option
    4. lbragstad to send a note to the operator list about removing domain config upload functionality
    5. lbragstad to propose removal date for secure ssl proxy configuration
  2. rderose
    1. rderose to assess and pick up the remaining federated attributes work
  3. samueldmq
    1. samueldmq to propose patch for removing direct imports of auth plugins
  4. sjain
    1. lbragstad and sjain to go through the certification configuration options and assess them


People present (lines said)

  1. lbragstad (162)
  2. samueldmq (24)
  3. hrybacki (17)
  4. bknudson (10)
  5. sjain (9)
  6. knikolla (7)
  7. gagehugo (5)
  8. dhellmann (4)
  9. rderose (3)
  10. openstack (3)
  11. rodrigods (1)
  12. spilla (1)
  13. lamt (1)
  14. raildo (1)


Generated by MeetBot 0.1.4.