18:00:08 <lbragstad> #startmeeting keystone
18:00:09 <openstack> Meeting started Tue Aug  1 18:00:08 2017 UTC and is due to finish in 60 minutes.  The chair is lbragstad. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:12 <openstack> The meeting name has been set to 'keystone'
18:00:16 <lbragstad> ping ayoung, breton, cmurphy, dstanek, edmondsw, gagehugo, henrynash, hrybacki, knikolla, lamt, lbragstad, lwanderley, notmorgan, rderose, rodrigods, samueldmq, spilla, aselius, dpar
18:00:20 <cmurphy> ohai
18:00:21 <edmondsw> o/
18:00:22 <knikolla> o/
18:00:22 <rodrigods> hey
18:00:22 <gagehugo> o/
18:00:25 <lbragstad> #link https://etherpad.openstack.org/p/keystone-weekly-meeting
18:00:29 <lbragstad> agenda ^
18:00:30 <spilla> o/
18:00:30 * cmurphy actually here today
18:00:41 <lamt> o/
18:00:49 <lbragstad> wow - y'all *almost* broke down the door
18:01:10 <rmascena> o/
18:01:43 <lbragstad> let's give it a minute or two for others to show up
18:01:45 <knikolla> the light agenda maybe :P
18:01:57 <lbragstad> knikolla: possibly!
18:02:21 <lbragstad> i won't lie - i don't mind the meeting being done in 30 minutes or less
18:03:36 <lbragstad> #topic announcements: release status
18:03:39 <rarora> o/
18:03:52 <lbragstad> last week we released pike-3 on schedule
18:04:10 <lbragstad> #link https://review.openstack.org/#/c/488411/
18:04:19 <lbragstad> we also released the final version of python-keystoneclient for pike
18:04:24 <lbragstad> #link https://review.openstack.org/#/c/488413/
18:04:40 <lbragstad> the only this is that pike-3 went out the door without project tags
18:05:17 <lbragstad> so - that's going to have to be one of the first things on our plate for queens
18:05:39 <lbragstad> thanks to rarora gagehugo lamt spilla and others for putting in all the work there
18:06:12 <lbragstad> that should be a pretty easy win to start queens off with
18:06:20 <lbragstad> #topic announcements: specs
18:06:24 <gagehugo> yeah it's pretty close
18:06:47 <lbragstad> but - we also need to clean up the specs repository to accurately reflect the things we didn't make into pike
18:06:52 <lbragstad> #link https://review.openstack.org/#/c/487534/
18:06:57 <lbragstad> #link https://review.openstack.org/#/c/487533/
18:07:36 <lbragstad> i've proposed bumping application creds and federated attributes to backlog until we're ready to start parsing what we want to go through for queens
18:07:49 <lbragstad> project tags will also needs a patch to bump it
18:07:52 <lbragstad> to backlog
18:07:53 <gagehugo> I can edit https://review.openstack.org/#/c/484529/ for that
18:08:08 <gagehugo> move it to backlog with those edits
18:08:18 <lbragstad> gagehugo: cool - thanks
18:08:36 <edmondsw> might want to move it to backlog separately and then get agreement on the edits
18:08:45 <lbragstad> #action gagehugo to propose https://review.openstack.org/#/c/484529/ to backlog until queens opens for development
18:09:54 <lbragstad> we have a lot of work that spilled over from pike this release - i think a big part of the PTG is going to be keeping discussions fresh to that we can carry things over gracefully
18:10:19 <knikolla> yeah
18:10:23 <gagehugo> edmondsw will do
18:10:31 <lbragstad> i'll get into that a bit more later
18:10:40 <lbragstad> now that we are in feature freeze
18:10:43 <lbragstad> #topic bugs
18:10:57 <lbragstad> we should be ultra focused on bugs, bug review, and triage
18:11:04 <lbragstad> #link https://goo.gl/F7Pc8x
18:11:14 <lbragstad> ^ that's a list of all bugs that are targetting pike-rc
18:11:25 <lbragstad> so - ideally, we need to have those fixed before we can get pike out the door
18:11:45 <lbragstad> if there is a bug in that list that you don't feel needs to be included in pike, let me know
18:12:21 <lbragstad> on the contrary, if there *is* a release blocking bug that pops up - let me know
18:12:41 <lbragstad> i'll be attending to that list daily for the rest of the release - reviewing and picking up whatever changes i can
18:13:14 <lbragstad> any questions on the current bug list?
18:14:18 <lbragstad> the good thing is that most of those bugs are in progress, so reviews should really help trim that list down
18:14:21 <edmondsw> microversions made the rc bug cut?
18:14:38 <lbragstad> edmondsw: this one?
18:14:41 <lbragstad> #link https://bugs.launchpad.net/keystone/+bug/1689644
18:14:41 <openstack> Launchpad bug 1689644 in OpenStack Identity (keystone) "Keystone does not report microversion headers" [Medium,In progress] - Assigned to Rohan Arora (ra271w)
18:14:56 <lbragstad> edmondsw: or microversion support in general?
18:15:01 <edmondsw> yeah... how quickly things can change. It was nearly unanimous at the PTG that we wouldn't do microversions :)
18:15:16 <knikolla> well… that's not really doing microversions :P
18:15:29 <lbragstad> knikolla: right - it's just communicating it to the caller
18:15:41 <lbragstad> real support for microversions still needs to be done
18:15:43 <edmondsw> how can you report microversions if you don't have microversions?
18:16:00 <lbragstad> edmondsw: the current approach returns 3.0 and 3.8
18:16:11 <lbragstad> as the min and max api versions
18:16:21 <lbragstad> for v3
18:16:24 <lbragstad> and 2.0 for v2.0
18:16:32 <lbragstad> but the approach is still in review
18:17:13 <edmondsw> sounds fun
18:18:20 <lbragstad> moving on
18:18:25 <lbragstad> #topic ptg planning
18:18:43 <lbragstad> i have an etherpad up to capture ideas we want to discuss at the PTG
18:18:45 <lbragstad> #link https://etherpad.openstack.org/p/keystone-queens-ptg
18:19:15 <lbragstad> and we're getting to the point where I need to start grouping things in bucket and organizing meeting times with other groups if we want to discuss cross-project things
18:19:29 <lbragstad> i assume the PTG is going to break down much like it did in Atlanta
18:19:42 <lbragstad> where the first couple days are going to be dedicated to cross-project initiatives
18:19:56 <lbragstad> and the last three are going to be project-focused
18:20:18 <gagehugo> will there be a policy meeting for cross-project?
18:20:30 <lbragstad> gagehugo: i fully expect to have one - yes
18:20:34 <gagehugo> cool
18:20:45 <lbragstad> it's one of the first topics i added for the cross-project section in the planning etherpad
18:20:54 <cmurphy> there's a schedule https://docs.google.com/spreadsheets/d/1xmOdT6uZ5XqViActr5sBOaz_mEgjKSCY7NEWcAEcT-A/edit#gid=397241312
18:21:00 <lbragstad> along with unified limits, application creds, etc...
18:21:15 <lbragstad> cmurphy: oh - good call
18:21:38 <cmurphy> and yeah looks like cross project stuff will be more monday/tuesday
18:21:55 <lbragstad> cool
18:22:16 <lbragstad> also - i sent out a reminder asking who was going to be attending
18:22:23 <gagehugo> there was short 1 hr meetings too at ATL, for some cross-project stuff
18:22:30 <lbragstad> the foundation would like to have an accurate estimate so that they can line up rooms properly
18:22:31 <gagehugo> idk how that works with the schedule
18:23:20 <lbragstad> if you're planning on attending the PTG please add your name to https://etherpad.openstack.org/p/keystone-queens-ptg if you haven't already done so
18:23:28 <lbragstad> gagehugo: yeah - i wasn't there the first two days in ATL
18:23:38 <edmondsw> lbragstad I will be there, but will probably be sitting in the nova room more than keystone
18:24:11 <lbragstad> edmondsw: ack
18:24:18 <lbragstad> edmondsw: i think we have a few people in that boat
18:24:20 <lbragstad> which is fine
18:24:34 <knikolla> as long as you join us for beer after, we're good
18:24:48 <lbragstad> this is what i wanted to spend the majority of the time on today
18:25:16 <edmondsw> :)
18:25:34 <lbragstad> is there anything on the current planning doc that people don't agree with?
18:25:39 <lbragstad> is there anything you *do* agree with?
18:25:56 <lbragstad> I'd like to get an idea of where people's interests lie and what they are hoping to work on and accomplish in pike
18:26:13 <lbragstad> (as a way to keep expectations in line and sane)
18:26:55 <knikolla> hmm.. is dstanek going to be there for the native saml topic?
18:27:01 <lbragstad> Personally for me - i'm going to be dedicating time to global role assignments  (along with championing community goals for policy)
18:27:02 <knikolla> he was championing it
18:27:18 <lbragstad> knikolla: he was - but I doubt he will make it to the PTG
18:27:23 <lbragstad> knikolla: i haven't heard anything yet
18:27:30 <cmurphy> app creds definitely a high priority for pike
18:27:37 <lbragstad> i completely agree
18:27:38 <knikolla> cmurphy: ++
18:28:04 <knikolla> i also want to see federated attributes. i'll probably pick it up if intel folks don't find the time to work on it.
18:28:06 <lbragstad> then again - unified limits has some pretty awesome payoffs and advantages that would be nice to have
18:28:51 <lbragstad> we also have to take a peak at oslo.policy to see if we can enhance it so that we can emit deprecation warnings when policy changes
18:29:05 * lbragstad is already feeling overwhelmed
18:29:12 <cmurphy> @.@
18:29:36 <knikolla> that's why we have 3 days at the ptg
18:30:23 <knikolla> lbragstad: how is read-only role a project specific thing?
18:30:49 <edmondsw> lbragstad looking at the room schedule, which of those rooms do you plan to have policy discussions in?
18:31:17 <gagehugo> yeah we should grab a room for that
18:31:41 <lbragstad> knikolla: good catch - moved
18:31:47 <lbragstad> edmondsw: the biggest one we can find?
18:31:53 <edmondsw> lol
18:32:00 <edmondsw> row 18?
18:32:02 <knikolla> lol
18:32:02 <lbragstad> edmondsw: the discussion we had in ATL was packed
18:32:11 <knikolla> i think that'll be detrimental
18:32:12 <lbragstad> or
18:32:36 <lbragstad> we coax people off-site?
18:33:03 <edmondsw> the API WG room was packed in ATL, and covered more than API WG stuff... maybe talk to them about carving out time there?
18:33:04 <lbragstad> but row 18 looks like it will work
18:33:23 <gagehugo> yeah the API-WG room in ATL was interesting
18:33:23 <lbragstad> we also don't need *every* project developer there
18:33:40 <lbragstad> i also assume there are going to be project developers who don't care about policy
18:33:51 <knikolla> contact your elected policy representative today :P
18:33:54 <lbragstad> but I'd figure at least 3 - 5 developers from each interested project?
18:33:58 <edmondsw> I'd kinda like it to be a dedicated room so people know that's going to be the topic and come accordingly
18:34:21 <knikolla> yeah, it being the nova room last time wasn't good.
18:34:24 <edmondsw> lbragstad that's some serious optimism! would be great
18:34:51 <edmondsw> having policy changes as a goal for queens should help attendance
18:34:58 <knikolla> honestly, i think teams should have a policy liason going forward
18:34:59 <edmondsw> and we can talk about more than policy-in-code
18:35:00 <lbragstad> yeah
18:35:10 <edmondsw> knikolla ++
18:35:27 <lbragstad> right - we really need to talk about breaking the scope check and putting it into code
18:35:48 * edmondsw nods vigorously
18:35:49 <lbragstad> it'd be nice to make some progress on a standard set of roles we should provide by default
18:36:38 <edmondsw> lbragstad that's a short list in my opinion... admin, member, observer
18:37:21 <lbragstad> yeah - but we can couple that with fixing admin-ness and isolating scope to in-code only and we're in a much better place
18:37:24 <edmondsw> maybe add a few internal roles, e.g. service, that we wouldn't expect end-users to ever have
18:37:36 <edmondsw> absolutely
18:38:06 <lbragstad> i'm really looking forward to doing what's needed to have those discussions in Denver
18:38:31 <lbragstad> but i'm also thinking it's going to take up most of my bandwidth for queens
18:38:58 <knikolla> seems fair. given that it's the single most important thing for now.
18:39:15 <lbragstad> yeah - in addition to application creds
18:39:24 <lbragstad> which i think have massive usability benefits
18:39:35 <knikolla> yeah, but requires less coordination with other teams
18:39:55 <lbragstad> yeah - we need to come to consensus on how to use them
18:40:32 <knikolla> besides the lifetime of an app cred. i thought that pretty much there was consensus?
18:40:52 <lbragstad> knikolla: yeah- i think the lifecycle is really the only thing left to discuss
18:41:05 <lbragstad> (there is some additional details about roping it into policy in the future, too)
18:41:12 <lbragstad> s/is/are/
18:42:14 <lbragstad> does anyone have things they'd like to get on the map for the PTG?
18:42:36 * lbragstad feels like he's been doing a lot of talking
18:42:59 <knikolla> i think the list is pretty comprehensive.
18:43:23 <lbragstad> ++ some topics are going to be pretty dense
18:43:35 <knikolla> i'd like to get another shot at revising 'role check in middleware' if folks want
18:43:53 <lbragstad> knikolla: hrybacki was talking to me about that a few weeks ago
18:44:00 <lbragstad> knikolla: you should be sure to check in with him
18:44:23 <knikolla> sounds good.
18:44:42 <lbragstad> #topic open discussion
18:44:44 <lbragstad> floor is open
18:46:48 <lbragstad> looks like we can get some time back
18:46:55 <lbragstad> office hours starts in about 14 minutes
18:46:58 <lbragstad> thanks for coming!
18:47:00 <lbragstad> #endmeeting