18:01:06 <lbragstad> #startmeeting keystone
18:01:06 <openstack> Meeting started Tue Aug 29 18:01:06 2017 UTC and is due to finish in 60 minutes. The chair is lbragstad. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:09 <openstack> The meeting name has been set to 'keystone'
18:01:15 <lbragstad> #link https://etherpad.openstack.org/p/keystone-weekly-meeting
18:01:18 <lbragstad> agenda ^
18:01:22 <cmurphy> o/
18:01:26 <lbragstad> ping ayoung, breton, cmurphy, dstanek, edmondsw, gagehugo, henrynash, hrybacki, knikolla, lamt, lbragstad, lwanderley, notmorgan, rderose, rodrigods, samueldmq, spilla, aselius, dpar
18:01:28 <lbragstad> o/
18:01:32 <rmascena> o/
18:01:35 <samueldmq> hello o/
18:01:37 <knikolla> o/
18:01:42 <rodrigods> o/
18:01:43 <gagehugo> o/
18:01:54 <hrybacki> o/
18:02:17 <lbragstad> pretty short agenda this week
18:02:30 <lbragstad> so we should have plenty of time for open discussion if needed
18:02:37 <spilla> o/
18:03:14 <lbragstad> #topic announcements: stable/pike
18:03:29 <lbragstad> stable/pike is out the door, with proper release notes
18:03:39 <cmurphy> \o/
18:03:49 <lbragstad> thanks everyone for all the hard work and making for a smooth release
18:03:53 <hrybacki> woot
18:03:55 <knikolla> \o/
18:04:01 <gagehugo> yay
18:04:16 <lbragstad> everything is being tracked in launchpad for stable/pike
18:04:36 <lbragstad> so if you see bugs come through and it's relevant, it should be business as usual for stable branches
18:04:47 <lbragstad> #topic PTG Planning and schedule
18:04:54 <lbragstad> #link https://etherpad.openstack.org/p/keystone-queens-ptg
18:05:19 <lbragstad> I have our schedule roughed out
18:05:43 <lbragstad> if anyone notices conflicts with other sessions - please let me know at your earliest convenience
18:05:55 <hrybacki> so, I won't be landing until 1100 on Monday but would love to participate in the policy-and-docs-in-code portion of the day
18:06:25 <lbragstad> i've sent notes to the mailing list advertising the schedule, but i haven't heard anything back yet
18:06:29 <lbragstad> so no news is good news, right?
18:06:49 <lbragstad> hrybacki: that's why i wanted to flip the sessions on tuesday
18:07:06 <lbragstad> do baremetal/vm stuff in the morning and policy in code in the afternoon
18:07:09 <hrybacki> ack. Are the VM/BM SIG discussions the same over two days?
18:07:10 <kmalloc> i'll be in late mondyaish
18:07:20 <kmalloc> and will be available tuesday -> friday early afternoon fwiw
18:07:29 <lbragstad> hrybacki: that's a good question
18:07:47 <samueldmq> lbragstad: 15 people, that's a good count
18:07:49 <lbragstad> i blocked off a lot of time there because i'm not sure when that groups plans to talk about specific things
18:08:08 * hrybacki nods
18:08:17 <lbragstad> those sessions involve a lot of other projects
18:08:32 <lbragstad> which is good - but we might have a queue of topics to get through before we get to keystone specific things
18:08:34 <hrybacki> silly question -- do we know that we'll have participation from the other projects?
18:09:05 <hrybacki> I've not been to a PTG so I'm not sure how the cross-project portion works out
18:09:09 <lbragstad> the baremetal/vm group contains of the core projects and focuses on making the entire platform better
18:09:18 * hrybacki nods
18:09:28 <hrybacki> so low priority? /s
18:09:29 <lbragstad> so far, all the sessions i've been to have had consistent representation from each project
18:09:36 <hrybacki> awesome
18:10:02 <lbragstad> which is part of the reason why we dedicate a specific day or two towards cross project work
18:10:12 <lbragstad> (hopefully minimizing conflicts
18:10:13 <lbragstad> )
18:10:27 <kmalloc> fwiw, i have a strong opinion on the limit bits now. so, i have *future* planning things, so i need to make sure that limit convo is when i'm available
18:10:42 <lbragstad> kmalloc: fantastic
18:10:51 <lbragstad> let's make sure we bring that up on tuesday then
18:11:14 <kmalloc> wfm
18:11:30 <lbragstad> noted in the etherpad
18:12:41 <lbragstad> anyone else have questions on the proposed schedule?
18:14:08 <lbragstad> #topic open discussion
18:14:28 <samueldmq> lbragstad: I have one question
18:14:35 <lbragstad> samueldmq: shoot
18:14:42 <samueldmq> why isn't "Role check in middleware" in the "Policy & RBAC" slot?
18:15:29 <lbragstad> samueldmq: oh - i think i put that in the vm/baremetal slot so that we could get more cross-project discussion going
18:15:42 <lbragstad> but it can certainly live in both
18:15:57 <samueldmq> it does actually
18:16:03 <lbragstad> actually - it is in the policy bit, too
18:16:06 <lbragstad> yep
18:16:08 <samueldmq> "RBAC Check in Middleware" is in the policy & rbac
18:16:33 <samueldmq> are we making sure the other folks driving the cross-project rbac stuff will attend it too
18:16:51 <samueldmq> since mon-tue is for the cross project goals (in policy in this case), correct?
18:16:58 <lbragstad> we should have representation available in the vm/baremetal sessions
18:17:12 <lbragstad> from the other projects
18:17:36 <samueldmq> ok, I see Global roles is already in vm/baremetal
18:17:49 <lbragstad> yeah - i'm still working on the PoC for it
18:18:00 <samueldmq> what about "Defining a standard set of roles" would that be nice to have cp discussions?
18:18:08 <lbragstad> #link https://review.openstack.org/#/q/topic:bp/global-roles
18:18:10 <samueldmq> in vm/baremetal
18:18:30 <samueldmq> well, I understand time is limited, and we can always pull more things in if we feel necessary
18:18:44 <lbragstad> yeah - i documented some more topics we should bring up in another etherpad, too
18:18:48 <lbragstad> #link https://etherpad.openstack.org/p/policy-queens-ptg
18:18:52 <samueldmq> schedule is looking great, lbragstad. well done
18:18:58 <lbragstad> thanks
18:19:07 <lbragstad> let me know if i missed something
18:20:13 <hrybacki> [raising general awareness] Has anyone responded to the doc team's request for verifying the install-guide? Looks like they asked us (and some others) specifically to verify and may be holding a 'Docs and Drinks' session evening during the PTG.
18:20:29 <lbragstad> hrybacki: i have not
18:20:58 <lbragstad> is anyone interested being a part of that validation?
18:21:03 <hrybacki> Okay. I'll likely attend that D&D session if it gets off the ground
18:21:29 <lbragstad> hrybacki: awesome - is the session dedicated to validating the install guide?
18:21:39 <lbragstad> or is there a different purpose?
18:21:41 <hrybacki> that was the impression I got out of the email
18:21:44 <lbragstad> ok
18:21:52 <hrybacki> feel free to assign me an AI for that
18:21:54 <lbragstad> so they are treating it like a work session
18:22:09 <hrybacki> I think so. I didn't see an etherpad with any specifics
18:22:20 <lbragstad> #action hrybacki to respond to the docs request for validating the install guide for keystone
18:22:21 <hrybacki> but that may have come in a reply since I last looked
18:22:30 <kmalloc> oh docs and drinks... not dungeons and dragons =/ :P
18:22:43 <hrybacki> kmalloc: I know :(
18:22:51 <lbragstad> the last thing i should do while drinking it writing docs
18:23:00 <lbragstad> is*
18:23:03 <hrybacki> lol
18:23:17 <lbragstad> i have a hard time with sentences sober ;)
18:23:24 <gagehugo> heh
18:23:33 <samueldmq> I'd be fun
18:23:34 <hrybacki> that work is for the editors :P
18:23:50 <lbragstad> hrybacki: depending on how the scheduling shakes out and when things happen, i might be able to tag along
18:24:11 <hrybacki> cool. It'd be good to network with the doc folks
18:24:20 <lbragstad> agreed
18:25:14 <hrybacki> lbragstad: I'd like to discuss the global scope PoC. How far you've gotten and how we (me) can step in to help. PTG is soooon
18:25:26 <hrybacki> but that can be a side convo if you feel that to be a better use of the groups time
18:25:26 <lbragstad> hrybacki: good question
18:26:02 <lbragstad> i can give a quick update
18:26:18 <lbragstad> so here is all the code i have
18:26:21 <lbragstad> #link https://review.openstack.org/#/q/topic:bp/global-roles
18:26:30 <lbragstad> which implements the ability to assign global roles to users and group
18:26:45 <lbragstad> and the last patch in that series allows you to scope tokens to global context
18:26:51 <lbragstad> so - that's the majority of the keystone bits
18:26:59 * hrybacki nods
18:27:16 <lbragstad> #link https://etherpad.openstack.org/p/keystone-global-roles-poc
18:27:26 <lbragstad> so - 1 and 2 in ^ are pretty much done
18:27:49 <lbragstad> next - is going to be making sure oslo.policy and oslo.context understand globally scoped tokens and pass that information along to the service
18:27:59 <lbragstad> then it's just wiring things up for the demo
18:28:43 <lbragstad> so - my goal is to get the oslo bits done this week and spend next week preparing a demo or a recording of the workflow (pending we don't have to make *massive* changes to each service)
18:29:02 <hrybacki> lbragstad: do you have hardware to work the demo on?
18:29:17 <lbragstad> hrybacki: my x1.carbon and devstack :)
18:29:28 <hrybacki> Okay :P
18:29:41 <hrybacki> where best can we step in to help you with this work now?
18:29:57 <lbragstad> hrybacki: help with the oslo bits would be awesome
18:30:05 <lbragstad> so - step 3
18:30:06 * knikolla goes to create a nova flavor called x1.carbon for his devstack
18:30:34 <hrybacki> lbragstad: okay. I've got cycles today and later this week which I can help out during
18:30:56 <hrybacki> but I may need some pointers to get me started in the right direction
18:30:58 <lbragstad> hrybacki: awesome - let me know when you want to dive in and we can sync on where to start
18:31:05 <hrybacki> lbragstad++
18:31:21 <lbragstad> also - reviews on the patches i have up would be a huge help
18:31:33 <lbragstad> they are pretty rough, but i've tried to break them into smaller bite-sized pieces
18:31:38 <hrybacki> ack. I'll look at those today so I have more context
18:31:46 <lbragstad> that'd be great
18:32:10 <lbragstad> anyone have anything else?
18:32:28 <samueldmq> lbragstad: I will look at project-tags
18:32:32 <samueldmq> then global roles
18:32:49 <samueldmq> if that order makes sense
18:33:15 <lbragstad> samueldmq: ++ yeah i need to take a gander at project tags again
18:33:43 <lbragstad> unless there are more questions, we can get some time back
18:34:09 <lbragstad> reminder: office hours starts at the top of the hour
18:34:31 <lbragstad> thanks for coming!
18:34:39 <lbragstad> #endmeeting