18:00:02 <lbragstad> #startmeeting keystone
18:00:02 <openstack> Meeting started Tue Oct 17 18:00:02 2017 UTC and is due to finish in 60 minutes.  The chair is lbragstad. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:06 <openstack> The meeting name has been set to 'keystone'
18:00:11 <lbragstad> #link https://etherpad.openstack.org/p/keystone-weekly-meeting
18:00:14 <lbragstad> agenda ^
18:00:22 <lbragstad> ping ayoung, breton, cmurphy, dstanek, edmondsw, gagehugo, henrynash, hrybacki, knikolla, lamt, lbragstad, lwanderley, kmalloc, rderose, rodrigods, samueldmq, spilla, aselius, dpar, SamYaple
18:00:25 <lbragstad> o/
18:00:26 <gagehugo> o/
18:00:28 <SamYaple> o/
18:00:31 <knikolla> o/
18:00:42 <hrybacki> o/
18:00:43 <edmondsw> o/
18:01:05 <kmalloc> zzzzz
18:01:20 <rodrigods> o/
18:01:34 <spilla> o/
18:03:02 <lbragstad> #topic announcements
18:03:08 <lbragstad> #info queens-1 is this week
18:03:09 <cmurphy> o/
18:03:26 <lbragstad> as a result - i'll be looking to schedule a retrospective within the next two weeks to recap queens-1
18:03:51 <lbragstad> i'm thinking we'll just hold it during office hours since folks are used to that time
18:04:18 <lbragstad> #info specification proposal freeze is this week
18:04:43 <lbragstad> if there is a spec you're working on that hasn't made it to review yet, be sure to at least push it by the end of the week
18:04:50 <lbragstad> remember this is only proposal freeze
18:04:51 <samueldmq> o/
18:05:12 <lbragstad> specification freeze will be queens-2
18:05:32 <lbragstad> we also have a bunch of trello cards coming due this week
18:05:33 <hrybacki> lbragstad: do we have any proposals we are expecting that haven't appeared yet?
18:05:34 <samueldmq> lbragstad: is ther eanything on the top of your head we had planned and did not propose a spec for yet?
18:05:41 <samueldmq> hmm .. .maybe the flask stuff
18:05:42 <hrybacki> samueldmq +1
18:05:56 <lbragstad> hrybacki: samueldmq not that i know of
18:06:10 * samueldmq nods
18:06:14 <lbragstad> as far as i know, everything we discussed at the ptg has been recorded in trello
18:06:17 <lbragstad> but...
18:06:32 <lbragstad> we do need to make those changes consistent with the keystone-specs repository
18:07:18 <lbragstad> (there are things we've committed to in trello that don't reflect that status in our specs repo)
18:08:12 <lbragstad> we have a bunch of things due this week, according to the dates we set in trello
18:08:18 <lbragstad> #link https://trello.com/c/b5ovuvqG/1-project-tags
18:08:38 <lbragstad> the project tags implementation is looking good, imo
18:09:02 <lbragstad> i feel like we can get the server bits merged by queens-1, and all the client bits by queens-2
18:09:48 <gagehugo> sure
18:09:53 <lbragstad> if you have spare review cycles - reviewing the project tags work would be awesome
18:10:12 <lbragstad> #link https://trello.com/c/25sBHXcM/14-write-up-a-specification-for-json-web-tokens
18:10:23 <lbragstad> thanks cmurphy for writing up the spec for ^
18:10:36 <cmurphy> reviews appreciated for that too
18:10:37 <lbragstad> i think that looks really good
18:11:12 <lbragstad> it'd be awesome to get that targeted for this release, but bandwidth is going to be hard
18:11:12 <gagehugo> yeah that's on my todo reading list
18:11:37 <lbragstad> either way - the spec does a great job of capturing the information and it should be an easy reproposal
18:11:55 <lbragstad> #link https://trello.com/c/XTkAiqaB/21-remove-v20-apis
18:12:04 <lbragstad> the last thing needed for ^ is a patch to tempest
18:12:22 <lbragstad> the v2.0 documentation removal is being tracked in #link https://trello.com/c/5WCMxrLg/12-docs-goals-organization
18:12:54 <lbragstad> but the removal card should be in Done by EOW so long as #link https://review.openstack.org/#/c/506751/ merges
18:13:26 <lbragstad> #link https://trello.com/c/Z6pUPEJu/3-oslopolicy-deprecation is getting close - i spent more time than i expected on that last week
18:13:49 <cmurphy> i also noticed the keystoneclient tests need to be updated after the v2 removal https://review.openstack.org/#/c/512509/
18:14:40 <lbragstad> cmurphy: aha - i assume there is more cleanup in ksc, too?
18:14:49 <lbragstad> (cleaning up v2.0 paths, etc...)
18:15:02 <cmurphy> probably
18:15:41 <lbragstad> when should we focus on removing those bits?
18:15:47 <gagehugo> that would make removing keystoneclient.session easier
18:15:54 <gagehugo> removing the v2 bits
18:16:02 <lbragstad> immediately? or should we allow for a grace period?
18:16:15 <lbragstad> (if someone still wants to use v2.0 should we force them to use an older client?)
18:17:07 <cmurphy> actually i don't think it makes sense to remove that from ksc right away
18:17:16 <cmurphy> people are more likely to update their clients than their services
18:17:24 <knikolla> ++
18:17:26 <lbragstad> yeah...
18:17:41 <lbragstad> should we table v2.0 removal from ksc and ksa for Rocky then?
18:19:18 <cmurphy> +1
18:19:28 <lbragstad> ok - i'll create a card in backlog
18:19:58 <lbragstad> #action lbragstad to create a trello card in backlog to slate v2.0 removal paths from ksa and ksc for Rocky
18:20:08 <lbragstad> #link https://trello.com/c/ZjsNk84y/4-oslopolicy-scope
18:20:12 <lbragstad> this one is iffy
18:20:25 <lbragstad> i'm going to be working on it today/tonight
18:20:37 <lbragstad> it's pretty straight forward - but it needs reviews
18:20:53 <lbragstad> I'm hoping to get it landed in oslo by queens-1 or very shortly after
18:21:25 <lbragstad> #link https://trello.com/c/XzM8IXy4/10-cross-project-policy-work
18:21:40 <lbragstad> this isn't necessarily due this week - but using it as a check point
18:21:57 <lbragstad> lots of patches are in review
18:22:01 <lbragstad> #link https://www.lbragstad.com/policy-burndown/
18:22:12 <lbragstad> only a few projects haven't started
18:22:37 <hrybacki> wonderful to see more repos in progress than not
18:22:51 <lbragstad> yeah - i was pretty stoked to see us get through 50%
18:23:23 <lbragstad> for folks interested in that - the reviews are super helpful
18:23:50 <lbragstad> ok - that's all i had for trello status
18:23:58 <lbragstad> is there anything i missed that folks want to mention?
18:24:09 <lbragstad> (with regard to what you're working on?)
18:24:47 <gagehugo> can you filter cards by due dates?
18:24:47 <cmurphy> it's not committed to in the trello board but i reproposed the app creds spec to queens just to get it in the queue
18:25:09 <lbragstad> cmurphy: nice - i'll put that in progress
18:25:13 <hrybacki> gagehugo: you can filter by labels
18:25:49 <hrybacki> so we could make milestone labels and that would allow you to filter properly
18:26:08 <gagehugo> ah ok
18:26:12 <gagehugo> was just curious
18:26:26 <hrybacki> ohhh you can actually. on the Trello menu, click 'Filter cards' and on the bottom you can pick some premade filters for date ranges
18:26:33 <lbragstad> nice!
18:26:46 <hrybacki> that's a new feature to me :)
18:26:53 <lbragstad> #link https://trello.com/b/5F0h9Hoe/keystone?menu=filter&filter=due:month
18:27:40 <lbragstad> #topic IAM session scheduling
18:27:46 <lbragstad> #https://beta.doodle.com/poll/ntkpzgmcv3k6v5qu
18:28:02 <lbragstad> #link https://beta.doodle.com/poll/ntkpzgmcv3k6v5qu
18:28:10 <lbragstad> besure to fill that out if you plan to attend
18:28:28 <lbragstad> i'll propose the session soon - but it will be next week sometime
18:28:36 <lbragstad> i still haven't heard from zaneb
18:28:52 * samueldmq will make sure to review project-tags again. and jwt
18:29:16 <lbragstad> so - be on the lookout of that if that's something you want to participate in
18:29:26 <lbragstad> #topic openstack/loci CI and images
18:29:32 <lbragstad> SamYaple: o/
18:29:36 <SamYaple> o/
18:30:04 <SamYaple> hey all. so a few months back i popped in talking about possibly putting dockerfiles in project repos
18:30:15 <SamYaple> we scraped that idea and went with a new project called LOCI
18:30:38 <SamYaple> great success has been made there, and with zuulv3 we now push directly to dockerhub on each commit to openstack/loci
18:30:57 <SamYaple> our next step is to push images when projects commit themselves
18:31:16 <SamYaple> we have done this with cinder already
18:31:17 <SamYaple> #link https://review.openstack.org/#/c/512398/
18:31:24 <lbragstad> SamYaple: so you'll bake a new image with each commit to keystone?
18:31:30 <SamYaple> and push!
18:31:31 <SamYaple> yes
18:31:50 <lbragstad> #link https://github.com/openstack/loci
18:32:00 <SamYaple> now, keystone doesnt actually need to do anything here, this is a request from infra that we talk with all the projects before we add a job to thier post pipeline
18:32:12 <SamYaple> but because its in the post pipeline, it wont affect keystone gating in anyway
18:32:32 <SamYaple> so this is more of a social question than a technical one, is keystone ok with a loci job in the post pipeline?
18:33:21 <lbragstad> i don't have an issue with it - the post pipeline seems like the appropriate place for something like this
18:33:51 <SamYaple> does anyone have any questions or concerns about this?
18:34:31 <samueldmq> seems awesome
18:34:33 <lbragstad> SamYaple: how is keystone setup in the container?
18:34:35 <samueldmq> what's the ultimate goal of this?
18:34:53 <SamYaple> samueldmq: better CICD
18:34:59 <SamYaple> lbragstad: pip installed
18:35:05 <samueldmq> run devstack in containers ? and then run the tests?
18:35:09 <lbragstad> running with Apache?
18:35:19 <SamYaple> lbragstad: you can optionally install apache2
18:35:26 <SamYaple> we actually use bindep to select profiles
18:35:38 <samueldmq> like, create an image of keystoen each time dependencies change. ci can be: install lastest image (with deps preinstalled), just put the code in
18:35:40 <samueldmq> and run the tests
18:36:04 <SamYaple> samueldmq: we were just talking about that in the channel. i would love to get devstack using loci images, optionally,
18:36:26 <SamYaple> there is a time delay between merge and post job that might make it bad for gates, but it should be fine for general dev
18:37:45 <lbragstad> sounds interesting
18:38:15 <knikolla> that sounds very cool
18:38:19 <cmurphy> where does it publish to? tarballs.o.o?
18:38:29 <SamYaple> lbragstad: we only install uwsgi by default, but `docker build https://github.com/openstack/loci.git --build-arg PROJECT=keystone --build-arg PROFILES="apache"`
18:38:32 <SamYaple> cmurphy: dockerhub
18:38:46 <lbragstad> SamYaple: aha - nice
18:38:54 <cmurphy> SamYaple: so what if dockerhub is down? does that delay the gate job?
18:38:56 <SamYaple> we actually had to get some new syntax into bindep to get this to work but https://review.openstack.org/#/c/512063/3/bindep.txt
18:39:05 <SamYaple> cmurphy: not at all. this is post pipeline
18:39:27 <cmurphy> okay, no objections from me :)
18:39:34 <SamYaple> technically the post job can fail and we wont push for that commit, so there is a small risk of not pushing, same with not publishing tarballs
18:40:03 <lbragstad> so you only push what you bless through testing
18:40:26 <SamYaple> unfortunately, zuulv3 doesnt have that part figured out yet
18:40:36 <SamYaple> so no matter what we test, what we push is "build only"
18:40:43 <lbragstad> ah
18:40:50 <SamYaple> once zuulv3 lets us share artifacts across jobs then testing and pushing can work
18:41:09 <lbragstad> yeah - i'm good with this then
18:41:18 <lbragstad> let us know if you need signoff on a commit
18:41:28 <SamYaple> ok i will submit the patch to project-config and ask for a signoff in the channel
18:41:38 <lbragstad> awesome - thanks SamYaple
18:41:39 <SamYaple> thanks all! and if you ahve more questions, #openstack-loci
18:41:52 <lbragstad> will do!
18:42:00 <lbragstad> #topic open discussion
18:42:05 <lbragstad> floor is open
18:42:26 <lbragstad> gentle reminder that office hours will be happening today
18:43:12 <lbragstad> we can focus on bugs or use the time to crush some spec reviews together
18:45:30 <lbragstad> if there is nothing else - we can break for a bit before office-hours
18:46:11 <lbragstad> thanks for coming!
18:46:15 <lbragstad> #endmeeting