18:00:05 <lbragstad> #startmeeting keystone
18:00:05 <openstack> Meeting started Tue Jan 23 18:00:05 2018 UTC and is due to finish in 60 minutes.  The chair is lbragstad. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:08 <lbragstad> ping ayoung, breton, cmurphy, dstanek, edmondsw, gagehugo, henrynash, hrybacki, knikolla, lamt, lbragstad, lwanderley, kmalloc, rderose, rodrigods, samueldmq, spilla, aselius, dpar, jdennis, ruan_he
18:00:09 <cmurphy> o/
18:00:10 <openstack> The meeting name has been set to 'keystone'
18:00:11 <hrybacki> o/
18:00:12 <lbragstad> #link https://etherpad.openstack.org/p/keystone-weekly-meeting
18:00:17 <lbragstad> agenda ^
18:00:17 <rderose> o/
18:00:19 <lbragstad> let's do this!
18:00:34 <hrybacki> good energy :)
18:00:49 <lbragstad> shakin' things up
18:01:07 <gagehugo> o/
18:01:34 <spilla_> o/
18:02:05 <lbragstad> we'll give folks another minute to join
18:02:31 <jessegler> o/
18:02:35 <knikolla> o/ (food took too long to arrive, will be monitoring the meeting from phone)
18:03:05 <lbragstad> #topic announcements
18:03:17 <lbragstad> let's go through the status of things
18:03:28 <lbragstad> #topic announcement: release status
18:03:36 <lbragstad> we're getting down to the wirte
18:03:41 <lbragstad> wire*
18:03:50 <lbragstad> feature freeze and client freeze are both friday
18:04:13 <lbragstad> with that, we did make a bunch of progress on reviews last week
18:04:18 <cmurphy> i think client freeze is thursday
18:04:20 <lbragstad> as noted in cmurphy's weekly recap
18:04:31 <lbragstad> cmurphy: oh - good call
18:04:52 <lbragstad> on that note - we should also be planning to have things *gating* on thursday if we want to land them this releas
18:04:54 <lbragstad> release*
18:05:01 <hrybacki> Do we need to request any FFEs?
18:05:54 <lbragstad> given the RC period is only two weeks, i'm not sure we'll have much time
18:06:01 * hrybacki nods
18:06:05 <cmurphy> requirements freeze is also friday http://lists.openstack.org/pipermail/openstack-dev/2018-January/126475.html
18:06:12 <lbragstad> but i expect we can assess on wednesday evening
18:06:29 <kmalloc> o/ i am unlurking now
18:06:54 <lbragstad> we have three major efforts left
18:07:08 <lbragstad> cmurphy: has been whipping up the application credential stuff
18:07:32 <lbragstad> which looks like it's waiting on a bug gix
18:07:33 <lbragstad> fix*
18:07:49 <lbragstad> cmurphy: anything you want to share there?
18:08:22 <cmurphy> the ansible folks brought up https://bugs.launchpad.net/keystone/+bug/1744948 with me so i'd like to get that fixed before merging anything else
18:08:23 <openstack> Launchpad bug 1744948 in OpenStack Identity (keystone) "allow_application_credential_creation contraint issue with suse + mariadb 10.2" [High,In progress] - Assigned to Colleen Murphy (krinkle)
18:08:42 <lbragstad> ack - i'll be reviewing that right after this meeting
18:08:46 <cmurphy> waiting for zuul results on that patch and they are testing it for me
18:09:09 <cmurphy> but everything else is looking good
18:09:15 <lbragstad> awesome
18:09:22 <samueldmq> nice
18:10:11 <lbragstad> the unified limits implementation is looking good, but we're working on pulling out a FK constraint that merged with the migration
18:10:39 <lbragstad> so that's gating on https://review.openstack.org/#/c/536644/
18:10:54 <lbragstad> dstanek is also looking into https://review.openstack.org/#/c/126030/25
18:11:09 <lbragstad> to make sure we captured all context of the problem before moving foward
18:11:12 <lbragstad> forward*
18:11:34 <lbragstad> the system scope stuff is just pending reviews
18:11:49 <lbragstad> there is a weird issue with tempest i started digging into with andreaf last night
18:12:09 <lbragstad> and that is happening when we add a system admin role to the admin user in bootstrap...
18:12:24 <lbragstad> not sure what the story is there yet, but that's one of the last patches in the series
18:13:12 <lbragstad> we're going to have a fast transition to rc period
18:13:35 <lbragstad> i still need to parse all keystone bugs for any show stoppers so that we can focus on those during that two week period
18:14:15 <lbragstad> if you interested in helping build out that list, let me know.. i want to try and have that done by monday at the latest so we have a list of things to shoot for for RC
18:14:30 <hrybacki> lbragstad: I can probably help you there
18:14:35 * cmurphy too
18:14:39 <gagehugo> bug stomp?
18:14:49 <lbragstad> hrybacki: cmurphy that'd be a massive help, i appreciate it
18:14:50 <samueldmq> Whooza
18:15:35 <lbragstad> feel free to tag things as queens-rc if it is something we need to fix before queens goes out the door
18:15:54 <lbragstad> #topic announcements: priority reviews
18:16:21 <lbragstad> for your reviewing convenience - we now have a review board dedicated to queens feature work we need to land this week
18:16:27 <lbragstad> #link https://goo.gl/NWdAH7
18:16:50 <lbragstad> if there is a review missing from there, let me know and i'll get it added (or removed)
18:17:12 <lbragstad> any questions on release related activity?
18:18:33 <samueldmq> Wow that list looks long for me
18:18:49 <lbragstad> yeah - 46 keystone patches and 4 client patches
18:18:58 <samueldmq> Priorities?
18:19:13 <lbragstad> d.) everything
18:19:14 <lbragstad> :)
18:19:27 <hrybacki> gates are gonna be in pain this week
18:19:28 <lbragstad> the good thing is that most of them are in good shape
18:19:30 <samueldmq> Cool, simple
18:19:36 <lbragstad> yes - that too
18:19:52 <samueldmq> I will try to do a few reviews this week
18:20:02 <lbragstad> i've been trying to baby sit them in off hours so we can maximize our reviews, but nothing beats being as early as possible
18:20:04 <samueldmq> As much as I can on that list
18:20:23 <samueldmq> hrybacki: that wont help :(
18:20:40 <hrybacki> samueldmq: I know -- but it happens every cycle :|
18:20:53 <hrybacki> good strategy lbragstad
18:21:18 <samueldmq> lbragstad: agreed, lets try to kill a few of then today and Tomorrow still
18:21:23 <hrybacki> office hours == review session?
18:21:34 <lbragstad> i'm good with that
18:21:59 <lbragstad> if people want to break up and review things in batches we can do that too
18:22:25 <samueldmq> lbragstad: thats a good strategy
18:22:34 <lbragstad> 2 - 3 people per feature?
18:22:40 <hrybacki> +1
18:22:44 <lbragstad> we can figure out that in office hours, too
18:22:49 <samueldmq> Make sure to distribute the cores wsll in the groups
18:22:54 <knikolla> +1
18:23:23 <lbragstad> alright - i'm going to hand it off to hrybacki
18:23:26 <lbragstad> #topic RH1 (CI) is coming down
18:23:29 <hrybacki> ack
18:23:43 <gagehugo> ++
18:23:46 <hrybacki> general awareness, the RH1 cloud (running TripleO CI OVB jobs) is coming down
18:23:51 <hrybacki> ahead of schedule actually
18:23:59 <hrybacki> https://bugs.launchpad.net/tripleo/+bug/1744763
18:24:00 <openstack> Launchpad bug 1744763 in tripleo "Ci: moving OVB jobs to RDO third party CI" [High,In progress] - Assigned to Sagi (Sergey) Shnaidman (sshnaidm)
18:24:08 <samueldmq> :(
18:24:19 <hrybacki> just general awareness -- the TripleO CI team is hammering away on this
18:24:51 <samueldmq> How representative is that in our current resource pool?
18:25:22 <hrybacki> samueldmq: that's hard to say. I don't think it will affect us too much. I don't think we have a billion gate jobs running OVB rn
18:25:33 <samueldmq> So that we could have an Idea of How much impact in current Ci capacity
18:25:57 <hrybacki> I'm honestly not sure -- been out of the upstream CI game for a cycle and things have changed a bit
18:26:07 <cmurphy> what is an ovb job?
18:26:19 <hrybacki> OpenStack Virtual Baremetal
18:26:38 <hrybacki> basically OpenStack on TripleO
18:26:43 <hrybacki> or quintupleo
18:27:09 <hrybacki> RH is pushing resources into a new cloud, RDO Cloud, and TripleO CI is expanding CI there
18:27:24 <cmurphy> is this something that affects keystone or is this related to infra resources?
18:27:54 <hrybacki> more related to infra resources -- I don't think it will hurt this team but I'm not 100% on that either
18:28:49 * hrybacki tries to find list of repos affected
18:30:09 <hrybacki> you can see the list in the 'same topic' section of this review: https://review.openstack.org/#/c/536507/2
18:31:04 <hrybacki> so mostly TripleO and THT related (didn't mean to eat up this much time in the mtg)
18:31:45 <hrybacki> that's all I have on that lbragstad
18:31:53 <lbragstad> no worries - thanks for the heads up
18:32:04 <lbragstad> #topic core reviewers
18:32:23 <lbragstad> for those who don't know yet, gagehugo became core last week :)
18:32:32 <hrybacki> congrats gagehugo :)
18:32:38 <gagehugo> :)
18:32:43 <lbragstad> i'm not sure who put this topic on the agenda thoguh
18:33:06 <gagehugo> wasn't me
18:33:17 <hrybacki> me -- just curious if we need to plan a way to gain more cores
18:33:17 <samueldmq> hehe
18:33:29 <samueldmq> Congrats gagehugo
18:33:30 <hrybacki> I know we talked about it at the last PTG -- and we've lost some since
18:33:36 <samueldmq> Well deserved
18:33:57 <gagehugo> samueldmq :) thanks
18:34:36 <lbragstad> i think a plan would be good - but i'm not sure how to approach building one
18:34:39 <cmurphy> i don't think we're ever going to have enough cores
18:34:47 <lbragstad> since it usually depends on the reviewer
18:34:54 <lbragstad> cmurphy: ++
18:35:04 <knikolla> make your first patch, get a free beer in dublin
18:35:19 <hrybacki> flight included? XD
18:35:43 <hrybacki> I guess the question is -- are nearing the point of /needing/ more core reviewers?
18:36:06 <lbragstad> i think review pressure has gone up - but i'm curious to hear what others think
18:36:09 <knikolla> we'll have a better answer after the progress today during office hours i think
18:36:23 <hrybacki> fair point knikolla
18:37:13 <hrybacki> okay, well let's put a pin in this for now
18:37:27 <lbragstad> ok
18:37:44 <lbragstad> #topic open discussion
18:38:13 <gagehugo> I feel like the pressure isn't just on keystone, a lot of projects seem to be hurting for reviewers
18:38:24 <cmurphy> yeah it's openstack-wide
18:38:31 <lbragstad> agreed
18:38:53 <gagehugo> :(
18:39:12 <lbragstad> the volume of work or need for it hasn't changed, though
18:39:31 <lbragstad> at least in my opinion
18:39:39 <lbragstad> or based on the people i talk to
18:40:09 <knikolla> i think it all comes down to how easy it is to have part time contributors
18:40:38 <knikolla> it's harder today to get paid to work a large chunk of your time upstream.
18:40:53 <hrybacki> ^^ +2
18:40:55 <gagehugo> knikolla ++
18:41:13 <lbragstad> yeah - that's going to be a big part of how we manage things going forward
18:42:22 <lbragstad> that was a big topic in sydney during the forum
18:44:49 <lbragstad> before we get into office hours, do we want to discuss breaking into review teams here?
18:44:59 <hrybacki> +1
18:45:15 <knikolla> ++
18:45:19 <hrybacki> fwiw I have the next 105 minutes free
18:45:32 <lbragstad> awesome
18:45:53 <lbragstad> i already planned on reviewing the application credential stuff, so we can get that unblocked
18:46:07 <lbragstad> and go through the entire stack again
18:46:27 <gagehugo> last week the app cred stuff worked for me
18:46:35 <lbragstad> if someone wants to join me, i'd appreciate the extra set of eyes
18:46:49 <hrybacki> I haven't had a chance to look at that stuff, I'd be happy to join
18:46:55 <lbragstad> cool
18:47:01 <knikolla> i've already done a fair chunk of system scope reviewing, so i'll keep on that.
18:47:09 <lbragstad> knikolla: perfect
18:47:23 <cmurphy> unified limits def needs more eyes
18:47:26 <lbragstad> ++
18:47:37 <gagehugo> I can look at whatever, I should be available all afternoon
18:47:47 <lbragstad> as soon as i'm done with the app creds stuff, i'll transition to unified limts
18:47:51 <lbragstad> limits*
18:48:05 * hrybacki fetches coffee before we begin
18:48:05 <lbragstad> (getting the app cred stuff gating would be good since it's close)
18:48:40 <lbragstad> gagehugo: do you want to pick through the unified limits stuff first?
18:48:43 * knikolla wishes the hazelnut coffee k-cups would arrive faster
18:48:52 <gagehugo> lbragstad yeah I can take a look at that
18:49:03 <lbragstad> gagehugo: thanks
18:49:26 <lbragstad> there is all the scope_types stuff, too (which cmurphy has already reviewed most of)
18:49:47 <gagehugo> I think I looked at them last week, will take another look
18:49:51 <lbragstad> (probably the lowest priority of the efforts though)
18:49:54 <gagehugo> ok
18:50:19 <knikolla> that should be easy reviews for the most part. and will block the gate for an entire day if we approve them all.
18:50:39 <lbragstad> we might be able to send a few through in batches
18:50:50 * lbragstad isn't a CI wizard though
18:51:04 <gagehugo> or push them through later in the day
18:51:04 * knikolla shrugs
18:51:16 <lbragstad> gagehugo: yeah - that might work, too
18:51:19 <gagehugo> things definitely run faster at 2am :)
18:51:56 <knikolla> good thinking. we can +2, and delay the +A for late night hours
18:52:11 <lbragstad> so long as two other cores +2 i'
18:52:24 <lbragstad> i'll +A at night if no one is around and the queue is clear
18:52:39 <lbragstad> (as long as people are OK with the process there)
18:52:44 <cmurphy> no one should be afraid to +A things, if it waits it waits but it's not going to knock over infra
18:54:02 <lbragstad> that works too, i'm going to be watching patches closely for the next few days anyway
18:54:11 <knikolla> cmurphy: you're right. I just feel like those are lower priority, so causing something higher priority which might need a respin to wait might be suboptimal. but whatever works.
18:54:27 <hrybacki> back
18:56:04 <lbragstad> #action lbragstad and hrybacki to review application credentials during office hours
18:56:13 <lbragstad> #action knikolla to review system scope during office hours
18:56:29 <lbragstad> #action gagehugo and lbragstad to review unified limits during office hours
18:57:56 <lbragstad> anything else people want to go through for reviews?
18:58:19 <hrybacki> that's a pretty solid start :)
18:58:26 <lbragstad> i'm happy with that plan
18:58:43 <lbragstad> give folks a minute to stretch their legs before getting started
18:58:46 <lbragstad> thanks all!
18:58:49 <lbragstad> #endmeeting