18:00:11 <lbragstad> #startmeeting keystone
18:00:12 <openstack> Meeting started Tue Jan 30 18:00:11 2018 UTC and is due to finish in 60 minutes.  The chair is lbragstad. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:13 <lbragstad> ping ayoung, breton, cmurphy, dstanek, gagehugo, henrynash, hrybacki, knikolla, lamt, lbragstad, lwanderley, kmalloc, rderose, rodrigods, samueldmq, spilla, aselius, dpar, jdennis, ruan_he
18:00:16 <openstack> The meeting name has been set to 'keystone'
18:00:21 <lbragstad> #link https://etherpad.openstack.org/p/keystone-weekly-meeting
18:00:23 <gagehugo> o/
18:00:23 <kmalloc> i'm here for a bit
18:00:25 <lbragstad> agenda ^
18:00:30 <kmalloc> even on vacashun
18:00:31 <lbragstad> kmalloc: aren't you on vacation this week?
18:00:38 <lamt`> o/
18:00:41 <kmalloc> yeah
18:00:42 <spilla__> o/
18:00:42 <henrynash> hi
18:00:44 <lbragstad> ah - well thanks for being here :)
18:01:08 <cmurphy> o/
18:01:24 <lbragstad> we'll give folks another minute or two
18:03:16 <lbragstad> alright - let's get started
18:03:19 <lbragstad> #topic release status
18:03:59 <lbragstad> now that features are mostly through... with the exception of application credentials, we started putting together a list of RC targeted bugs
18:04:06 <lbragstad> #link https://goo.gl/A5Wz4Z
18:04:13 <lbragstad> #link https://etherpad.openstack.org/p/keystone-queens-bug-list
18:04:29 <lbragstad> that second list is a list of all open bugs that haven't been resolved since queens opened for development
18:05:03 <lbragstad> most of those actually have fixes that are up for review..
18:05:17 <lbragstad> so getting those reviewed would be a good thing to get done, especially with the condition of the gate
18:05:20 <lbragstad> the earlier the better
18:05:42 <lbragstad> #topic release status: documentation efforts
18:06:02 <lbragstad> the last real big effort we have left to complete for this release is documentation work
18:06:16 <lbragstad> we do have an outreachy intern working on some of this stuff
18:06:38 <lbragstad> but, again, with the gate... i wouldn't be surprised if folks needed to jump in and give her a hand here and there
18:06:42 <lbragstad> just to get things processing faster
18:07:02 <lbragstad> the big item here is the v2.0 documentation... we can't let that go out the door if we've formally removed the API in queens
18:07:08 <lbragstad> so that's just something to watch out for
18:07:19 <lbragstad> and it blends into the next topic
18:07:30 <lbragstad> #topic release status: remaining v2.0 cleanup
18:07:48 <lbragstad> while we've removed the v2.0 APIs, there are a lot of things we need to clean up in the controller and what not
18:08:15 <lbragstad> i'm working on a couple patches to move the needle there, if you're interested in helping let me know
18:08:34 <lbragstad> and we can be a bit more tactical in how we divvy up the work
18:08:48 <lbragstad> #topic trello boards
18:08:52 <lbragstad> hrybacki: o/
18:09:13 <lbragstad> if hrybacki isn't around, i'll make this quick
18:09:24 <hrybacki> o/
18:09:31 <lbragstad> there he is
18:09:32 <hrybacki> sorry irccloud is being wonky
18:09:50 <lbragstad> hrybacki: want to share what we've done with the trello boards?
18:10:05 <hrybacki> Yes so, we have begun migrating work that was slated for Queens from the Queens board to a newly created Rocky board
18:10:16 <hrybacki> Apologies for lack of warning if you got pinged a bunch yesterday
18:10:19 <lbragstad> #link https://trello.com/b/wmyzbFq5/keystone-rocky-roadmap
18:10:30 <hrybacki> In total, we had 23 cards (including some epics) moved
18:10:51 <lbragstad> epics are going to be a little funny though, too
18:11:05 <hrybacki> WRT to epic cards, lbragstad and I thought the best approach would be to leave unfinished cards in Queens and then clone the card, port it to Rocky, and create a reference between them
18:11:19 <hrybacki> historical context per release will be a nice artifact from this
18:11:45 <hrybacki> we're operating under the assumption that the storyboard migration won't happen in Rocky
18:12:03 <lbragstad> based on the community goal proposal
18:12:07 * hrybacki nods
18:12:12 <lbragstad> it doesn't look like it's going to happen :-/
18:12:49 <lbragstad> we can certainly keep the process for handling epics between releases flexible - so if there is anything you notice in the current workflow, please share
18:12:56 <hrybacki> the Rocky board needs to be re-shaped in a follow up meeting that has yet to happen. Once lbragstad and I have that done feedback would be appreciated. We'll make sure to talk about Trello during the retrospective at PTG
18:13:07 <hrybacki> +1 lbragstad
18:13:15 <hrybacki> that's all I have. Anyone have any questions?
18:13:36 <lbragstad> in conclusion - the Queens board should be much more reflective of what what accomplished in total
18:13:39 <lbragstad> #link https://trello.com/b/5F0h9Hoe/keystone-queens-roadmap
18:14:57 <lbragstad> i know at the last ptg, much of the trello work was done after we left denver
18:15:08 <lbragstad> since we decided on it like Thursday
18:15:14 <gagehugo> yeah
18:15:14 * hrybacki nods
18:15:28 <lbragstad> is anyone against working through trello and shaping it as the week goes this next time?
18:17:51 <lbragstad> cool - if there isn't anything else we can move on
18:18:00 <lbragstad> #topic internship ideas
18:18:25 <lbragstad> we had someone come into the channel last week asking for internship ideas for google's Summer of Code internship
18:18:38 <lbragstad> i started jotting down ideas here
18:18:40 <lbragstad> #link https://etherpad.openstack.org/p/keystone-internship-ideas
18:18:44 <hrybacki> FWIW I think Patrole testing would be a great idea
18:19:06 <lbragstad> ++
18:19:10 <vkmc> o/ hey all, I'm coordinator for gsoc openstack
18:19:11 <hrybacki> I'll be focused on using it next release and would love to mentor someone
18:19:17 <hrybacki> o/ vkmc
18:19:20 <lbragstad> vkmc: aweome!
18:19:26 <lbragstad> awesome*
18:19:39 <lbragstad> vkmc: is there anything we need to be aware of?
18:19:41 <vkmc> I wasn't the one reaching you in the first place, but I'm here if I can help clarifying any doubt about the program
18:19:58 <hrybacki> I know there are concerns about the timelines
18:20:02 <lbragstad> i haven't dug into any of the details of the internship or what the expectations are
18:20:31 <hrybacki> vkmc: what are some common misconceptions you've found?
18:20:35 <vkmc> yes, gsoc have an organization application period (deadline was last week, we reached it and we are waiting from Google to tell us if we are selected or not)
18:20:35 <lbragstad> or the expected experience level of the interns, which will have some effect on the propose ideas
18:21:08 <vkmc> Google picks organizations according to the commitment a community shows with the program (how many mentors are interested, how many internship tasks, etc)
18:21:50 <vkmc> hrybacki, usually regarding how much time it consumes: it should take you more than 2 hours a week, students are expected to be independent and proactive and mentors are expected to act as a guide, not as a full time tutor
18:21:51 <lbragstad> is anyone here interested in mentoring?
18:22:23 <vkmc> lbragstad, we ask them to start contributing to the project they are interested it as part of their application for the internship
18:22:41 <hrybacki> lbragstad: If we were able to lock someone down for Patrole/Policy work, yes (I can justify that from down below)
18:22:42 <vkmc> so mentors (and the community, in this case, keystone team) get a feeling of how is working with that person
18:23:31 <vkmc> the applicants are students from all the world, technical experience may vary between applicants
18:23:46 <vkmc> they are new (or fairly new) to open source
18:24:33 <lbragstad> this all sounds pretty similar to the process for outreachy
18:24:44 <vkmc> lbragstad, pretty much the same :)
18:25:09 <vkmc> gsoc it's a 3 months internship, coding tasks only, students only
18:25:38 <vkmc> outreachy it's a 3 months internship, coding/documentation/i18n/marketing tasks, it doesn't matter if you are a student or not, underrepresented people in open source
18:25:42 <vkmc> that's the difference, in a nutshell
18:25:54 <lbragstad> that makes sense
18:25:55 <vkmc> if we are lucky, we will have both internship happening at the same time
18:26:07 <vkmc> internships*
18:26:22 <lbragstad> when would we need to have our list of possible proposals by?
18:26:25 <lbragstad> #link https://etherpad.openstack.org/p/keystone-internship-ideas
18:27:02 <vkmc> lbragstad, the sooner the better
18:27:26 <vkmc> deadline has passed and we are relying on internship ideas from other projects, but if we have your internship ideas as well, we have more chances to get selected by google and get more internship spots
18:28:03 <lbragstad> team - how long do you think it would take to go through and add/remove/vote on items?
18:28:05 <hrybacki> vkmc: what is the cycle on the program? twice a year?
18:28:19 <vkmc> hrybacki, once a year for gsoc, twice a year for outreachy
18:28:32 <vkmc> the internship happens in may-aug
18:28:33 <hrybacki> ack. thank you
18:29:02 <vkmc> this year timeline can be seen here
18:29:05 <vkmc> #link https://summerofcode.withgoogle.com/how-it-works/#timeline
18:29:20 * cmurphy can go through them after the meeting
18:30:10 <lbragstad> would EOW be too long?
18:30:18 <lbragstad> or do we need to have the list sooner?
18:30:24 <hrybacki> lbragstad: so maybe we review our internship ideas, identify people who would be willing to mentor for idea X, then submit those?
18:30:37 <lbragstad> yeah - that'd be a good idea
18:31:13 <vkmc> hrybacki++
18:31:34 <lbragstad> gagehugo: would anyone from the patrole team be interested in mentoring?
18:31:41 <vkmc> I don't think eow is too long
18:31:53 <gagehugo> felipemonterio^
18:31:53 <lbragstad> cool - so we can try to have that done by friday
18:32:03 <gagehugo> lbragstad I will ping them
18:32:30 <lbragstad> gagehugo: awesome - thanks (i tried pinging blancos)
18:32:38 <vkmc> feel free to join us in #openstack-gsoc
18:32:44 <knikolla> sorry i'm late
18:33:24 <vkmc> don't hesitate on pinging me or people in that channel if you have any doubt or concern about the program, mentoring, and how OpenStack participation is
18:33:31 <lbragstad> does anyone else have questions regarding the program?
18:33:39 <vkmc> there are mentors that have joined it in the past, to it and Outreachy
18:35:58 <lbragstad> thanks for the information vkmc
18:36:07 <hrybacki> +1
18:36:45 <lbragstad> #action team to work through internship ideas by Friday
18:37:05 <lbragstad> #topic keystone functional gate test
18:37:07 <lbragstad> gagehugo: o/
18:37:07 <vkmc> lbragstad, thanks all for bringing this topic up
18:37:09 <vkmc> o/
18:37:35 <gagehugo> There is a work in progress to setup a gate job to run keystone's functional tests
18:37:39 <gagehugo> #link https://review.openstack.org/#/c/531014/
18:38:02 <gagehugo> it still needs some minor fixing such as setting up a non-admin user
18:38:06 <gagehugo> but for the most part it works
18:38:29 <gagehugo> it builds an image from the current change, then deploys a keystone instance using openstack-helm
18:38:37 <gagehugo> https://github.com/openstack/openstack-helm
18:38:52 <lbragstad> does the current functional stuff use devstack?
18:38:53 <cmurphy> why does it use openstack-helm and not just like devstack?
18:39:16 <gagehugo> I don't think we currently run the functional tests anywhere
18:39:29 <gagehugo> there's only 6 of them atm
18:39:57 <lbragstad> if you pull devstack and set and environment variable, it will set something up for you i think?
18:40:03 <gagehugo> cmurphy OSH has an LDAP chart that would be good to use
18:40:05 <lbragstad> it's been a while since i've done that
18:40:13 <cmurphy> gagehugo: oh neat
18:40:25 <gagehugo> lbragstad I mean nothing in the gate does, I think I've gotten it to run locally before?
18:41:19 <gagehugo> the idea I had going was get something running, then start porting the unit tests that should be functional tests
18:41:34 <lbragstad> gagehugo: so are you looking for early reviews?
18:41:46 <gagehugo> yeah, just any thoughts for now
18:41:54 <gagehugo> not a big priority
18:41:55 <cmurphy> gagehugo: these would still just use `tox -e functional` right?
18:42:05 <gagehugo> cmurphy yup, it calls that in the playbook
18:42:10 <lbragstad> ++
18:42:12 <lbragstad> cool
18:42:17 <gagehugo> I would also like to make a shell script to run this locally too
18:43:35 <lbragstad> ideally - everything in test_v3_$RESOURCE.py is going to get ported to a functional test?
18:43:44 <gagehugo> lbragstad yeah
18:44:05 <lbragstad> and all the test_backend modules will stay as unit tests
18:44:58 <gagehugo> yeah, the tests that call the full stack should be moved to functional tests imo
18:45:11 <cmurphy> i think it would still make sense to keep the test_v3_* as unit tests too just so they're easy to run?
18:45:25 * lbragstad wonders
18:45:47 <gagehugo> this would probably be good to bring up at the PTG
18:46:02 <gagehugo> for the testing refactor story (epic)
18:46:12 <lbragstad> would it just be a difference of `tox -e py27 -- keystone.tests.unit.test_v3_resource.py ` versus `tox -e functional -- keystone.tests.unit.test_v3_resource.py`
18:46:25 <lbragstad> or keystone.tests.functional.test_v3_resource.py *
18:46:42 <cmurphy> no because you'd have to spin up devstack/helm in addition to running tox
18:46:50 <cmurphy> or am i misunderstanding
18:46:59 <lbragstad> that's a good question
18:47:07 <lbragstad> imo - and i could be wrong
18:47:22 <cmurphy> for example with the osc functional tests you have to start devstack and set your OS_ variables and then you can run tox
18:47:38 <gagehugo> that's how this osh gate is setup atm
18:47:43 <lbragstad> i think about having functional tests stand up some webtest app iff there isn't some override endpoint supplied
18:48:55 <cmurphy> ah that could work in theory
18:49:22 <cmurphy> but not for like ldap and federation testing
18:49:42 <lbragstad> yeah - that'd still need something to stand up the ldap/federation bits
18:49:56 <lbragstad> maybe we make that a hook, if it isn't already?
18:50:37 <lbragstad> i think devstack had a hook for federation setup
18:50:59 <cmurphy> knikolla: was working on that
18:51:07 <lbragstad> yeah
18:51:11 <cmurphy> but the point of using OSH is that ldap stuff is already there?
18:51:23 <lbragstad> right
18:51:46 <lbragstad> i know openstack-ansible wanted to have something similar so they could test ldap functional stuff
18:54:37 <lbragstad> either way - we should talk about this at the ptg
18:54:53 <gagehugo> ++
18:54:55 <cmurphy> ++
18:55:05 <lbragstad> gagehugo: anything else?
18:55:10 <gagehugo> nope that's all I had
18:55:15 <lbragstad> cool - thanks for the heads up
18:55:30 <lbragstad> #topic open discussion
18:55:41 <lbragstad> we have 5 minutes left
18:55:52 <lbragstad> does anyone have anything they want to share?
18:55:56 <gagehugo> ptg ticket prices go up on the 1st or 2nd?
18:57:12 <lbragstad> #link https://www.eventbrite.com/e/project-teams-gathering-dublin-2018-tickets-39055825024
18:57:27 <lbragstad> also - financial assistance is/was available if you need it
18:58:51 <lbragstad> we can end a couple minutes early
18:58:55 <lbragstad> thanks for coming!
18:58:56 <ayoung> ++
18:59:01 <lbragstad> #endmeeting