18:00:01 <lbragstad> #startmeeting keystone
18:00:03 <openstack> Meeting started Tue Feb 13 18:00:01 2018 UTC and is due to finish in 60 minutes.  The chair is lbragstad. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:04 <lbragstad> ping ayoung, breton, cmurphy, dstanek, gagehugo, henrynash, hrybacki, knikolla, lamt, lbragstad, lwanderley, kmalloc, rderose, rodrigods, samueldmq, spilla, aselius, dpar, jdennis, ruan_he
18:00:06 <openstack> The meeting name has been set to 'keystone'
18:00:18 <kmalloc> BUT I DUNT WANNA /needsmorecoffee :P
18:00:20 <kmalloc> ;)
18:00:34 <lbragstad> #link https://etherpad.openstack.org/p/keystone-weekly-meeting
18:00:36 <gagehugo> o/
18:00:36 <lbragstad> agenda ^
18:01:16 <knikolla> o/
18:01:48 <lbragstad> i know we have a couple people that are going to miss - but we'll give it another minute since the agenda is light today
18:03:20 <lbragstad> ok - let's get started
18:03:27 <lbragstad> #topic RC status
18:03:39 <lbragstad> so - a couple things cropped up
18:03:54 <lbragstad> we still have to figure out what is going on with the translations
18:04:08 <lbragstad> i attempted to back port those to stable/queens, but one apparently went into merge conflict
18:04:34 <lbragstad> i checked with the translation team yesterday and they suggested we wait to see what the proposal bot does today
18:04:45 <lbragstad> we'll likely have to follow back up with them
18:04:59 <kmalloc> wfm
18:05:02 <hrybacki> o/
18:05:04 <gagehugo> ok
18:05:05 <kmalloc> just ping me when it goes up if i don't see it
18:05:08 <kmalloc> i'll push those through
18:05:15 <lbragstad> kmalloc
18:05:16 <lbragstad> thanks
18:05:19 <lbragstad> in other news
18:05:20 <kmalloc> any proposal bot/release bot stuff for stab* branches is easy
18:05:39 <lbragstad> it's never a release without a fire of some kind
18:05:47 <kmalloc> eh, this isn't even a fire
18:05:50 <lbragstad> https://bugs.launchpad.net/keystone/+bug/1748970
18:05:51 <openstack> Launchpad bug 1748970 in OpenStack Identity (keystone) "Role assignment API doesn't prune system roles when querying role.id={role_id}" [High,In progress] - Assigned to Lance Bragstad (lbragstad)
18:05:52 <kmalloc> this is a mild smolder
18:06:14 <kmalloc> grizzly.. that was a fire of a release :P
18:06:15 <lbragstad> #Link https://bugs.launchpad.net/keystone/+bug/1748970 is going to need to be fixed and backported before we cut rc2
18:06:38 <lbragstad> in addition to that, i found another bug where system role assignments aren't cleaned up when users/groups are deleted
18:06:54 <lbragstad> #link https://review.openstack.org/#/c/543622/
18:07:10 <lbragstad> i apologize, this was my doing and likely a gap in my testing when i did the implementation
18:07:19 <lbragstad> i'm going to get bug reports open for ^
18:07:32 <lbragstad> so that we can track appropriate fixes for them and get them backported as well
18:08:23 <lbragstad> after that - we should be good to go
18:08:40 <samueldmq> lbragstad: cool
18:08:41 <lbragstad> i did talk to smcginnis yesterday about rc2, and he suggested we wait until the end of the week to propose it
18:09:00 <samueldmq> are all the tests for system scope consolidated in a place, such a separate test class?
18:09:14 <samueldmq> or are they mixed up with the other role assignment tests
18:09:14 <lbragstad> that's if we land the translations, the fix for 1748907 and the role assignment clean up patch
18:09:24 <lbragstad> they are in with the role assignment tests
18:09:44 * samueldmq nods
18:10:53 <lbragstad> i plan on getting all that stuff squared away during office hours
18:11:20 <lbragstad> qq for the group though, do we consider the fact that bootstrap doesn't assign the admin a role on the system a bug?
18:11:34 <lbragstad> #link https://review.openstack.org/#/c/530410/
18:12:17 <kmalloc> i'd say yeah
18:12:33 <kmalloc> since we're looking to transition to system-roles
18:12:40 <lbragstad> ok - i'll get another bug report open for that and repropose it
18:13:01 <lbragstad> otherwise it would be possible for people to lock themselves out of APIs
18:13:08 <lbragstad> if that bootstrapping didn't happen
18:13:35 <kmalloc> yep
18:13:52 <lbragstad> is anyone going to be around during office hours that can help expedite reviews for these?
18:14:22 <kmalloc> yeah. i'll be around
18:15:00 <lbragstad> awesome
18:15:24 <lbragstad> #action lbragstad to finish opening bugs for fresh rc blocking issues
18:15:32 <hrybacki> I'm heads down this week =/
18:15:40 <lbragstad> #action lbragstad to respin patches for release blockers
18:15:41 <hrybacki> yes, all of them
18:16:00 <lbragstad> #action kmalloc to review
18:16:02 <lbragstad> :)
18:16:21 <gagehugo> I'll be around but not super available
18:16:31 <lbragstad> gagehugo ack
18:17:29 <lbragstad> i think that's all i have on release status
18:17:44 <lbragstad> does anyone have anything else release-wise before we cut rc2?
18:19:01 <lbragstad> cool - sounds like we can move on
18:19:04 <lbragstad> #topic open discussion
18:19:44 <lbragstad> does anyone have anything in general?
18:20:40 <samueldmq> when are we cutting rc2?
18:20:55 <lbragstad> pending the fixes we need to land, we're shooting for the end of the week
18:21:03 * samueldmq nods
18:21:22 <lbragstad> but we have until next week
18:21:53 <samueldmq> ok, good
18:22:06 <lbragstad> yep - anything else?
18:23:38 <lbragstad> alright - i know everyone is busy, i appreciate the time!
18:23:45 <lbragstad> thanks for coming, all
18:23:47 <lbragstad> #endmeeting