16:01:56 <lbragstad> #startmeeting keystone
16:01:56 <openstack> Meeting started Tue Mar 19 16:01:56 2019 UTC and is due to finish in 60 minutes.  The chair is lbragstad. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:59 <openstack> The meeting name has been set to 'keystone'
16:02:06 <lbragstad> o/
16:02:11 <lbragstad> #link https://etherpad.openstack.org/p/keystone-weekly-meeting
16:02:14 <lbragstad> agenda ^
16:02:16 <wxy|> o/
16:03:09 <lbragstad> relatively light schedule today
16:04:02 <kmalloc> o/
16:04:12 <lbragstad> #topic RC1/RC2
16:04:14 <lbragstad> cmurphy o/
16:04:16 <gagehugo> o/
16:04:23 <ayoung> hey ho lets go
16:04:43 <cmurphy> so wrt rc1 I think we should cut it once https://review.openstack.org/641128 and https://review.openstack.org/642026 land
16:04:54 <lbragstad> ++
16:04:58 <cmurphy> then there are three bugs that i think are candidates for rc2
16:04:59 <kmalloc> wfm, i'll have the cache fix today
16:05:03 <kmalloc> so we can RC2 those
16:05:04 <cmurphy> #link https://bugs.launchpad.net/keystone/+bug/1801873
16:05:05 <openstack> Launchpad bug 1801873 in OpenStack Identity (keystone) "Unable to delete domains when users was managed by LDAP back-end" [Medium,New]
16:05:10 <cmurphy> #link https://bugs.launchpad.net/keystone/+bug/1819957
16:05:11 <openstack> Launchpad bug 1819957 in keystonemiddleware "Caching with stale data when a server disconnects due to network partition and reconnects" [High,Triaged] - Assigned to Morgan Fainberg (mdrnstm)
16:05:17 <cmurphy> #link https://bugs.launchpad.net/keystone/+bug/1817313
16:05:18 <openstack> Launchpad bug 1817313 in OpenStack Identity (keystone) "RBAC Enforcer Programming Error raised for malformed federation protocol request" [High,Triaged]
16:05:27 <kmalloc> the RBAC Enforcer will be harder to fix.
16:05:33 <kmalloc> might be later this week
16:05:35 <cmurphy> and if we agree we want an rc2 then that also gives us some extra time to land other system scope changes
16:05:48 * kmalloc is already voting for RC2
16:05:50 <lbragstad> agreed
16:05:52 <cmurphy> yeah
16:05:52 <kmalloc> cache bug alone
16:06:01 <kmalloc> the others are important to fix.
16:06:07 <lbragstad> fwiw
16:06:13 <cmurphy> are there other high priority bugs to highlight?
16:06:16 <kmalloc> but the cache one is likely to break things in weird ways and probably has in production
16:06:22 <cmurphy> the python3 ldap fixes just landed so those are good
16:06:36 <lbragstad> #link https://review.openstack.org/#/c/642102/ and #link https://review.openstack.org/#/c/624794/ landed so we should be able to get some of the system scope patches for users and projects moving
16:06:44 <cmurphy> yay
16:07:05 <gagehugo> cool
16:08:14 <lbragstad> are people leaning towards an RC2?
16:08:25 * cmurphy is
16:08:37 * gagehugo thinks it's a good idea for the caching issue
16:08:50 <lbragstad> do we want to track the patches we need for rc2 somewhere?
16:09:00 <lbragstad> dashboard, etherpad, post-it notes?
16:09:04 <gagehugo> couldn't hurt to etherpad it
16:09:30 <cmurphy> we can create a milestone thingy in launchpad and target rc2 bugs to that
16:09:37 <lbragstad> ++
16:09:47 * cmurphy does that
16:09:47 <lbragstad> what about patches in review? just trace through the bugs?
16:11:07 <cmurphy> maybe an etherpad is good for that
16:11:15 <lbragstad> ack
16:11:29 <lbragstad> anyone interested in wrangling that up?
16:12:28 <gagehugo> separate etherpad? or make it part of the weekly schedule until the due date?
16:12:38 <lbragstad> either or?
16:12:43 <lbragstad> i don't think i have a preference
16:13:40 <gagehugo> I can make one real quick then
16:14:16 <lbragstad> #action gagehugo to whip up an etherpad for patches that need to land for RC2
16:14:31 <cmurphy> thanks gagehugo
16:14:33 <gagehugo> #link https://etherpad.openstack.org/p/keystone-stein-rc2-tracking
16:15:05 <lbragstad> i assume we should get content in there by EOD and start pushing people to review them
16:15:19 <cmurphy> ++
16:15:28 <lbragstad> anything else for release candidates?
16:15:37 <cmurphy> nothing from me
16:15:50 <lbragstad> #topic Revisiting meeting time
16:15:52 <lbragstad> cmurphy again o/
16:16:13 <cmurphy> so it's the end of the cycle which is a good time to revisit the meeting time
16:16:31 <cmurphy> I'm also about to move to the US west coast and I think I'm the only person who currently attends from europe
16:16:45 <cmurphy> so it's a good opportunity to make this less painful for wxy| and vishakha
16:17:05 <knikolla> ++
16:17:39 <lbragstad> ++
16:17:56 <gagehugo> ++
16:18:11 <knikolla> so what time would work best?
16:18:19 <cmurphy> I can draw up a doodle poll to find a new time
16:19:03 <lbragstad> #action cmurphy to organize a doodle to find a new meeting time
16:19:11 <lbragstad> thanks
16:19:24 <cmurphy> I'll send the poll to the mailing list
16:19:29 <lbragstad> awesome
16:19:35 <lbragstad> anything else on meeting times?
16:19:40 <cmurphy> we can probably keep the current time for next meeting and announce the new time then?
16:20:01 <lbragstad> yeah - i'd give at least a week or two before adopting the new time, whatever that is
16:20:03 <knikolla> ++
16:20:07 <gagehugo> sounds good
16:20:08 <cmurphy> mmk
16:20:28 <lbragstad> anything else on the meeting time?
16:20:43 <cmurphy> not from me
16:20:46 <lbragstad> #topic review
16:20:51 <lbragstad> er - reviews*
16:21:05 <lbragstad> does anyone have things that need reviews? outside of what we already discussed for RC2?
16:21:27 <lbragstad> additionally, if you do have things that are needed for RC2, you should add them to the etherpad :)
16:21:28 <lbragstad> #Link https://etherpad.openstack.org/p/keystone-stein-rc2-tracking
16:22:20 <cmurphy> I don't have anything to highlight atm
16:22:49 <lbragstad> sounds good
16:23:12 <lbragstad> if something does come up - please be loud and let people know, now is the time to get eyes on things we need for stein
16:23:24 <lbragstad> #topic open discussion
16:23:43 <lbragstad> so i responded to a note to the mailing list about duplicate forum sessions
16:23:48 <lbragstad> is anyone else following that?
16:24:04 * gagehugo looks at his email
16:24:25 <kmalloc> as an FYI, i may or may not be at the summit
16:24:32 * lbragstad nods
16:25:20 <kmalloc> discussing some timing with brie now to see how this all will work out timing wise
16:25:22 <knikolla> schrodinger's kmalloc
16:25:59 * cmurphy torn on duplicate sessions
16:26:01 <kmalloc> nah, it's the heisenberg-uncertaintey kmalloc
16:26:11 <kmalloc> you can either know where i am or where i am going.
16:26:16 <kmalloc> :P
16:26:24 <kmalloc> i might just pass over the summit
16:26:31 <lbragstad> cmurphy what are your thoughts?
16:28:12 <cmurphy> i feel like nova is always the first target for changes like these so ironing things out with them is probably going to end up applying to everyone else
16:28:31 <cmurphy> but they're also pretty big topics and maybe worth taking double time?
16:28:33 <cmurphy> idk
16:28:53 <lbragstad> oh - that's true
16:29:24 <cmurphy> or maybe scope should be two sessions and limits condensed to one session?
16:29:38 <lbragstad> literally, my *only* hesitation for keeping both sessions for unified limits and policy is splitting the audience
16:29:46 <cmurphy> yeah
16:30:13 <lbragstad> also - i'm trying to remind myself that this is forum specific
16:30:26 <lbragstad> so - operators should be at the fore-front of our intended audience, imo
16:30:51 <lbragstad> since we can push developer conversations to the PTG
16:31:01 <cmurphy> hmm i thought forum was more about cross collaboration than operator-specific
16:31:16 <gagehugo> operators like to come to forums though
16:31:31 <gagehugo> s/like to/often
16:31:44 <lbragstad> that's the part i'm kinda concerned about
16:31:59 <gagehugo> but idk about the center concept
16:33:37 <cmurphy> lbragstad: so if you think operators should be the intended audience, does that mean you think the sessions should be condensed or left separate?
16:34:04 <lbragstad> hmm
16:34:14 <lbragstad> i was thinking condensed... but...
16:34:43 <lbragstad> that was because the forum sessions would be specific to relaying information operators need to know about unified limits or policy migrations
16:35:02 <lbragstad> then we have those conversations fresh in our minds for developers specific conversations later in the week?
16:35:16 <lbragstad> i think i was expecting a forum session for each to suffice
16:35:22 <lbragstad> but, maybe not?
16:36:19 <lbragstad> i know some groups do 'part 1' and 'part 2' sessions at the forum?
16:36:23 <lbragstad> s/?//
16:36:34 <lbragstad> idk if people think that makes sense here
16:37:32 <kmalloc> i think for big topics it makes a lot of sense to part 1/2 it
16:37:42 <cmurphy> reading melwitt's email it looks like she's also focused on gathering feedback from operators and users in both cases, and i think the feedback for nova will most likely apply to other projects, so i think it makes some sense to condense them and then dive deeper during the ptg if we need to
16:38:07 <lbragstad> yeah - i certainly think those sessions will be useful for other services
16:39:20 <lbragstad> kmalloc how would you break it up into two sessions?
16:40:01 <cmurphy> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-March/003894.html
16:40:09 <cmurphy> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-March/003951.html
16:40:14 <cmurphy> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-March/003994.html
16:40:41 <lbragstad> nice - thanks
16:40:58 <kmalloc> not sure
16:41:15 <kmalloc> usually it's just been extended conversations with a focus on the groups present
16:41:19 <kmalloc> e.g. nova/others
16:42:50 * gagehugo has to run to another meeting
16:44:59 <lbragstad> does anyone else have opinions on what we should do here?
16:46:01 <lbragstad> otherwise - i would mind hearing from the foundation or melwitt on how we can consolidate and what that even looks like if we can do that
16:46:03 <cmurphy> I think I lean toward either a) condensing both or b) condensing limits and keeping scope as part1/part2
16:46:23 <lbragstad> ok
16:46:35 <lbragstad> i assume a is your preference?
16:47:03 <cmurphy> only because it means slightly less running around :)
16:47:15 <lbragstad> hey, i'm all for that
16:47:35 <lbragstad> we should loop in melwitt and maybe diablo_rojo though?
16:48:00 <lbragstad> if we consolidate, we might have to amend descriptions and whatnot
16:48:18 <lbragstad> and we might still have to do that if we don't consolidate in order to differentiate the sessions
16:48:49 <cmurphy> ++
16:49:03 <lbragstad> alright
16:49:17 <lbragstad> sounds like we need to catch up with those two or jamesmcarthur
16:49:26 <lbragstad> but we can do that at some point today
16:49:33 <lbragstad> does anyone have anything else to go over?
16:49:51 <jamesmcarthur> hello
16:50:03 <lbragstad> jamesmcarthur yo
16:50:25 <lbragstad> we have some questions on forum sessions that probably need your help with
16:50:30 <jamesmcarthur> sure, hit me
16:50:33 <lbragstad> but we need melwitt to discuss it, too
16:50:34 <lbragstad> i think
16:50:48 <jamesmcarthur> ok - np
16:51:07 <jamesmcarthur> i should be online most of today, otherwise feel free to email
16:51:26 <lbragstad> can we ping in -dev if we congregate today?
16:53:51 <lbragstad> alright - i don't have anything else
16:54:14 <lbragstad> we have office hours in about 10 minutes for those interested
16:54:37 <lbragstad> thanks for the time everyone!
16:54:43 <cmurphy> thanks lbragstad!!
16:54:43 * lbragstad slides the keys to cmurphy
16:54:52 <lbragstad> #endmeeting