16:00:25 <cmurphy> #startmeeting keystone
16:00:25 <openstack> Meeting started Tue Mar 26 16:00:25 2019 UTC and is due to finish in 60 minutes. The chair is cmurphy. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:25 <lbragstad> o/
16:00:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:28 <openstack> The meeting name has been set to 'keystone'
16:00:39 <cmurphy> #link agenda https://etherpad.openstack.org/p/keystone-weekly-meeting
16:01:09 <vishakha> o/
16:01:19 <gagehugo> o/
16:02:04 <cmurphy> lbragstad: did you have an agenda item? i thought there was something from you
16:02:21 <lbragstad> nope - bad copy/pasta i think on my part
16:02:35 <cmurphy> okay
16:02:46 <cmurphy> #topic announcements
16:03:00 <cmurphy> I sent a meeting poll on the mailing list but failed to advertise it effectively
16:03:12 <cmurphy> so we can wait a bit before deciding on a slot
16:03:16 <cmurphy> and I can pester people
16:03:22 <cmurphy> #link https://doodle.com/poll/zxv6d2mxngmhb3vc
16:03:55 <cmurphy> so let's say next meeting will be at the same time same place?
16:04:12 * lbragstad nods
16:04:22 <vishakha> yes.
16:05:33 <cmurphy> #agreed next meeting at usual time, decide new meeting slot then
16:05:40 <cmurphy> #topic rc2
16:05:48 <cmurphy> #link https://etherpad.openstack.org/p/keystone-stein-rc2-tracking
16:06:37 <cmurphy> we are powering through that list pretty well
16:06:50 <cmurphy> all most everything is merged, there are a few outstanding reviews on the botton
16:07:10 <cmurphy> the only thing without a fix proposed afaict is for the rbacenforcer issue
16:07:22 <cmurphy> #link https://bugs.launchpad.net/keystone/+bug/1817313 RBACEnforcer error
16:07:23 <openstack> Launchpad bug 1817313 in OpenStack Identity (keystone) "RBAC Enforcer Programming Error raised for malformed federation protocol request" [High,Triaged]
16:08:25 <cmurphy> is there anything missing from that etherpad?
16:09:08 <knikolla> o/
16:09:21 <gagehugo> not that I know of
16:09:21 <kmalloc> o/
16:09:28 <lbragstad> i think it looks pretty good
16:09:31 <cmurphy> hi guys
16:09:35 <kmalloc> yeah the RBAC one i'm working on today
16:09:40 <cmurphy> sweet
16:09:43 <kmalloc> had a long weekend of stuff. to deal with
16:09:48 <kmalloc> bled over into monday
16:10:49 <cmurphy> no problem
16:10:53 * kmalloc has to check if a backport for the RBAC one is going to be needed for rocky
16:10:55 <cmurphy> i'm preparing a move so my head is mostly missing
16:11:40 <lbragstad> when do you expect to be settled in?
16:11:41 * kmalloc hands cmurphy a one of those lock cables so she doesn't leave her head behind somewhere in the move.
16:11:58 <cmurphy> lbragstad: april 1 is when my timezone will change
16:12:12 <cmurphy> (it's not an elaborate april fools joke)
16:12:17 <lbragstad> nice
16:12:26 <lbragstad> dealing with final release jet lagged then ;)
16:12:32 <cmurphy> yep yep
16:12:50 <cmurphy> anything else on rc2?
16:14:05 <lbragstad> we still need a patch for the reno issue?
16:14:28 <cmurphy> we do but that will only be needed on master
16:14:33 <cmurphy> i think
16:14:35 <cmurphy> so not an rc2 blocker
16:14:46 <lbragstad> ok - that sounds about right
16:15:48 <cmurphy> the reno issue for anyone who wasn't following irc yesterday is that we're merging a bunch of changes to release notes that will be backported to stable/stein which breaks how reno renders notes
16:16:36 <lbragstad> because it thinks the release notes should be published to unreleased, when in fact, they were released on stein (right?)
16:16:47 <kmalloc> i hate reno for this reason.
16:16:51 <cmurphy> right
16:17:14 <cmurphy> well it's manageable at least
16:17:31 <kmalloc> it's just an issue with the branch detection bits.
16:17:34 <cmurphy> when we're done we'll propose a cleanup fix to the ignored notes file to master
16:17:39 <kmalloc> yeah.
16:17:59 <kmalloc> thats fine. i'd really like to see reno go to a per-release subdirectory
16:18:28 <kmalloc> e.g. /stien, /rocky, etc rather than guessing based upon git info
16:18:55 <kmalloc> but that is a lot of extra work for now. so a simple cleanup patch would be ok
16:19:01 <cmurphy> yep
16:20:01 <cmurphy> okay
16:20:11 <cmurphy> #topic ptg planning
16:20:37 <cmurphy> #link https://etherpad.openstack.org/p/DEN-keystone-forum-sessions forum and ptg brainstorming
16:20:48 <cmurphy> i guess a couple of things i wanted to touch on
16:21:27 <cmurphy> is the list of attendees at the top of that reflective of both forum and ptg?
16:21:44 <vishakha> yes both
16:21:51 <cmurphy> does anyone know they're not going to be at one or the other?
16:21:52 <lbragstad> for me it is
16:22:28 <gagehugo> I plan on being there all week
16:23:04 <cmurphy> okay
16:23:20 <cmurphy> lbragstad reminded me that we should start firming up a schedule for the ptg topics
16:23:44 <cmurphy> maybe before i do that we could add some +1s on things people think are really important?
16:24:21 <cmurphy> to make sure we frontload them since probably people will leave early and/or have conflicts on saturday
16:24:56 <cmurphy> some of it may have to be kind of ad-hoc, like discussing limits with nova team following forum discussion
16:26:10 <cmurphy> i'll try to come up with a rough outline by next week
16:26:51 <gagehugo> ok
16:27:31 <cmurphy> looks like there are some dinner options at the bottom, has anyone looked into any of them and have opinions?
16:27:31 <knikolla> i'll be there summit+ptg
16:27:40 <cmurphy> yay
16:27:50 <gagehugo> I like food
16:27:56 <cmurphy> lol
16:28:06 <lbragstad> i just did a real quick search
16:28:09 <knikolla> i like trains
16:28:27 <lbragstad> and dumped the results in etherpad... but there are *tons* of options around the conference
16:28:45 <gagehugo> there are many places to eat downtown there
16:28:57 <gagehugo> no shortage of options
16:29:00 <knikolla> yeah, thankfully this time we'll be in downtown
16:29:06 <cmurphy> is there a day that works best to do dinner? should we do a poll?
16:29:12 <cmurphy> group dinner planning is pretty much my greatest phobia but i'll try to get over it
16:29:45 <lbragstad> a poll would be good... i'm suffering major procrastination on planning that week
16:30:21 <cmurphy> me too
16:31:25 <cmurphy> #action cmurphy create poll for team dinner
16:31:47 <cmurphy> #action cmurphy organize PTG brainstorm into rough schedule
16:32:19 <cmurphy> lbragstad: we should sync with gmann on meeting the the qa team too
16:32:29 <lbragstad> yeah - that's a good idea
16:32:42 <lbragstad> i don't think we nailed down a for sure time?
16:32:54 <cmurphy> i don't think so
16:33:16 <cmurphy> but they have it in their notes too https://etherpad.openstack.org/p/qa-train-ptg
16:34:07 * gagehugo has to run to another meeting
16:34:18 <cmurphy> o/
16:34:27 <cmurphy> anything else to discuss on ptg or forum?
16:35:47 <cmurphy> #topic open reviews
16:36:14 <cmurphy> #link https://review.openstack.org/641374 vision reflection
16:36:19 <cmurphy> should we just go ahead and merge that?
16:36:24 <cmurphy> we can continue to rework it
16:36:35 <lbragstad> ++
16:37:41 <cmurphy> I think everything else I care about is already linked in the rc2 etherpad
16:37:47 <lbragstad> will that need a rebase?
16:38:07 <cmurphy> oh looks like
16:38:14 <cmurphy> will fix
16:38:35 <cmurphy> anything anyone wants to highlight for reviews?
16:38:50 <lbragstad> i think most things i need reviews on are in the rc2 tracking etherpad
16:41:19 <cmurphy> okie
16:41:25 <cmurphy> #topic open discussion
16:41:37 <cmurphy> floor is open
16:41:57 <lbragstad> not sure if everyone read the scroll back
16:42:17 <lbragstad> but cmurphy and i were talking about ways to optimize the protection testing we've added this release
16:43:01 <lbragstad> if anyone has ideas on how to optimize that stuff besides drying up the token issuance code and the bootstrapping, lemme know
16:43:10 <lbragstad> i'd like to get something proposed by the time we get to the PTG
16:43:20 <lbragstad> that improves performance of those tests
16:44:45 <cmurphy> in my dreams I imagine some kind of framework that uses a kind of matrix of scope + role + expected return code to describe all of these cases concisely
16:44:56 <lbragstad> ++
16:45:02 <lbragstad> that'd be amazing
16:45:12 <cmurphy> but i think there are corner cases where that would be tricky
16:45:24 <lbragstad> yeah... that's what i stumbled on originally
16:47:49 <cmurphy> oh another thing for open reviews:
16:47:52 <cmurphy> #link https://review.openstack.org/647737
16:48:31 <lbragstad> that'll need to be backported, too?
16:48:35 <cmurphy> yep
16:51:23 <cmurphy> anything else to discuss or should we take back 9 minutes of freedom?
16:51:37 * lbragstad doesn't have anything
16:52:45 <cmurphy> alrighty
16:52:48 <cmurphy> #endmeeting