16:00:30 <cmurphy> #startmeeting keystone
16:00:31 <openstack> Meeting started Tue May 28 16:00:30 2019 UTC and is due to finish in 60 minutes.  The chair is cmurphy. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:35 <openstack> The meeting name has been set to 'keystone'
16:00:43 <cmurphy> #link https://etherpad.openstack.org/p/keystone-weekly-meeting agenda
16:00:46 <cmurphy> o/
16:00:49 <gagehugo> o/
16:00:56 <vishakha> o/
16:01:46 <lbragstad> o/
16:03:07 <cmurphy> okay let's get started
16:03:31 <cmurphy> #topic Train roadmap reorganized
16:03:42 <cmurphy> #link https://trello.com/b/ClKW9C8x/keystone-train-roadmap
16:04:08 <cmurphy> kind of an announcement - i went through the roadmap board and tried to reorganize it to have a flow that was easier to follow
16:04:20 <cmurphy> at the moment it's organized into Epics -> Stories -> Tasks
16:05:06 <cmurphy> epics are more overarching topics or categories, stories are like main features, tasks are individual units of work that would have deadlines on them
16:05:38 <cmurphy> did anyone already notice and have a chance to look at it and see if it makes sense?
16:06:07 <lbragstad> ++
16:06:25 <lbragstad> we have an insane amount of stories
16:06:35 <cmurphy> yeah :/
16:06:43 <lbragstad> sorry - i don't mean that in a bad way
16:07:00 <lbragstad> but it's kinda crazy to see them all listed out
16:07:08 <cmurphy> it's a tad overwhelming
16:07:16 <cmurphy> we may want to prune some
16:07:59 * lbragstad nods
16:08:30 <cmurphy> everyone should still feel free to edit the board, but if you're creating tasks please add them to the checklist for the story and add a link back to the story in the task description
16:09:11 <vishakha> Ok. Thanks Colleen
16:10:30 <cmurphy> and if you think of any feedback on how it's organized let me know, the idea is to make this easy for everyone to follow
16:10:52 <cmurphy> hopefully with the stories/tasks breakdown this may translate into storyboard more easily too
16:11:17 <lbragstad> looks like i have a bunch of pings to check in trello - i'll take some notes as i go through those
16:11:36 <cmurphy> thanks lbragstad
16:12:10 <cmurphy> any other thoughts on this topic?
16:13:09 <cmurphy> #topic M-1 check-in meeting
16:13:24 <cmurphy> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-May/006622.html
16:14:27 <cmurphy> we agreed at the PTG to try to keep up momentum by doing these check-ins regularly, so with M-1 already coming up we need to schedule the first one
16:14:37 <cmurphy> i think everyone here already filled in the poll :)
16:14:58 <cmurphy> i'll send out individual reminders to everyone else
16:15:22 <cmurphy> any thoughts or ideas regarding this check-in meeting?
16:16:20 <gagehugo> seems fine to me
16:17:57 <cmurphy> alright i'll send an update when there's enough data to schedule it
16:19:22 <cmurphy> #topic Train specs
16:19:43 <cmurphy> spec proposal due date is next week
16:20:04 <cmurphy> which means ideally specs should be non-WIP and ready to review
16:21:50 <cmurphy> from the PTG we had several planned, some aren't proposed yet so i wanted to check up on them
16:22:23 <cmurphy> "Update app cred access rules spec" - I just proposed this this morning
16:22:31 <cmurphy> #link https://review.opendev.org/661784
16:22:49 <cmurphy> "Assigning roles on root domain" - I have that down for lbragstad
16:23:46 <lbragstad> yep - i'll get to that today or tomorrow
16:23:46 <cmurphy> lbragstad: is that something you're working on?
16:23:50 <cmurphy> cool
16:23:57 <lbragstad> sorry for the wait on that
16:24:05 <cmurphy> no problem
16:24:29 <cmurphy> "Model timestamps" - I have that down for knikolla
16:24:45 <cmurphy> doesn't seem like knikolla is here so i'll check in with him after the meeting
16:25:23 <cmurphy> "Renewable users" which used to be renewable app creds, I think knikolla was working on that but it still needs an update
16:25:49 <cmurphy> "Federated user attributes" this was merged, needs a minor tweak though:
16:26:01 <cmurphy> #link https://review.opendev.org/659876
16:26:40 <cmurphy> "Immutable resources" this is proposed, I need to follow up with ayoung on his -1
16:27:02 <cmurphy> "Resource options for all" is merged
16:27:39 <cmurphy> "Explicit/predictable IDs" - i wrote down that this would be a spec, ayoung wrote a blog post i'm not sure if he was going to follow up with a spec
16:28:02 <cmurphy> did I miss any?
16:31:24 <lbragstad> not that i know of
16:32:16 <cmurphy> okay moving on
16:32:24 <cmurphy> #topic office hours
16:32:47 <cmurphy> I feel like office hours the last couple of weeks has been kind of a bust
16:33:23 <cmurphy> there aren't many of us here today, and it's late for vishakha
16:33:32 <cmurphy> is this something we should still try to pursue?
16:33:38 <cmurphy> today and in general
16:33:45 <gagehugo> hmm
16:34:55 <lbragstad> i'm kind of indifferent - it's kmalloc_away still out?
16:35:03 <gagehugo> same
16:35:03 <cmurphy> i think till next week
16:35:04 <lbragstad> isn't*
16:35:16 <kmalloc_away> I'm sortof back
16:35:25 <lbragstad> he lives!
16:36:12 <kmalloc_away> Back home, jetlagged though. Amazing what 3 hrs time shift does when it is gmt-10 vs -7
16:36:30 <kmalloc_away> So, sortof here :P
16:36:40 <kmalloc_away> Reading up.
16:37:03 <cmurphy> just discussing what to do about office hours
16:37:10 <kmalloc_away> I prefer specific topics vs general office hours at this point
16:37:21 <kmalloc_away> We are often around for question answering anyway
16:37:50 <cmurphy> yes that was already the idea
16:37:54 <kmalloc_away> Rallying for specific goals is a good use of the time, otherwise office hours feels mostly quiet
16:37:56 <cmurphy> i had started preparing topics https://etherpad.openstack.org/p/keystone-office-hours-topics
16:38:06 <cmurphy> but then people disappear
16:38:08 <kmalloc_away> And we can stop without explicit goals for a given week/day.
16:39:43 <cmurphy> if we do a bug triage today - will people be around and interested in participating?
16:39:56 <lbragstad> o/
16:40:07 <lbragstad> i can help out with that for a bit (like an hour)
16:40:11 <gagehugo> on and off yes
16:40:19 <kmalloc_away> I'll be hit/miss for another day or two getting back to normal schedule
16:40:34 <vishakha> I will be there too
16:40:49 <cmurphy> okay great
16:40:50 <vishakha> For an hour
16:41:50 <cmurphy> do folks prefer to start on the hour at 1700 UTC or immediately after the meeting (supposing the meeting ends early)
16:43:21 <vishakha> 1700 utc is fine from my side
16:43:35 <lbragstad> same
16:43:47 <cmurphy> okay
16:44:43 <cmurphy> #agreed start office hours at the scheduled time rather than immediately after meeting
16:45:02 <cmurphy> #agreed prepared topics still best strategy, office hours can be cancelled if there are no topics
16:45:09 <cmurphy> #topic open discussion
16:45:22 <cmurphy> anything else to discuss or reviews that need attention?
16:46:48 * lbragstad doesn't have anything
16:47:52 <cmurphy> okay, we'll end it here and come back for bug triage in a few minutes in #openstack-keystone
16:47:57 <cmurphy> #endmeeting