16:00:49 <cmurphy> #startmeeting keystone
16:00:50 <openstack> Meeting started Tue Jun 25 16:00:49 2019 UTC and is due to finish in 60 minutes.  The chair is cmurphy. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:54 <openstack> The meeting name has been set to 'keystone'
16:00:59 <vishakha> o/
16:01:02 <gagehugo> o/
16:01:08 <cmurphy> #link https://etherpad.openstack.org/p/keystone-weekly-meeting agenda
16:01:11 <lbragstad> o/
16:02:56 <cmurphy> lbragstad: i moved you up front
16:03:01 <cmurphy> #topic oslo.limit update
16:03:05 <lbragstad> uh oh
16:03:07 <lbragstad> ok
16:03:13 <lbragstad> i'm not prepared... but here goes
16:03:20 <cmurphy> oh we can wait
16:03:23 <cmurphy> if you want
16:03:28 <cmurphy> i can go to next topic first
16:03:32 <lbragstad> i'll stumble my way through
16:03:34 <lbragstad> i should be quick
16:03:45 <lbragstad> ok - so this is pretty much a follow up from last week
16:04:14 <lbragstad> if you haven't look yet, i have a bunch of relatively trivial reviews that need eyes
16:04:18 <lbragstad> starting here
16:04:20 <lbragstad> #link https://review.opendev.org/#/c/665708/
16:04:28 <lbragstad> thanks cmurphy for working through those :)
16:04:33 <cmurphy> o7
16:04:47 <lbragstad> more importantly than the trivial ones though
16:04:57 <lbragstad> is that this is where it starts to get interesting
16:04:59 <lbragstad> #link https://review.opendev.org/#/c/666085/
16:05:08 <lbragstad> i have one quick thing to fix there and that should be passing
16:05:17 <lbragstad> and that's where all the ksa stuff starts coming into place
16:05:18 <lbragstad> play*
16:05:40 <lbragstad> hand-in-hand with that we need to look at #link https://review.opendev.org/#/c/666444/4
16:05:57 <lbragstad> there are some awkward bits in that patch that i'd like to smooth out
16:06:13 <lbragstad> but if we don't nail it the first time around, we can improve it later
16:06:25 <lbragstad> and finally we have
16:06:26 <lbragstad> #link https://review.opendev.org/#/c/667242/3
16:06:58 <lbragstad> ^ that's actually got an example that you can run (point it at devstack and setup the limits and registered limits in keystone according to the comments in the script)
16:07:17 <cmurphy> that will definitely help me review it
16:07:18 <lbragstad> it's really a functional test and it should probably be graduated to one
16:07:23 <lbragstad> yeah ++
16:07:43 <lbragstad> i had to write that out before i could actually start implementing the flat enforcement model
16:07:53 <lbragstad> it's just a dummy service, but it's using nova
16:08:04 <lbragstad> so, cores and ram_mb are the example limits
16:08:09 <lbragstad> s/limits/resources/
16:08:46 * gagehugo takes a look
16:09:08 <lbragstad> if you run $ python example.py from /doc/source/user, it should take care of discovering the example.conf for you
16:09:49 <lbragstad> you should just need to create projects, copy the ids over (i should clean that up), register cores and ram_mb as limits, and create overrides for a couple of the projects
16:10:18 <lbragstad> project foo is assuming the defaults put in place by the registered limits
16:10:44 <lbragstad> project bar and project bazz have overrides that loosen/restrict the defaults put in place
16:10:59 <lbragstad> and the enforcement calls prove that the limits are enforced
16:11:37 <lbragstad> i'm hoping we can iterate on the feedback quickly, then get something out the door for johnthetubaguy and melwitt to use
16:11:47 <bnemec> +1000
16:12:10 <lbragstad> also - thanks to bnemec for helping me with the config stuff... i was struggling with that
16:13:07 <lbragstad> does anyone have questions so far? or any red flags that need to be raised?
16:13:56 <kmalloc> ++
16:14:57 <lbragstad> if folks want to do a higher bandwidth review as a group, i'm happy to facilitate that, too
16:15:16 <cmurphy> that might be useful
16:15:24 * lbragstad nods
16:15:55 <lbragstad> office hours? or should i set up another time?
16:16:21 <cmurphy> an office hour session would be good i think
16:16:32 <lbragstad> i agree
16:16:39 <vishakha> me too agree
16:16:48 <cmurphy> i need to take my car to the shop after this so today isn't good for me, next week?
16:16:48 <lbragstad> today? or next week?
16:16:57 <lbragstad> sure - next week works
16:16:58 <cmurphy> would give me time to go over it on my own first
16:17:46 <lbragstad> i think that's about all i had for the oslo.limit update
16:17:50 <lbragstad> any more questions?
16:18:19 <cmurphy> #agreed use July 2 office hour to group review oslo.limit changes
16:21:39 <cmurphy> looks like no other questions on oslo.limit
16:21:53 <cmurphy> thanks for all your work on that lbragstad
16:22:00 <bnemec> +1
16:22:01 <lbragstad> mhmm - you're welcome
16:22:21 <cmurphy> #topic midcycle planning
16:22:33 <cmurphy> #link https://etherpad.openstack.org/p/keystone-train-midcycle-topics planning etherpad
16:22:34 <kmalloc> wfm.
16:23:03 <cmurphy> I started an etherpad to gather topics for our virtual midcycle
16:23:17 <cmurphy> please add things to it
16:24:01 <cmurphy> after chatting with Julia I propose we do a two-day event with about a 3-hour session (with breaks) each day
16:24:24 <cmurphy> thoughts?
16:24:36 <lbragstad> cmurphy are you looking for discussion topics or group work items?
16:24:46 <gagehugo> that works for me
16:24:47 <cmurphy> lbragstad: either/both
16:24:49 <vishakha> Plan seems good :)
16:24:54 <bnemec> This was going to be virtual, right?
16:24:57 <cmurphy> bnemec: yes
16:25:01 <bnemec> I see kmalloc had a question about that on the etherpad.
16:25:09 <kmalloc> i figured it would be
16:25:20 <kmalloc> but needed to call it out that i just can't do more travel for this atm.
16:25:22 <cmurphy> definitely virtual
16:25:35 <vishakha> cmurphy: what will be the possible dates?
16:25:45 <cmurphy> vishakha: that was my next question
16:26:15 <cmurphy> milestone 2 is the week of July 22 which is in about 4 weeks
16:26:17 <kmalloc> we should do a poll for the best dates.
16:26:33 <cmurphy> i figure some time between milestone 2 and feature proposal freeze would be good
16:26:37 <kmalloc> but jul 22-ish feels good
16:26:55 <cmurphy> so that we can try to work out implementation issues
16:27:24 <lbragstad> so - between july 22 and august 16?
16:27:56 <cmurphy> yeah, not sure exactly what the optimal week is
16:28:04 <cmurphy> is anyone going on vacation this july/august?
16:28:09 <lbragstad> o/
16:28:22 <lbragstad> i might be, but we haven't formalized any plans, yet
16:28:59 <bnemec> I'm out July 29 - Aug. 2.
16:30:36 <cmurphy> lbragstad: what's your timeline for deciding? or if we iron this out quick enough will you be able to work around it?
16:30:49 <lbragstad> i should be able to work around it
16:31:02 <lbragstad> tentatively - we're thinking the end of july
16:31:29 <cmurphy> okay i'll send out a poll today
16:31:44 <cmurphy> i wonder how doodle handles multi day events
16:31:53 <lbragstad> i guess we'll find out
16:31:58 <cmurphy> \o/
16:32:42 <cmurphy> #action cmurphy send out poll for virtual midcycle scheduling
16:33:10 <cmurphy> #action everyone add suggestions for midcycle topics https://etherpad.openstack.org/p/keystone-train-midcycle-topics
16:33:27 <cmurphy> any other questions, thoughts, concerns about this?
16:33:39 <cmurphy> do people think they'll be able to get the time from their employer to participate in this?
16:34:34 * lbragstad hopes
16:35:10 <gagehugo> yeah I most likely will
16:35:36 <vishakha> yes offcourse
16:35:51 <kmalloc> i am not worried about getting time to participate.
16:36:00 <kmalloc> but i do ask that we don't make it a week-long thing :P
16:36:10 <kmalloc> like 1-3 days
16:36:24 <cmurphy> kmalloc: i proposed above 2 days 3 hours each
16:36:39 * lbragstad thinks that's reasonable
16:36:44 <kmalloc> cmurphy: you could use a civs poll instead with ranked choices for days
16:36:59 <kmalloc> the hours should be fairly stable knowing it's 3hrs each day
16:37:15 <cmurphy> hmm that might work
16:39:54 <cmurphy> let me know if anyone has any other thoughts or questions about this
16:40:05 <cmurphy> #topic open reviews
16:40:18 * lbragstad just has the oslo.limit stuff that was linked earlier
16:40:27 <lbragstad> but it looks like that's getting into the gate now
16:41:52 <cmurphy> this one is pretty important https://review.opendev.org/664712 we haven't been testing opportunistic db tests for a while i guess
16:42:04 <cmurphy> shocking that things aren't broken
16:42:33 <bnemec> Should go buy a lottery ticket. :-)
16:42:52 <cmurphy> seriously
16:43:03 <cmurphy> this whole stack is also ready to go https://review.opendev.org/#/q/status:open+topic:bp/whitelist-extension-for-app-creds
16:43:37 <cmurphy> i think it's straightforward but we could also review that as a group next week if that would be helpful
16:43:47 <lbragstad> ++
16:44:02 <lbragstad> i'll take a look
16:44:07 <cmurphy> sweet
16:44:19 <cmurphy> any other reviews to highlight?
16:47:09 <cmurphy> #topic open discussion
16:47:12 <cmurphy> floor is open
16:47:42 <cmurphy> as mentioned i have an appointment after this so no office hours
16:49:36 <cmurphy> cfp for shanghai is still open, i hope everyone is submitting something :)
16:49:50 <vishakha> yeah I am trying :)
16:50:40 <cmurphy> they haven't asked me about project update/onboarding yet but i assume they will soon, if anyone wants to be added to one or both of those to help justify attending the summit let me know
16:51:20 <kmalloc> i am not submitting! :)
16:51:23 <kmalloc> >.>
16:51:24 <kmalloc> <.<
16:51:31 <kmalloc> my wife would kill me
16:51:34 <cmurphy> kmalloc: i think you'll have more important things to do :P
16:51:36 <bnemec> I think in the past the project update email actually came after the cfp closed.
16:51:44 <vishakha> the person can be non-core also to give update or onboarding?
16:51:59 <cmurphy> bnemec: i hope they send it sooner so i can plan for it :/
16:52:02 <cmurphy> vishakha: yes of course :)
16:52:14 <vishakha> cmurphy: ok
16:53:11 <bnemec> Yeah, it's not great timing.
16:53:24 <cmurphy> especially when it's china
16:53:34 <bnemec> I've just been assuming I'd give one when I ask for travel approval.
16:53:59 <bnemec> That has almost backfired once or twice. In Berlin the update sessions filled up and we almost didn't have an Oslo one.
16:54:26 <cmurphy> yeah it's easier to justify to my company if my "talk" is on the schedule and i can link to it
16:55:46 <bnemec> So I guess the advice would be to submit your talks and keep the project update/onboarding as a fallback plan.
16:57:07 <cmurphy> ++
16:57:20 <cmurphy> if there's nothing else we can close it here
16:57:30 <cmurphy> thanks everyone
16:57:32 <cmurphy> #endmeeting