15:01:29 <dmendiza[m]> #startmeeting keystone
15:01:29 <opendevmeet> Meeting started Tue Mar  8 15:01:29 2022 UTC and is due to finish in 60 minutes.  The chair is dmendiza[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:29 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:29 <opendevmeet> The meeting name has been set to 'keystone'
15:01:34 <dmendiza[m]> #topic Roll Call
15:01:36 <xek> o/
15:01:51 <dmendiza[m]> Courtesy ping for ayoung, bbobrov, crisloma, d34dh0r53, dpar, dstanek, gagehugo, hrybacki, knikolla, lamt, lbragstad, lwanderley, kmalloc, rodrigods, samueldmq, spilla, ruan_he, wxy, sonuk, vishakha,Ajay, rafaelweingartner
15:01:54 <gagehugo_> o/
15:01:57 <knikolla> o/
15:01:59 <d34dh0r53> o/
15:02:11 <h_asahina> o/
15:02:12 <dmendiza[m]> Hi everybody!
15:02:23 <dmendiza[m]> #topic Review Past Meeting Action Items
15:02:36 <dmendiza[m]> #link https://meetings.opendev.org/meetings/keystone/2022/keystone.2022-03-01-15.00.html
15:02:40 <dmendiza[m]> we didn't have any
15:02:52 <dmendiza[m]> Moving on ...
15:02:56 <dmendiza[m]> #topic Liaison Updates
15:03:32 <dmendiza[m]> I don't have anything this week.  I remembered to pay attention to the Oslo meeting this week, and then it didn't happen. 😑
15:04:26 <dmendiza[m]> I'll talk about Yoga/Zed when we get to that topic
15:04:38 <dmendiza[m]> #topic OAuth 2.0 Reviews
15:04:57 <dmendiza[m]> looks like h_asahina added a topic for us to review implementation patches for OAuth
15:05:13 <h_asahina> yes
15:05:17 <dmendiza[m]> #link https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext
15:05:53 <h_asahina> My collegue submitted three patches
15:05:58 <dmendiza[m]> At this time, I think we should probably wait until the Yoga is branched and try to land these into Zed
15:06:13 <dmendiza[m]> which should happen this week
15:08:09 <h_asahina> um... We need to release them in Yoga.
15:08:39 <h_asahina> isn't it impossible?
15:10:09 <knikolla> we're a lot past feature freeze for yoga
15:10:12 <dmendiza[m]> It's a little late in the cycle unfortunately 😥
15:10:27 <dmendiza[m]> #link https://releases.openstack.org/yoga/schedule.html
15:10:32 <h_asahina> I understand there's not time left, but these patches were submitted feb 28.
15:10:42 <dmendiza[m]> Feature Freeze was the week of Feb 21
15:11:15 <dmendiza[m]> And now we're in RC1 week
15:12:27 <dmendiza[m]> gagehugo_ knikolla what's your confidence level for getting these patches landed in the next couple of days?
15:14:24 <knikolla> i see they have -1s and unresolved comments
15:15:10 <gagehugo_> I am not sure we want to rush that  in, if it ends up breaking the release we will have a bad time. It is way past feature freeze as pointed out, but we can probably get it into zed.
15:15:45 <knikolla> ++
15:15:52 <dmendiza[m]> Yeah, seems safer to get these landed in early Zed
15:16:04 <dmendiza[m]> h_asahina: would it be possible for you to backport these downstream
15:16:05 <dmendiza[m]> ?
15:16:57 <gagehugo_> backporting to yoga is good too
15:17:24 <dmendiza[m]> yeah, I would be OK with a Yoga backport after we land these in Zed
15:17:57 <h_asahina> In this context, the backporting means these changes will be integrated into keystone Yoga later?
15:18:37 <h_asahina> or just cherry-picking them by ourselves just for us?
15:18:57 <dmendiza[m]> Yeah, we'll release Keystone Yoga without them, and then backport the patches into stable/yoga once they land
15:19:13 <dmendiza[m]> or if you need them before that happens you could cherry-pick for your own deployment
15:19:59 <h_asahina> Okey, that would be possible.
15:20:07 <knikolla> them being new APIs, I don't think they're backport candidates
15:21:45 <xek> on this topic, who is able to merge backports? is it still just Lance?
15:22:43 <dmendiza[m]> xek: https://review.opendev.org/admin/groups/ed7e98cd14f0ec4dfd09d10bbb64e1bd3ac1fa15,members
15:23:05 <dmendiza[m]> So, Lance, Colleen and stable-maint-core https://review.opendev.org/admin/groups/2267a5998d4224dd0acf1081eb2ee7b11573b7ea,members
15:24:47 <xek> maybe we could officially work on extending this list, but I guess this is another topic
15:25:29 <dmendiza[m]> Yes, we'll revisit backporting OAuth after it lands
15:26:07 <dmendiza[m]> xek: I can look into getting more folks into the keystone-stable-maint group
15:26:23 <opendevreview> Merged openstack/oslo.limit master: Update master for stable/yoga  https://review.opendev.org/c/openstack/oslo.limit/+/832061
15:26:32 <dmendiza[m]> #action dmendiza[m] to look into updating the keystone-stable-maint group
15:26:42 <dmendiza[m]> looks like the bots are starting to branch yoga
15:26:58 <dmendiza[m]> #topic Zed cycle
15:27:04 <h_asahina> If the backporting is possible, when will it happen
15:27:17 <h_asahina> sorry for interruption
15:28:07 <dmendiza[m]> h_asahina: backport patches can be submitted as soon as they land on the master branch
15:28:27 <dmendiza[m]> The Zed cycle schedule is out:
15:28:28 <dmendiza[m]> #link https://releases.openstack.org/zed/schedule.html
15:28:56 <h_asahina> thanks dmendiza:
15:29:24 <h_asahina> So please review it continuously
15:29:49 <h_asahina> regarding -1, these are mine and will be fixed soon.
15:30:32 <dmendiza[m]> Also, your weekly reminder that we have an etherpad for the Zed cycle PTG
15:30:36 <dmendiza[m]> #link https://etherpad.opendev.org/p/z-ptg-keystone
15:32:25 <h_asahina> ok. thanks.
15:33:18 <dmendiza[m]> #topic Bug Review
15:33:57 <dmendiza[m]> d34dh0r53 and I didn't get a chance to work on https://bugs.launchpad.net/keystone/+bug/1959674 last week, unfortunately
15:34:07 <dmendiza[m]> #link https://bugs.launchpad.net/keystone/?orderby=-id&start=0
15:34:30 <dmendiza[m]> No new bugs in Keystone since last week
15:34:45 <dmendiza[m]> #link https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0
15:34:53 <dmendiza[m]> Looks like we do have a one new bug in python-keystoneclient
15:35:00 <dmendiza[m]> #link https://bugs.launchpad.net/python-keystoneclient/+bug/1963925
15:35:28 <dmendiza[m]> > Unit tests fail in CentOS Stream 9
15:35:55 <dmendiza[m]> I think I know what this is about
15:36:21 <dmendiza[m]> openssl in CentOS 9 has been updated to stop using certain hashing algorithms
15:36:26 <dmendiza[m]> I think this is probably related to that
15:39:05 <dmendiza[m]> #link https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0
15:39:10 <dmendiza[m]> No new keystoneauth bugs
15:39:21 <dmendiza[m]> #link https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0
15:39:43 <dmendiza[m]> No new keystonemiddleware bugs
15:39:49 <dmendiza[m]> #link https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0
15:39:54 <dmendiza[m]> no new pycadf bugs
15:40:04 <dmendiza[m]> #link https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0
15:40:09 <dmendiza[m]> and no new ldappool bugs
15:40:25 <dmendiza[m]> That's it for bug review
15:40:34 <dmendiza[m]> #topic Open Discussion
15:40:43 <dmendiza[m]> Any other topics y'all want to talk about?
15:42:10 <gagehugo_> yeah
15:42:11 <xek> I'm looking for reviews on the backport of https://review.opendev.org/q/I77148641715efe09e3adc2e9432e66e50fb444b4
15:42:44 <gagehugo_> Apologies for the short notice, but I'll be stepping down from keystone. I will send out an email probably later today to announce it officially.
15:43:56 <gagehugo_> It's been great working with you knikolla, and thanks dmendiza[m] for stepping up to lead as PTL for this cycle!
15:44:48 <dmendiza[m]> 😵
15:44:54 <dmendiza[m]> You'll be missed for sure gagehugo_
15:45:01 <xek> gagehugo_, we will definitely miss you, maybe you could check up on things from time to time?
15:45:35 <gagehugo_> most likely I can yeah :)
15:47:29 <d34dh0r53> sad to see you go gagehugo_
15:48:32 <gagehugo_> thanks everyone
15:54:09 <knikolla> likewise it's been a pleasure. sad to see you go gagehugo_ :(
15:54:55 <dmendiza[m]> Thanks for all your work gagehugo_ we'll see you around. 😃
15:55:03 <dmendiza[m]> Thanks everyone for joining
15:55:06 <dmendiza[m]> #endmeeting