15:02:18 <dmendiza[m]> #startmeeting keystone
15:02:18 <opendevmeet> Meeting started Tue Jul 19 15:02:18 2022 UTC and is due to finish in 60 minutes. The chair is dmendiza[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:18 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:18 <opendevmeet> The meeting name has been set to 'keystone'
15:02:28 <dmendiza[m]> #topic Roll Call
15:02:33 <dmendiza[m]> Courtesy ping for admiyo, bbobrov, crisloma, d34dh0r53, dpar, dstanek, hrybacki, knikolla, lbragstad, lwanderley, kmalloc, rodrigods, samueldmq, ruan_he, wxy, sonuk, vishakha, Ajay, rafaelwe, xek
15:02:42 <xek> o/
15:03:13 <d34dh0r53> o/
15:03:23 <h_asahina> o/
15:03:29 <d34dh0r53> lurking, conflict with another meeting
15:05:31 <dmendiza[m]> Hi y'all
15:05:35 <dmendiza[m]> Let's get started
15:05:41 <dmendiza[m]> #topic Review Past Meeting Action Items
15:05:53 <dmendiza[m]> I'm still kicking this bandit action item down the road
15:06:01 <dmendiza[m]> Actually, let me try that real quick
15:06:26 <dmendiza[m]> #link https://meetings.opendev.org/meetings/keystone/2022/keystone.2022-07-12-15.00.html
15:06:56 <knikolla> o/
15:08:05 <dmendiza[m]> OK, kicking off that bandit run
15:08:34 <dmendiza[m]> The other action item was about M2
15:09:56 <dmendiza[m]> Hmmm ... doesn't look like Keystone is in the Milestone-2 releases 🤔
15:13:20 <dmendiza[m]> #action dmendiza[m] to check on milestone-2 release
15:13:44 <dmendiza[m]> back to Bandit
15:13:54 <dmendiza[m]> looks like I was able to run `tox -e bandit` from a fresh clone without any problems
15:14:04 <dmendiza[m]> using Python 3.9
15:14:21 <dmendiza[m]> so I think we're good? Not sure admiyo is around anymore anyway?
15:14:37 <dmendiza[m]> We probably don't need to revisit this. I'll move out of the agenda
15:15:12 <dmendiza[m]> #info `tox -e bandit` appears to work with a fresh clone of keystone in Python 3.9
15:15:31 <dmendiza[m]> #topic Liaison Updates
15:15:36 <dmendiza[m]> No updates from me.
15:15:45 <dmendiza[m]> #topic OAuth 2.0
15:15:52 <dmendiza[m]> hi h_asahina
15:15:57 <h_asahina> hi
15:16:45 <h_asahina> i've found the line about OAuth2.0 on the etherpad
15:16:57 <h_asahina> > We should consider moving the MTLS spec to AA
15:17:21 <dmendiza[m]> Yeah, we were discussing that during the last reviewathon
15:17:33 <h_asahina> does this mean you want to postpone merging to the next release?
15:17:38 <dmendiza[m]> and given our review capacity it would probably be better to move that spec to the next cycle
15:18:32 <dmendiza[m]> I think it's going to be difficult for us to merge everything we have pending and also the mTLS work
15:21:04 <h_asahina> I understand, but to be honest, we are in trouble if the spec won't be merged as scheduled.
15:21:38 <dmendiza[m]> Oh? 🤔
15:23:34 <h_asahina> we have started to develop our other projects based on the this feature described in the spec.
15:24:01 <h_asahina> /the this/this/
15:25:53 <h_asahina> i understnad there's not enough keystone cores although there are some other specs to review.
15:26:24 <dmendiza[m]> I understand it may be disappointing to have to wait another cycle, but I think this is a feature that we don't want to rush. We are ceirtanly wanting to get the work merged in the AA cycle.
15:28:05 <h_asahina> i'm afraid of that the same thing will happen in the AA cycle
15:29:10 <dmendiza[m]> I see. I am hoping that by the time AA cycle starts we will be able to have a few more core reviewers
15:30:15 <h_asahina> I hope that too. all we can do is submitting the spec and patch on schedule believing it works.
15:31:16 <h_asahina> starting from spec review again in the AA release makes me a little bit anxious
15:31:31 <dmendiza[m]> I do appreciate you continuing to work with us to get these features merged into Keystone.
15:31:57 <dmendiza[m]> We don't have to wait until AA to review the spec
15:32:05 <dmendiza[m]> We can continue to review the spec now
15:32:24 <dmendiza[m]> the implementation will have to wait until AA to be merged
15:32:29 <h_asahina> ok, there's no room for negotiation?
15:34:26 <dmendiza[m]> I think that the best that we can do is continue to review the spec and implementation and see how far we get before Milestone-3
15:34:41 <dmendiza[m]> but there is a possibility that we will run out of time
15:35:54 <h_asahina> also can i think there's a few possiblity to merege this spec before Milestone-3?
15:36:44 <dmendiza[m]> We have about ~5 weeks
15:38:58 <dmendiza[m]> I am not sure how we can merge the spec and all the required work in that time? 🤔
15:39:04 <dmendiza[m]> I think we should be able to merge the spec
15:40:09 <knikolla> i don't think we should rush, but i guess we can give it a shot.
15:40:39 <dmendiza[m]> agreed knikolla
15:40:59 <dmendiza[m]> let's play it by ear, h_asahina and see how far we can get in the next few weeks
15:41:32 <h_asahina> thanks. it will be helpful.
15:42:26 <knikolla> dmendiza[m]: d34dh0r53: xek: we can try to go through the oauth 2.0 with mtls RFC so that on Friday's meeting we have done the background reading and can go through the spec as a group.
15:42:39 <knikolla> go through during the week* (homework)
15:42:41 <d34dh0r53> ack
15:43:00 <d34dh0r53> #action (all) go through the OAuth 2.0 spec
15:43:29 <dmendiza[m]> Sounds good
15:43:41 <dmendiza[m]> Let's move on to Secure RBAC
15:43:59 <dmendiza[m]> #topic Secure RBAC
15:45:06 <dmendiza[m]> Not a whole lot of progress on my end
15:45:16 <dmendiza[m]> Looks like this week's pop-up meeting is canceled
15:45:26 <dmendiza[m]> the next meeting will be on August 2
15:45:41 <dmendiza[m]> I'll definitely join tne next one and see where we're at
15:45:56 <dmendiza[m]> I'll also probably make some time before M-3 to do the needful for Keystone
15:46:54 <dmendiza[m]> Any questions/comments about Secure RBAC
15:46:55 <dmendiza[m]> ?
15:50:41 <dmendiza[m]> OK, moving on
15:50:54 <dmendiza[m]> #topic open dicussion
15:51:03 <dmendiza[m]> Any other topics y'all want to talk about?
15:58:09 <dmendiza[m]> Alrighty then, y'all.
15:58:16 <dmendiza[m]> See you Friday for the reviewathon.
15:58:22 <dmendiza[m]> Please read your homework before then.
15:58:26 <dmendiza[m]> #endmeeting