#openstack-keystone: keystone

Meeting started by d34dh0r53 at 15:00:00 UTC (full logs).

Meeting summary

  1. roll call (d34dh0r53, 15:00:06)
  2. review past meeting work items (d34dh0r53, 15:02:52)
    1. https://meetings.opendev.org/meetings/keystone/2022/keystone.2022-12-06-15.00.html (d34dh0r53, 15:03:09)
    2. ACTION: reviewathon https://review.opendev.org/c/openstack/keystoneauth/+/838104 (d34dh0r53, 15:03:52)
    3. ACTION: reviewathon https://review.opendev.org/c/openstack/keystone/+/838108 (d34dh0r53, 15:04:10)
    4. ACTION: reviewathon https://review.opendev.org/c/openstack/keystone/+/860928 (d34dh0r53, 15:04:26)
    5. ACTION: reviewathon https://review.opendev.org/c/openstack/keystoneauth/+/860923 (d34dh0r53, 15:04:42)
    6. ACTION: d34dh0r53 look into user-defined attribute access control (d34dh0r53, 15:06:04)
    7. ACTION: reviewathon https://review.opendev.org/c/openstack/keystone/+/863420 (d34dh0r53, 15:07:42)
    8. ACTION: knikolla[m] please review https://review.opendev.org/c/openstack/pycadf/+/863702 (d34dh0r53, 15:08:31)
    9. ACTION: knikolla[m] please review https://review.opendev.org/c/openstack/keystonemiddleware/+/866805 (d34dh0r53, 15:08:44)

  3. liaison updates (d34dh0r53, 15:09:26)
    1. HELP: Please let me know if you're interested in volunteering for a liaison role (d34dh0r53, 15:10:33)

  4. specification OAuth 2.0 (hiromu) (d34dh0r53, 15:10:58)
    1. https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext (d34dh0r53, 15:11:06)
    2. https://review.opendev.org/c/openstack/keystone-specs/+/843765 (d34dh0r53, 15:11:18)
    3. https://review.opendev.org/c/openstack/keystone-specs/+/843765/17..18 . this might be better. (hiromu, 15:12:01)

  5. specification Secure RBAC (dmendiza[m]) (d34dh0r53, 15:14:52)
    1. https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_ (d34dh0r53, 15:15:00)
    2. https://review.opendev.org/c/openstack/keystone/+/863420 (d34dh0r53, 15:17:01)
    3. https://review.opendev.org/c/openstack/keystone/+/822601 (d34dh0r53, 15:17:27)

  6. open discussion (d34dh0r53, 15:20:39)
  7. bug review (d34dh0r53, 15:33:53)
    1. https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0 (d34dh0r53, 15:39:16)
    2. https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0 (d34dh0r53, 15:39:53)
    3. https://bugs.launchpad.net/keystoneauth/+bug/1999431 is new (d34dh0r53, 15:40:11)
    4. https://bugs.launchpad.net/keystoneauth/+bug/1999431 is low-hanging-fruit, any volunteers on that one? (d34dh0r53, 15:43:06)
    5. https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0 (d34dh0r53, 15:46:04)
    6. https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0 (d34dh0r53, 15:46:33)
    7. https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0 (d34dh0r53, 15:47:05)

  8. conclusion (d34dh0r53, 15:48:08)


Meeting ended at 15:49:09 UTC (full logs).

Action items

  1. reviewathon https://review.opendev.org/c/openstack/keystoneauth/+/838104
  2. reviewathon https://review.opendev.org/c/openstack/keystone/+/838108
  3. reviewathon https://review.opendev.org/c/openstack/keystone/+/860928
  4. reviewathon https://review.opendev.org/c/openstack/keystoneauth/+/860923
  5. d34dh0r53 look into user-defined attribute access control
  6. reviewathon https://review.opendev.org/c/openstack/keystone/+/863420
  7. knikolla[m] please review https://review.opendev.org/c/openstack/pycadf/+/863702
  8. knikolla[m] please review https://review.opendev.org/c/openstack/keystonemiddleware/+/866805


Action items, by person

  1. d34dh0r53
    1. d34dh0r53 look into user-defined attribute access control
  2. UNASSIGNED
    1. reviewathon https://review.opendev.org/c/openstack/keystoneauth/+/838104
    2. reviewathon https://review.opendev.org/c/openstack/keystone/+/838108
    3. reviewathon https://review.opendev.org/c/openstack/keystone/+/860928
    4. reviewathon https://review.opendev.org/c/openstack/keystoneauth/+/860923
    5. reviewathon https://review.opendev.org/c/openstack/keystone/+/863420
    6. knikolla[m] please review https://review.opendev.org/c/openstack/pycadf/+/863702
    7. knikolla[m] please review https://review.opendev.org/c/openstack/keystonemiddleware/+/866805


People present (lines said)

  1. d34dh0r53 (83)
  2. hiromu (8)
  3. zaitcev (8)
  4. opendevmeet (3)
  5. gmann (3)


Generated by MeetBot 0.1.4.