#openstack-keystone: keystone

Meeting started by d34dh0r53 at 15:03:20 UTC (full logs).

Meeting summary

  1. roll call (d34dh0r53, 15:03:32)
  2. review past meeting work items (d34dh0r53, 15:04:16)
    1. https://meetings.opendev.org/meetings/keystone/2023/keystone.2023-05-23-15.12.html (d34dh0r53, 15:04:35)
    2. ACTION: d34dh0r53 investigate https://bugs.launchpad.net/keystone/+bug/2009752 (d34dh0r53, 15:05:56)
    3. ACTION: d34dh0r53 Look into adding/restoring a known issues section to our documentation (d34dh0r53, 15:06:12)
    4. ACTION: d34dh0r53 add https://bugs.launchpad.net/keystone/+bug/1305950 to the known issues section of our documentation (d34dh0r53, 15:06:27)
    5. ACTION: d34dh0r53 update https://review.opendev.org/c/openstack/keystonemiddleware/+/882401 to include test_ec2_token_middleware.py (d34dh0r53, 15:06:55)
    6. ACTION: d34dh0r53 look at https://bugs.launchpad.net/keystone/+bug/2018644 (d34dh0r53, 15:07:15)
    7. ACTION: drencrom look at https://review.opendev.org/c/openstack/keystonemiddleware/+/878027 to see if we can add the test_ec2_token_middleware.py to it (d34dh0r53, 15:08:58)

  3. liaison update (d34dh0r53, 15:09:19)
  4. specification OAuth 2.0 (hiromu) (d34dh0r53, 15:11:07)
  5. Secure RBAC (dmendiza[m]) (d34dh0r53, 15:15:02)
    1. https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_ (d34dh0r53, 15:15:17)
    2. https://review.opendev.org/c/openstack/keystone/+/863420 (d34dh0r53, 15:15:20)
    3. https://review.opendev.org/c/openstack/keystone/+/822601 (d34dh0r53, 15:15:24)

  6. SQLAlchemy 2.0 (stephenfin) (d34dh0r53, 15:17:36)
    1. https://review.opendev.org/q/topic:sqlalchemy-20+is:open+project:openstack/keystone (d34dh0r53, 15:17:49)

  7. open discussion (d34dh0r53, 15:21:09)
    1. ussuri: https://review.opendev.org/c/openstack/keystone/+/874846 (d34dh0r53, 15:31:26)
    2. victoria: https://review.opendev.org/c/openstack/keystone/+/874847 (d34dh0r53, 15:31:28)
    3. wallaby: https://review.opendev.org/c/openstack/keystone/+/874844 (d34dh0r53, 15:31:30)
    4. ACTION: investigate dependency issue in this patch wallaby: https://review.opendev.org/c/openstack/keystone/+/874844 (d34dh0r53, 15:38:51)

  8. bug review (d34dh0r53, 15:39:03)
    1. https://bugs.launchpad.net/keystone/?orderby=-id&start=0 (d34dh0r53, 15:39:18)
    2. https://bugs.launchpad.net/keystone/+bug/2020766 (d34dh0r53, 15:40:42)
    3. https://bugs.launchpad.net/keystone/+bug/2020847 (d34dh0r53, 15:41:29)
    4. https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0 (d34dh0r53, 15:43:43)
    5. https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0 (d34dh0r53, 15:44:19)
    6. https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0 (d34dh0r53, 15:44:47)
    7. https://bugs.launchpad.net/keystonemiddleware/+bug/2020821 (d34dh0r53, 15:45:03)
    8. https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0 (d34dh0r53, 15:48:02)
    9. https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0 (d34dh0r53, 15:48:17)

  9. conclusion (d34dh0r53, 15:48:31)


Meeting ended at 15:53:52 UTC (full logs).

Action items

  1. d34dh0r53 investigate https://bugs.launchpad.net/keystone/+bug/2009752
  2. d34dh0r53 Look into adding/restoring a known issues section to our documentation
  3. d34dh0r53 add https://bugs.launchpad.net/keystone/+bug/1305950 to the known issues section of our documentation
  4. d34dh0r53 update https://review.opendev.org/c/openstack/keystonemiddleware/+/882401 to include test_ec2_token_middleware.py
  5. d34dh0r53 look at https://bugs.launchpad.net/keystone/+bug/2018644
  6. drencrom look at https://review.opendev.org/c/openstack/keystonemiddleware/+/878027 to see if we can add the test_ec2_token_middleware.py to it
  7. investigate dependency issue in this patch wallaby: https://review.opendev.org/c/openstack/keystone/+/874844


Action items, by person

  1. d34dh0r53
    1. d34dh0r53 investigate https://bugs.launchpad.net/keystone/+bug/2009752
    2. d34dh0r53 Look into adding/restoring a known issues section to our documentation
    3. d34dh0r53 add https://bugs.launchpad.net/keystone/+bug/1305950 to the known issues section of our documentation
    4. d34dh0r53 update https://review.opendev.org/c/openstack/keystonemiddleware/+/882401 to include test_ec2_token_middleware.py
    5. d34dh0r53 look at https://bugs.launchpad.net/keystone/+bug/2018644
  2. drencrom
    1. drencrom look at https://review.opendev.org/c/openstack/keystonemiddleware/+/878027 to see if we can add the test_ec2_token_middleware.py to it


People present (lines said)

  1. d34dh0r53 (83)
  2. drencrom (6)
  3. zaitcev (4)
  4. dmendiza[m] (4)
  5. opendevmeet (3)
  6. hiromu (2)
  7. knikolla (1)
  8. xek (1)
  9. opendevreview (1)


Generated by MeetBot 0.1.4.