#openstack-keystone: keystone

Meeting started by d34dh0r53 at 15:02:24 UTC (full logs).

Meeting summary

  1. roll call (d34dh0r53, 15:02:33)
  2. review past meeting work items (d34dh0r53, 15:06:10)
    1. ACTION: d34dh0r53 Look into adding/restoring a known issues section to our documentation (d34dh0r53, 15:07:42)
    2. ACTION: d34dh0r53 add https://bugs.launchpad.net/keystone/+bug/1305950 to the known issues section of our documentation (d34dh0r53, 15:07:50)

  3. liaison updates (d34dh0r53, 15:07:57)
  4. specification OAuth 2.0 (hiromu) (d34dh0r53, 15:10:15)
    1. https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext (d34dh0r53, 15:10:24)
    2. https://review.opendev.org/c/openstack/keystone-specs/+/861554 (d34dh0r53, 15:10:28)
    3. https://review.opendev.org/q/topic:bp%252Fsupport-oauth2-mtls (d34dh0r53, 15:10:32)
    4. https://review.opendev.org/c/openstack/keystone/+/838108 (d34dh0r53, 15:10:36)
    5. https://review.opendev.org/c/openstack/keystoneauth/+/838104 (d34dh0r53, 15:10:38)
    6. https://docs.openstack.org/keystonemiddleware/latest/index.html (hiromu, 15:12:22)
    7. https://bugs.launchpad.net/keystone/+bug/2029134 (noonedeadpunk, 15:17:29)
    8. https://bugs.launchpad.net/keystone/+bug/2028809 (noonedeadpunk, 15:22:14)

  5. specification Secure RBAC (dmendiza[m]) (d34dh0r53, 15:24:50)
    1. https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_ (d34dh0r53, 15:24:56)
    2. https://review.opendev.org/c/openstack/keystone/+/863420 (d34dh0r53, 15:25:00)
    3. https://review.opendev.org/c/openstack/keystone/+/822601 (d34dh0r53, 15:25:04)
    4. https://review.opendev.org/c/openstack/keystone-tempest-plugin/+/885799 (d34dh0r53, 15:25:08)

  6. open discussion (d34dh0r53, 15:26:09)
    1. https://bugs.launchpad.net/keystone/+bug/2028809 (d34dh0r53, 15:26:31)
    2. ACTION: d34dh0r53 investigate switching the default hashing algo to scrypt in 2024.x (d34dh0r53, 15:41:19)
    3. https://review.opendev.org/c/openstack/keystonemiddleware/+/889191 (d34dh0r53, 15:45:40)
    4. https://review.opendev.org/c/openstack/keystoneauth/+/883852 (d34dh0r53, 15:47:34)

  7. bug review (d34dh0r53, 15:48:52)
    1. https://bugs.launchpad.net/keystone/?orderby=-id&start=0 (d34dh0r53, 15:49:00)
    2. ACTION: hiromu is going to look at https://bugs.launchpad.net/keystone/+bug/2029134 (d34dh0r53, 15:50:00)
    3. ACTION: noonedeadpunk and d34dh0r53 are looking for a workaround/fix for https://bugs.launchpad.net/keystone/+bug/2028809 (d34dh0r53, 15:50:23)
    4. #link https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0 (d34dh0r53, 15:57:18)
    5. https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0 (d34dh0r53, 15:57:42)
    6. https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0 (d34dh0r53, 15:57:59)
    7. https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0 (d34dh0r53, 15:58:22)
    8. https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0 (d34dh0r53, 15:58:39)

  8. conclusion (d34dh0r53, 15:59:21)


Meeting ended at 16:00:26 UTC (full logs).

Action items

  1. d34dh0r53 Look into adding/restoring a known issues section to our documentation
  2. d34dh0r53 add https://bugs.launchpad.net/keystone/+bug/1305950 to the known issues section of our documentation
  3. d34dh0r53 investigate switching the default hashing algo to scrypt in 2024.x
  4. hiromu is going to look at https://bugs.launchpad.net/keystone/+bug/2029134
  5. noonedeadpunk and d34dh0r53 are looking for a workaround/fix for https://bugs.launchpad.net/keystone/+bug/2028809


Action items, by person

  1. d34dh0r53
    1. d34dh0r53 Look into adding/restoring a known issues section to our documentation
    2. d34dh0r53 add https://bugs.launchpad.net/keystone/+bug/1305950 to the known issues section of our documentation
    3. d34dh0r53 investigate switching the default hashing algo to scrypt in 2024.x
    4. noonedeadpunk and d34dh0r53 are looking for a workaround/fix for https://bugs.launchpad.net/keystone/+bug/2028809
  2. hiromu
    1. hiromu is going to look at https://bugs.launchpad.net/keystone/+bug/2029134
  3. noonedeadpunk
    1. noonedeadpunk and d34dh0r53 are looking for a workaround/fix for https://bugs.launchpad.net/keystone/+bug/2028809


People present (lines said)

  1. d34dh0r53 (85)
  2. noonedeadpunk (23)
  3. hiromu (10)
  4. opendevmeet (3)
  5. dmendiza[m] (3)
  6. xek (1)
  7. zaitcev (1)
  8. knikolla (1)


Generated by MeetBot 0.1.4.