15:03:47 <d34dh0r53> #startmeeting keystone
15:03:47 <opendevmeet> Meeting started Wed Sep 13 15:03:47 2023 UTC and is due to finish in 60 minutes.  The chair is d34dh0r53. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:47 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:47 <opendevmeet> The meeting name has been set to 'keystone'
15:04:27 <d34dh0r53> #topic roll call
15:04:28 <d34dh0r53> admiyo, bbobrov, crisloma, d34dh0r53, dpar, dstanek, hrybacki, knikolla[m], lbragstad, lwanderley, kmalloc, rodrigods, samueldmq, ruan_he, wxy, sonuk, vishakha, Ajay, rafaelwe, xek, gmann, zaitcev, reqa, dmendiza[m]
15:04:30 <d34dh0r53> o/
15:05:24 <dmendiza[m]> 🙋
15:06:25 <d34dh0r53> #topic review past meeting work items
15:06:43 <d34dh0r53> #link https://meetings.opendev.org/meetings/keystone/2023/keystone.2023-09-06-15.01.html
15:07:10 <d34dh0r53> busy with release stuff so I'll have to push the documentation section stuff to next week
15:07:18 <d34dh0r53> #action d34dh0r53 Look into adding/restoring a known issues section to our documentation
15:07:26 <d34dh0r53> #action d34dh0r53 add https://bugs.launchpad.net/keystone/+bug/1305950 to the known issues section of our documentation
15:07:35 <d34dh0r53> finally reviewathon https://review.opendev.org/q/topic:bp%252Fenhance-oauth2-interoperability
15:08:47 <d34dh0r53> we were able to get this voted on, it's failing on a transient error (I think), rechecking now
15:09:20 <d34dh0r53> that does it for the past meeting work items, moving on to...
15:09:25 <d34dh0r53> #topic liaison updates
15:09:31 <d34dh0r53> Nothing from VMT
15:11:27 <d34dh0r53> we're in RC1 for bobcat right now, I have a temporary -1 on
15:11:32 <d34dh0r53> #link https://review.opendev.org/c/openstack/releases/+/894662
15:12:04 <d34dh0r53> in order to get the default manager role patch merged
15:12:06 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone/+/822601
15:12:14 <d34dh0r53> which is currently gating
15:12:50 <dmendiza[m]> heh, didn't realize that was stuck in gate limbo
15:12:59 <d34dh0r53> I'll update and approve the release patch once that's in as I believe that's all we still need to get in for bobcat
15:13:14 <d34dh0r53> yeah, devstack dropped support for focal :/
15:14:04 <d34dh0r53> #link https://zuul.opendev.org/t/openstack/status#822601
15:14:16 <d34dh0r53> if you're curious
15:14:28 <d34dh0r53> that does it for liaison updates
15:14:32 <d34dh0r53> next up we have
15:14:53 <d34dh0r53> #topic specification OAuth 2.0 (hiromu)
15:15:02 <d34dh0r53> #link https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext
15:15:04 <d34dh0r53> #link https://review.opendev.org/q/topic:bp%252Fenhance-oauth2-interoperability
15:15:06 <d34dh0r53> External OAuth 2.0 Specification
15:15:08 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone-specs/+/861554
15:15:10 <d34dh0r53> OAuth 2.0 Implementation
15:15:12 <d34dh0r53> #link https://review.opendev.org/q/topic:bp%252Fsupport-oauth2-mtls
15:15:14 <d34dh0r53> OAuth 2.0 Documentation
15:15:16 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone/+/838108
15:15:18 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystoneauth/+/838104
15:15:57 <d34dh0r53> working on getting the external OAuth 2.0 support patch merged
15:16:09 <d34dh0r53> hopefully today :fingerscrossed:
15:16:38 <d34dh0r53> and it doesn't look like Hiromu is here today so we'll move on to
15:16:51 <d34dh0r53> #topic specification Secure RBAC (dmendiza[m])
15:17:01 <d34dh0r53> #link https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_
15:17:02 <d34dh0r53> Manager Role Implementation
15:17:04 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone/+/822601
15:17:18 <d34dh0r53> dmendiza[m]: any updates? what's next once the manager role is in?
15:17:27 <dmendiza[m]> Yeah, not much else going on other than that patc
15:17:28 <dmendiza[m]> *patch
15:17:33 <d34dh0r53> sweet
15:17:53 <dmendiza[m]> I'll have to double check the community goal to figure out what we're supposed to do next
15:18:03 <dmendiza[m]> #link https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html
15:18:07 <dmendiza[m]> oh derp, you already linked it
15:19:12 <d34dh0r53> :) cool
15:20:02 <d34dh0r53> #topic open discussion
15:20:15 <d34dh0r53> there's one agenda item
15:20:23 <d34dh0r53> bug fix https://review.opendev.org/c/openstack/keystonemiddleware/+/88535
15:20:37 <d34dh0r53> but the link is broken, I *think* it's probably referring to this fix:
15:20:48 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystonemiddleware/+/885351
15:20:59 <d34dh0r53> which I can review after the meeting
15:21:40 <d34dh0r53> there's no IRC handle for that item so I'm not sure who to ping
15:22:20 <d34dh0r53> LMK if there is a different keystonemiddleware review
15:22:34 <d34dh0r53> anything else for open discussion?
15:24:29 <d34dh0r53> moving on
15:24:32 <dmendiza[m]> I'm good
15:24:48 <d34dh0r53> #topic bug review
15:24:55 <d34dh0r53> #link https://bugs.launchpad.net/keystone/?orderby=-id&start=0
15:25:48 <d34dh0r53> we have a new bug:
15:25:52 <d34dh0r53> #link https://bugs.launchpad.net/keystone/+bug/2035006
15:27:17 <d34dh0r53> dmendiza[m]: can you take a look at that when you have a minute?
15:27:35 <dmendiza[m]> ack
15:27:43 <d34dh0r53> thx
15:27:46 <d34dh0r53> next up
15:27:50 <d34dh0r53> #link https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0
15:28:01 <d34dh0r53> no new bugs for python-keystoneclient
15:28:21 <d34dh0r53> #link https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0
15:28:33 <d34dh0r53> keystoneauth is good
15:28:51 <d34dh0r53> #link https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0
15:29:09 <d34dh0r53> keystonemiddleware is good too
15:29:13 <d34dh0r53> #link https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0
15:29:27 <d34dh0r53> nothing new for pycadf
15:29:28 <d34dh0r53> #link https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0
15:29:46 <d34dh0r53> and ldappool is good
15:29:50 <d34dh0r53> #topic conclusion
15:30:00 <d34dh0r53> Thanks everyone!
15:30:22 <d34dh0r53> Don't forget to register for the PTG!
15:30:24 <d34dh0r53> #link https://ptg2023.openinfra.dev
15:30:30 <d34dh0r53> #endmeeting