#openstack-keystone: keystone

Meeting started by d34dh0r53 at 15:00:38 UTC (full logs).

Meeting summary

  1. roll call (d34dh0r53, 15:00:45)
  2. review past meeting work items (d34dh0r53, 15:03:04)
    1. https://meetings.opendev.org/meetings/keystone/2023/keystone.2023-11-29-15.00.html (d34dh0r53, 15:03:10)
    2. ACTION: d34dh0r53 Look into adding/restoring a known issues section to our documentation (d34dh0r53, 15:03:41)
    3. ACTION: d34dh0r53 Look into adding/restoring a known issues section to our documentation (d34dh0r53, 15:03:54)

  3. liaison updates (d34dh0r53, 15:04:50)
  4. specification OAuth 2.0 (hiromu) (d34dh0r53, 15:06:25)
    1. https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext (d34dh0r53, 15:06:36)
    2. https://review.opendev.org/q/topic:bp%252Fenhance-oauth2-interoperability (d34dh0r53, 15:06:38)
    3. https://review.opendev.org/c/openstack/keystone-specs/+/861554 (d34dh0r53, 15:06:42)
    4. https://review.opendev.org/q/topic:bp%252Fsupport-oauth2-mtls (d34dh0r53, 15:06:46)
    5. https://review.opendev.org/c/openstack/keystone/+/838108 (d34dh0r53, 15:06:50)
    6. https://review.opendev.org/c/openstack/keystoneauth/+/838104 (d34dh0r53, 15:06:52)

  5. specification Secure RBAC (dmendiza[m]) (d34dh0r53, 15:09:37)
    1. https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_ (d34dh0r53, 15:09:46)
    2. https://review.opendev.org/c/openstack/keystone/+/902730 (dmendiza[m], 15:13:56)

  6. specification Add schema version and support to "domain" attribute in mapping rules (gtema) (d34dh0r53, 15:17:00)
    1. https://review.opendev.org/c/openstack/keystone-specs/+/748042 (d34dh0r53, 15:17:08)
    2. https://review.opendev.org/c/openstack/keystone/+/739966 (gtema, 15:19:19)

  7. open discussion (d34dh0r53, 15:21:08)
    1. https://meetings.opendev.org/meetings/keystone/2021/keystone.2021-11-09-15.00.html - it was discussed here (bbobrov, 15:27:19)
    2. https://governance.openstack.org/tc/reference/runtimes/2024.1.html (dmendiza[m], 15:30:51)

  8. bug review (d34dh0r53, 15:37:21)
    1. https://bugs.launchpad.net/keystone/?orderby=-id&start=0 (d34dh0r53, 15:38:42)
    2. https://bugs.launchpad.net/keystone/+bug/2044624 (d34dh0r53, 15:41:12)
    3. https://bugs.launchpad.net/keystone/+bug/2045974 (d34dh0r53, 15:43:26)
    4. https://bugs.launchpad.net/keystone/+bug/2045995 (d34dh0r53, 15:54:07)
    5. https://bugs.launchpad.net/keystone/+bug/2046355 (d34dh0r53, 15:59:33)

  9. conclusion (d34dh0r53, 16:00:06)


Meeting ended at 16:01:27 UTC (full logs).

Action items

  1. d34dh0r53 Look into adding/restoring a known issues section to our documentation
  2. d34dh0r53 Look into adding/restoring a known issues section to our documentation


Action items, by person

  1. d34dh0r53
    1. d34dh0r53 Look into adding/restoring a known issues section to our documentation
    2. d34dh0r53 Look into adding/restoring a known issues section to our documentation


People present (lines said)

  1. d34dh0r53 (98)
  2. bbobrov (32)
  3. zigo (26)
  4. gtema (13)
  5. dmendiza[m] (11)
  6. opendevmeet (3)
  7. xek (1)
  8. mharley (1)


Generated by MeetBot 0.1.4.