#openstack-keystone: keystone

Meeting started by d34dh0r53 at 15:02:41 UTC (full logs).

Meeting summary

  1. roll call (d34dh0r53, 15:03:00)
  2. review past meeting work items (d34dh0r53, 15:09:58)
    1. ACTION: d34dh0r53 Look into adding/restoring a known issues section to our documentation (d34dh0r53, 15:10:37)
    2. ACTION: d34dh0r53 add https://bugs.launchpad.net/keystone/+bug/1305950 to the known issues section of our documentation (d34dh0r53, 15:10:45)
    3. https://meetings.opendev.org/meetings/keystone/2024/keystone.2024-02-07-15.02.html (d34dh0r53, 15:11:05)

  3. liaison updates (d34dh0r53, 15:11:16)
    1. https://governance.openstack.org/tc/resolutions/20230724-unmaintained-branches.html (d34dh0r53, 15:13:46)

  4. specification OAuth 2.0 (hiromu) (d34dh0r53, 15:15:02)
    1. https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext (d34dh0r53, 15:15:11)
    2. https://review.opendev.org/q/topic:bp%252Fenhance-oauth2-interoperability (d34dh0r53, 15:15:13)
    3. https://review.opendev.org/c/openstack/keystone-specs/+/861554 (d34dh0r53, 15:15:17)
    4. https://review.opendev.org/q/topic:bp%252Fsupport-oauth2-mtls (d34dh0r53, 15:15:21)
    5. https://review.opendev.org/c/openstack/keystone/+/838108 (d34dh0r53, 15:15:25)
    6. https://review.opendev.org/c/openstack/keystoneauth/+/838104 (d34dh0r53, 15:15:27)

  5. specification Secure RBAC (dmendiza[m]) (d34dh0r53, 15:18:14)
    1. https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_ (d34dh0r53, 15:18:23)
    2. https://review.opendev.org/c/openstack/keystone/+/902730 (Merged) (d34dh0r53, 15:18:31)
    3. https://review.opendev.org/c/openstack/keystone-tempest-plugin/+/903713 (d34dh0r53, 15:18:33)

  6. specification Improve federated users management (previously: Add schema version and support to "domain" attribute in mapping rules) (gtema) (d34dh0r53, 15:23:35)
    1. https://review.opendev.org/c/openstack/keystone-specs/+/748748 - waiting for reviews (d34dh0r53, 15:23:41)

  7. open discussion (d34dh0r53, 15:26:27)
  8. bug review (d34dh0r53, 15:30:34)
    1. https://bugs.launchpad.net/keystone/?orderby=-id&start=0 (d34dh0r53, 15:30:40)
    2. https://bugs.launchpad.net/keystone/+bug/2052916 (d34dh0r53, 15:31:00)
    3. https://bugs.launchpad.net/keystone/+bug/2053137 (d34dh0r53, 15:31:57)
    4. https://opendev.org/openstack/keystone/src/commit/7dc175a41f92e3f01cf26912431d0f2c98a03b32/keystone/assignment/core.py#L103 returns an empty list (bbobrov, 15:34:37)
    5. https://opendev.org/openstack/keystone/src/commit/7dc175a41f92e3f01cf26912431d0f2c98a03b32/keystone/assignment/core.py#L1342 because the role assignments are first deleted (bbobrov, 15:35:32)
    6. https://review.opendev.org/c/openstack/keystone/+/908998 - the test to demo the issue btw (bbobrov, 15:36:54)
    7. https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0 (d34dh0r53, 15:39:18)
    8. https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0 (d34dh0r53, 15:39:47)
    9. https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0 (d34dh0r53, 15:40:11)
    10. https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0 (d34dh0r53, 15:40:29)
    11. https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0 (d34dh0r53, 15:41:35)

  9. conclusion (d34dh0r53, 15:41:51)
    1. https://openinfra.dev/ptg/ (d34dh0r53, 15:42:33)
    2. https://etherpad.opendev.org/p/dalmation-ptg-keystone (d34dh0r53, 15:44:35)


Meeting ended at 15:47:54 UTC (full logs).

Action items

  1. d34dh0r53 Look into adding/restoring a known issues section to our documentation
  2. d34dh0r53 add https://bugs.launchpad.net/keystone/+bug/1305950 to the known issues section of our documentation


Action items, by person

  1. d34dh0r53
    1. d34dh0r53 Look into adding/restoring a known issues section to our documentation
    2. d34dh0r53 add https://bugs.launchpad.net/keystone/+bug/1305950 to the known issues section of our documentation


People present (lines said)

  1. d34dh0r53 (79)
  2. bbobrov (12)
  3. dmendiza[m] (4)
  4. opendevmeet (3)
  5. gtema (3)
  6. opendevreview (2)
  7. xek (1)


Generated by MeetBot 0.1.4.