#openstack-keystone: keystone

Meeting started by d34dh0r53 at 15:01:48 UTC (full logs).

Meeting summary

  1. roll call (d34dh0r53, 15:02:02)
  2. review past meeting work items (d34dh0r53, 15:04:23)
    1. https://meetings.opendev.org/meetings/keystone/2024/keystone.2024-06-26-15.01.html (d34dh0r53, 15:05:01)

  3. liaison updates (d34dh0r53, 15:05:20)
    1. https://security.openstack.org/ossa/OSSA-2024-001.html (d34dh0r53, 15:07:09)

  4. specification OAuth 2.0 (hiromu) (d34dh0r53, 15:09:13)
    1. https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext (d34dh0r53, 15:09:27)
    2. https://review.opendev.org/q/topic:bp%252Fenhance-oauth2-interoperability (d34dh0r53, 15:09:39)
    3. https://review.opendev.org/q/topic:bp%252Fsupport-oauth2-mtls (d34dh0r53, 15:09:57)

  5. specification Secure RBAC (dmendiza[m]) (d34dh0r53, 15:10:35)
    1. https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_ (d34dh0r53, 15:10:44)

  6. specification Improve federated users management (gtema) (d34dh0r53, 15:11:19)
    1. https://review.opendev.org/c/openstack/keystone/+/920892 (d34dh0r53, 15:11:26)

  7. specification OpenAPI support (gtema) (d34dh0r53, 15:14:15)
    1. https://review.opendev.org/q/topic:%22openapi%22+project:openstack/keystone (d34dh0r53, 15:14:34)
    2. the discussion is in https://review.opendev.org/c/openstack/keystone/+/923181 (gtema, 15:19:09)

  8. open discussion (d34dh0r53, 15:28:08)
    1. ACTION: d34dh0r53 move reviewathon to 14:00 UTC for Daylight time (d34dh0r53, 15:32:36)
    2. https://review.opendev.org/c/openstack/keystone-specs/+/903172 (d34dh0r53, 15:33:07)

  9. bug review (d34dh0r53, 15:38:05)
    1. https://bugs.launchpad.net/keystone/?orderby=-id&start=0 (d34dh0r53, 15:38:13)
    2. https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0 (d34dh0r53, 15:38:47)
    3. https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0 (d34dh0r53, 15:39:06)
    4. https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0 (d34dh0r53, 15:39:28)
    5. https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0 (d34dh0r53, 15:39:49)
    6. https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0 (d34dh0r53, 15:40:08)

  10. conclusion (d34dh0r53, 15:40:33)


Meeting ended at 15:41:46 UTC (full logs).

Action items

  1. d34dh0r53 move reviewathon to 14:00 UTC for Daylight time


Action items, by person

  1. d34dh0r53
    1. d34dh0r53 move reviewathon to 14:00 UTC for Daylight time


People present (lines said)

  1. d34dh0r53 (74)
  2. gtema (38)
  3. mhen (5)
  4. opendevmeet (3)
  5. xek (1)
  6. Luzi (1)


Generated by MeetBot 0.1.4.