#openstack-keystone: keystone

Meeting started by d34dh0r53 at 15:00:21 UTC (full logs).

Meeting summary

  1. roll call (d34dh0r53, 15:01:16)
  2. review past meeting work items (d34dh0r53, 15:03:06)
    1. https://meetings.opendev.org/meetings/keystone/2024/keystone.2024-07-10-15.00.html (d34dh0r53, 15:03:30)

  3. liaison updates (d34dh0r53, 15:03:53)
  4. specification OAuth 2.0 (hiromu) (d34dh0r53, 15:06:03)
    1. https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext (d34dh0r53, 15:06:51)
    2. https://review.opendev.org/q/topic:bp%252Fenhance-oauth2-interoperability (d34dh0r53, 15:07:11)
    3. https://review.opendev.org/c/openstack/keystone-specs/+/861554 (merged) (d34dh0r53, 15:07:35)
    4. https://review.opendev.org/q/topic:bp%252Fsupport-oauth2-mtls (d34dh0r53, 15:07:51)
    5. https://review.opendev.org/c/openstack/keystone/+/838108 (merged) (d34dh0r53, 15:08:07)
    6. https://review.opendev.org/c/openstack/keystoneauth/+/838104 (merged) (d34dh0r53, 15:08:14)

  5. specification Secure RBAC (dmendiza[m]) (d34dh0r53, 15:09:00)
    1. https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_ (d34dh0r53, 15:09:08)
    2. https://review.opendev.org/c/openstack/keystone/+/902730 (Merged) (d34dh0r53, 15:09:26)
    3. https://review.opendev.org/c/openstack/keystone-tempest-plugin/+/903713 (Merged) (d34dh0r53, 15:09:33)
    4. https://review.opendev.org/c/openstack/tempest/+/912489 (Merged) (d34dh0r53, 15:09:41)

  6. specification domain manager (mhen) (d34dh0r53, 15:17:55)
    1. https://review.opendev.org/c/openstack/keystone-specs/+/903172 (d34dh0r53, 15:18:08)
    2. https://review.opendev.org/q/topic:%22domain-manager%22 (d34dh0r53, 15:18:24)
    3. ACTION: reviewathon look at https://review.opendev.org/c/openstack/keystone/+/924132 (d34dh0r53, 15:34:50)

  7. specification OpenAPI support (gtema) (d34dh0r53, 15:35:29)
    1. https://review.opendev.org/c/openstack/keystone-specs/+/910584 (merged) (d34dh0r53, 15:35:37)
    2. https://review.opendev.org/q/topic:%22openapi%22+project:openstack/keystone (d34dh0r53, 15:35:45)
    3. https://review.opendev.org/c/openstack/keystone/+/923324 covers credentials with schemas (gtema, 15:40:12)
    4. ACTION: reviewathon https://review.opendev.org/c/openstack/keystone/+/923067 and https://review.opendev.org/c/openstack/keystone/+/923324 (d34dh0r53, 15:42:13)

  8. open discussion (d34dh0r53, 15:42:40)
    1. https://review.opendev.org/c/openstack/keystone/+/924522 - reformat patch. Would appretiate merge soon to reduce merge conflicts (d34dh0r53, 15:43:04)
    2. https://review.opendev.org/q/topic:%22renovate%22 (d34dh0r53, 15:43:10)

  9. bug review (d34dh0r53, 15:48:03)
    1. https://bugs.launchpad.net/keystone/?orderby=-id&start=0 (d34dh0r53, 15:48:12)
    2. https://bugs.launchpad.net/keystone/+bug/2073377 (d34dh0r53, 15:48:44)
    3. https://review.opendev.org/c/openstack/keystone/+/924153 (gtema, 15:49:37)
    4. https://bugs.launchpad.net/keystone/+bug/2072945 (d34dh0r53, 15:51:59)
    5. https://bugs.launchpad.net/keystone/+bug/2072639 (d34dh0r53, 15:57:11)
    6. https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0 (d34dh0r53, 15:58:36)
    7. https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0 (d34dh0r53, 15:59:00)
    8. https://bugs.launchpad.net/keystoneauth/+bug/2072481 (d34dh0r53, 15:59:57)
    9. https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0 (d34dh0r53, 16:03:54)
    10. https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0 (d34dh0r53, 16:04:12)
    11. https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0 (d34dh0r53, 16:04:42)

  10. conclusion (d34dh0r53, 16:05:14)


Meeting ended at 16:05:25 UTC (full logs).

Action items

  1. reviewathon look at https://review.opendev.org/c/openstack/keystone/+/924132
  2. reviewathon https://review.opendev.org/c/openstack/keystone/+/923067 and https://review.opendev.org/c/openstack/keystone/+/923324


People present (lines said)

  1. d34dh0r53 (104)
  2. gtema (27)
  3. mhen (14)
  4. opendevmeet (4)
  5. dmendiza[m] (4)
  6. xek (1)
  7. zaitcev (1)
  8. mharley[m] (1)


Generated by MeetBot 0.1.4.