#openstack-keystone: keystone

Meeting started by d34dh0r53 at 15:00:43 UTC (full logs).

Meeting summary

  1. roll call (d34dh0r53, 15:01:13)
  2. review past meeting work items (d34dh0r53, 15:03:23)
    1. https://meetings.opendev.org/meetings/keystone/2024/keystone.2024-09-25-15.01.html (d34dh0r53, 15:03:28)

  3. liaison updates (d34dh0r53, 15:03:46)
  4. specification OAuth 2.0 (hiromu) (d34dh0r53, 15:05:48)
    1. https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext (d34dh0r53, 15:05:52)
    2. https://review.opendev.org/q/topic:bp%252Fenhance-oauth2-interoperability (d34dh0r53, 15:05:56)
    3. https://review.opendev.org/c/openstack/keystone-specs/+/861554 (merged) (d34dh0r53, 15:06:05)
    4. https://review.opendev.org/q/topic:bp%252Fsupport-oauth2-mtls (d34dh0r53, 15:06:18)
    5. https://review.opendev.org/c/openstack/keystone/+/838108 (merged) (d34dh0r53, 15:06:30)
    6. https://review.opendev.org/c/openstack/keystoneauth/+/838104 (merged) (d34dh0r53, 15:06:37)
    7. https://review.opendev.org/c/openstack/keystone/+/860928 (d34dh0r53, 15:08:08)

  5. specification Secure RBAC (dmendiza[m]) (d34dh0r53, 15:08:57)
    1. https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_ (d34dh0r53, 15:09:02)

  6. specification OpenAPI support (gtema) (d34dh0r53, 15:16:18)
    1. https://review.opendev.org/q/topic:%22openapi%22+project:openstack/keystone (d34dh0r53, 15:16:23)

  7. specification domain manager (mhen) (d34dh0r53, 15:19:15)
    1. https://review.opendev.org/q/topic:%22domain-manager%22 (d34dh0r53, 15:19:20)

  8. specification Type annotations (stephenfin) (d34dh0r53, 15:25:52)
    1. https://review.opendev.org/q/project:openstack/keystoneauth+topic:typing (d34dh0r53, 15:25:56)

  9. open discussion (d34dh0r53, 15:31:37)
    1. ACTION: reviewathon discuss and hopefully perform the removal of passlib https://review.opendev.org/q/topic:%22passlib%22 (d34dh0r53, 15:38:05)

  10. bug review (d34dh0r53, 15:38:27)
    1. https://bugs.launchpad.net/keystone/?orderby=-id&start=0 (d34dh0r53, 15:38:32)
    2. https://bugs.launchpad.net/keystone/+bug/2083004 (d34dh0r53, 15:39:22)
    3. https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0 (d34dh0r53, 15:48:47)
    4. https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0 (d34dh0r53, 15:52:49)
    5. https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0 (d34dh0r53, 15:53:13)
    6. https://bugs.launchpad.net/keystonemiddleware/+bug/2081732 (d34dh0r53, 15:53:45)
    7. https://review.opendev.org/c/openstack/keystonemiddleware/+/931148 (d34dh0r53, 15:54:41)
    8. https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0 (d34dh0r53, 15:55:07)
    9. https://bugs.launchpad.net/ldappool/+bugs?ordterby=-id&start=0 (d34dh0r53, 15:55:24)

  11. conclusion (d34dh0r53, 15:55:55)
    1. https://etherpad.opendev.org/p/oct2024-ptg-keystone (d34dh0r53, 15:56:17)


Meeting ended at 15:57:20 UTC (full logs).

Action items

  1. reviewathon discuss and hopefully perform the removal of passlib https://review.opendev.org/q/topic:%22passlib%22


People present (lines said)

  1. d34dh0r53 (104)
  2. gtema (27)
  3. dmendiza[m] (16)
  4. TheJulia (9)
  5. stephenfin (7)
  6. opendevmeet (3)


Generated by MeetBot 0.1.4.