#openstack-keystone: keystone

Meeting started by d34dh0r53 at 15:12:21 UTC (full logs).

Meeting summary

    1. https://openinfra.dev/legal/code-of-conduct (d34dh0r53, 15:12:35)

  1. roll call (d34dh0r53, 15:12:42)
  2. review past meeting work items (d34dh0r53, 15:15:18)
    1. https://meetings.opendev.org/meetings/keystone/2024/keystone.2024-11-13-15.02.html (d34dh0r53, 15:15:28)

  3. liaison updates (d34dh0r53, 15:15:40)
  4. specification OAuth 2.0 (hiromu) (d34dh0r53, 15:21:16)
    1. https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext (d34dh0r53, 15:21:27)
    2. https://review.opendev.org/q/topic:bp%252Fenhance-oauth2-interoperability (d34dh0r53, 15:21:35)
    3. https://review.opendev.org/c/openstack/keystone-specs/+/861554 (merged) (d34dh0r53, 15:21:46)
    4. https://review.opendev.org/q/topic:bp%252Fsupport-oauth2-mtls (d34dh0r53, 15:21:53)
    5. https://review.opendev.org/c/openstack/keystone/+/838108 (merged) (d34dh0r53, 15:22:01)
    6. https://review.opendev.org/c/openstack/keystoneauth/+/838104 (merged) (d34dh0r53, 15:22:05)

  5. specification Secure RBAC (dmendiza[m]) (d34dh0r53, 15:22:39)
    1. https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_ (d34dh0r53, 15:23:02)

  6. specification OpenAPI support (gtema) (d34dh0r53, 15:26:43)
    1. https://review.opendev.org/q/topic:%22openapi%22+project:openstack/keystone (d34dh0r53, 15:26:48)
    2. https://review.opendev.org/c/openstack/keystone/+/925020 could now also land to ease api-ref work (d34dh0r53, 15:26:54)

  7. specification domain manager (mhen) (d34dh0r53, 15:30:27)
  8. specification Type annotations (stephenfin) (d34dh0r53, 15:33:03)
    1. https://review.opendev.org/q/project:openstack/keystoneauth+topic:typing (d34dh0r53, 15:33:06)
    2. https://review.opendev.org/c/openstack/keystone/+/931959 - ruffing the keystone misses +W (d34dh0r53, 15:33:13)
    3. ACTION: d34dh0r53 Update SHA in https://review.opendev.org/c/openstack/releases/+/934599 to HEAD of keystoneauth (d34dh0r53, 15:35:47)

  9. specification Include bad password details in audit messages (stanislav-z) (d34dh0r53, 15:36:04)
    1. https://review.opendev.org/c/openstack/keystone-specs/+/915482 (d34dh0r53, 15:36:07)
    2. https://review.opendev.org/c/openstack/keystone/+/932423 (d34dh0r53, 15:36:10)

  10. open discussion (d34dh0r53, 15:38:04)
    1. https://review.opendev.org/q/topic:%22pagination%22+project:openstack/keystone (d34dh0r53, 15:38:09)
    2. https://review.opendev.org/c/openstack/keystone-tempest-plugin/+/934272 (tkajinam, 15:42:49)

  11. bug review (d34dh0r53, 15:47:02)
    1. https://bugs.launchpad.net/keystone/?orderby=-id&start=0 (d34dh0r53, 15:47:04)
    2. https://bugs.launchpad.net/keystone/+bug/2089051 (d34dh0r53, 15:47:25)
    3. https://bugs.launchpad.net/keystone/+bug/2089051 (d34dh0r53, 15:47:29)
    4. https://review.opendev.org/c/openstack/keystone/+/935689 (tkajinam, 15:48:19)
    5. https://bugs.launchpad.net/keystone/+bug/2088355 (d34dh0r53, 15:51:31)
    6. https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0 (d34dh0r53, 15:57:25)
    7. https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0 (d34dh0r53, 15:57:41)
    8. https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0 (d34dh0r53, 15:57:50)
    9. https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0 (d34dh0r53, 15:58:13)
    10. https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0 (d34dh0r53, 15:58:22)

  12. conclusion (d34dh0r53, 15:58:37)


Meeting ended at 15:59:20 UTC (full logs).

Action items

  1. d34dh0r53 Update SHA in https://review.opendev.org/c/openstack/releases/+/934599 to HEAD of keystoneauth


Action items, by person

  1. d34dh0r53
    1. d34dh0r53 Update SHA in https://review.opendev.org/c/openstack/releases/+/934599 to HEAD of keystoneauth


People present (lines said)

  1. d34dh0r53 (101)
  2. gtema (35)
  3. tkajinam (16)
  4. dmendiza[m] (5)
  5. opendevmeet (3)
  6. stanislav-z (1)


Generated by MeetBot 0.1.4.