15:05:41 <gtema> #startmeeting keystone
15:05:41 <opendevmeet> Meeting started Wed Jun  4 15:05:41 2025 UTC and is due to finish in 60 minutes.  The chair is gtema. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:05:41 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:05:41 <opendevmeet> The meeting name has been set to 'keystone'
15:05:57 <gtema> Reminder: This meeting takes place under the OpenInfra Foundation Code of Conduct
15:06:04 <gtema> #link https://openinfra.dev/legal/code-of-conduct
15:06:19 <gtema> #topic roll call
15:06:36 <gtema> admiyo, bbobrov, crisloma, d34dh0r53, dpar, dstanek, hrybacki, lbragstad, lwanderley, kmalloc, rodrigods, samueldmq, ruan_he, wxy, sonuk, vishakha, Ajay, rafaelwe, xek, gmann, zaitcev, reqa, dmendiza[m], dmendiza, mharley, jph, gtema, cardoe, deydra
15:06:54 <dmendiza[m]> 🙋‍♂️
15:07:12 <gtema> o/
15:07:36 <gtema> also here pretty lonely today
15:07:55 <d34dh0r53> o/ sorry, I was heads down and lost track of time
15:08:13 <gtema> #topic review past meeting work items
15:08:25 <d34dh0r53> I can take over if needed
15:08:39 <gtema> #link https://meetings.opendev.org/meetings/keystone/2025/keystone.2025-05-28-15.02.html
15:08:52 <gtema> no AIs
15:09:02 <gtema> #topic liaison updates
15:09:18 <gtema> nothing known to me
15:09:35 <cardoe> o/
15:10:31 <gtema> Dave Wilde (d34dh0r53): please try to continue - I experience pretty significant lag with the bridge
15:10:56 <d34dh0r53> ack
15:11:45 <d34dh0r53> any liaison updates?
15:11:50 <gtema> not from me
15:12:04 <dmendiza[m]> gtema: you should send a "#chair d34dh0r53"
15:12:16 <gtema> #chair d34dh0r53
15:12:16 <opendevmeet> Current chairs: d34dh0r53 gtema
15:12:46 <d34dh0r53> good call dmendiza , thanks
15:12:55 <d34dh0r53> #topic specification OAuth 2.0 (hiromu)
15:13:09 <d34dh0r53> #link https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext
15:13:14 <d34dh0r53> #link https://review.opendev.org/q/topic:bp%252Fenhance-oauth2-interoperability
15:13:17 <d34dh0r53> #External OAuth 2.0 Specification
15:13:33 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone-specs/+/861554 (merged)
15:13:45 <d34dh0r53> OAuth 2.0 Implementation
15:13:59 <d34dh0r53> #link https://review.opendev.org/q/topic:bp%252Fsupport-oauth2-mtls (merged)
15:14:05 <d34dh0r53> OAuth 2.0 Documentation
15:14:12 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone/+/838108 (merged)
15:14:21 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystoneauth/+/838104 (merged)
15:14:30 <d34dh0r53> no updates from me on this one
15:14:42 <d34dh0r53> #topic specification Secure RBAC (dmendiza[m])
15:14:46 <d34dh0r53> #link https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_
15:14:46 <d34dh0r53> 2024.1 Release Timeline
15:14:47 <d34dh0r53> Update oslo.policy in keystone to enforce_new_defaults=True
15:14:48 <d34dh0r53> Update oslo.policy in keystone to enforce_scope=True
15:15:23 <dmendiza[m]> Yeah...  I should get back to this or remove it from the recurring agenda
15:15:37 <dmendiza[m]> I think we still need to beef up tests for "manager"
15:15:55 <d34dh0r53> okay
15:16:49 <d34dh0r53> #action dmendiza update S-RBAC topic in meeting etherpad
15:17:17 <d34dh0r53> next up
15:17:31 <d34dh0r53> #topic specification OpenAPI support (gtema)
15:17:36 <d34dh0r53> #link https://review.opendev.org/q/topic:%22openapi%22+project:openstack/keystone
15:18:03 <gtema> there are 2 changes that I would appreciate a review:
15:18:13 <gtema> #link https://review.opendev.org/q/topic:%22openapi%22+project:openstack/keystone+is:open
15:18:31 <gtema> those are splitting request/response schemas and preparing further addressing of similar issues
15:19:10 <d34dh0r53> ack, I can take a look later today
15:19:28 <gtema> thanks a lot
15:19:45 <gtema> nothing else on the topic
15:20:08 <d34dh0r53> cool
15:20:29 <d34dh0r53> #topic open discussion
15:21:26 <gtema> nothing from my side today
15:22:03 <d34dh0r53> CFP for Summit closes June 13th
15:22:20 <d34dh0r53> #link https://summit2025.openinfra.org/cfp/
15:22:37 <gtema> I filled a talk for federation and passkey rework
15:22:42 <d34dh0r53> Get yer talks in :)
15:23:42 <gtema> are you interested in me filling a rust rework talk separately? I did that talk as webinar 2 times already, but maybe the summit will worth that again
15:24:13 <gtema> in addition to that yesterday on TC meeting Amy was mentioning that eventually we would have again a Project status updates, but there is no info so far
15:26:29 <d34dh0r53> I think it would be an interesting talk, probably with quite a few attendees
15:27:06 <d34dh0r53> Amy also mentioned project status updates with no updates again today :)
15:30:38 <d34dh0r53> cool, moving on to bug review
15:30:44 <d34dh0r53> #topic bug review
15:30:55 <d34dh0r53> #link https://bugs.launchpad.net/keystone/?orderby=-id&start=0
15:31:03 <d34dh0r53> we have a couple of new bugs
15:31:04 <d34dh0r53> #link https://bugs.launchpad.net/keystone/+bug/2112477
15:31:57 <d34dh0r53> That could definitely be a bug, but it needs to be reproduced
15:33:31 <gtema> well, reproducing anything with AD is not a thing that most likely anybody is very willing to do
15:35:05 <d34dh0r53> This will likely come up on our roadmap in the next month or so
15:35:53 <d34dh0r53> We're going to be doing some AD testing with LDAP
15:36:13 <gtema> ok, sounds good
15:38:00 <d34dh0r53> next bug up
15:38:05 <d34dh0r53> #link https://bugs.launchpad.net/keystone/+bug/2112112
15:38:10 <d34dh0r53> looks like stephenfin is working on this and has a fix proposed
15:39:02 <gtema> actually the alternative to that is the one I referred in the openapi
15:39:50 <gtema> my fix makes stephefins's fixsuperfluous
15:41:17 <d34dh0r53> I'll let you two discuss
15:41:44 <stephenfin> The second one, sure. The first one is significantly simpler and IMO should go in since it'll be much easier/less risky to backport
15:41:53 <d34dh0r53> #link https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0
15:42:07 <d34dh0r53> #undo
15:42:07 <opendevmeet> Removing item from minutes: #link https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0
15:45:45 <d34dh0r53> #link https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0
15:46:11 <d34dh0r53> no new bugs in python-keystoneclient
15:46:26 <d34dh0r53> #link https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0
15:46:45 <d34dh0r53> no new bugs in keystoneauth
15:47:03 <d34dh0r53> #link https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0
15:47:19 <d34dh0r53> keystonemiddleware is good
15:47:38 <d34dh0r53> #link https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0
15:47:46 <d34dh0r53> nothing new in pycadf
15:47:48 <d34dh0r53> #link https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0
15:48:00 <d34dh0r53> ldappool is good
15:48:10 <d34dh0r53> #topic conclusion
15:48:14 <d34dh0r53> thanks folks, nothing else from me
15:50:33 <d34dh0r53> #endmeeting