15:12:02 <d34dh0r53> #startmeeting keystone
15:12:02 <opendevmeet> Meeting started Wed Jun 11 15:12:02 2025 UTC and is due to finish in 60 minutes.  The chair is d34dh0r53. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:12:02 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:12:02 <opendevmeet> The meeting name has been set to 'keystone'
15:12:42 <xek> o/
15:12:50 <gtema> o/
15:13:46 <d34dh0r53> Reminder: This meeting takes place under the OpenInfra Foundation Code of Conduct
15:13:54 <d34dh0r53> #link https://openinfra.dev/legal/code-of-conduct
15:14:01 <d34dh0r53> #topic roll call
15:14:11 <d34dh0r53> admiyo, bbobrov, crisloma, d34dh0r53, dpar, dstanek, hrybacki, lbragstad, lwanderley, kmalloc, rodrigods, samueldmq, ruan_he, wxy, sonuk, vishakha, Ajay, rafaelwe, xek, gmann, zaitcev, reqa, dmendiza[m], dmendiza, mharley, jph, gtema, cardoe, deydra
15:14:14 <d34dh0r53> dmendiza:
15:14:47 <d34dh0r53> o/
15:14:52 <dmendiza[m]> 🙋‍♂️
15:15:14 <d34dh0r53> #topic review past meeting work items
15:15:28 <d34dh0r53> #link https://meetings.opendev.org/meetings/keystone/2025/keystone.2025-06-04-15.05.html
15:15:37 <d34dh0r53> one action item from last week
15:16:01 <d34dh0r53> dmendiza update S-RBAC topic in meeting etherpad
15:16:10 <dmendiza[m]> I did not do that 😅
15:16:41 <d34dh0r53> ack
15:17:10 <d34dh0r53> #action dmendiza update S-RBAC topic in meeting etherpad
15:17:19 <d34dh0r53> #topic liaison updates
15:17:23 <d34dh0r53> nothing from me
15:17:37 <gtema> not from me either
15:18:08 <d34dh0r53> 👍️
15:18:14 <d34dh0r53> #topic specification OAuth 2.0 (hiromu)
15:18:16 <d34dh0r53> #link https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext
15:18:18 <d34dh0r53> #link https://review.opendev.org/q/topic:bp%252Fenhance-oauth2-interoperability
15:18:21 <d34dh0r53> External OAuth 2.0 Specification
15:18:24 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone-specs/+/861554 (merged)
15:18:26 <d34dh0r53> OAuth 2.0 Implementation
15:18:28 <d34dh0r53> #link https://review.opendev.org/q/topic:bp%252Fsupport-oauth2-mtls (merged)
15:18:31 <d34dh0r53> OAuth 2.0 Documentation
15:18:34 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone/+/838108 (merged)
15:18:37 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystoneauth/+/838104 (merged)
15:19:13 <d34dh0r53> We're waiting for two tacker and two barbican patches to merge
15:19:47 <d34dh0r53> once those are merged we can merge the keystonemiddleware patch and I think everything is done
15:20:10 <d34dh0r53> next up
15:20:15 <d34dh0r53> #topic specification Secure RBAC (dmendiza)
15:20:17 <d34dh0r53> #link https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_
15:20:20 <d34dh0r53> 2024.1 Release Timeline
15:20:22 <d34dh0r53> Update oslo.policy in keystone to enforce_new_defaults=True
15:20:24 <d34dh0r53> Update oslo.policy in keystone to enforce_scope=True
15:20:38 <dmendiza[m]> Not much still ...  I'm making a note to review this for Upstream Friday
15:20:50 <d34dh0r53> ack, thanks dmendiza
15:20:59 <d34dh0r53> #topic specification OpenAPI support (gtema)
15:21:02 <d34dh0r53> #link https://review.opendev.org/q/topic:%22openapi%22+project:openstack/keystone
15:21:22 <gtema> I need 2 reviews: https://review.opendev.org/q/topic:%22openapi%22+is:open+project:openstack/keystone
15:21:37 <gtema> for splitting request/response schemas on user operations
15:22:11 <d34dh0r53> ack
15:22:22 <d34dh0r53> we can go through those in the Reviewathon
15:22:28 <gtema> 👍️
15:22:36 <d34dh0r53> #topic open discussion
15:23:07 <d34dh0r53> CFP for Summit closes on the 13th
15:23:15 <d34dh0r53> No expectation that it will be extended
15:23:59 <d34dh0r53> #link https://summit2025.openinfra.org/cfp/
15:24:05 <d34dh0r53> that's all from me
15:24:18 <gtema> have you guys pushed something wrt Keystone?
15:24:23 <gtema> I mean cfp
15:24:44 <d34dh0r53> I haven't, xek might have
15:24:51 <d34dh0r53> Have you?
15:25:26 <gtema> as said last week on federation. I still haven't for reimplementing keystone in Rust though - not confident
15:27:14 <d34dh0r53> Well, I think the room would be full if they accepted it :)
15:27:55 <gtema> really? think so?
15:28:12 <gtema> looking at general perception of Rust in TC I would not be sure
15:28:32 <gtema> but we can see ;-)
15:28:37 <d34dh0r53> I think you'd have a lot of popcorn eaters
15:28:55 <gtema> lol, okay, I'll submit it then
15:29:04 <d34dh0r53> 👍️
15:30:29 <d34dh0r53> moving on
15:30:34 <d34dh0r53> #topic bug review
15:30:37 <d34dh0r53> #link https://bugs.launchpad.net/keystone/?orderby=-id&start=0
15:30:49 <d34dh0r53> no new bugs for keystone this week
15:30:53 <d34dh0r53> #link https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0
15:31:04 <gtema> wow, that is a surprise ;-)
15:31:16 <d34dh0r53> I know, right?
15:31:31 <d34dh0r53> not surprisingly, there are no new bugs in python-keystoneclient
15:31:39 <d34dh0r53> #link https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0
15:31:54 <d34dh0r53> nothing new in keystoneauth
15:32:02 <d34dh0r53> #link https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0
15:32:11 <d34dh0r53> keystonemiddleware is also good
15:32:15 <d34dh0r53> #link https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0
15:32:30 <d34dh0r53> pycadf is clean
15:32:34 <d34dh0r53> #link https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0
15:32:41 <d34dh0r53> ldappool is good as well
15:32:44 <d34dh0r53> #topic conclusion
15:32:52 <d34dh0r53> Thanks all!
15:33:05 <xek> Thanks!
15:33:55 <gtema> thks folks
15:34:17 <d34dh0r53> #endmeeting