#openstack-keystone: keystone

Meeting started by d34dh0r53 at 15:20:44 UTC (full logs).

Meeting summary

    1. https://openinfra.dev/legal/code-of-conduct (d34dh0r53, 15:22:31)

  1. roll call (d34dh0r53, 15:22:47)
  2. review past meeting work items (d34dh0r53, 15:24:50)
    1. https://meetings.opendev.org/meetings/keystone/2025/keystone.2025-07-23-15.08.html (d34dh0r53, 15:24:53)

  3. liaison updates (d34dh0r53, 15:25:06)
  4. specification OAuth 2.0 (hiromu) (d34dh0r53, 15:26:15)
    1. https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext (d34dh0r53, 15:26:17)
    2. https://review.opendev.org/q/topic:bp%252Fenhance-oauth2-interoperability (d34dh0r53, 15:26:20)

  5. specification Secure RBAC (dmendiza) (d34dh0r53, 15:26:52)
    1. https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_ (d34dh0r53, 15:26:54)

  6. specification OpenAPI support (gtema) (d34dh0r53, 15:34:15)
    1. https://review.opendev.org/q/topic:%22openapi%22+project:openstack/keystone (d34dh0r53, 15:34:16)

  7. open discussion (d34dh0r53, 15:38:57)
    1. https://review.opendev.org/c/openstack/tempest/+/954029 (dmendiza[m], 15:45:15)

  8. bug review (d34dh0r53, 15:55:14)
    1. https://bugs.launchpad.net/keystone/?orderby=-id&start=0 (d34dh0r53, 15:55:16)
    2. https://bugs.launchpad.net/keystone/+bug/2119091 (d34dh0r53, 15:55:42)
    3. ACTION: dmendiza look into https://bugs.launchpad.net/keystone/+bug/2119091 (d34dh0r53, 15:57:12)
    4. https://bugs.launchpad.net/keystone/+bug/2119031 (d34dh0r53, 15:57:24)
    5. https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0 (d34dh0r53, 16:07:35)
    6. https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0 (d34dh0r53, 16:07:45)
    7. https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0 (d34dh0r53, 16:07:57)
    8. https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0 (d34dh0r53, 16:08:13)
    9. https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0 (d34dh0r53, 16:08:22)

  9. conclusion (d34dh0r53, 16:08:33)


Meeting ended at 16:09:26 UTC (full logs).

Action items

  1. dmendiza look into https://bugs.launchpad.net/keystone/+bug/2119091


People present (lines said)

  1. d34dh0r53 (72)
  2. dmendiza[m] (30)
  3. bbobrov (12)
  4. opendevmeet (3)
  5. mharley[m] (3)
  6. drencrom (3)
  7. breton (1)
  8. xek (1)
  9. cardoe (1)


Generated by MeetBot 0.1.4.