15:03:03 <d34dh0r53> #startmeeting keystone
15:03:03 <opendevmeet> Meeting started Wed Oct 15 15:03:03 2025 UTC and is due to finish in 60 minutes.  The chair is d34dh0r53. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:03 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:03 <opendevmeet> The meeting name has been set to 'keystone'
15:03:08 <d34dh0r53> Reminder: This meeting takes place under the OpenInfra Foundation Code of Conduct
15:03:11 <d34dh0r53> #link https://openinfra.dev/legal/code-of-conduct
15:03:17 <d34dh0r53> #topic roll call
15:03:33 <d34dh0r53> admiyo, bbobrov, crisloma, d34dh0r53, dpar, dstanek, hrybacki, lbragstad, lwanderley, kmalloc, rodrigods, samueldmq, ruan_he, wxy, sonuk, vishakha, Ajay, rafaelwe, xek, gmann, zaitcev, reqa, dmendiza[m], dmendiza, mharley, jph, gtema, cardoe, deydra
15:06:25 <d34dh0r53> #topic review past meeting work items
15:06:29 <d34dh0r53> #link https://meetings.opendev.org/meetings/keystone/2025/keystone.2025-10-01-15.07.html
15:06:51 <d34dh0r53> I still need to work out an exact time with the horizon folks, but they're aware
15:07:14 <d34dh0r53> #action dwilde plan PTG session with Horizon folks
15:07:22 <d34dh0r53> that's it for the action items
15:07:34 <d34dh0r53> #topic liaison updates
15:07:41 <d34dh0r53> nothing from vmt or releases
15:08:38 <d34dh0r53> #topic specification OAuth 2.0 (hiromu)
15:08:42 <d34dh0r53> #link https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext
15:08:45 <d34dh0r53> #link https://review.opendev.org/q/topic:bp%252Fenhance-oauth2-interoperability
15:08:48 <d34dh0r53> no updates from me
15:08:57 <d34dh0r53> #topic specification Secure RBAC (dmendiza)
15:09:00 <d34dh0r53> #link https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_
15:09:06 <d34dh0r53> 2025.2 Release Timeline
15:09:08 <d34dh0r53> Update oslo.policy in keystone to enforce_new_defaults=True
15:09:11 <d34dh0r53> Update oslo.policy in keystone to enforce_scope=True
15:12:00 <d34dh0r53> no updates this week, I guess
15:12:01 <d34dh0r53> next up
15:12:06 <d34dh0r53> #topic specification Secuirty Compliance Testing (dmendiza)
15:12:08 <d34dh0r53> #link https://review.opendev.org/c/openstack/devstack/+/957969
15:12:44 <d34dh0r53> I've added
15:12:46 <d34dh0r53> my +1
15:14:14 <d34dh0r53> #topic specification OpenAPI support (gtema)
15:14:15 <d34dh0r53> #link https://review.opendev.org/q/topic:%22openapi%22+project:openstack/keystone
15:18:07 <d34dh0r53> #topic open discussion
15:18:10 <d34dh0r53> drencrom
15:18:15 <d34dh0r53> pep8 (mypy) is broken on 2024.2 branch (see for example https://zuul.opendev.org/t/openstack/build/2fdbd3164c8c4241a5a6edd1895f6d3c)
15:20:41 <d34dh0r53> #topic bug review
15:20:44 <d34dh0r53> #link https://bugs.launchpad.net/keystone/?orderby=-id&start=0
15:22:02 <d34dh0r53> we have a couple of new bugs
15:22:06 <d34dh0r53> #link https://bugs.launchpad.net/keystone/+bug/2127188
15:22:23 <d34dh0r53> This is in progress with a patch proposed, I'll review it this week
15:22:29 <d34dh0r53> next
15:22:38 <d34dh0r53> #link https://bugs.launchpad.net/keystone/+bug/2126676
15:23:17 <d34dh0r53> This one is also In Progress, although I'm not sure who's working on it
15:23:27 <d34dh0r53> That does it for keystone
15:23:48 <d34dh0r53> #link https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0
15:24:12 <d34dh0r53> noting new in python-keystoneclient
15:24:17 <d34dh0r53> #link https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0
15:24:21 <d34dh0r53> keystoneauth is good
15:24:24 <d34dh0r53> #link https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0
15:24:30 <d34dh0r53> so is keystonemiddleware
15:24:33 <d34dh0r53> #link https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0
15:24:40 <d34dh0r53> no new bugs in pycadf
15:24:43 <d34dh0r53> #link https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0
15:24:52 <d34dh0r53> and ldappool is good to go
15:24:55 <d34dh0r53> #topic conclusion
15:25:16 <d34dh0r53> If an irc meeting happens alone, did it really happen?
15:25:19 <d34dh0r53> :)
15:25:29 <d34dh0r53> have a good week folks
15:25:33 <d34dh0r53> #endmeeting