20:00:03 <robcresswell> #startmeeting keystone_horizon
20:00:04 <openstack> Meeting started Thu Mar 30 20:00:03 2017 UTC and is due to finish in 60 minutes.  The chair is robcresswell. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:07 <openstack> The meeting name has been set to 'keystone_horizon'
20:00:10 <robcresswell> o/
20:00:34 <david-lyle> o/
20:01:59 <robcresswell> This'll be an awfully one-sided meeting :p
20:02:36 <lbragstad> o/
20:02:54 <david-lyle> everything is great!
20:02:59 <robcresswell> haha
20:03:09 <robcresswell> #link https://etherpad.openstack.org/p/keystone-horizon
20:03:45 <robcresswell> I still need to fix tempest on that patch to change default session type
20:03:46 <lbragstad> dstanek rderose around?
20:03:56 <robcresswell> thats blocking the v2 deprecation
20:04:01 <robcresswell> on horizons side, that is.
20:04:34 <robcresswell> I dont suppose anyone got a chance to look at https://review.openstack.org/#/c/339487/ ?
20:05:08 <lbragstad> i have not
20:05:16 <lbragstad> cmurphy might be a good one to add to that?
20:05:57 <robcresswell> There's a comment from colleen already, was hoping someone could back it up
20:06:03 <david-lyle> looking at that, I'm not sure why that would be needed.
20:06:09 <robcresswell> No response from kenji either
20:06:21 <david-lyle> oh target, nvmd
20:07:14 <robcresswell> It was started way before all the recent efforts, so it might not be needed now, and I didnt want to pressure for reviews until it was at least confirmed. I'll see if I can get in touch with kenji to see whats going on.
20:07:23 <david-lyle> wait, I'm not crazy, it should be set https://github.com/openstack/django_openstack_auth/blob/master/openstack_auth/policy.py#L138
20:07:31 <david-lyle> and that would be unnecessary
20:08:05 <david-lyle> but I think sjmc7 had a bug filed against doa for something similar
20:08:15 <robcresswell> recently?
20:08:19 <david-lyle> no
20:08:24 * david-lyle looks
20:08:35 <david-lyle> I don't think it was fixed, he had a patch
20:10:09 <robcresswell> https://review.openstack.org/#/c/361466/ ?
20:10:36 <david-lyle> yeah, just found the same
20:11:25 <david-lyle> that would be the proper place to fix it anyway
20:11:39 <lbragstad> looks a little stale
20:11:52 <david-lyle> we prefer well aged
20:12:17 <cmurphy> :)
20:12:34 <lbragstad> david-lyle ++ i like that term
20:13:06 <david-lyle> the fix should be in d-o-a regardless, because if we're grabbing the wrong domain_id it's wrong universally
20:13:50 <david-lyle> let me try to digest steve's patch and then will look at kenji's
20:15:06 <robcresswell> #action david-lyle to look at https://review.openstack.org/#/c/361466
20:15:11 <robcresswell> Pretty sure that's legally binding.
20:15:45 <david-lyle> not the #action
20:15:50 <david-lyle> dirty pool
20:16:10 <lbragstad> ba-dum-pshh
20:16:27 <robcresswell> rderose: Any progress on 8.2.6
20:16:32 <robcresswell> ?*
20:17:06 <lbragstad> robcresswell i don't think i've seen anything recently
20:17:13 <lbragstad> robcresswell i'm going to double check though
20:17:15 <robcresswell> cool
20:17:19 <robcresswell> Thanks
20:18:13 <lbragstad> robcresswell ack - nothing that I can see
20:18:26 <robcresswell> cool, thanks lbragstad
20:18:51 <robcresswell> Last question I had was regarding some Horizon work. I've been rewriting our Overview pages
20:19:08 <robcresswell> These so far have just been Compute usage and a few quotas
20:19:33 <robcresswell> We've some ideas to expand that, as well as solve performance issues, but I was wondering if there was anything that would be nice to have from a keystone pov
20:20:06 <lbragstad> included in horizon's overview page?
20:20:17 <robcresswell> The general concept behind those pages is to be able to check the overall status of a deployment and carry out some common actions from one location
20:20:34 <robcresswell> lbragstad: Yeah. I think keystone likely wouldnt, but I wanted to mention it in case something came up.
20:21:31 <lbragstad> robcresswell is this what you're referencing - https://docs.openstack.org/developer/horizon/ ?
20:22:04 <robcresswell> nono, the panel titled "Overview" in the dashboard
20:22:15 <lbragstad> oh - wow, i was way off
20:22:19 <lbragstad> nevermind
20:23:13 <lbragstad> from a regular user perspective (anyone you isn't an admin) the overview would be pretty boring from an identity perspective
20:23:30 <robcresswell> There's both an admin and project panel
20:23:39 <lbragstad> once you start getting into project/domain admin-like thing, then it's more interesting
20:24:08 <robcresswell> If you've any suggestions on what might be good to see, fire away
20:24:33 <robcresswell> We're looking at expanding quota coverage and adding common actions to the page... launch instance etc.
20:24:35 <lbragstad> as an admin - maybe it's useful to see the total number of projects?
20:24:47 <lbragstad> or total number of users?
20:25:10 <robcresswell> lbragstad: How easily retrievable are those? Is there an API for those values, or is it a list and count situation?
20:25:31 <lbragstad> it'd be a list and count situation
20:25:38 <david-lyle> just need pagination
20:25:41 * david-lyle ducks
20:26:10 <robcresswell> :( list and count makes me sad
20:26:33 <lbragstad> it's certainly not necessary - if the only way to do it is suboptimal
20:26:44 <robcresswell> I'll look into it. We're going to have to do a similar thing for Neutron anyway since they only offer Limits
20:27:05 <robcresswell> Cinder & nova have usages, though with slightly different implementations... >.<
20:27:15 <david-lyle> for a reasonable installation, I don't think it's even possible, the list will truncate
20:27:21 * robcresswell should stop before the rant takes over again.
20:27:24 <lbragstad> wait - usage...
20:28:04 <lbragstad> the usage implementation is different between nova and cinder?
20:28:17 <lbragstad> just different in how horizon has to ask for the information?
20:28:36 <lbragstad> or different in how the data is represented?
20:28:54 <robcresswell> same representations, just slightly different calls
20:29:00 <lbragstad> aha
20:29:08 <robcresswell> This kind of thing is irksome when you try and write common implementations
20:29:17 <lbragstad> sure
20:29:31 <robcresswell> What should be a loop becomes a different interface for each service :/
20:29:44 <lbragstad> not sure how much it will help this specific conversation, but we have the limit implementation being proposed to keystone now
20:30:07 <robcresswell> Well, whatever you do, just make it the same as the previous guys
20:30:24 <lbragstad> which will eventually have an impact on how services calculate useage
20:30:48 <robcresswell> I discovered today that services format error messages differently too, that was fun.
20:30:59 <lbragstad> nice
20:31:02 <robcresswell> like keystone is error.message and ironic is error_message.faultstring
20:31:09 <robcresswell> because why not :)
20:31:37 <lbragstad> ;)
20:31:51 <robcresswell> Is that part of the wider hierarchical quota effort?
20:32:17 <lbragstad> yeah - coming to some sort of agreement on limits is essentially the first step
20:33:10 <robcresswell> Nice, I saw that thread
20:33:31 <lbragstad> from there we want to try and propose a library that calculates usage consistently so it can be consumed across the projects
20:33:39 <robcresswell> \o/
20:33:45 <lbragstad> and not leave the projects high and dry to make different assumptions
20:34:05 <lbragstad> about usage
20:34:38 <lbragstad> per sdague's note, we want to try and come to consensus on the approach this week and give it a yay or nay for pike
20:34:49 <robcresswell> Yeah, the only solution for Neutron right now is to get their limits and then run a list for every resource and count them :/
20:34:56 <robcresswell> which is obviously slow
20:35:13 <lbragstad> so neutron currently doesn't supply a quota API?
20:35:24 <robcresswell> Not as far as I can tell
20:35:32 <lbragstad> it gives you a limit and the total number of things and you have to do the usage calculation?
20:35:43 <robcresswell> I've tried asking in the channel, but I think you have to be a core to get a reponse
20:36:01 <robcresswell> Just a limit for how many of X you can create
20:36:08 <lbragstad> ok - interesting
20:36:18 <lbragstad> that would directly benefit from the work we'll be doing then
20:36:23 <lbragstad> because the limit would be moved into keystone
20:36:32 <robcresswell> Then you have to calculate whats being used via lists. Again, might be misinformed, but thats all I could find.
20:36:40 <lbragstad> and the usage calculation would be done by a library invoked by neutron
20:37:17 <robcresswell> Anything common would be fantastic
20:37:47 <robcresswell> Writing UIs on top of OpenStack is fairly horrible right now
20:37:52 <lbragstad> yeah - in every way we've thought about it, we can't not have a common thing
20:38:15 <robcresswell> I would rather our APIs were common and bad than inconsistently good and bad, haha.
20:38:29 <lbragstad> :)
20:38:53 <robcresswell> Anyway, I think we can call the meeting, unless anyone has anything else to discuss?
20:39:02 <lbragstad> I'm good
20:39:07 <robcresswell> I'll keep an eye on the limits discussion
20:39:26 <robcresswell> Great, thanks for your time everyone
20:39:29 <robcresswell> #endmeeting