15:04:51 <d34dh0r53> #startmeeting Keystone Weekly Meeting
15:04:51 <opendevmeet> Meeting started Tue May 24 15:04:51 2022 UTC and is due to finish in 60 minutes.  The chair is d34dh0r53. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:51 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:51 <opendevmeet> The meeting name has been set to 'keystone_weekly_meeting'
15:05:02 <d34dh0r53> #topic Roll Call
15:05:17 <d34dh0r53> admiyo, bbobrov, crisloma, d34dh0r53, dpar, dstanek, hrybacki, knikolla, lbragstad, lwanderley, kmalloc, rodrigods, samueldmq, ruan_he, wxy, sonuk, vishakha, Ajay, rafaelwe
15:05:25 <d34dh0r53> Courtesy ping
15:05:48 <d34dh0r53> #topic Review past meeting work items
15:06:00 <d34dh0r53> #link https://meetings.opendev.org/meetings/keystone/2022
15:07:21 <h-asahina> o/
15:07:58 <d34dh0r53> I don't see any logs for last weeks meeting, and there aren't any action items from 2022-05-10
15:08:12 <d34dh0r53> #topic Liaison Updates
15:08:40 <d34dh0r53> Doug didn't hand any updates off to me, anyone have anything here?
15:10:23 <d34dh0r53> #topic specification
15:10:50 <d34dh0r53> #info OAuth 2.0
15:11:05 <d34dh0r53> #link https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext
15:11:50 <h-asahina> Hi, I'd like to notify that we might have to change the contents of our BP.
15:12:08 <h-asahina> BP: https://blueprints.launchpad.net/keystone/+spec/enhance-oauth2-interoperability
15:12:20 <d34dh0r53> h-asahina: ok
15:12:57 <h-asahina> I'd like to discuss with Spec I'll submit to avoid misunderstanding.
15:13:39 <h-asahina> and want to discuss if the change is in line with Keystone's roadmap.
15:13:43 <d34dh0r53> h-asahina: ok
15:14:07 <h-asahina> I'm planing to submit the Spec nextweek or the week after next.
15:14:30 <h-asahina> so, i'd like to confirm that do you hold meeting the week after next? I suppose we have OIS that week.
15:14:37 <h-asahina> we or some people
15:15:03 <d34dh0r53> h-asahina: yeah, that is the week of the OIS and I'm not sure if we'll hold the meeting or not.
15:15:18 <d34dh0r53> #action d34dh0r53 talk to dmendiza[m] about the weekly meeting during the summit
15:15:43 <d34dh0r53> h-asahina: when I touch base with dmendiza[m] I'll ask him and we'll let you know
15:15:44 <h-asahina> thanks. but seems the next week is better.
15:16:15 <d34dh0r53> h-asahina: next week might be better to discuss, although dmendiza[m] probably won't be here.  He's on PTO until just before the Summit
15:17:08 <h-asahina> ah. i got it.
15:17:53 <h-asahina> well, sooner is better.
15:18:21 <d34dh0r53> h-asahina: I'll try to let you know by the end of this week when the best time to raise this topic is
15:18:36 <h-asahina> great. thanks.
15:19:14 <d34dh0r53> it looks like reviews for the current set of OAuth 2.0 patches are up to date
15:19:36 <d34dh0r53> #info Secure RBAC
15:19:50 <d34dh0r53> #link https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_
15:20:20 <d34dh0r53> no updates here from my side
15:21:57 <d34dh0r53> #info Gate inherited assignments from parent (bbobrov)
15:22:11 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone-specs/+/334364
15:22:56 <d34dh0r53> dmendiza[m] and I talked about this one a bit but we didn't come to any conclusions.
15:23:41 <d34dh0r53> #topic public discussion
15:23:47 <d34dh0r53> bandit seems to be broken, cannot build keystone from git
15:25:11 <admiyo> Yeah I saw the Bandit issue
15:25:30 <admiyo> there are a few things I am finding building on Ubuntu instead of Fedora,  was nt sure if that was one of the,
15:25:32 <admiyo> them
15:26:23 <admiyo> I think there is going to be some pain moving from 39 to 3.10 as well
15:28:43 <d34dh0r53> admiyo: on the keystone side?
15:31:03 <d34dh0r53> interesting, I may poke at this as well
15:31:18 <d34dh0r53> moving on
15:31:21 <d34dh0r53> #topic bug review
15:31:34 <d34dh0r53> from last week we have this:
15:31:38 <d34dh0r53> #link https://bugs.launchpad.net/keystone/+bug/1950325 (bbobrov)
15:33:04 <d34dh0r53> #link https://bugs.launchpad.net/keystone/?orderby=-datecreated&start=0
15:33:11 <d34dh0r53> no new keystone bugs
15:33:35 <d34dh0r53> #link https://bugs.launchpad.net/python-keystoneclient/?orderby=-datecreated&start=0
15:33:45 <d34dh0r53> no new python-keystoneclient bugs
15:34:05 <d34dh0r53> #link https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-datecreated&start=0
15:34:13 <d34dh0r53> no new keystoneauth bugs
15:34:39 <d34dh0r53> #link https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-datecreated&start=0
15:34:46 <d34dh0r53> no new keystonemittleware bugs
15:35:04 <d34dh0r53> #link https://bugs.launchpad.net/pycadf/+bugs?orderby=-datecreated&start=0
15:35:09 <d34dh0r53> no new pycadf bugs
15:35:30 <d34dh0r53> #link https://bugs.launchpad.net/ldappool/+bugs?orderby=-datecreated&start=0
15:35:36 <d34dh0r53> and no new ldappool bugs
15:36:35 <d34dh0r53> #link https://review.opendev.org/c/openstack/python-keystoneclient/+/811966
15:36:48 <d34dh0r53> it look like this has merged, so no need to review it
15:37:22 <d34dh0r53> #topic open discussion
15:37:32 <d34dh0r53> Anyone have anything?
15:40:42 <d34dh0r53> Okay, thanks everyone!
15:40:45 <d34dh0r53> #endmeeting