20:00:19 <sdake> #startmeeting kolla
20:00:20 <openstack> Meeting started Mon Feb 16 20:00:19 2015 UTC and is due to finish in 60 minutes.  The chair is sdake. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:24 <openstack> The meeting name has been set to 'kolla'
20:00:26 <sdake> #topic rollcall
20:00:27 * jpeeler is here
20:00:33 <sdake> \o/ containerize all the things!!
20:00:35 <britthouser> o/
20:00:37 <sdake> hey jpeeler
20:00:41 <sdake> hey britt
20:00:46 <scollier> hey sdake, i'll be lurking
20:01:00 <sdake> hey :)
20:01:13 <sdake> daneyon around?
20:01:28 <daneyon> here
20:01:53 <sdake> #topic agenda
20:02:02 <sdake> #link https://wiki.openstack.org/wiki/Meetings/Kolla#Agenda_for_next_meeting
20:02:12 <sdake> anyone have anything to add to our fabulous agena? :)
20:02:49 <sdake> #topic new technical direction
20:03:11 <sdake> I think everyone here has had a read through the new technical direction
20:03:20 <sdake> I sent an announcement updaet to the mailing list htis morning
20:03:33 <sdake> in there, I pointed out we have drawn a line in the sand regarding what we will and wont be tackling
20:03:49 <sdake> but that was more my thinking, we didn't really agree to that as a group
20:03:52 <sdake> does anyone have any objection to the mailing list email?
20:04:05 <daneyon> i reviewed it and i thought it was on point
20:04:41 <sdake> jpeeler any thoughts?
20:04:55 <sdake> our other core rhallisey is on pto this week
20:04:57 <sdake> yay for vacations
20:05:10 <jpeeler> yeah there were no surprises, all sounded good
20:05:19 <sdake> cool
20:05:23 <sdake> #topic continuous integration
20:05:34 <sdake> I've got some really good news on this point
20:05:51 <sdake> I found a person with project-config magic powers
20:06:03 <sdake> he will be adding a functional test gate for kolla
20:06:14 <daneyon> yay!!!
20:06:21 <sdake> the way it works is the gate will be running some script which *WE* write
20:06:41 <sdake> I'd like to have some discussion about how we go about doing that
20:07:11 <sdake> first off, I'd like to tackle somethign simple, like functional testing of rabbitmq
20:07:18 <sdake> (the rabbitmq container)
20:07:21 <sdake> we need to
20:07:24 <sdake> 1) start the container
20:07:29 <sdake> 2) run test cases on the container
20:07:39 <sdake> we could do this in a shell script
20:07:49 <sdake> or using testr+python
20:07:53 <sdake> any preferences?
20:08:25 <daneyon> so, make sure the rabbit svc is running, listening on the specified port and can run a rabbutmqctl status command?
20:08:38 <sdake> that would be one test
20:09:10 <sdake> what we do first will lay the gorundwork for all the test cases that come later
20:09:22 <sdake> so ideally we want something that can scale into hundreds of test cases
20:09:41 <sdake> I think shell gives us the most control
20:09:49 <sdake> and python gives us the most scale
20:09:59 <daneyon> should we actually test sending/receiving a real OS message over the rabbit MQ bus?
20:10:13 <sdake> yes I think send/reciee tests are good
20:10:14 <jpeeler> why not?
20:10:21 <jpeeler> yeah the more we test the better
20:10:40 <jpeeler> i think we should make an action item to look into it, especially if we don't have to use testr
20:10:42 <sdake> my question is should we use a test framework or roll our own
20:11:23 <sdake> can testr start our containers for us?
20:11:35 <sdake> and run third party binaries?
20:11:47 <clarkb> yes
20:11:49 <sdake> I assume so but dont knwo for sure
20:11:55 <clarkb> it does remote testing
20:12:18 <sdake> clarkb cool I'll hit you up after the meeting - perhaps you can provide me an eample ;)
20:12:24 <clarkb> so know how to trigger things other than subunit
20:13:12 * sdake needs to find a unit test magic powers person
20:13:49 <sdake> jpeeler daneyon can you state your preferences - roll our own or use a framework?
20:14:12 <jpeeler> well i bet there's no reason to roll our own - looking at that right now
20:14:18 <daneyon> I'd defer to you and jpeeler.
20:14:26 <clarkb> sdake https://testrepository.readthedocs.org/en/latest/MANUAL.html#remote-or-isolated-test-environments
20:14:31 <daneyon> I don;t have enough background in testing.
20:14:34 <sdake> clarkb cool thanks
20:14:57 <jpeeler> maybe dox could be good, but that's based off 3 minutes on google
20:14:59 <sdake> jpeeler any chance you can take on writing our first test case?
20:15:14 <daneyon> At a high level, if we can move faster using testr and it can start containers and run 3rd party bins, I'd lean in that direction
20:15:23 <sdake> me as wel ldaneyon
20:15:36 <sdake> writing the first test case will be the hardest
20:15:49 <sdake> and jpeeler wrote teh first test case for heat ;)
20:15:58 <sdake> so jpeeler is the only person I know with magic powers wrt unit testing :)
20:15:59 <daneyon> is there a ref test case that is a good starting point to review?
20:16:25 <jpeeler> i did... but heat testing evolved a bit from that
20:16:32 <sdake> if we had 1 to start with, more would be easy
20:17:11 <sdake> jpeeler do you have 3 or 4 hours to look into making our first unit test case this week?  If not, I'll tackle it
20:17:27 <jpeeler> sdake: i can take it on. and i'll try to not deviate from openstack conventions
20:17:49 <sdake> #action jpeeler to be superman and write our first functional test case to launch a rabbitmq container and run rabbitmqctl against it
20:17:51 <daneyon> does tempest fit into this?
20:17:53 <sdake> thanks jpeeler ;)
20:18:00 <sdake> daneyon one step at a time :)
20:18:09 <sdake> we can't run tempest until we have more stuff runnign I think
20:18:16 * jpeeler cringes at the word
20:18:19 <sdake> I want to get teh gate running a gainst the rabbitmq container
20:18:19 <sdake> then we are set
20:18:44 <sdake> any other discussion on ci topic?
20:19:07 <daneyon> has the changes been implemented to the rabbitmq container to get it running w/o k8s?
20:19:23 <sdake> likely not - i'l do that today
20:19:23 <daneyon> If not, I can update the image
20:19:31 <sdake> if you want to do that, wfm
20:19:40 <daneyon> let me do it
20:19:44 <sdake> sounds good
20:19:54 <sdake> #action daneyon to make rabbitmq container to run without k8s
20:20:08 <sdake> #topic changing meeting time for APAC/EMEA participation
20:20:16 <daneyon> has a bp been filed yet to update the rmq container?
20:20:27 <sdake> daneyon you will need to file one  Ithink
20:20:32 <daneyon> will do
20:20:45 <sdake> Andre is in Japan
20:20:54 <sdake> he has done alot of good work and I'd like to get him into our weekly meetings
20:21:06 <sdake> but our current meeting time is like 2am or something rediculous forhim
20:21:27 <sdake> I think a meeting time of 1500-1600 UTC would work for emea/apac/us
20:21:30 <daneyon> ouch
20:21:32 <sdake> although early on the west coast
20:22:01 <sdake> here is what I propose
20:22:05 <sdake> I'll make a doodle poll
20:22:18 <sdake> and see if we can get the most coverage
20:22:28 <sdake> also there is some folks in europe that want to particpate - not just andre
20:22:48 <sdake> I'll send a vote for the doodle poll to the ml and leave it open for 1 week
20:22:58 <sdake> does that work for folks?
20:23:10 <jpeeler> yep
20:23:21 <daneyon> sure
20:23:42 <sdake> cool, since larsks and radez have moved on to other projects, will be nice to have a couple good replacements :)
20:23:54 <daneyon> agreed
20:24:00 <sdake> #topic milestone #3 planning
20:24:21 <sdake> last week was pretty much eaten up by our review of our technical direction change
20:24:32 <sdake> our new technical direction is extremely viable
20:24:35 <sdake> whereas before it was not
20:24:39 <sdake> so I'm super excited
20:24:49 <sdake> unfortunately I didn't have a chance to distill the spec into blueprints
20:24:58 <sdake> but that is what I'll be tackling this week
20:25:08 <daneyon> exciting
20:25:08 <sdake> sounds like we have the following work
20:25:16 <sdake> jpeeler -> first unit test
20:25:25 <sdake> sdake -> writ eblueprints from new technical direction
20:25:33 <sdake> daneyon -> rabbitmq container "2.0" :)
20:25:52 <sdake> rhallisy -> drinking beers on the beach
20:26:06 <daneyon> pradeep knocked out creating the req docker repo
20:26:13 <sdake> oh right I saw that
20:26:20 <sdake> we need a fig repo too
20:26:31 <sdake> i'll ask him if he can tackle that
20:27:05 <daneyon> i updated the get-image script. I'm just about ready to submit a patch set for updates to the heat dev template.
20:27:12 <sdake> so we all have work to tackle this week, then going into next week we should have quite a bit of outstanding work to sort out
20:27:37 <daneyon> sdake: re fig repo... did you get any feedback from atomic-dev re fig in a container?
20:27:58 <sdake> yes - its not packaged in fedora
20:28:07 <sdake> probably what needs to happen with fig is it needs to be packaged in fedora
20:28:15 <sdake> if I still hae the permissions I'll submit a review request for that
20:28:20 <sdake> I'll add that to my tasks this week as well
20:28:30 <jpeeler> sdake: feel free to CC me on that review
20:28:34 <sdake> and jpeeler can rubber stamp :)
20:28:42 <sdake> thanks jpeeler
20:28:45 <daneyon> either that our we create a akollaglue/fig container?
20:29:03 <sdake> I lke idea of fig in a container but I don't want to complicate things early on
20:29:06 <daneyon> we can use a specific tag from the GH repo
20:29:15 <daneyon> OK
20:29:28 <sdake> we did that with kubernetes and that wasn't ideal :(
20:29:37 <sdake> #topic open discussion
20:30:08 <sdake> I have to admit at the beginning of the year I was a bit lost as to roadmap
20:30:16 <daneyon> as i mentioned, i'm pretty much done with the dev heat template.
20:30:18 <sdake> but now i feel extremely confident in where we are heading and how to get there
20:30:30 <sdake> nice daneyon
20:30:46 <daneyon> it touches the root README, let me know if doc updates need to be in a seperate patch
20:30:54 <sdake> all in one is good
20:31:02 <sdake> i like docs with the changes personally :)
20:31:05 <jpeeler> where's the docker repo that was mentioned earlier?
20:31:30 <sdake> jpeeler this docker repo contains the --pid=host version of docker
20:31:36 <sdake> daneyon do you have a link?
20:31:45 <daneyon> ya, one sec.
20:32:09 <daneyon> #link https://copr.fedoraproject.org/coprs/pkilambi/docker
20:32:46 <daneyon> the updated heat template uses this repo
20:33:40 <sdake> britt thanks for coming - are you mostly planning to lurk or do you hae any open discussion you would like to discuss :)
20:33:41 <daneyon> lets get to work :-)
20:33:52 <britthouser> just lurking today
20:34:04 <sdake> nice ok cool
20:34:10 <sdake> well, any other open discussion?
20:34:16 <sdake> if not, I'll terminate the meeting
20:34:28 <jpeeler> i'm good, thanks steve
20:34:29 <sdake> thanks for coming folks :)
20:34:34 <sdake> #endmeeting