21:59:59 <sdake> #startmeeting kolla
22:00:00 <openstack> Meeting started Wed Jun  3 21:59:59 2015 UTC and is due to finish in 60 minutes.  The chair is sdake. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:00:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:00:03 <openstack> The meeting name has been set to 'kolla'
22:00:06 <sdake> #topic rollcall
22:00:16 <SamYaple> hello
22:00:20 <sdake> steak for dinner!
22:00:27 <mandre> ji
22:00:29 <pdb-mobile> Hey
22:00:29 <mandre> hu
22:00:29 <rhallisey> hi
22:00:30 <smeisner> hello
22:00:30 <bmace> greetings
22:00:31 <loth> hi
22:00:31 <mandre> hi
22:00:32 <mstachow> hi :D
22:00:36 <dasm> o/
22:00:37 <mandre> got it right this time
22:01:04 <sdake> i'll wait a couple more minutre for any laggards :)
22:01:16 <sdake> but looks like we have a small army ready to invade :)
22:01:38 <daneyon_> hey
22:01:45 <rhallisey> daneyon_, long time no see
22:01:49 <jpeeler> i'm here, but i'm probably going to have to take off early today
22:02:13 <sdake> ack jpeeler
22:02:16 <sdake> letsget rooing
22:02:18 <sdake> #topic announcements
22:02:33 <daneyon_> rhallisey, ya I had to support another event after Vancouver that sucked a lot of my time
22:02:36 <sdake> I'll be at a conference next and be unable to chair the meeting
22:02:50 <rhallisey> daneyon_, finally got cinder working
22:02:58 <sdake> need a cat from the community to offer their time to chair the meeting
22:03:10 <sdake> i'll set the agenda
22:03:14 <rhallisey> I can do it
22:03:15 <sdake> and provide a bit of coaching
22:03:17 <daneyon_> rhallisey u are the man!!!! I've seen the reviews going by but have yet to check it out.
22:03:30 <sdake> sweet
22:03:38 <SamYaple> good job rhallisey
22:03:42 <sdake> #action rhallisey to chair next kolla team meeting while steak is out to dinner
22:03:49 <rhallisey> ha
22:03:59 <sdake> second announcement
22:04:03 <sdake> I'd like to hold a midcycle for our devs to get together
22:04:11 <sdake> since we didn't really have summit conference space this year
22:04:29 <sdake> location would be san jose July 10-25 in that range
22:04:29 <sdake> 1-2 days
22:05:04 <sdake> I'll post a doodle poll on  the ml to see if we can sort out a couple days
22:05:10 <sdake> anyone have problems with the location?
22:05:37 <daneyon_> I will on the road for training 7/6-7/9, so it will be difficult for me to travel the following week.
22:06:00 <sdake> daneyon ack, i'lll put a couple weeks in and people can vote on days they like
22:06:11 <sdake> i'll go with where I get the most coverage from the core team and our fresh faces
22:06:23 <mandre> and I'll be traveling to France on 7/20, that may be difficult for me as well
22:06:32 <daneyon_> If it's in SJC, I can pull off a day trip. If it's later in the month, then no prob
22:07:00 <sdake> well lets sort it out in the doodle poll :)
22:07:12 <sdake> just wanted to let folks know its coming on the ml
22:07:29 <sdake> and that you may need to hit your bosses up for travel budget ;)
22:07:30 <SamYaple> whenever the date, i need as much notice as possible otherwise RAX will hold me back
22:07:44 <sdake> ack
22:08:06 <sdake> #topic manifesto definition finalization
22:08:16 <sdake> I put our manifesto we produced last week on our wiki at:
22:08:38 <sdake> #link https://wiki.openstack.org/wiki/Kolla
22:08:59 <sdake> I had an experienced mentor take a look and she said it was a bit wordy
22:09:05 <sdake> grilled me about what we do
22:09:29 <sdake> and indicated there wasn't a good match with our manfiesto
22:09:36 <sdake> so I'd like to edit if possible
22:09:43 <daneyon_> OK
22:10:03 <sdake> #link https://etherpad.openstack.org/p/kolla-manifesto
22:10:11 <sdake> can folks log into that real quick like
22:10:11 <mandre> it's missing an important word IMO, "production"
22:10:34 <sdake> I think we need to make a list of words we should use, shsould not use, and potentially use, along with rules we want to follow
22:10:38 <sdake> and refine what we havebased upon that
22:10:45 <sdake> does that approach sound workable?
22:14:23 <sdake> if your -1 on an idea add your name next to it so we know who to grill :)
22:15:19 <SamYaple> is the manifesto what we want to be, or what we are?
22:15:31 <bmace> exactly, i expect it is what we want to be
22:15:35 <SamYaple> same
22:15:54 <sdake> where we want to be in t-6 months
22:16:09 <bmace> i think ha is reasonable then, imho
22:16:15 <sdake> re the use of buzzword bingo names ANsible DOcker OpenStack I  think these are mandatory - we have made choices on these tehcnologies
22:16:48 <sdake> leave the original statemenet intact
22:16:59 <sdake> any other contirbutions to the rules?
22:17:01 <daneyon_> oops... i started changing our manifesto
22:17:17 <sdake> ya well shit happens
22:17:19 <mandre> I'll argue with that, they don't describe our goals, but the tools we chose to get there
22:17:23 <sdake> lets add a new one at end
22:17:53 <sdake> ok so rules are mandatory
22:17:58 <sdake> everything else is not mandatory
22:18:07 <sdake> I'd like folks to write a mission statement each nidviduallly
22:18:10 <sdake> put your name next to it
22:18:26 <rhallisey> ehh I wrote the first one :D
22:18:29 <sdake> do at bottoom of etherpad
22:20:35 <pdb-mobile> What kind of length are we aiming for, longer or shorter than current?
22:20:43 <SamYaple> pdb-mobile: 1-2 sentences
22:23:44 <sdake> shorter
22:23:48 <sdake> shorter = sweeter :)
22:24:04 <sdake> well this is fun so far - interesting to see what everone thinks our mission should be :)
22:24:47 <sdake> bmace had a question, edited my mission statemnet
22:25:03 <sdake> what I would recommend if you have questions, is to add (nick) Question at end of the persons mission statement
22:27:25 <bmace> sdake i didn't really call out specific technologies but i can add them in if need be.  beyond docker / ansible i think some sort of scripting on top of that will be necessary, so something specific to kolla, unless you want to force all users of kolla to develop their own mechanism to do that...
22:27:45 <bmace> something needs to be there to configure what nodes have what services on them, etc, unless you want people to need to edit playbooks
22:28:24 <SamYaple> bmace: i agree with not calling out the specifics
22:28:54 <SamYaple> I view the extra tools as templates/optional. Kolla is first and formost about the containers (to me)
22:29:29 <bmace> oh, definitely optional.. but i think the option to have it there already needs to exist..
22:29:32 <bmace> or everyone has to build their own
22:29:39 <bmace> rather than 'can' build their own
22:29:55 <SamYaple> but if its "optional" should it be mentioned _specifically_ in the manifesto
22:30:27 <bmace> well, at that point the manifesto will only be to build containerized open stack services, since all the ha stuff is optional to
22:30:29 <bmace> too
22:30:30 <sdake> ok guys lets have a break for a minute and make a decision
22:30:32 <dasm> bmace: are we thinking about reimplementing the wheel, or reusing existing tools, like heat, tripleo, etc?
22:30:52 <sdake> there is some conflict about whether we should name the specific tools/systems are are using
22:30:56 <bmace> i don't think any of those things are particularly wheels
22:30:59 <sdake> please vote +1 to use these names
22:31:08 <pdb-mobile> You could argue there are two projects here. One being the containers and the other being orchestration
22:31:08 <sdake> pleave vote -1 to not use these names
22:31:13 <sdake> we will go with majority
22:31:20 <dasm> -1
22:31:29 <rhallisey> -1
22:31:37 <sdake> to be specific, names are "Docker, Ansible, OpenStack"
22:31:42 <daneyon_> -1
22:31:44 <mstachow> -1
22:31:47 <SamYaple> -1
22:31:55 <jpeeler> Well I think OpenStack could be an exception
22:32:02 <sdake> no exceptions
22:32:02 <loth> -1, excluding openstack
22:32:03 <daneyon_> +1 using OpenStack
22:32:06 <rhallisey> s/openstack/tripleo
22:32:06 <mandre> -1
22:32:13 <sdake> exceptions are always bad ;(
22:32:17 <jpeeler> heh, an openstack project can't mention openstack?
22:32:27 <mandre> and yes, I also think OpenStack is mandatory
22:32:29 <sdake> one could argue we are a docker project?
22:32:33 <SamYaple> this is confusing then. either mentino them one at a time, but Openstack _should_ be mandatory
22:32:39 <SamYaple> sdake: i disagree
22:32:49 <mandre> today is docker, tomorrow might be something else
22:32:52 <daneyon_> I think it's fair to use OpenStack in the manifest since the project is specific to OpenStack clouds
22:32:53 <jpeeler> we were talking about joining the openstack namespace
22:33:03 <jpeeler> last meeting
22:33:29 <sdake> ok well it looks like folks think we shouldn't mention specific names, there is some contention about using openstack based upon this vote
22:33:31 <sdake> so lets vote on OpenStack only please
22:33:32 <bmace> agreed w/ SamYaple.  the containers made are specifically related to OpenStack and really only meant for that purpose, even if you could possibly use some of them for something else.
22:33:33 <sdake> +1 use OpenSetack
22:33:37 <sdake> -1 don't ue OpenStack
22:33:39 <SamYaple> +1
22:33:42 <bmace> +1
22:33:44 <loth> +1
22:33:45 <dasm> +1, use openstack
22:33:46 <daneyon_> unless we plan to support cloudstack, then I +1 openstack in the manifesto
22:33:48 <rhallisey> +1
22:33:48 <pdb-mobile> +1
22:33:49 <jpeeler> +1 openstack is fine
22:33:51 <mandre> +1
22:33:55 <mstachow> +1
22:34:42 <sdake> I vote -1 only because I don't think exceptions are ever wise.
22:34:48 <sdake> so decision is made
22:34:59 <sdake> remove docker/ansible from your mission statements plz
22:35:02 <sdake> and include OpenStack
22:35:06 <daneyon_> Maybe someone in the community adds rkt or lxc support
22:35:23 <sdake> already been voted on no need to discuss
22:35:26 <SamYaple> daneyon_: rkt natively supports docker containers
22:35:32 <pdb-mobile> Theres something in the python manifesto about being too rigid with exceptions ;)
22:35:33 <daneyon_> righ
22:35:35 <daneyon_> t
22:35:36 <SamYaple> (or that is a requiremnet of rkt should i say)
22:36:06 <sdake> and do not edit other peoples mission statements
22:36:07 <sdake> christ
22:36:12 <daneyon_> maybe someone decides to add hyper_ support ;-)
22:36:41 <SamYaple> daneyon_: that can be done now with configuration
22:36:56 <SamYaple> htought the windows setup is outside scope of kolla I would think, just like vmware setup
22:36:58 <daneyon_> right
22:37:39 <sdake> 3 minutes to edit your mission statements, then we wil lvote on best one
22:37:51 <sdake> one with most votes wins
22:38:13 <sdake> :41
22:38:13 <SamYaple> esh just like that? no merging of statements?
22:38:29 <sdake> we will start with the highest vote and edit  from there
22:38:33 <SamYaple> fair
22:38:34 <sdake> perhaps next week ;)
22:38:54 <sdake> please add your rationale for your vote
22:38:58 <daneyon_> SamYaple I was refereeing to hyper_ (https://hyper.sh/) and not HyperV
22:39:00 <sdake> (sdake) xyz
22:39:09 <sdake> (Sdake) -1 too wordy
22:39:11 <sdake> this is an example
22:39:17 <sdake> t-2 minutes to voting
22:39:53 <SamYaple> daneyon_: my brain did not process the lack of V
22:39:55 <daneyon_> sdake are we allowed to vote for our own?
22:39:59 <sdake> of course
22:40:05 <sdake> you ahve to vote on everyones
22:40:10 <sdake> either +1 or -1
22:40:14 <sdake> with a rationale
22:40:19 <sdake> (making this up a I go along :)
22:40:25 <SamYaple> mandre: can you adjust "OpenStack micro-services" to "micro-services needed to run Openstack" or similar?
22:40:33 <sdake> lets edit after the vote
22:40:38 <SamYaple> since we do provide database/message-broker?
22:40:45 <sdake> if you are in general agreement vote +1, if you need editing vote +1, if you dont like vote -1
22:40:54 <sdake> ok time to vote :)
22:46:46 <sdake> vote faster we are running out of time :)
22:47:53 <sdake> VOTE DONT EDIT
22:48:03 <sdake> edit comes next week - we only have 12 minutes
22:48:22 <sdake> I want to see a vote from every person on every mission plz
22:48:29 <sdake> with a rationale
22:48:51 <SamYaple> does pdb not have enough to call it now? I dont see anything anywhere near it
22:49:59 <sdake> i want a vote on every mission statement with a rationale
22:50:04 <sdake> so we know what people want in the community
22:50:30 <sdake> it is pretty clear from my votes and rationales I want container content and deployment
22:50:44 <sdake> I need to know what the community wants - kolla is not me :)
22:51:29 <sdake> name next to vote plz
22:52:55 <pdb-home> so many colors :o
22:54:12 <sdake> yay this is fun :)
22:55:16 <SamYaple> oh i should have edited out the primary/secondary part on mine. that was to get my thoughts down :/
22:55:32 <pdb-home> phew, think Ive voted on all now
22:55:59 <sdake> ok guys i'm going to end the meeting and continue the agenda to next week
22:56:05 <sdake> finish up voting and lets have a bit of discussion in #kolla
22:56:17 <sdake> agreed?
22:56:22 <SamYaple> agreed
22:56:34 <sdake> samyaple one ring to rule them all :)
22:56:36 <sdake> #endmeeting