16:00:23 <sdake> #startmeeting kolla
16:00:29 <openstack> Meeting started Wed Jul  8 16:00:23 2015 UTC and is due to finish in 60 minutes.  The chair is sdake. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:29 <mfalatic> o/
16:00:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:33 <openstack> The meeting name has been set to 'kolla'
16:00:35 <sdake> #topic rollcall
16:00:38 <mfalatic> oops
16:00:40 <mfalatic> o/
16:00:46 <rhallisey> hi
16:00:48 <inc0> o/
16:00:51 <mstachow> o/ all
16:00:53 <sdake> o/ folks - lots of progress in the code base yay ;)
16:00:58 <SamYaple> \o
16:01:42 <kevsi_> Hi.
16:01:48 <pbourke> o/
16:02:00 <sdake> pretty sure jpeeler is on pto because of impending loss of freedom ;)
16:02:13 <jpeeler> no i'm here still!
16:02:18 <sdake> oh yay :)
16:02:20 <SamYaple> /kick jpeeler
16:02:21 <jpeeler> thanks for the ping
16:02:24 <jpeeler> noooooooo
16:02:26 <SamYaple> ;)
16:02:35 <sdake> #topic announcements
16:02:52 <sdake> this timeslot hs historically been at 16:00 UTC
16:03:02 <sdake> we are goingto try movin it 30 minutes later to make more people happy
16:03:07 <sdake> that will happen in 2 weeks
16:03:16 <sdake> so not next meeting but the meeting after
16:03:22 <sdake> i'll send an announcement to the ml
16:03:30 <sdake> if the time is problematic now is your chance to speak up :)
16:03:47 <sdake> the 2200 timeslot remains the same
16:03:53 <inc0> well, this one is late anyway
16:04:02 <SamYaple> 2200 that one is problematic
16:04:05 <SamYaple> :)
16:04:20 <sdake> samyaple lets fine tuen that after we get 1630 solid ;)
16:04:26 <SamYaple> i wont derail further
16:04:51 <sdake> #2 - please register for kolla-palooza midcycle - link in #kolla topic
16:05:07 <sdake> need an accurate count for dinner , hopefully by 9th of july ;)
16:05:15 <sdake> (as in tomorrow)
16:05:21 <sdake> any other announcements from folks?
16:05:30 <pbourke> sdake: do remote attendees need to register?
16:05:46 <sdake> pbourke please do so I can sort out logistics
16:05:53 <sdake> but its not mandatory
16:05:57 <pbourke> ok
16:06:09 <sdake> that way I can send you a personal email with login info etc
16:06:22 <sdake> we will probably use google groups or webex
16:06:25 <sdake> webex scales better
16:06:35 <sdake> but runs on linux poorly
16:06:58 <sdake> i'm going to try to find some usb handheld microphones prior to the event
16:07:17 <sdake> if anyone has a suggestion on mic hardware, send me a private note at stdake@cisco.com pls
16:07:38 <sdake> #topic CI Status
16:08:18 <sdake> so still blocked on internal config for openvswitch
16:08:24 <diga> O/
16:08:26 <sdake> anyone want to tackle this problem?
16:08:27 <sdake> hey diga
16:08:40 <diga> hi sdake
16:08:50 <diga> I am working on that
16:08:59 <diga> Will resolve that stuff by tomorrow
16:09:04 <sdake> diga nnice, let me set arbitrary deadline of 15th for that ;)
16:09:14 <diga> +1
16:09:16 <diga> sorry was too much busy from last two days
16:09:23 <sdake> welcome to life ;)
16:09:38 <diga> :)
16:09:38 <sdake> cool so once that is unblocked samyaple has the multi-host setup for it ready to go I think
16:09:46 <sdake> and we can put it in the gate
16:09:52 <sdake> and be ready to functional test via smoke testing
16:09:54 <jpeeler> yay
16:10:05 <diga> yes
16:10:09 <jpeeler> on that topic, is the new build script ready to be put in the gate?
16:10:22 <sdake> jpeeler ya i think samyaple was going to hack on project-config to do it
16:10:26 <SamYaple> jpeeler: i was thinking a test non-voting gate
16:10:29 <sdake> but if someone else wants to do it that would be fantastic
16:10:33 <SamYaple> but i dont know how to do that
16:10:34 <sdake> but we dont want to edit the existing gate
16:10:37 <sdake> we want a new one
16:10:40 <SamYaple> yes
16:10:52 <jpeeler> i can help SamYaple
16:10:55 <sdake> jpeeler interested in that?
16:11:05 <SamYaple> yay
16:11:14 <SamYaple> i get to learn
16:11:16 <sdake> #action jpeeler to help sam sot out new python script as a nonvoting gate
16:11:34 <sdake> #topic Ansible Modules License Status
16:11:53 <sdake> so in essence we need modules that are licensed pglv3 but we can't use them
16:12:01 <sdake> because it affects our ability to get into big tent
16:12:07 <sdake> so samyaple wrote his own ;)
16:12:16 <sdake> samyaple can you give us a summary pls
16:12:22 <SamYaple> sure
16:12:49 <SamYaple> openstack-infra/shade is a library that allows generic wrappings for openstack environemnts
16:12:54 <SamYaple> the ansible modules use shade
16:13:06 <SamYaple> the modules are gplv3 licensed and cant be relicensed
16:13:22 <SamYaple> i have built some "they do the job" modules in the meantime
16:13:36 <SamYaple> they only add, no updates or deletes, but it should get us by
16:13:52 <SamYaple> ansible 2.0 drops and we will be able to switch to the upstream modules
16:14:03 <SamYaple> thats about everything
16:14:14 <SamYaple> we are unblocked, but not 100% strength
16:14:27 <sdake> re ansible 2.0 drops and we will be able to use upstream modules - I need to run that by legal apparently samyaple
16:14:30 <sdake> which is in progress
16:14:38 <SamYaple> why they accepted OSAD
16:14:43 <SamYaple> same deal
16:15:10 <sdake> agree we are using same model as osad here with the modules - make our own
16:15:27 <sdake> but both of our projects need to work together to make sure we can use these new moduels with the legal team at the foundation
16:15:46 <sdake> or it could affect our ability to use the trademark
16:15:52 <SamYaple> what i am saying is the "new modules" will be just like any other ansible modules.
16:15:55 <sdake> (which we want to be able to use)
16:16:00 <SamYaple> and we use lots of baked in ansible modules
16:16:07 <SamYaple> thats basically all ansible is, gplv3 modules
16:16:31 <sdake> ya best not to thin about it until we are presented wit hthe problem ;)
16:16:34 <pbourke> was going to say the same. they will essentially be like using 'copy'
16:16:36 <SamYaple> fair
16:16:43 <pbourke> but best be safe
16:16:45 <SamYaple> well move on
16:17:02 <sdake> #tpoic Liberty-2 planning (#link https://launchpad.net/kolla/+milestone/liberty-2)
16:17:59 <sdake> #topic Liberty-2 planning
16:18:10 <sdake> #link https://launchpad.net/kolla/+milestone/liberty-2
16:18:16 <sdake> pls open
16:18:36 <sdake> lots of blue - yay :)
16:18:42 <SamYaple> pls give me more blueprints
16:18:48 <sdake> some purple in there - that is fantastic for only the first week :)
16:19:02 <sdake> you definately need m0ar sam :)
16:19:16 <sdake> so just a reminder our deadline is july 31st
16:19:24 <sdake> can we get a quick update of two blueprints:
16:19:34 <diga> sdake: Need to talk about this BP - https://blueprints.launchpad.net/kolla/+spec/kolla-compose-script
16:19:46 <sdake> #link https://blueprints.launchpad.net/kolla/+spec/ansible-service
16:19:48 <sdake> diga ok hang tight bro
16:19:58 <sdake> samyaple can you give us quick update on that
16:20:02 <diga> ok
16:20:25 <SamYaple> we have 4 services done, mariadb,rabbitmq,keystone,glance (last two in code review)
16:20:38 <SamYaple> I will be handling nova and neutron
16:20:53 <SamYaple> then it will be funcitonal and the others can be handled in no particular order
16:20:53 <sdake> who is tackling heat?
16:21:05 <sdake> heat needs to be in our core list as well
16:21:11 <SamYaple> we have no assignes for these others yet. they would need constant rebasing
16:21:18 <sdake> ok
16:21:29 <sdake> we willw ait for you to wrap up then on nova and neutron
16:21:29 <SamYaple> it will probably be a week before we can do this async
16:21:34 <sdake> and then we will ask people to volunteer for the remainder
16:21:40 <SamYaple> agreed
16:22:01 <sdake> #link https://blueprints.launchpad.net/kolla/+spec/standard-start
16:22:42 <sdake> the progress on this is fantastic
16:22:45 <sdake> I think we are almost done here
16:22:57 <sdake> everything is up for code review afaik
16:23:26 <sdake> there may be a few lagging, so if you have implementation for this blueprint pls get her done this week ;)
16:23:46 <sdake> diga shoot with your blueprint
16:24:13 <diga> just want to discuss on - https://blueprints.launchpad.net/kolla/+spec/kolla-compose-script
16:24:27 <sdake> that should bascially be a git mv
16:24:30 <sdake> not much to that one
16:24:47 <diga> okay
16:24:54 <sdake> did that answer your q?
16:24:55 <SamYaple> sdake: it also includes writing the kolla-ansible script
16:25:01 <SamYaple> "Rename the kolla script to kolla-compose and create a new kolla-ansible script to manage playbook operation."
16:25:06 <sdake> samyaple there is a separate blueprint for kolla-ansible
16:25:06 <diga> yepm yep
16:25:15 <SamYaple> ill edit the BP then
16:25:20 <sdake> sounds good
16:25:38 <sdake> ya guys when i write these blueprints i dont always do a perfect job
16:25:46 <sdake> feel free to edit them to your liking ;)
16:25:49 <diga> :)
16:26:01 <sdake> liberty 2 is off to a great start
16:26:10 <sdake> anyone know status of cinder or horizon?
16:26:16 <sdake> rhallisey on cinder ?
16:26:20 <sdake> since these were broken in liberty 1 release
16:26:47 <pbourke> sdake: a recent joiner to our team has a fix that apparently fixes horizon
16:26:54 <sdake> nice!
16:26:55 <rhallisey> sdake, nothing has changed, I just added oslo in so it won't sit in restarting
16:27:05 <sdake> rhallisey does that fix cinder?
16:27:07 <pbourke> sdake: he's in the process of filing a bug and creaing a review
16:27:16 <sdake> pbourke there is a bug already
16:27:20 <sdake> pbourke what was his name do you recall?
16:27:20 <pbourke> aha
16:27:28 <sdake> or her name
16:27:28 <rhallisey> I'm assuming the iscsi issue is still hanging around, so no not yet
16:27:48 <rhallisey> I've been cleaning the 200 docker images off my machine for the last 2 hours
16:27:54 <sdake> rhallisey ack - if you need some kind of help feel free to ask in #olla ;)
16:28:00 <rhallisey> sure thing
16:28:06 <sdake> fastest way to do that is rm -rf /var/lib/docker ;)
16:28:16 <sdake> and resstart docker
16:28:24 <rhallisey> that would do it
16:28:27 <rhallisey> lol
16:28:32 <sdake> thats what I use ;)
16:28:39 <rhallisey> drop a bomb on docker lol
16:28:43 * jpeeler has wondered if that would work
16:29:10 <sdake> #topic Midcycle sesion planning
16:29:16 <sdake> jpeeler it works fantastically
16:29:39 <pbourke> sdake: his name is mark I'll get him to give you a shout about it
16:29:40 <sdake> #link ttps://etherpad.openstack.org/p/liberty-kolla-midcycle-planning
16:29:53 <sdake> pbourke just point him at  the correct existing bug
16:30:01 <pbourke> will do
16:30:05 <sdake> if you woudln't mind :)
16:30:12 <rhallisey> sdake, missing an h on the paste
16:30:15 <sdake> if folks can open that midcycle planning page
16:30:19 <rhallisey> 'ttps'
16:30:34 <sdake> #link https://etherpad.openstack.org/p/liberty-kolla-midcycle-planning
16:30:39 <SamYaple> you have to break the code rhallisey
16:32:58 <markd_> sdake: just creating the horizon bug that Pbourke mentioned.  is there a bug already on the Horizon login ?
16:33:01 <sdake> ok line 9 guys
16:33:14 <pbourke> markd_: check your pidgin ;)
16:33:16 <sdake> markd_ yes let me get with you after meeting ok?
16:33:27 <markd_> Ok
16:33:29 <sdake> or pbourke can point the bug out to you
16:33:46 <sdake> so add design sessiosn you would like to discuss at line 9
16:33:48 <sdake> each session is 50 mins in length
16:33:50 <sdake> with a 10 min break
16:34:00 <sdake> maybe 45/15 , have to see how thigns are going ;)
16:40:54 <SamYaple> diga: for the checks, what do you mean?
16:42:34 <diga> I mean, when we create containerfor services - Need to have check whether service is running properly & when it goes down kolla should know
16:43:10 <SamYaple> diga: "kolla should know" hmmm well have to talk about what kolla is then
16:43:31 <diga> SamYaple: I dont know but this is something important for multinode depoyment model
16:43:46 <SamYaple> agreed, im not trying to kick it away :)
16:43:52 <sdake> we will wrap this up at 50 after
16:44:00 <diga> I mean it should return the status of conainers
16:44:16 <sdake> then have anothe collaborative editing session at our next meeting to get wit hteh folks that can only make our 2200 slot
16:44:40 <SamYaple> after it deploys, yes. actively check containers as if kolla were a service? i would argue no
16:44:46 <sdake> please add more detail for lines 23/24/25/26 etc ;)
16:50:04 <SamYaple> Session Topic: How to pronouce Kolla
16:50:12 <sdake> haha
16:50:12 <rhallisey> nice
16:50:14 <sdake> who nows ;)
16:50:18 <sdake> #topic open discussion
16:50:22 <sdake> ok thanks folks that was really good
16:50:25 <SamYaple> were all going to show up and say it differently
16:50:27 <sdake> we will finish the job on that next week
16:50:31 <jpeeler> hey, so i have a pending blueprint i need to write
16:50:34 <sdake> and have a final schedule published friday of next week
16:50:58 <jpeeler> it's a container that uses heat to deploy our kolla containers
16:51:10 <jpeeler> i just wanted to mention it here... since i've been mostly silent about it. apologies
16:51:18 <jpeeler> plan on writing it up today
16:52:04 <SamYaple> I will use this as an oppurunity to ask for reviews on two important patches I would like to see merged ASAP so i dont have 4 layer deep patchsets to rebase again :) https://review.openstack.org/#/c/198494/ https://review.openstack.org/#/c/199406/
16:52:23 <sdake> samyaple will review after meeting
16:52:39 <SamYaple> jpeeler: i like that idea! i was thinking of a container to deploy to keep the host clean as well
16:52:43 <sdake> jpeeler osunds good
16:52:43 <SamYaple> looking forward to it!
16:53:17 <rhallisey> ya it's going to be pretty cool
16:53:48 <SamYaple> i want to get the nova-docker driver running in dokcer ;)
16:53:55 <sdake> groan
16:54:02 <SamYaple> ok fine, just running at all
16:54:08 <sdake> lol
16:54:31 <sdake> jpeeler go ahead file your blueprint i'll put in discussion state
16:54:37 <sdake> and add to next week agenda for discussion
16:54:46 <sdake> new blueprints go through discussion->approved
16:54:46 <jpeeler> ok will do
16:54:47 <sdake> unless they com with code
16:54:51 <sdake> then they generally go straight to approved :)
16:54:52 <SamYaple> hey real quick poll. Are we going to be including ceph in Kolla? or just supporting it as a backend? +1 or -1
16:55:02 <sdake> ceph yes
16:55:03 <jpeeler> sdake: oh well then i'll go the code route heh
16:55:05 <sdake> if we can make it happen
16:55:05 <inc0> +1
16:55:07 <mstachow> +1
16:55:37 <pbourke> +1
16:55:50 <rhallisey> let me fix cinder then I'll move on to that +1
16:55:58 <SamYaple> if you guys want ceph containers, I can make that happen real quick like.
16:56:03 <SamYaple> rhallisey: i already have ceph containers
16:56:17 <inc0> please do Sam
16:56:24 <rhallisey> that would be cool
16:56:31 <inc0> and Ryan can move to ceph as default
16:56:36 <rhallisey> yup
16:56:41 <inc0> and ditch whole iScsi thing alltogether
16:56:42 <SamYaple> fair enough. ill add an implementation of it and you just kick it around
16:56:46 <sdake> keep in mind folks liberty 2 needs to work out of the box ;)
16:56:55 <SamYaple> yea this is L3
16:57:08 <sdake> wfm
16:57:13 <SamYaple> sdake: what needs to work in L2....?
16:57:19 <SamYaple> just core or ALL containers?
16:57:26 <SamYaple> define core
16:57:28 <sdake> bascailly all our containers in ansible would be my goal
16:57:32 <sdake> what we deploy today
16:57:37 <sdake> in compose
16:58:05 <sdake> i think gaps are heat, horizon, cinder
16:58:05 <sdake> that we dont have ansible code for
16:58:12 <SamYaple> yea cant promise cinder since it deals with the disks
16:58:15 <SamYaple> the rest yea
16:58:16 <sdake> and then we need a swift and ceilometer implemtnation at some point down the road
16:58:28 <sdake> ya cinder is busted container wise
16:58:33 <sdake> we need it working :)
16:58:46 <sdake> ok ending meeting we can overflow in #kolla
16:58:47 <sdake> #endmeeting