16:32:25 <sdake> #startmeeting kolla
16:32:27 <openstack> Meeting started Wed Dec 16 16:32:25 2015 UTC and is due to finish in 60 minutes.  The chair is sdake. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:32:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:32:31 <openstack> The meeting name has been set to 'kolla'
16:32:32 <sdake> #topic rollcall
16:32:41 <rhallisey> hello
16:32:43 <sdake> \o/ back in the land of the living ;)
16:32:44 <nihilifer> o/
16:32:50 <Jeffrey4l> o/
16:32:51 <jpeeler> hi
16:32:59 <inc0> o/
16:32:59 <barrett1> o/
16:33:36 <ajafo> hi
16:33:37 <marek_> hi
16:33:59 <sdake> #topic midcycle prep
16:34:22 <sdake> not sure when the midcycle will be, probably sometime in late january
16:34:24 <britthouser> 0/
16:34:41 <sdake> i will soon get a poll going to determine what time works best for people
16:35:04 <sdake> we need to go ahead and produce our list of sessions for the midcycle now though
16:35:21 <sdake> the midcycle will be two days in length
16:35:52 <sdake> https://etherpad.openstack.org/p/kolla-mitaka-midcycle
16:36:56 <sdake> lets spend 10-15 mins on the etherpad putting in our session ideas please
16:37:07 <elemoine> o/
16:37:24 <britthouser> sessions being working session planning session, both?
16:38:34 <inc0> britthouser, well, it's midcycle so form is more loose
16:38:52 <britthouser> thanks inc0...my first one so I wasn't sure
16:39:36 <sdake> i suspect upgrades will be a 4 hour session or more ;)
16:39:46 <sdake> but we still need more dmaterial
16:40:13 <inc0> <hides under the table before 4 hrs of incoming hate>
16:40:16 <nihilifer> diagnostics == monitoring?
16:40:56 <sdake> nihilifer  yes among another things
16:41:18 <sdake> moniitoring is a component of diagnostics
16:41:29 <inc0> 18 months roadmap planning will not end after 1hr for sure
16:41:45 <sdake> diagnostics is a catchall for anything diag related ;)
16:42:15 <sdake> can folks do me a solid and sign their names into etherpad please so I know where the session ideas came from
16:42:19 <barrett1> On the roadmap - want to get ahead of the update cycle run by the Product WG
16:43:57 <sdake> barrett1  roger understood - would you mind signing in as a contribu ptop please
16:44:16 <sdake> ok i'll igve this another 3-5 minutes then we can move on, and have another session next week to catch people that missed this session
16:44:21 <barrett1> sdake: will do
16:44:37 <britthouser> thanks rhallisey
16:44:53 <rhallisey> britthouser, sure thing :D
16:46:20 <inc0> I think we can revisit this list on following meeting
16:46:23 <sdake> #topic mitaka-1 release
16:46:30 <sdake> ok lets move on :)
16:46:30 <barrett1> sdake: 1 caveat - I go on sabbatical at the end of this week and will return to work on 1/28. If the midcycle happens earlier in Jan I won't be able to attend. Leong Sun is covering for me and would be able to attend.
16:46:51 <sdake> barrett1 understood
16:47:24 <sdake> #link https://launchpad.net/kolla/+milestone/mitaka-1
16:47:58 <sdake> so basically because I was out of action I never cut a m1 release
16:48:33 <sdake> unfortunately the way the openstack process works for projects not managed by the release team, the PTL is a SPOF in the tagging and release process of milestones
16:48:37 <britthouser> I think I can break away this week on work on my BP
16:48:40 <sdake> fortunately its just m1, so its not deadly
16:49:01 <britthouser> it shouldn't be a large amount of work.
16:49:27 <sdake> I am going to cut a m1 on dec 23rd
16:49:46 <sdake> I am going to move any blueprints not in good progress or above to mitaka-2 at end of this week (18th)
16:50:06 <britthouser> ok
16:51:07 <sdake> can folks that own blueprints please update the state sometime today of whether its good progress, started, implemented, needs code review, etc
16:51:15 <sdake> I see magnum in there, and I thought that was done for example
16:51:17 <sdake> nihilifer  ^^ ? :)
16:51:57 <nihilifer> sdake: yes, sorry, i forgot to close it
16:52:03 <sdake> its all good
16:52:13 <sdake> if folks have stuff like this please set to implemented
16:52:41 <sdake> unfortunately because it isn't friday yet, we can't discuss mitaka-2
16:52:55 <sdake> but I'd like mitaka-2's main theme to be upgrades
16:53:02 <sdake> any objections?
16:53:07 <rhallisey> none
16:53:09 <nihilifer> nope
16:53:12 <rhallisey> BPs are all in place
16:53:23 <sdake> nice
16:53:27 <inc0> yeah, and I think we got our differences sorted out for now
16:53:54 <inc0> just request from my side - review nova upgrade code to confirm way we're going to attack upgrades
16:54:05 <sdake> will look at it
16:54:12 <sdake> my mother broke her l4 vertebrea
16:54:16 <sdake> so looking after her a bit
16:54:22 <sdake> bsically my life is a POS atm
16:54:31 <britthouser> yikes....yeah when it rains it pours!
16:54:34 <barrett1> sdake: Sorry to hear that!
16:54:37 <sdake> no doubt
16:54:51 <sdake> it could be worse so I count my blessings :)
16:54:55 <britthouser> =)
16:55:30 <sdake> #topic open discussion
16:55:40 <sdake> ok folks, know meeting isn't all that exciting today
16:55:41 <nihilifer> i actually see 2 points more in agenda
16:55:51 <sdake> which nihilifer ?
16:56:07 <nihilifer> https://wiki.openstack.org/wiki/Meetings/Kolla
16:56:11 <nihilifer> let me go to mine
16:56:16 <nihilifer> #topic kolla-mesos
16:56:18 <sdake> #endu
16:56:23 <sdake> #topic kolla-mesos
16:56:32 <sdake> nihilifer only I can set #tpk
16:56:34 <nihilifer> ok, let me share an update
16:56:37 <sdake> ok nihilifer  all yours ;)
16:57:04 <nihilifer> we currently have a working tool deploying services on marathon and ansible tasks on chronos
16:57:24 <nihilifer> currently supported services - mariadb, keystone, glance and horizon
16:57:53 <nihilifer> i think we're in point where people can feel free to take any available component of kolla and try to run it on mesos
16:58:15 <nihilifer> if you're confused about structure of repository, feel free to ask me directly
16:58:25 <inc0> nihilifer, can you please write quickstart guide for mesos?
16:58:37 <kproskurin> and me if nihilifer is away
16:58:44 <rhallisey> inc0, good idea
16:58:49 <sdake> ya docs are fantastic folks :) wtb em :))
16:59:02 <nihilifer> inc0: sure. you mean quickstart for contributing to kolla-mesos?
16:59:11 <jpeeler> for getting up and running
16:59:12 <inc0> nihilifer, for deploying;)
16:59:29 <nihilifer> for now thre's quickstart for vagrant and running the kolla-mesos-deploy tool
16:59:49 <nihilifer> but ok, i can try to make it more detailed
16:59:59 <nihilifer> last but not least
17:00:09 <inc0> yeah, something that will describe how it all works and so on plz
17:00:20 <nihilifer> we're looking for reviews from kolla-core guys as well
17:00:30 <inc0> docs will help...;)
17:00:31 <nihilifer> and thanks for those who're doing it currently
17:00:33 <nihilifer> that's all
17:00:51 <nihilifer> sdake: we can move to the next topic, i think
17:01:01 <rhallisey> I mentioned it last meeting.  Add kolla-mesos to your watch list
17:01:08 <rhallisey> if you want to help
17:01:48 <kproskurin> it’s really low trafic right now so it’s easy to get in
17:01:49 <sdake> #topic open discussion
17:02:08 <marek_> I think we have 1 more topic.
17:02:16 <sdake> the upgrades?
17:02:25 <marek_> Upgrading containers - use case & POF implementation plan (https://etherpad.openstack.org/p/kolla_upgrading_containers)
17:02:32 <marek_> sdake yes
17:02:40 <sdake> #undo
17:02:42 <nihilifer> upgrades regarding kolla-mesos
17:02:42 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0xa6845d0>
17:02:51 <sdake> #topic upgrade brainstorm
17:03:01 <sdake> #link https://etherpad.openstack.org/p/kolla_upgrading_containers
17:03:20 <marek_> Ok guys, thanks & let me mention I'm new to Kolla team @ Mirantis so please bear with me.
17:03:21 <sdake> oh 5his is mesos specific?
17:03:30 <marek_> sdake yes
17:03:31 <nihilifer> sdake: yes
17:03:51 <sdake> ok my apologies, I htought we covered upgrades already :)
17:04:09 <nihilifer> well, we'd like to share the similar idea regarding mesos
17:04:11 <sdake> marek_ so would you like a brainstorm session or which?
17:04:18 <marek_> sdake: it's ok. So basically I will work on a simple tool for upgrading mesos apps with new version of Docker images.
17:04:39 <marek_> sdake: yes - I've made POF & a plan on etherpad and before I start coding I'd like you to review it.
17:05:17 <sdake> marek_  cool so I think instead of just me reviewing, it makes sense for broader community to have a review of the proposed plan
17:05:27 <sdake> would you mind sending an email to the mailing list iwth [kolla] tags
17:05:36 <sdake> requesting such assistance?
17:05:43 <marek_> sdake: ok, np.
17:06:16 <sdake> so looking over the doc, looks liek you spent some good time on it, hopefully a review will help you out
17:06:34 <nihilifer> anyone would like to share some thoughts atm?
17:06:45 <sdake> make sure to indicate what you are looking to get out of the effort marek_
17:07:04 <inc0> so, tags
17:07:17 <inc0> we just battled against using tags as version pointers
17:07:40 <inc0> I would show you different approach but gerrit is down
17:08:13 <nihilifer> inc0: so what you propose to use instead of tags?
17:08:18 <inc0> anyway argument was that people might want to use tags for their own business specific purposes so we shouldn't use it for our logic
17:08:19 <nihilifer> labels?
17:08:24 <inc0> file in container
17:08:33 <inc0> I just made patchset that enables it
17:09:03 <inc0> that what I will use (probably) in ansible upgrades
17:09:10 <inc0> and it would be good to keep this aligned
17:09:27 <sdake> agree re alignment
17:09:31 <nihilifer> ok, so we'll look on it when gerrit goes back
17:09:57 <inc0> sure
17:10:04 <nihilifer> yes, marek_'s idea is very similar to what inc0 proposed in visible yet patch
17:10:14 <marek_> guys but in general, I'd like to know if the tool I plan to write up will be useful & if this is what we want for upgrades in Mesos env (for starters).
17:10:17 <sdake> #action marek_ to send email to list to kickoff discussion about merging mesos upgrades with current upgrade plan
17:10:35 <inc0> yeah let's move it to mailing list
17:10:40 <marek_> ok
17:10:41 <sdake> marek_ I think we just decided the answer to that was we need to have this on the ml
17:11:06 <sdake> #topic open discussion
17:11:27 <sdake> anyone want the floor?
17:11:42 <inc0> merry christmas everyone!
17:11:49 <britthouser> Merry Christmas!
17:11:51 <sdake> inc0 ;)
17:11:55 <sdake> happy holidays !
17:11:57 <inc0> or happy hannukah
17:12:09 * sdake moar pc then inc0
17:12:12 <rhallisey> merry christmas
17:12:13 <rhallisey> :)
17:12:21 <barrett1> Happy Holidays!
17:12:46 <sdake> ok folks, remember, cutting a release on teh 23rd, so please try to wr=ap up by then
17:13:00 <sdake> at minimum, keep blueprints in corrrect state
17:13:05 <sdake> thanks for coming
17:13:10 <rhallisey> thanks
17:13:11 <sdake> #endmeeting