16:30:12 <sdake> #startmeeting kolla
16:30:12 <openstack> Meeting started Wed Jan 20 16:30:12 2016 UTC and is due to finish in 60 minutes.  The chair is sdake. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:30:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:30:15 <sdake> #topic rollcall
16:30:15 <openstack> The meeting name has been set to 'kolla'
16:30:23 <Jeffrey4l> o/
16:30:24 <SamYaple> o/
16:30:26 <zhurong> 0/
16:30:27 <nihilifer> o/
16:30:27 <Liuqing> o/
16:30:31 <pbourke> o/
16:30:33 <sdake> \o/ good morning/evening depending on your local :)
16:30:35 <sdake> locale that is
16:30:38 <inc0> o/
16:31:12 <sdake> Jeffrey4l thanks for making it at what I am sure i like 3am for you :)
16:31:27 <sdake> i/is
16:31:33 <Jeffrey4l> actually, it is 0:50 am now. Not too late. :P
16:31:37 <akwasnie> o/
16:31:38 <jpeeler> hi
16:31:41 <Jeffrey4l> 0:30 am
16:31:42 <sdake> ahh thats not terrible
16:31:53 <elemoine> o/
16:31:54 <sdake> but sstill not ideal
16:32:12 <Jeffrey4l> right..
16:32:18 <sdake> and to our other apac attendees, we are going to fix the meeting times to fit an apac schedule half the time
16:32:19 <inc0> yeha we need APAC-friendly meeting
16:32:20 <britthouser> 0/
16:32:29 <sdake> #topic announcement
16:32:33 <sdake> #undo
16:32:33 <Liuqing> inc0:  agree
16:32:34 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x9522c50>
16:32:36 <sdake> #topic announcements
16:32:57 <sdake> 1. there is a vote for meeting times for the APAC specific meeting for odd ISO weeks
16:33:06 <sdake> please vote on all the hours you can attend
16:33:20 <sdake> i will give preference to our apac + core members
16:33:31 <sdake> for that meeting time
16:33:38 <SamYaple> spliting the meeting between weeks like this still splits the team into two cores essentially, with a bit of overlap
16:33:42 <sdake> this mean emea wil probably get short end of stick for this meeting
16:34:05 <sdake> i disagree, but we can discuss further on mailing list if you like SamYaple  - please respond to the thread
16:34:11 <inc0> SamYaple, that's how it works, but AMR people can make sure to keep both teams in track
16:34:24 <sdake> 2. our midcycle is ready to rock - February 9th 10th, please schedule your flights now
16:34:42 <sdake> breakfast/lunch/dinner is provided the 9th, breakfast/lucnh provided the 10th
16:34:55 <elemoine> the time of the "emea" meeting won't change?
16:35:06 <sdake> we are concluding at 3:30 PM on the 10th for our wesst coast folks to catch a flight home wednesday
16:35:20 <sdake> elemoine yes the existing meeting will stay intact on even weeks
16:35:32 <sdake> that is emea/us timezone friendly
16:35:45 <elemoine> sdake, ok
16:36:00 <sdake> please RSVP for the midcycle - also note the facilities don't offer phone service, so it will be difficult to have remote participation
16:36:22 <sdake> I am going to put my cell lphone in the center o the room on speaker so folks can listen in, and connect it ot webex, but fwiw, it wont be very interactive
16:36:34 <sdake> so really recommend getting budget to attend in person
16:36:44 <Liuqing> cool
16:37:08 <sdake> 3. .21st is our dealdine for mitaka 2, I am tagging in the afternoon tomorrow, so please wrap up any work you think is necessary for mitaka -2
16:37:29 <sdake> also please update the state of bugs/llaunchpad tracker blueprints to match existing work
16:37:57 <inc0> sdake, can you borrow one of these fancy cisco conference microphones and hook it up to phone?;)
16:38:00 <sdake> (21st is tomorrow, so I will be tagging in 24 hours)
16:38:21 <sdake> inc0 I don't work in an office, so I can't get that kind of gear ufnortunately
16:38:30 <sdake> are there any announcements from the community?
16:39:20 <sdake> here is the meeting agenda:
16:39:24 <sdake> #link https://wiki.openstack.org/wiki/Meetings/Kolla
16:39:42 <sdake> #topic mitaka-2 announcement
16:39:46 <ajafo_> o/
16:39:46 <sdake> I will be announcing after the tag
16:40:00 <sdake> so lets put all mitaka-1 and mitaka-2 changefs in the announcement please
16:40:09 <sdake> lets sort it by what went inn mitaka-1 vs what is going in mitaka-2
16:40:29 <sdake> #link #link https://etherpad.openstack.org/p/announce-kolla-mitaka-2
16:40:33 <sdake> timeboxed to maxx 15 minutes
16:40:42 <sdake> so 55 after we will move on
16:40:46 <sdake> #link #link https://etherpad.openstack.org/p/announce-kolla-mitaka-2
16:40:49 <sdake> #link https://etherpad.openstack.org/p/announce-kolla-mitaka-2
16:40:52 <sdake> ugh sorry :)
16:45:48 <sdake> can i get some help writing thi folks :)
16:46:00 <sdake> the launchpad for mitaka-1 is completely accurate
16:46:10 <sdake> mitaka-2 less so
16:50:37 <nihilifer> are we going to mention about drop-root stuff?
16:53:34 <SamYaple> nihilifer: through it up there
16:53:54 <ajafo_> should we mention about implementation some ubuntu binary containers?
16:54:19 <SamYaple> ajafo_: yea! throw it up there
16:54:26 <SamYaple> good progress on ubuntu-binary implementation
16:56:13 <sdake> ok i'm going to extend the timebox
16:56:18 <sdake> lets give it 4 more minutes
16:56:26 * sdake breaks all the rules :)
16:59:25 <ajafo_> and new containers? like mistral?
17:00:19 <SamYaple> ajafo_: always
17:01:10 <sdake> ok i want to finish the job on this announcement
17:01:17 <sdake> announcements are one of our most important items
17:01:23 <sdake> so i'll extend time box 5 more minutes
17:01:33 <sdake> please finish in that allotted itme, I am definately moving on at 5  after
17:03:20 <sdake> please dont remove color from etherpad
17:03:32 <sdake> it helps folks understand who contributed what
17:03:42 <sdake> (to the etherpad session)
17:04:50 <SamYaple> alright
17:05:30 <SamYaple> sdake: 10 minutes past the original time ;)
17:05:43 <sdake> ya
17:05:45 <sdake> we are movign on
17:05:47 <sdake> thanks folks
17:05:48 <ajafo_> I've got some problems with colours see other write in other :)
17:05:53 <sdake> that took longer then I thought it owuld
17:06:00 <sdake> ssecond let me find agenda in my sea of windows
17:06:12 <sdake> if someone could fix up that prestage language on the timing so its not so awkward I'd apprecaiate it
17:06:32 <sdake> #topic Upgrade Status
17:06:43 <inc0> ok
17:06:43 <sdake> inc0 and friends, mind giving an update on current status
17:06:53 <inc0> so we got keystone merged \o/
17:07:03 <sdake> and tested
17:07:14 <inc0> which means other projects are green to go and follow playbook structure of ks
17:07:14 <sdake> in 3 node ha
17:07:26 <sdake> inc0 nova?
17:07:46 <inc0> in review, need to address comments and so on
17:07:50 <inc0> but that's on me
17:07:52 <nihilifer> i unfortunately didn't made progress with neutron upgrade, but i'd try to do this this week
17:08:00 <nihilifer> i'll*
17:08:04 <inc0> so nihilifer will do neutron
17:08:05 <sdake> nihilifer  march - need sto be done by march :)
17:08:15 <nihilifer> ok
17:08:19 <elemoine> btw, kudos on the upgrade work, it's a major thing!
17:08:20 <inc0> we still need cinder play and other services
17:08:21 <SamYaple> where is the list of who is assigned what for upgrades?
17:08:22 <sdake> sooner obviously better
17:08:26 <sdake> yes ugprade is super huge
17:08:30 <inc0> most of them are really simple
17:08:39 <sdake> ok so i'll take na action to create the work items for the master upgrade task
17:08:41 <inc0> SamYaple, we have bps per project
17:08:50 <inc0> if it's assigned, its assigned
17:08:52 <sdake> #action sdake to make work items in upgrade-kolla blueprint
17:09:03 <sdake> i'll do that after my meeting with inc0
17:09:12 <inc0> its already done;)(
17:09:13 <sdake> then i'll announce on ml that we are in need of contributors for that work
17:09:18 <sdake> the work iteems?
17:09:22 <SamYaple> bps per project is a bit overkill, this is what work items are for
17:09:23 <sdake> are in upgrade-kolla?
17:09:24 <sdake> cool
17:09:37 <inc0> https://blueprints.launchpad.net/kolla?searchtext=upgrade
17:09:46 <sdake> we decided in this case to do separeate bps because the work may be signifciantly unique per service
17:09:49 <sdake> anyway whats done is done
17:10:05 <sdake> we are tracking everything in the master blueprint as well as individual blueprints
17:10:11 <SamYaple> for some, yea. like nova and neutron, but as stated most will not
17:10:16 <SamYaple> something to keep in mind for the future
17:10:28 <sdake> agree SamYaple
17:10:41 <inc0> so most of services, like heat for example will be super simple in terms of play
17:10:42 <sdake> fwiw I wanted oen blueprint, but the project has a mind of its own :)
17:10:45 <sdake> #topic heka status
17:10:47 <inc0> and generally follow keystone case
17:10:58 <sdake> inc0 gotta move on, we aree itght on time, sorry :)
17:11:02 <akwasnie> there is also a master bp that agregate the rest https://blueprints.launchpad.net/kolla/+spec/upgrade-kolla
17:11:12 <sdake> inc0 but we will get this kicking on the mailing list today
17:11:25 <sdake> elemoine you have the floor
17:11:27 <elemoine> on heka
17:11:33 <elemoine> so, currently working on Heka for Kolla PoCs, to figure out if we'll still need Rsyslog
17:11:51 <elemoine> first PoC I've been focusing on is "Use Heka to collect OpenStack logs".  This relies on the OpenStack services writing their logs to stderr.
17:12:10 <elemoine> my work is in <https://review.openstack.org/#/c/269745/>
17:12:25 <elemoine> I have a couple observations already
17:12:43 <elemoine> I had to make the OpenStack services write their logs to stderr instead of stdout. stdout is buffered somewhere and I cannot make it available to neither "docker logs" nor Heka
17:13:12 <sdake> hmm
17:13:21 <elemoine> I really don't know what's going on here
17:13:36 <SamYaple> So i reaised a question on this elemoine
17:13:38 <elemoine> and I think Angus experienced the same issue in kolla-mesos
17:13:45 <SamYaple> what of services that have multiple logs, how will logging work?
17:13:53 <SamYaple> i dont think we can use stdout/err like you purpose
17:14:22 <elemoine> yeah, we will need a way to know where the logs come from
17:14:43 <elemoine> I need to think about this
17:14:54 <elemoine> good question SamYaple
17:14:55 <sdake> elemoine any progress on getting the spec into the repo?
17:15:05 <elemoine> other observation:
17:15:14 <elemoine> Heka cannot access the logs if the container is run with tty set to true.  It may be a bug in Heka or in an upstream module.  I don't know.
17:15:31 <elemoine> sdake, I'll do that tomorrow
17:15:37 <sdake> elemoine  soundsgood
17:15:41 <elemoine> have been focusing on the PoC
17:15:42 <sdake> there is always tomorroow :)
17:16:04 <elemoine> sdake, it's late here already :)
17:16:11 <sdake> just kidding around
17:16:16 <sdake> its an old idiom in the united states
17:16:41 <elemoine> so there's this tty problem
17:16:51 <sdake> so i think we need more of a rsyslo type action, where data comes from /dev/log instead of coming from stderr
17:17:03 <sdake> that way the logs can be sorted into their proper streams
17:17:18 <sdake> if we get this in a spec we can discuss it there
17:17:35 <sdake> so we dont end up wasting your time on courses of developemnt which wont yeild a positve outcome ;)
17:17:50 <sdake> any other updates elemoine ?
17:18:06 <elemoine> I still need to be sure we won't able to use stdout
17:18:17 <elemoine> stderr I mean
17:18:19 <sdake> wfm
17:18:27 <elemoine> that's all for me
17:18:32 <sdake> ok i'm going to move on, since our agenda is tight on time and i want to give everyone equal time
17:18:35 <sdake> #topic Kolla Python API
17:18:42 <sdake> not sure who put htis on the agenda
17:18:47 <sdake> but whoever it was, you have the floor
17:18:48 <nihilifer> i putted it
17:18:55 <nihilifer> Angus registered a bp https://blueprints.launchpad.net/kolla/+spec/kolla-python-api
17:19:03 <nihilifer> to have a python api for kolla
17:19:20 <sdake> cool i remember the irc conversation
17:19:24 <Liuqing> nihilifer: will have another project for kolla python api?
17:19:26 <sdake> I am in favor of his ideas adn his thinking here
17:19:39 <nihilifer> the problem is that both kolla and kolla-mesos have to be configured via /etc files
17:19:48 <nihilifer> or have some bash scripts
17:20:01 <nihilifer> that would make integrating kolla with anything (i.e. fuel) hard
17:20:03 <Jeffrey4l> Is it the same like oracle's python-kollaclient?
17:20:16 <sdake> Jeffrey4l no completely different topci  ithink
17:20:17 <nihilifer> Jeffrey4l: maybe similar
17:20:43 <sdake> well what do I know ;)
17:20:52 <nihilifer> so, we would like to have a python library, to which we can push the whole configuration in some serializable format
17:20:59 <nihilifer> instead of editing files
17:21:13 <sdake> ok well this is a big change
17:21:14 <nihilifer> i'm welcome for propositions of technical implementation
17:21:27 <sdake> and need sto be discussed on the mailing list for wider community visiblity
17:21:46 <nihilifer> Angus and me will of course make a ML and spec
17:21:56 <sdake> spec may not be necessary
17:22:01 <sdake> lets focus on the mailign list discussion first
17:22:02 <nihilifer> now i just wanted you to be aware of this idea
17:22:19 <sdake> our typical process is to discuss the ideas in the blueprint
17:22:26 <sdake> make sure to suggest that in the mailing list thread
17:22:32 <nihilifer> sdake: ok
17:22:46 <sdake> blueprint is where we sort of hash out hte design
17:22:54 <sdake> if it needs more detail, then we write a spec
17:23:02 <nihilifer> got it
17:23:12 <sdake> especially if its contentious or the community is not in compelte agreeement on course of action
17:23:12 * elemoine confuses bp and specs I believe
17:23:32 <sdake> nihilifer anything further?
17:23:38 <nihilifer> on this topic, no
17:23:42 <nihilifer> i think we can move on
17:23:54 <sdake> #topic OpenStack configuration without kolla-ansible (as a container)
17:23:54 <sdake> * Open Discussion
17:23:57 <SamYaple> I have topic
17:24:15 <sdake> 3 minutes on config without kolla ansible, then sam your up for 3 mins
17:24:28 <nihilifer> well, currenltly we're doing the most of config tasks
17:24:37 <sdake> nihilifer di you add this agenda item?
17:24:42 <nihilifer> like creating tenants in openstack
17:24:47 <nihilifer> sdake: yes
17:24:48 <sdake> folks if you could add your name next to the agenda item, i'd super appreciate it in the future
17:25:08 <SamYaple> i would like to add that kolla-ansible container only exists to containerize dependancies. its completely possible to be without kolla-ansible..... by pushing the deps to the hosts
17:25:18 <nihilifer> ok, so for now we're using ansible for creating tenats or any other entities in openstack
17:25:46 <sdake> nihilifer we dont want a bunch of deps on the host
17:25:51 <sdake> that is why kolla-ansible exists
17:26:01 <sdake> so keep that in mind when proposing whateveer change you have in mind :)
17:26:12 <nihilifer> ok. but we can create entities in openstack just by openstacclient, can't we?
17:26:20 <SamYaple> nihilifer: that requries host deps
17:26:24 <sdake> openstackclient installs a whole slew of host deps
17:26:24 <SamYaple> but yes
17:26:26 <sdake> like 30 or more
17:26:30 <inc0> nihilifer, and openstackclient has a lot of deps
17:26:33 <Liuqing> how about using openstacksdk?
17:26:34 <nihilifer> well, i thought about keeping them in container
17:26:41 <SamYaple> thats koll-ansible :P
17:26:43 <SamYaple> we can rename it
17:26:47 <pbourke> ha
17:26:49 <SamYaple> kolla-toolbox
17:26:50 <inc0> well, it uses shade
17:26:51 <sdake> oh is the objection the name?
17:27:00 <sdake> or how its implemented?
17:27:03 <inc0> but shade uses openstackclient
17:27:27 <sdake> SamYaple cn your topic overflow into #kolla after our meeting?
17:27:33 <SamYaple> its rather important
17:27:45 <sdake> ok nihilifer  - please start a ml thread
17:27:47 <SamYaple> gates b0rked. need this patch merged https://review.openstack.org/#/c/270031/
17:27:48 <sdake> #topic sam's topic
17:27:48 <nihilifer> ok
17:27:58 <SamYaple> gates b0rked. need this patch merged https://review.openstack.org/#/c/270031/
17:28:04 <SamYaple> parent patch here https://review.openstack.org/#/c/270070/1
17:28:16 <SamYaple> once gate is fixed we need to address this new pip issue
17:28:24 <sdake> SamYaple i have meeting right now, but will review after it cinclude sif its not merged
17:28:28 <pbourke> SamYaple: we just need to wait till pip release a fix
17:28:29 <SamYaple> the patch above is a quick temp fix to get things building again
17:28:32 <pbourke> SamYaple: there's already one proposed
17:28:41 <pbourke> afaik
17:28:43 <SamYaple> pbourke: ok good info to have
17:28:51 <SamYaple> but i thought this was a long time coming thing
17:28:55 <SamYaple> its been WARNING us ofr a while
17:28:59 <sdake> pbourke  can you hunt down when the patch is going to be merged
17:29:01 <SamYaple> so ill be suprised if this is "fixed"
17:29:10 <Jeffrey4l> yep. Wait for a pip fix will take long.
17:29:12 <pbourke> Jeffrey4l linked it on the bug I think
17:29:24 <pbourke> https://github.com/pypa/pip/pull/3389
17:29:32 <sdake> 1 minute
17:29:41 <sdake> apologies for mismanaging the time for our meetingagenda
17:29:43 <SamYaple> ok i think we need to move back to channel
17:29:47 <Liuqing> and we could bump to latest pip until the bug fixed in pip
17:29:48 <SamYaple> i rasied the issue, everyone is aware now
17:29:55 <sdake> but releae annoouncements are the 3rd most important thing we do as a project :)
17:29:57 <sdake> thanks sam
17:30:07 <sdake> thanks for coming folks, we are out of time
17:30:12 <pbourke> bye
17:30:15 <sdake> #endmeeting