16:30:11 <sdake> #startmeeting kolla
16:30:12 <openstack> Meeting started Wed Feb 24 16:30:11 2016 UTC and is due to finish in 60 minutes.  The chair is sdake. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:30:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:30:15 <openstack> The meeting name has been set to 'kolla'
16:30:16 <sdake> #topic rollcall
16:30:17 <SamYaple> o/
16:30:18 <pbourke> o/
16:30:20 <akwasnie> hi :)
16:30:22 <britthouser> 0/
16:30:25 <sdake> yo folks
16:30:25 <pbourke> so close to being first
16:30:27 <pbourke> cheers SamYaple
16:30:31 <pbourke> :p
16:30:35 <inc0> o/
16:30:42 <dave-mccowan> o/ hola
16:30:44 <SamYaple> so you know what they call almost winning pbourke ?
16:30:47 <SamYaple> losing
16:30:53 <pbourke> lol
16:30:54 <sdake> age before beauty pbourke  ;)
16:31:32 <rhallisey> hello
16:32:00 <jpeeler> hi
16:32:07 <sdake> #topic announcements
16:32:34 <sdake> 1. meeting times have changed, even weeks are 16;30, odd weeks are 23:00
16:32:41 <carolbarret> #openstack-meeting
16:32:46 <carolbarret> #openstack-meetings
16:32:48 <sdake> ISO weeks - to find the week run date "+%V"
16:32:55 <akwasnie> 1630 timezone?
16:33:02 <akwasnie> ah, ok
16:33:12 <SamYaple> akwasnie: UTC
16:33:34 <sdake> carolbarret is there an issue with meeting conflct?
16:33:54 <sdake> the meetings are staying in the channel openstack-meeting-4
16:34:22 <sdake> the irc channel gate sorts out conflicts and -1's the patch if its wrong ;)
16:35:04 <sdake> 2. we need to get cracking on our austin summit sessions - ttx has requested the info in the next few weeks
16:35:06 <sdake> so the next two meetings, we need to sort that out
16:35:11 <vhosakot> sorry, I'm late
16:35:14 <vhosakot> o/ :)
16:35:24 <sdake> 3. mitaka releases between 2nd-4th of march, 1 week to go - and we got a ton of work to do
16:35:57 <sdake> 4. I am going to kick all medium/low blueprints to newton if they are not in the good progress stage, so please make it so in launchpad - if you dont' have permissions ping me and i'll add you to the drivers group to change your blueprint states
16:36:06 <SamYaple> sdake: you mean mitaka-3 right?
16:36:16 <sdake> SamYaple yes mitaka-3
16:36:25 <sdake> then we have 1 month for stablization via rcs
16:36:48 <sdake> the final date I believe is aprril 13th, but not certain - i'll double check and get backt o folks that want o know our actual release date
16:37:06 <sdake> any announcements from community folk?
16:38:08 <sdake> #topic Kolla Austin Summit topics [timebox 15 minutes]
16:38:50 <sdake> #link https://etherpad.openstack.org/p/kolla-newton-summit
16:43:40 <elemoine_> o/
16:43:49 <xionglingfeng> hi everyone :-)
16:43:53 <elemoine_> sorry for being late, I thought there was no meeting
16:44:51 <dave-mccowan> we're collaborating in  https://etherpad.openstack.org/p/kolla-newton-summit
16:45:29 <xionglingfeng> So this conference is only about the design of Newton cycle?
16:47:17 <vhosakot> dave-mccowan: add your name under "Contributors" at the top
16:48:31 <xionglingfeng> me?
16:49:03 <vhosakot> xionglingfeng: you too :)
16:49:30 <xionglingfeng> I am still thinking what shall I write on the pad LOL
16:49:52 <sdake> wheee :)
16:49:54 <rhallisey> xionglingfeng, anything you want to discuss
16:50:08 <sdake> ok lets keep going until the hour mark or until we run out of ideas ;)
16:50:24 <xionglingfeng> Im struggling about the cinder NFS thing :-(
16:51:07 <xionglingfeng> since nova_compute and nova_libvirt r split into two component, it is really difficult to make cinder NFS working
16:52:14 <xionglingfeng> any suggestions on this?
17:00:25 <sdake> ok folks
17:00:34 <sdake> we went past our timebox and our extended timebox
17:00:40 <sdake> lets finish this up next meeting
17:00:57 <sdake> #topic risk item status
17:01:36 <sdake> https://etherpad.openstack.org/p/kolla-mitaka-midcycle-roadmap
17:02:14 <sdake> elemoine_ akwasnie1 diagnostics status?
17:02:19 <sdake> I know heka is msotly merged
17:02:28 <akwasnie1> elasticsearch is merged
17:02:44 <elemoine_> what remains is integrating the two
17:02:45 <akwasnie1> we will start integration this week, i think
17:02:51 <akwasnie1> yup :)
17:02:51 <elemoine_> I created a wip CR for that
17:03:15 <elemoine_> I hope akwasnie1 and I can collaborate on it
17:03:24 <xionglingfeng> quick question: since we already have ELK and heka for logs, why we still keep rsyslog?
17:03:27 <akwasnie1> sure :)
17:03:34 <akwasnie1> rsyslog is removed
17:03:39 <xionglingfeng> cool
17:04:04 <sdake> we have EHK - special snowflakes ftw ;)
17:04:11 <xionglingfeng> LOL
17:04:21 <xionglingfeng> What is the time schedule for kolla release?
17:04:32 <sdake> Jeffrey4l reconfig
17:04:33 <xionglingfeng> I mean, what time is feature freeze, something like this?
17:04:42 <elemoine_> makes me wonder if we should rename the enable_elk var to something else
17:04:45 <sdake> feature freeze is theoretically march 2nd-4th
17:04:54 <sdake> i say theoretically because we are on releease-indepndent schedule
17:05:01 <elemoine_> I guess it could just be enable_elasticsearch in fact
17:05:01 <xionglingfeng> okok got u
17:05:04 <sdake> so we set our own schedules and release criteria
17:05:16 <xionglingfeng> ok. Is there any page for the schedule?
17:05:18 <sdake> however, i'd like to follow upstream release-managed as much as possible
17:05:25 <xionglingfeng> sure
17:05:34 <sdake> xionglingfeng google for openstack mitaka schedule
17:05:36 <elemoine_> sdake: makes sense to me
17:05:43 <sdake> Jeffrey4l ping re reconfig
17:05:57 <sdake> inc0 your up on infrastructure upgrades
17:06:11 <inc0> HAProxy is up for review
17:06:13 <xionglingfeng> I have OS time schedule. Because you mentioned kolla has own schedule so I just wondering if it is documented.
17:06:17 <inc0> rabbitmq is inprog
17:06:22 <inc0> mariadb is on SamYaple
17:06:39 <sdake> keepalived is also in the haproxy review
17:06:51 <sdake> ceph remains
17:06:53 <inc0> we need upgrades of logging stuff, but that's lower priority
17:06:53 <sdake> what  else?
17:06:56 <xionglingfeng> what about n-1 support?
17:07:06 <SamYaple> xionglingfeng: that is unlikely to ever happen
17:07:15 <xionglingfeng> lol
17:07:16 <xionglingfeng> kk
17:07:24 <sdake> xionglingfeng add to the etherpad for austin summit discussion
17:07:26 <inc0> but elemoine akwasnie1 you might want to check on this one, hopefully is as simple as rebuild containers
17:07:39 <sdake> its not going to happen in mitaka - mitaka needs more capacity or less features
17:07:46 <elemoine_> inc0: I can have a log at upgrade of logging stuff, although I am not sure what that implies at this point
17:08:07 <sdake> sounds like diags is not really in risk any longer
17:08:09 <inc0> elemoine_, at very least implement naive redeploy with serial plz
17:08:15 <sdake> sounds like infrastructure upgrades is not at risk any longer
17:08:26 <inc0> ceph is still for the taking
17:08:29 <inc0> ceph upgrades
17:08:34 <SamYaple> nah ceph is fine
17:08:34 <sdake> migration path - pbourke ?
17:08:38 <SamYaple> im working on it now
17:08:45 <SamYaple> its not doing storage infrace properly
17:08:49 <sdake> SamYaple can you assign the blueprint to yourself
17:08:56 <SamYaple> i did at one point...
17:09:02 <sdake> and set the state to started or good progress
17:09:05 <elemoine_> inc0: I can have a look, but I need to get more familiar with the exact needs
17:09:08 <sdake> i unset them at midcycle because we moved around who was working on what
17:09:21 <inc0> elemoine_ I'm here to help
17:09:34 <sdake> vm functional testing no longer at risk
17:09:35 <sdake> so that leaves reconfig
17:09:40 <elemoine_> inc0: ok, I'll ping you on IRC then
17:09:56 <sdake> #info reconfig is at risk and essential blueprint for mitaka
17:10:00 <elemoine_> inc0: any container I should look at as a model?
17:10:18 <inc0> elemoine_, keystone is the simpliest, nova is most complex
17:10:25 <elemoine_> is reconfig related to upgrade?
17:10:31 <inc0> not really
17:10:34 <sdake> elemoine_ sort of but not really
17:10:35 <elemoine_> or are the two independent?
17:10:44 <sdake> they are two seprate actions
17:10:47 <xionglingfeng> reconfig?
17:10:51 <elemoine_> ok, I'll figure it out
17:11:10 <xionglingfeng> do u mean that modify the configuration files then redeploy the containers?
17:11:11 <elemoine_> xionglingfeng: reconfig == restart container after config change
17:11:11 <SamYaple> hey i really dont like "reconfig" is there opposition to "reconfigure"?
17:11:14 <xionglingfeng> Or i misunderstood
17:11:17 <xionglingfeng> okok got u
17:11:17 <inc0> reconfig means I want to keep my containers as they are but change config files
17:11:28 <elemoine_> SamYaple: reconfiguration, sorry :)
17:11:37 <SamYaple> elemoine_: i meant for the name
17:11:43 <elemoine_> SamYaple: I agree with you
17:11:46 <sdake> reconfigure is a bit long but i dont care as long as it works ;)
17:11:54 <inc0> updtading_configuration_files_to_the_latest_version_based_on_what_is_currently_in_ansible_templates
17:11:57 <SamYaple> reload
17:12:04 <elemoine_> we don't have short names elsewhere
17:12:11 <SamYaple> i dont care, just the partital short name is annoying
17:12:16 <xionglingfeng> reconfig==write new version of configuration files and restart containers, isn't it?
17:12:21 <SamYaple> xionglingfeng: yes
17:12:28 <xionglingfeng> So the risk is?
17:12:46 <elemoine_> that it's not finished before mitaka I guess
17:12:46 <sdake> the risk is there is only one patch in the queue to do the job and it ahsn't been updatedd in 5 days
17:13:04 <sdake> and there needs to be  a role for every service
17:13:16 <sdake> i'll speak to Jeffrey4l offline about it, he must be asleep ;)
17:13:27 <sdake> ok, any questions, or shall I move on?
17:13:28 <elemoine_> sounds worrying…
17:13:30 <SamYaple> sdake: its been updated...
17:13:36 <SamYaple> its fairly active right now
17:13:39 <sdake> SamYaple cool - i'll check it out
17:13:39 <SamYaple> looks good
17:13:49 <rhallisey> well once there's a template the rest should fly up there
17:13:51 <sdake> SamYaple I haven't looked at the queue this morning yet
17:14:01 <rhallisey> we told him to make sure one merges first
17:14:02 <xionglingfeng> hav to leave   meeting conflict
17:14:06 <xionglingfeng> see u guys :-)
17:14:09 <rhallisey> see ya
17:14:09 <sdake> xionglingfeng ttyl
17:14:12 <SamYaple> thanks xionglingfeng
17:14:12 <elemoine_> xionglingfeng: bye
17:14:34 <sdake> #topic essential blueprint status
17:15:08 <sdake> https://launchpad.net/kolla/+milestone/mitaka-3
17:15:12 <sdake> #link https://launchpad.net/kolla/+milestone/mitaka-3
17:15:14 <xionglingfeng> BTW, I think I have some spare time working on both core components and trove/murano in the following months. So if anything I can help, just let me know
17:15:16 <xionglingfeng> :-)
17:15:34 <sdake> essential is looking good
17:15:43 <sdake> we have many in the not started state however
17:15:46 <sdake> so lets focus on those first
17:15:55 <sdake> mariadb lights out recovery
17:16:00 <elemoine_> xionglingfeng: trove logs are not collected
17:16:06 <sdake> SamYaple ^
17:16:16 <sdake> also playbook for neutron playbook for openvswitch for upgrades ^^
17:16:21 <elemoine_> xionglingfeng: it would be good to add that, and that should be pretty straightforward
17:16:26 <sdake> are those not started state as well, or are they started?
17:17:20 <SamYaple> they are started
17:17:20 <sdake> remember, we have 1 week ;)
17:17:25 <SamYaple> i need to push them up for review
17:17:31 <SamYaple> im testing multinode neutron
17:17:34 <sdake> cool, mind i set them to started?
17:17:36 <SamYaple> it _seems_ to be working
17:17:40 <sdake> if they are ready to review, then theyare probably good dprogress
17:17:55 <sdake> or ready for review
17:18:10 <SamYaple> yea in neutrons case its basic service upgrade template
17:18:14 <sdake> SamYaple would you mind setting the state for those 3 to what you think is appropriate?
17:18:17 <SamYaple> mariadb is harder, still idempoteizing it
17:19:27 <sdake> nihilifer you ahve several upgrade blueprints in started state
17:19:32 <sdake> I see they have reviews up
17:19:38 <sdake> and your blocked on multinode testing
17:19:55 <sdake> folks - please don't block on mulitnode  testing just test single node and we can sort out multinode qa in the rcs
17:20:11 <sdake> iwith qualifier (if you can't test multinode)
17:20:34 <sdake> the goal is to get things from not started->started->good progress->ready for review->implemented
17:20:42 <sdake> I leave it to you to judge what state your work is in
17:21:02 <sdake> but I can't read your minds,  so please set the tracker appropriately so operators don't have a heart attack when they look at our tracker
17:21:19 <sdake> upgrade playbook for heat, half done
17:21:34 <sdake> rest are all good progress
17:21:45 <sdake> I'd define good progress as *it will be implemented by march 2nd-4th*
17:22:02 <inc0> how are we doing on Grand-Backport?
17:22:11 <sdake> inc0 lets get mitaka-3 out of the way first
17:22:23 <sdake> I had planned to discuss high prioirrty blueprints
17:22:27 <sdake> but there isn't enough  time
17:22:28 <sdake> so :)
17:22:32 <sdake> #topic open discussion
17:22:35 <sdake> inc0 you have the floor
17:22:52 <elemoine_> inc0: grand backport == backporting thin containers ?
17:23:04 <sdake> elemoine_ no the first part of the proposal
17:23:12 <vhosakot> I have something to talk in open discussion.. should we add docker version and ansible version as well in requirements.txt ?
17:23:12 <elemoine_> ah ok
17:23:13 <inc0> elemoine_ thin containers and named volumes
17:23:13 <sdake> the containers backport hasn't hit its voting deadline yet
17:23:25 <elemoine_> got it
17:23:27 <sdake> vhosakot one at a time :)
17:23:32 <inc0> sdake, but I think we have majority already
17:23:36 <sdake> whoever has the floor drives discussion in open discussion
17:23:48 <vhosakot> sdake: got it!
17:23:50 <sdake> inc0 cool wedidn't yesterday i'll check ml and make it so
17:24:24 <sdake> so inc0 anything to add re grand backport ? :)
17:24:27 <inc0> ok, I'd love to have 1.1.0 asap tbh...we need to really test this one
17:24:31 <rhallisey> ya I think we hit the majority
17:24:38 <inc0> its more important (way more important) than Mitaka-3 imho
17:24:45 <inc0> I'm done
17:24:54 <sdake> #action sdake to check for majority on thin container backport and post results on mailing list
17:24:56 <SamYaple> i agree inc0
17:25:19 <sdake> inc0 we need to finish the features for mitaka by eadline atleast essential/high
17:25:34 <sdake> I don't want features in the rcs if we can help it
17:25:46 <sdake> we have 80 bugs in the tracker, which is about 40 too many to handle in the rcs
17:26:02 <inc0> ok, but I want to say that while noone will deploy mitaka for next few months, 1.1.0 will get deployed as first kolla on prod
17:26:04 <sdake> vhosakot you have the floor
17:26:05 <sdake> 3 minutes ;-)
17:26:11 <vhosakot> sdake: thanks :)
17:26:13 <vhosakot> I have something to talk in open discussion.. should we add docker version and ansible version as well in requirements.txt ?
17:26:19 * SamYaple begs for reviews https://review.openstack.org/#/c/283887
17:26:21 <sdake> inc0 ack that, i think we need to do that during rcs
17:26:23 <SamYaple> that was holding up ceph upgrades ^
17:26:35 <inc0> vhosakot, we are separating kolla-ansible from kolla
17:26:37 <sdake> SamYaple will review after meeting
17:26:54 <inc0> and we can't add docker version because it's not pip installable
17:27:13 <vhosakot> inc0: ah, ok.. agreed.. cool
17:27:15 <sdake> ansible can't be added to requiremetns.txt because of openstack policies
17:27:19 <sdake> there is a bug in the tracker on this piont
17:27:22 <inc0> that too
17:27:34 <sdake> i'll find it for you later if you want to read up on it
17:27:38 <inc0> ansible has wrong licence
17:27:39 <vhosakot> sdake: thats it.. I will ping in #kolla channel about a feature I need to start or help with
17:27:53 <SamYaple> ok im out guys
17:27:55 <SamYaple> lunch
17:28:01 <elemoine_> https://bugs.launchpad.net/kolla/+bug/1547533
17:28:01 <openstack> Launchpad bug 1547533 in kolla "Tech-Debt: Namespace the Docker volumes" [Medium,Confirmed]
17:28:04 <sdake> any other open discussion?
17:28:12 <elemoine_> would love a decision on this
17:28:19 <sdake> decision on what
17:28:24 <elemoine_> https://bugs.launchpad.net/kolla/+bug/1547533
17:28:27 <sdake> oh you rbug
17:28:35 <elemoine_> volume naming
17:28:39 <sdake> i'll tak a look elemoine_
17:28:45 <sdake> I think we  dont need namespacing on further thinking
17:28:55 <elemoine_> thanks, I've added a few ideas in the bug
17:29:07 <SamYaple> elemoine_: i know what youre asking, we can implement that in newton
17:29:13 <elemoine_> sdake: which means renaming kolla_logs to something else I guess
17:29:14 <inc0> if docker doesn't support volume rename
17:29:20 <SamYaple> mesos has this thing
17:29:25 <sdake> thanks for coming folks
17:29:26 <SamYaple> inc0: it doesnt need to
17:29:34 <sdake> our meeting time is up :)
17:29:41 <elemoine_> bye
17:29:45 <sdake> lets overflow into #kolla as needed
17:29:46 <vhosakot> bye :)
17:29:48 <sdake> #endmeeting