16:01:23 <rhallisey> #startmeeting kolla
16:01:24 <openstack> Meeting started Wed Jul  6 16:01:23 2016 UTC and is due to finish in 60 minutes.  The chair is rhallisey. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:28 <openstack> The meeting name has been set to 'kolla'
16:01:31 <rhallisey> #topic rollcall
16:01:33 <rhallisey> hello
16:01:34 <inc0> o/
16:01:37 <wirehead_> o/
16:01:38 <mliima_> hi :)
16:01:39 <Jeffrey4l_> o/
16:01:39 <coolsvap> o/
16:02:13 <rhallisey> alrighty then
16:02:17 <rhallisey> #topic Announcements
16:02:39 <rhallisey> Summit talks are due on the 12th
16:02:56 <rhallisey> if anyone is planning a talk, there are 6 days left to submit
16:03:22 <inc0> Midcycle is next week
16:03:34 <vhosakot> o/
16:03:41 <rhallisey> if you have anything you are thinking about, mention it with some people and maybe we can help the idea along
16:03:46 <rhallisey> inc0, yes thanks
16:03:52 <rhallisey> midcycle is also next week
16:03:55 <pbourke> o/
16:04:05 <rhallisey> in North Carolina
16:04:07 <wirehead_> If you haven’t gotten tickets for midcycle and get plane tickets now, you will probably be in trouble with your boss.
16:04:20 <rhallisey> :)
16:04:24 <rhallisey> #topic Customization of dockerfiles
16:04:35 <rhallisey> inc0, anything to add for this?
16:04:47 <inc0> yeah
16:05:08 <inc0> so we need to start doing work of adding placeholders for customizations
16:05:14 <inc0> let me show you an example
16:05:36 <inc0> https://review.openstack.org/#/c/329651/
16:06:14 <coolsvap> #link https://review.openstack.org/#/c/329651/
16:06:29 <akwasnie> Hi, sorry for being late!
16:06:31 <rhallisey> this work can be divided among the community
16:06:41 <rhallisey> inc0, is thet BP setup for that?
16:06:42 <Jeffrey4l_> inc0, how to add a new package?
16:07:12 <inc0> rhallisey, we don't have bp with work items
16:07:16 <inc0> I'll do it after meeting
16:07:16 <Jeffrey4l_> for example, add `tmux` to the heat container. ( even though it is meaningless)
16:07:34 <rhallisey> inc0, ok let's get that out there.  Fix up that patch and merge it.
16:07:36 <inc0> Jeffrey4l_, hold on
16:07:51 <rhallisey> once we have that one done the work can be spread out
16:08:09 <Jeffrey4l_> ok
16:08:18 <inc0> you'll need to add {{ heat_api_packages_append = ["tmux"] }} in customization file
16:09:12 <inc0> ok, so I'll start with writing docs:)
16:09:13 <Jeffrey4l_> inc0, where is the customization file locate?
16:09:32 <inc0> build.py --template-override path-to-customization-file
16:09:47 <rhallisey> inc0, yes please :)
16:10:08 <inc0> #action inc0 to provide docs for customization
16:10:28 <rhallisey> ok cool
16:10:29 <inc0> #action inc0 to provide blueprint with work items
16:10:45 <inc0> ok, that's on me, after that take on items guys
16:11:04 <rhallisey> inc0, ya just make a writeup of the work items and we can spread them out
16:11:10 <rhallisey> #topic Gating
16:11:30 <rhallisey> dmsimard write another email about gating that I think brought up some good points
16:11:35 <rhallisey> s/write/wrote
16:12:14 <rhallisey> as for moving towards voting gates, I've seen a lot more green lately
16:12:33 <rhallisey> Jeffrey4l_, I know you've been working hard on that :)
16:12:35 <rhallisey> nice job
16:12:51 <coolsvap> Jeffrey4l_ +1 nice
16:12:53 <rhallisey> there is a new issue that I've seen: http://logs.openstack.org/51/298451/21/check/gate-kolla-dsvm-deploy-centos-binary/f212710/console.html#_2016-07-06_01_49_11_762175
16:12:54 <Jeffrey4l_> yes. the gate is more stable now.
16:13:08 <rhallisey> issue with neutron-ovs-agent
16:13:12 <wirehead_> I’m assuming we can’t dip a toe in by creating an artificial gate that votes no if all of the ‘deploy’ or ‘build’ gates are red.
16:13:39 <Jeffrey4l_> rhallisey, this fix is under review https://review.openstack.org/336352
16:13:46 <rhallisey> awesome
16:14:06 <Jeffrey4l_> one question: should we move the xenial in the CI for ubuntu?
16:14:08 <rhallisey> so tieing into what I first mentioned about that email, getting out gates to stable is one step in the right direction
16:14:18 <rhallisey> beyond that we need to extend out gate coverage
16:14:40 <rhallisey> it's something that's going to propel the general stability of the project
16:14:49 <Jeffrey4l_> move the/move to
16:15:17 <inc0> Jeffrey4l_, we should be good
16:15:27 <inc0> I didnt experience any issues with xenial yet
16:16:00 <Jeffrey4l_> inc0, if we move to xenial, all the branch will use it.
16:16:09 <Jeffrey4l_> what do you guys think this?
16:16:11 <inc0> yeah, but as base system
16:16:25 <Jeffrey4l_> include liberty, mitaka and newtwon
16:16:47 <rhallisey> I think that sounds reasonable
16:16:54 <Jeffrey4l_> now, one issue from ubuntu kernel block the ubuntu 16.04 as the base image.
16:17:03 <Jeffrey4l_> https://review.openstack.org/329454
16:18:27 <rhallisey> ok good to know
16:18:39 <rhallisey> one more think per the email
16:18:42 <rhallisey> #link https://github.com/openstack/packstack#packstack-integration-tests
16:18:54 <rhallisey> those are the tests linked that packstack does
16:19:11 <rhallisey> it worth to think about in terms of ideas for gate coverage
16:19:16 <Jeffrey4l_> yes.
16:19:52 <rhallisey> 1) stability 2) getting minimal coverage
16:19:57 <Jeffrey4l_> but additional, kolla has more matrix beyond that. like ubunt+source cent0S+source centos+binary etc
16:20:04 <rhallisey> yes it does
16:20:07 <rhallisey> which is awesome
16:20:45 <rhallisey> in total we have a lot of gate, but we have some hold when it comes to basic coverage
16:20:58 <rhallisey> well talk a bunch more about this at the midcycle
16:21:04 <rhallisey> #topic Kolla-kubernetes
16:21:20 <rhallisey> #link https://review.openstack.org/#/c/335279/
16:21:26 <rhallisey> #link https://review.openstack.org/#/c/334255/
16:21:47 <rhallisey> the first link is a spec to ansible as a deployment tool that hands off to kube
16:22:10 <rhallisey> there is some good discussion ongoing there that could be worth jumping into if you haven't already
16:22:26 <rhallisey> wirehead_, did you want to mention anything
16:22:32 <rhallisey> or anyone else for that matter?
16:22:54 <wirehead_> Well, Kube 1.3 has init containers that might solve some of our workflow issues in a better fashion.
16:23:07 <wirehead_> I think I wrote enough paragraphs for the next day or two on the spec. :D
16:23:11 <rhallisey> hehe
16:23:32 <rhallisey> wirehead_, think we can get a poc of that? To compare?
16:23:36 <wirehead_> Yeah.
16:24:00 <inc0> yeah, init containers might actually be good for you guys
16:24:08 <rhallisey> wirehead_, something to keep in mind too is that the init containers would need to work for both bootstrap and upgrades
16:24:10 <wirehead_> gherlien submitted the doc patch for kube 1.3 instructions yesterday and I’m running my tests.
16:24:32 <inc0> rhallisey, I think that's still doable
16:25:21 <rhallisey> I mean it's technically do able with init containers, but we want to be sure it's the best possible method
16:25:33 <wirehead_> We might end up taking both options.
16:25:41 <rhallisey> avoid auto magic and make sure were flexibile
16:25:43 <inc0> I'd be opposed to do both
16:25:53 <inc0> as we want to make one but good
16:25:56 <rhallisey> inc0, so init + ansible?
16:26:10 <wirehead_> c.f. MariaDB using init containers to get started, because it’s a snowflake, but database migrations using ansible.
16:26:11 <inc0> wirehead_, are you going to midcycle?
16:26:13 <wirehead_> Yes.
16:26:19 <inc0> let's talk there shall we?
16:26:31 <rhallisey> I'm not sure if I'm opposed.. it could move us closer to a state were kube could one day handle the whole thing
16:26:40 <rhallisey> idk
16:26:45 <inc0> rhallisey, opposed for both at same time
16:26:56 <inc0> I think we need to make a call
16:27:08 <rhallisey> ok let's have a poc of it to see how it works
16:27:09 <wirehead_> Opposed to both at the same time for no reason, but OK with using a different option to handle the snowflakes.
16:27:13 <inc0> if its hybrid of both - cool, but single arch
16:27:17 <rhallisey> then we can discuss what we like
16:27:36 <wirehead_> Yeah, I’m fully acknowledging that my opinions have been flipping as the code develops.
16:27:52 <rhallisey> wirehead_, no worries, I've been all over the place
16:28:04 <rhallisey> the tech is changing rapidly and we have to adjust on the fly
16:28:12 <inc0> wirehead_, we've rewritten kolla couple of times ourselves;)
16:28:22 <rhallisey> ya not to mention that ^
16:28:25 <wirehead_> This is also probably a good time to consider if there’s something we need in upstream kube 1.4
16:29:04 <rhallisey> wirehead_, the only thing I can think of is additional HA.  But since we haven't gotten there yet I can't quantify it
16:29:22 <wirehead_> PetSets. :)
16:30:05 <rhallisey> I briefly read about them
16:30:09 * rhallisey will read further
16:30:23 <rhallisey> #topic Open Discussion
16:31:06 <wirehead_> So, we’re still blocked on merging https://review.openstack.org/#/c/327925/
16:31:40 <wirehead_> To clarify, to inc0 and maybe kfox1111… we want a new variable that dictates that we’re using kolla-kubernetes
16:32:30 <rhallisey> wirehead_,  interesting
16:32:33 <rhallisey> k will comment on later
16:32:52 <inc0> wirehead_, why not set 0.0.0.0 if this variable is not set?
16:33:05 <Jeffrey4l_> need guy to reply my concern https://review.openstack.org/#/c/327925/8/ansible/roles/common/tasks/config.yml
16:34:07 <wirehead_> It’s getting really bike-shed-y.
16:34:07 <Jeffrey4l_> is anyone interested in ansiblize dockerfile? spec is here https://review.openstack.org/336757 , a poc is here https://review.openstack.org/334208
16:34:46 <inc0> Jeffrey4l_, I'm really opposed to this
16:34:47 <pbourke> Jeffrey4l_: i feel its too big of a change for the project
16:34:54 <inc0> if you do everything in single ansible run
16:34:55 <wirehead_> inc0: So, you mean that we set one variable that’s kolla_kubernetes=yes, and then from that set 0.0.0.0 as the interface address?
16:35:02 <inc0> you effectively lose docker layers
16:35:16 <pbourke> most arguments are a repeat of the dsl
16:35:34 <Jeffrey4l_> pbourke, is is ansible script. not dsl.
16:35:55 <pbourke> i know, but many of the arguments that were made against the dsl also apply here
16:35:56 <inc0> in reality it's worse than dsl, as again, you lose bunch of docker mechanisms
16:36:02 <Jeffrey4l_> and i will make some change to reduce the repeat.
16:36:31 <inc0> wirehead_, I'd love to not have kolla_kubernetes=yes in ansible...
16:36:34 <Jeffrey4l_> inc0, now. docker image cache is useless actually in kolla. we use the parent image mechanisms more.
16:36:41 <Jeffrey4l_> s/now/no.
16:37:08 <inc0> not true
16:37:37 <inc0> also I'm ok with refactoring of dockerfiles
16:37:40 <Jeffrey4l_> btw, I will change the current implemention to use only one ansible playbooks to generate all the images.
16:37:50 <inc0> but not doing total repave of everything
16:39:46 <rhallisey> shall we carry over to #kolla?
16:39:52 <inc0> yeah, I guess
16:39:55 <Jeffrey4l_> ok
16:40:01 <rhallisey> #end meeting
16:40:09 <rhallisey> #endmeeting