16:00:02 <inc0> #startmeeting kolla
16:00:03 <openstack> Meeting started Wed Jan 18 16:00:02 2017 UTC and is due to finish in 60 minutes.  The chair is inc0. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:06 <openstack> The meeting name has been set to 'kolla'
16:00:23 <sdake> woot
16:00:24 <inc0> #topic w00t for kolla! rollcall plz
16:00:30 <egonzalez> woot! o/
16:00:33 <mliima> w000000000000t
16:00:40 <jascott1> woot!
16:00:40 <sp___> woot !!
16:00:54 <inc0> chatbot seems to be laggy too
16:00:59 <openstack> Jeffrey4l: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
16:01:11 <sdake> inc0 ya its ok
16:01:11 <sdake> Jeffrey4l inc0 made it in time :)
16:01:18 <wirehead_> meow meow
16:01:20 <inc0> sorry guys
16:02:03 <sdake> inc0 its a-ok
16:02:12 <mandre> o/
16:02:14 <duonghq> o/
16:02:16 <kfox1111> o/
16:02:27 <pbourke> o/
16:02:35 <Jeffrey4l> sorry, got some network issue.
16:02:41 <qwang> O/
16:03:19 <Jeffrey4l> 0/
16:03:41 <inc0> #topic announcements
16:03:49 <inc0> kolla-k8s 0.4.0 is out
16:03:55 <inc0> so yay
16:04:01 <inc0> anything else?:)
16:05:03 <inc0> guess not
16:05:21 <inc0> #topic Kolla deliverable
16:05:33 <inc0> sdake, what exactly you meant by it?
16:05:44 <sdake> umm
16:05:48 <sdake> i put hte agenda together
16:05:52 <sdake> i thought we would want to talk about blueprints
16:05:57 <sdake> since the deadline is like t-1 week out
16:06:06 <sdake> and figure out which blueprints to move to pike now
16:06:07 <inc0> yeah, makes sense
16:06:10 <sdake> so peopel could focus on ocata
16:06:33 <sdake> inc0 however your our ptl, so you decide how tot hanle htis sectio n:)
16:06:44 <inc0> https://launchpad.net/kolla/+milestone/ocata-3
16:06:51 <inc0> no, I agree
16:06:53 <inc0> let's do this
16:06:57 <inc0> thanks
16:08:11 <sdake> real quick, on annuncmeenet,s sorry was multitasking
16:08:27 <sdake> if folks wnat to be a part of the helm wg eithe email me or email inc0, and we will get you set up
16:08:33 <sdake> stdake@cisco.com
16:08:36 <sdake> thanks :)
16:08:42 <sdake> this is the openstack + helm wg
16:08:55 <inc0> so, let's get to blueprints
16:09:00 <inc0> 1. fluentd seems to be going ok
16:09:00 <sdake> so slow progress
16:09:00 <duonghq> vice
16:09:02 <duonghq> nice
16:09:14 <sdake> inc0 i typically boot these out of the relesae ;)
16:09:19 <inc0> 2. keystone upgrades - this has to land.
16:09:20 <sdake> and move them to pike
16:09:41 <inc0> let's update status tho
16:10:24 <sdake> yup - inc0 its hard to get popeple to keep the status updated on the blueprints
16:10:24 <inc0> also, let's make this Friday a bug day
16:10:39 <sdake> inc0 no dobut - 190 bugs :(
16:10:44 <inc0> its night impossible
16:10:54 <inc0> so let's make every Friday till release bug day;)
16:11:13 <inc0> cores focus on bugs, people fix bugs
16:11:30 <sdake> inc0 that wont work for me personally but sounds like a good idea ;)
16:11:49 <inc0> you can fix bugs without having cores around
16:11:58 <sdake> right
16:11:58 <inc0> what I mean is to try to help non-cores
16:12:12 <inc0> and non cores, please use this time if you want contributions
16:12:15 <inc0> we'll be around
16:12:20 <inc0> I'll send mail to ML later
16:12:31 <sdake> inc0 typically the way I handle the blueprints in the past is to kick out all the low and medium that are not in good progress to pike
16:12:50 <sdake> inc0 and then bounce high at mileston e#3 release
16:12:51 <inc0> and that;s what I'm going to do
16:12:54 <sdake> cool
16:13:00 <sdake> inc0 just trying to help with my experience ;)
16:13:10 <inc0> but my personal request, if anyone has bp on them, update it's status
16:13:21 <inc0> otherwise I assume it's not being worked on
16:13:25 <sdake> inc0 anything that is slow progress, i would bounce now
16:13:46 <inc0> well, I want to give people chance to make changes to this status
16:13:53 <sdake> inc0 sounds good
16:13:54 <inc0> I'll do some due diligence myself
16:14:00 <inc0> after meeting
16:14:10 <sbezverk> inc0: sorry for being late, what is the current topic?
16:14:13 <sdake> inc0 ya i had to spend inordinate amoutns of time reviewing the whiteboard in the blueprints as ptl to detemrine status :)
16:14:19 <sdake> sbezverk kolla deliverable blueprints
16:14:27 <sbezverk> sdake: thanks
16:14:28 <inc0> sbezverk, if you have koilla/kolla-ansible bp on you, please update status
16:15:01 <inc0> #action all - update status on blueprints
16:15:17 <inc0> that was correct syntax?
16:15:22 <sdake> yup should be
16:15:34 <sdake> not sure tbh - i think its ok tho :)
16:15:34 <inc0> well, whatever, I'll send this to ML too
16:15:40 <sdake> good idea re ml inc0
16:16:18 <inc0> ok, so let's stop on that, again, make sure your bp status is up to date, today I'll send ML and give full 24hrs for that
16:16:24 <inc0> tomorrow I'm bouncing blueprints
16:16:53 <inc0> same will go to kolla-ansible deliverable, so I'll skip this
16:17:09 <inc0> #topic kolla-kubernetes 0.5.0
16:17:19 <inc0> timebox you wanted was 10min sdake? we can extend it
16:17:25 <inc0> since we saved time on bps
16:17:25 <sdake> ok
16:17:33 <sdake> well i dont know how much time we need 10 mins shoudl be enough
16:17:39 <inc0> fine then
16:18:11 <sdake> since we are release independent and havne't released a 1.0.0 I changed around the tracker here: https://launchpad.net/kolla-kubernetes
16:18:30 <sdake> the idea is inc0 will submit a request at his earliest convience to change us to release:cycle_traling
16:18:35 <sdake> I think that can happen in early pike
16:18:39 <sdake> for only a month or so
16:18:50 <sdake> but cant happen now bcause release models are forzen by the release team
16:18:56 <sdake> releae model changes
16:19:06 <inc0> that would be great, but frankly I'd do it adter 1.0
16:19:13 <sdake> we released 0.4.0 on sunday: https://launchpad.net/kolla-kubernetes/master/0.4.0
16:19:29 <kfox1111> yeah, probably better after 1.0.
16:19:31 <sdake> Thanks a ubnc hto eveyrone involved - and especially writing the reno release notes at teh last minute - and jeffrey4l for fighuring out how to get them to render
16:19:35 <kfox1111> we still need to define what is required for 1.0 too.
16:19:47 <inc0> agree kfox1111 <- wanted to say it myself
16:19:49 <sdake> here is 0.5.0 with a 1 month window
16:20:01 <sdake> https://launchpad.net/kolla-kubernetes/+milestone/0.5.0
16:20:03 <sdake> ionly 5 small blueprints
16:20:05 <inc0> I'd suggest making this full PTG session
16:20:07 <sdake> 5 large blueprints
16:20:18 <sdake> inc0 wfm - we have ptg planning on agenda too
16:20:44 <sdake> the 5 large blueprints, the idea of this "sprint" (even though openstack doesn't use agile but is more waterfall + opensorucy:)
16:20:53 <sdake> is to get us to the point we have a complete implementation
16:21:15 <sdake> the service layer is already in progress
16:21:20 <inc0> we also need galera
16:21:23 <sdake> the key thing here is people should sign up for stuff that interests them
16:21:29 <kfox1111> sdake: there may be two much work on that 0.5.0 mile stone to be time based.
16:21:30 <inc0> or even a/p myself replication
16:21:30 <sdake> inc0 that can go under the services workitem
16:21:40 <sdake> kfox1111 i understand -we can kick things out as needed
16:21:55 <sdake> kfox1111 open source projects don't have capacity planning
16:22:01 <sdake> kfox1111 because its avolunteer effort
16:22:15 <sdake> kfox1111 so if things don't make the 1 mo deadine, they go to 0.6.0
16:22:16 <kfox1111> right. so either they move the release data, or don't implement stuff.
16:22:25 <kfox1111> do we move the deadline or not implement stuff?
16:22:33 <sdake> the deadline is lined up to finish prior to the ptg
16:22:38 <kfox1111> ah.
16:22:38 <sdake> so we have an implementation to discuss at the ptg
16:22:43 <inc0> depends on stuff kfox1111
16:22:48 <kfox1111> that would be a good deadline to keep. yeah.
16:22:51 <sdake> so for this sprint, I think we keep the deadline as is
16:22:57 <kfox1111> +1
16:23:11 <sdake> for other deadlines, release:independent deliverables are flexible
16:23:24 <sdake> ok , so PLEASE SIGN UP - just replace unassigned
16:23:32 <sdake> note you will have to click through the blueprint to see  what to sign up for
16:23:41 <sdake> feel free to add to the work items too if you are going to actually do the work :)
16:23:52 <kfox1111> I've got some other stuff that I'll make bp's for and add to that milestone.
16:23:54 <sdake> i htink the scope of 0.5.0 is doable given the team size we have
16:24:05 <sdake> kfox1111 to 0.5.0 you mean?
16:24:09 <kfox1111> yeah,
16:24:22 <sdake> kfox1111 cool - hopefully they make sense for a basic demoable thing that works :)
16:24:33 <kfox1111> plumbing.
16:24:34 <sdake> so people can try it out prior to ptg
16:24:36 <sdake> kfox1111 roger
16:24:47 <sdake> any Q&A?
16:24:48 <kfox1111> every container needs an overridable image pull policy,
16:25:03 <kfox1111> every cconfigmap needs an overridable name,
16:25:04 <kfox1111> etc.
16:25:11 <sdake> kfox1111 ok - wel yo uknow how to add work items :)
16:25:14 <sdake> note there are a ton of blueprints i nthe backlog as well
16:25:14 <inc0> if we can have demoable thing by ocata, I'd be very happy PTL
16:25:20 <kfox1111> yup. :)
16:25:29 <sdake> inc0 we are close I think :)
16:25:39 <sdake> kfox1111 if you are adding smoethign make sure its not already in teh backlog
16:25:46 <inc0> yeah, I see that and I'm already happy PTL
16:25:48 <kfox1111> another one not on the list is deployment docs.
16:25:58 <sdake> inc0 service layer finishes up (which uses entrypoint) and we are pretty good to go
16:26:08 <sdake> kfox1111 yes docs, we need much better docs
16:26:09 <sdake> all around
16:26:18 <sdake> kfox1111 that is a continous improvement thing and  doens't need a blueprint
16:26:21 <sdake> but does need attention
16:26:24 <kfox1111> I'm workign on a reboot testing gate job
16:26:29 <kfox1111> and we probably need an upgrade job too.
16:26:52 <sdake> nice kfox1111  :)
16:26:54 <inc0> well upgrade is something we need for 1.0
16:26:58 <inc0> at least minor upgrades
16:27:00 <inc0> which are easier
16:27:08 <kfox1111> we have plumbing now for 2/3 in the gate, and trunk soon.
16:27:20 <kfox1111> so upgrade testing shoudl be possible now.
16:27:37 <sdake> inc0 i think you missed an announcement on the integration with registry in the gate
16:27:45 <inc0> it's still WIP
16:27:46 <sdake> so i'm done, maybe you can talk about that a bit?
16:27:51 <sdake> oh I thought it merged
16:27:51 <inc0> that's why I haven't announce it just yet
16:27:55 <inc0> nope
16:28:00 <kfox1111> sdake: its close.
16:28:11 <sdake> cool m ybad then :)
16:28:14 <kfox1111> probably today. :)
16:28:14 <l4yerffeJ> inc0, it is merged
16:28:18 <inc0> https://review.openstack.org/#/c/418550/
16:28:29 <inc0> l4yerffeJ, in ansible, we were referring to k8s
16:28:43 <sdake> inc0 oh - I was talking about kolla-ansible deliverable there
16:28:51 <inc0> ok
16:28:53 <sdake> inc0 sorry to change subjects on ya
16:28:54 <l4yerffeJ> ok.
16:28:57 <inc0> then yeah, it's merged
16:28:58 <sdake> icn0 but i think its a big deal
16:29:04 <inc0> k8s is close
16:29:05 <inc0> I know
16:29:11 <sdake> we cna probabl8y move on :)
16:29:16 <inc0> we can have voting gates as far as I'm concerned
16:29:25 <inc0> voting deploy gates
16:29:34 <sdake> if we are to talk about that - change topic :)
16:29:39 <inc0> #topic gates
16:29:46 <sdake> m0ar gates!!
16:29:50 <inc0> I'll inject it here since it's kinda important
16:30:02 <inc0> 1 thing I need to ask you guys (k8s) is to move to source gates
16:30:05 <sdake> kinda^crucial
16:30:06 <inc0> when registry lands
16:30:17 <inc0> as binary gates in kolla aren't voting
16:30:20 <sdake> inc0 yup we need source gates at minimum
16:30:25 <sdake> inc0 i'll take tha ton
16:30:31 <kfox1111> trunk-source non voting.
16:30:33 <sdake> inc0 assumign i can figure it out on my own
16:30:35 <inc0> hence there is potential that registry will have broken images
16:30:41 <kfox1111> 3.x voting.
16:30:52 <l4yerffeJ> i hope trunk source voting  in kolla-ansible ;)
16:30:58 <kfox1111> then random broken trunk won't prevent progress on kolla-kubernetes.
16:31:01 <inc0> kfox1111, I'd go with trunk source voting
16:31:09 <kfox1111> trunk is unstable. stable is stable.
16:31:33 <sdake> kfox1111 one thing to note, when we branch, we will have separatee gates per version
16:31:35 <inc0> but one of kolla things is that we master deployment tool works with master images
16:31:37 <l4yerffeJ> voting gate force committer to fix the gate first.
16:31:52 <sdake> kfox1111 so the issue you are discussing wont be a thing post 1.0
16:31:57 <kfox1111> sdake: once 1.0 hits and kolla-kubernetes is not in such active dev, I agree.
16:32:02 <inc0> we should have smoketest deploy gates in kolla itself too
16:32:03 <sdake> kfox1111 right
16:32:03 <inc0> for k8s
16:32:06 <inc0> we already have it for ansible
16:32:11 <kfox1111> but for now, enhancements to kolla-kubernetes affects multiple versions.
16:32:17 <sdake> inc0 ya cross-repo gating would be nice for kolla-k8s
16:32:23 <sdake> kfox1111 roger i understand
16:32:27 <kfox1111> +1 for cross repo gating.
16:32:36 <kfox1111> I'm working on getting helm packages built out of the kolla-kubernetes gate.
16:32:45 <kfox1111> so we could use those known good helm packages in the kolla gate.
16:32:56 <l4yerffeJ> cross repo gate is easy to implement. use zuul-cloner to pull the kolla's code.
16:33:09 <inc0> ok, let's do this then kfox1111
16:33:12 <kfox1111> that woudl work too.
16:33:24 <inc0> 1. make cross repo gating on images
16:33:37 <inc0> 2. make source deploy gates voting for trunk
16:33:50 <sdake> we probably need a blueprint to track the gating work
16:33:53 <inc0> no time limit, when it makes sense
16:33:55 <sdake> so we knwo what todo
16:34:02 <kfox1111> if the images are cached, and those 2 other things hold, yeah. voting shoudl be fine then.
16:34:03 <l4yerffeJ> cross project bp ;/
16:34:07 <sdake> inc0 infra will give us max 90 minutes
16:34:17 <inc0> per gate
16:34:20 <sdake> l4yerffeJ is that possible in launchpad?
16:34:25 <l4yerffeJ> sdake, we can have more time actuall.
16:34:34 <l4yerffeJ> sdake, seems no ;(
16:34:37 <sdake> l4yerffeJ the best i've been able to negotate is 90 minutes :)
16:34:49 <sbezverk> kfox1111: you can already use helm package by using helm-repo container
16:34:51 <l4yerffeJ> now 90 mins is enought.
16:34:52 <inc0> yeah, I think we can extend timeout
16:34:53 <sdake> l4yerffeJ we can put links to the cross launchpad sub-projects
16:34:55 <inc0> but I doubt we need to
16:35:05 <kfox1111> sbezverk: yeah. but need to store the packages somewhere.
16:35:07 <sdake> inc0 infra pretty strongly opposed to gates longer then 60 minutess
16:35:19 <sdake> i had to work hard to get infra to accept 90 minute gates, although we generally dont even need 90 minutes now
16:35:19 <kfox1111> sbezverk: working on getting that into tarballs.o.o
16:35:28 <sbezverk> kfox1111: pakcges will be stored on a persistent storage
16:35:40 <sbezverk> kfox1111: I see what you mean
16:36:00 <sdake> inc0 could you take an action to create a blueprint in each of the deliverables for gating, and i'll take an action to cross-ink them in launchpad
16:36:16 <sdake> inc0 and if the entire team can make an effort to fill out work items, that would be great :)
16:36:24 <kfox1111> sounds good.
16:36:25 <sdake> we can just keep rolling this blueprint from release to release
16:36:28 <inc0> sdake, I'll just create bp in kolla for kolla-k8s deploy gates
16:36:38 <inc0> no need for over-documentation
16:36:41 <sdake> inc0 kolla-k8s needs gating too
16:36:47 <inc0> we can just paste link to other bps in whiteboard
16:36:52 <inc0> but these are separate bps;)
16:36:57 <sdake> inc0 right that is what I was suggesting
16:36:59 <kfox1111> k. please let me know when it lands so I can watch it.
16:37:15 <sdake> inc0 ok, i'll take action to create teh blueprint for gating for kolla-kubernetes
16:37:19 <sdake> inc0 perhaps you can do for kolla
16:37:24 <inc0> kfox1111, we'll need your help in kolla gates;)
16:37:41 <kfox1111> inc0: np. I'm here for you. :)
16:37:42 <sdake> kfox1111 once i get blueprint created for kolla-kubernetes, perhaps you can fill out the work items that relate to kolla-kubernetes specifically (not cross repo gating)
16:37:54 <kfox1111> k.
16:38:11 <sdake> i'd say cross repo gating is lower priority -t hen say the 0.5.0 blueprints
16:38:20 <sdake> although after ptg, i'd say its higher priority then eveyrhting else
16:38:33 <inc0> #link https://blueprints.launchpad.net/kolla/+spec/kolla-k8s-deploy-gates
16:38:35 <sdake> however that is one lone voice's opinion
16:38:48 <inc0> I'll target it for Pike, as I don't assume it happening in ocata (nor it has to)
16:38:52 <inc0> would be nice tho
16:38:55 <sdake> inc0 coo lthanks dude
16:39:11 <sdake> inc0 i think we will be challeneged to deliver 0.5.0 :)
16:39:11 <kfox1111> sdake: my time is easier to prioritize around the microservices and support. less so about orchestration.
16:39:19 <sdake> kfox1111 understood
16:39:24 <sdake> kfox1111 whatever works for each individual
16:39:34 <kfox1111> yeah.
16:39:48 <inc0> ok, we need to move on
16:40:31 <inc0> #topic PTG planning
16:40:35 <inc0> #link https://etherpad.openstack.org/p/kolla-ocata-ptg
16:40:41 <inc0> have at it gents
16:40:56 <zhubingbing> o/
16:40:58 <zhubingbing> ;(
16:41:51 <sp___> inc0:  what if we wont get travel support >
16:41:56 <sp___> ?
16:42:04 <inc0> sp___, teleconferences will be on
16:42:13 <inc0> everyone will be able to call in
16:42:37 <sdake> inc0 nice - is the foundation organizing that part - or are we hacking it together with cellphones and whatnot?
16:42:48 <inc0> hacking afaik
16:42:55 <sdake> inc0 roger
16:42:56 <inc0> but we'll have ethernet cable
16:43:18 <sdake> I have a great USB microphone
16:43:19 <inc0> so one laptop + some higher grade teleco microphone/speakers should be fine
16:43:24 <inc0> there ya go
16:43:25 <sdake> my kid use it for gmaing
16:43:29 <sdake> I can bring it if you like
16:43:39 <sdake> I can't guarantee itworks well in a room
16:43:51 <inc0> I'll check if intel has some stashed conf gear
16:43:55 <sp___> how will we get connect to call ?
16:43:58 <wirehead_> It’s gonna be like this: http://fashiongrunge.com/wp-content/uploads/2013/09/hackers24ji.jpg
16:44:07 <inc0> sp___, hangouts link will be published
16:44:19 <sp___> inc0: thanks
16:44:29 <wirehead_> Or, maybe if we’re lucky: http://thatmikeflynn.com/public/images/hackers_2.jpg
16:44:31 <inc0> or some alternative
16:44:37 <sdake> inc0 i can't guarantee this mic will work with hangouts, but I'll test it
16:44:39 <inc0> since hangouts has issues in China
16:44:43 <egonzalez> some region does not have access to hangout
16:44:53 <inc0> sdake, I'll bring some gear myself
16:44:55 <sdake> inc0 I think zoom.us is accessiable thru the GFW and works on linux
16:45:08 <inc0> worst case scenerio, we'll raise money in room and send runner to nearest best buy
16:45:11 <sdake> inc0 cool - i'l bring backups just in case :)\
16:45:48 <inc0> tool will be determined
16:45:50 <Jeffrey4l> one think for Chinese to participate OpenStack is cross the wall ;)
16:45:58 <Jeffrey4l> one thing*
16:46:08 <inc0> I'm actually very happy that we'll have teleconference
16:46:24 <inc0> timezones will be hard for some of us, but there is only so much we can do
16:46:37 <inc0> I think China will also need to move to nocturnal life for a week;)
16:46:42 <sbezverk> Jeffrey4l: based on the latest Damon movie, it looked like a scary thing ;)
16:46:52 <Jeffrey4l> so personally i am OK with hangout
16:47:03 <inc0> ok, let's get back on track
16:47:05 <inc0> list of sessions
16:47:14 <inc0> timebox 10min
16:47:22 <inc0> let's make sure it's up to date
16:47:32 <clarkb> the infra team has had good luck using pbx.openstack.org / asterisk, but not sure we have tested it from china
16:47:50 <zhubingbing> ;)
16:48:56 <inc0> clarkb, thanks! thats good info
16:50:04 <sdake> sup clarkb :)
16:50:19 <sdake> clarkb we will have to tlak mroe - I don't know how to access pbx.openstack.org (what device is reuqired, etc)
16:50:29 <sdake> clarkb i think Jeffrey4l could test it from china for you
16:50:42 <sdake> alhtough just guessing as Jeffrey4l is super busy
16:50:43 <Jeffrey4l> i am downloading the client and try to test.
16:50:49 <sdake> Jeffrey4l rockin thanks :)
16:50:57 <clarkb> details are at https://wiki.openstack.org/wiki/Infrastructure/Conferencing
16:51:09 <Jeffrey4l> interesting service ;)
16:51:20 <sdake> clarkb thanks :)
16:51:33 <Jeffrey4l> thanks clarkb
16:52:13 <sp___> clarkb: thanks
16:52:22 <zhubingbing> clarkb: thanks
16:52:26 <zhubingbing> ;)
16:56:33 <inc0> ok, times up
16:56:39 <inc0> #topic open discussion
16:56:44 <inc0> 4 more minutes
16:57:00 <inc0> anyone want to discuss anything?
16:58:21 <inc0> guess not:)
16:58:31 <inc0> allright, thanks everyone!
16:58:38 <mliima> bye
16:58:38 <inc0> #endmeeting kolla